Outlook ara sunucuy...
 
Bildirimler
Hepsini Temizle

Outlook ara sunucuya bağlanamıyor. (Hata kodu:0)  

  RSS
barisballi
(@barisballi)
Üye

Merhaba;

Şirketimizde Windows 2012 R2 server üzerinde Exchange 2013 server kullanıyoruz. DC olarak da bu server olarak kullanılıyor. Sanal server değil, fiziksel sunucudur. Dün outlook 2013 kullanıcı adı ve şifre sormaya başladı. Exchange srv baktığımda sertifika süresinin dolduğunu gördüm ve yeni sertifika hazırladım. Şuanda outlook 2013 ve üzeri uygulamalarda exchange bağlantısı yapılamıyor ama owa üzerinden mail gönder - al yapılabiliyor. Alınan hata ;

"Ara sunucunun güvenlik sertifikasıyla ilgili bir sorun var. Güvenlik sertifikasındaki ad geçersiz ve mail.sirketim.com.tr hedef sitesinin adıyla eşleşmiyor.

Outlook ara sunucuya bağlanamıyor. (hata kodu:0)"

Yaptıklarım:

- Birçok kez sertifika oluşturdum ve sistemi shut down yaptım.

- Set-ClientAccessServer ve Set-OutlookProvider komutları ile tanımları tekrar yaptım.

-Mail profilini sildim. Ancak yeni profil eklenirken exchange server ile bağlantı hatası verdiğinden işlemi tamamlamıyor. Girdiğim kullanıcı adı ve şifresi doğru olmasına rağmen kabul etmiyor.

- Outlook 2010 kullanan sistemlerde bağlantı sorunu yaşanmıyor.

Yardımlarınızı rica ediyorum. Teşekkürler.

 

 

 

 

Alıntı
Gönderildi : 08/01/2020 18:03
Recep YÜKSEL
(@recepyuksel)
Kıdemli Üye Forum Yöneticisi

Merhaba,

Exchange yönetim knsolu değilde IIS yönetim konsolu üzerinde yeni sertifikanın ilgili servislere atanmış (bağlanmış) olduğundan emin olabilirmisiniz? 

Saygılarımla.

************************************************************
Probleminiz çözüldüğünde sonucu burada paylaşırsanız,
sizin ile aynı problemi yaşayanlar için yardım etmiş olursunuz.
Eğer sorununuz çözüldü ise "çözüldü" olarak işaretlerseniz
diğer üyeler için çok büyük kolaylık sağlayacaktır.
************************************************************

CevapAlıntı
Gönderildi : 08/01/2020 21:08
barisballi
(@barisballi)
Üye

@recepyuksel

Merhaba;

IIS'de Default Web Site - Bindings' bölümünde yeni sertifika https 443 portuna bağlanmış durumda. Aynı şekilde Exchange back end kısmında da  https 444 numaralı portuna bağlanmış durumda.

DefaultWebsite1
DefaultWebsite2
ExchangeBackEnd

 

CevapAlıntı
Gönderildi : 09/01/2020 09:45
Recep YÜKSEL
(@recepyuksel)
Kıdemli Üye Forum Yöneticisi

Peki o kullanıcı hesabı Office 2010 ile bağlantı kuruyor ise o makinadaki Office 2013 sorun olmuş olabilirmi? Yoksa tüm Office 2013 kullananlardamı sorun var? 

************************************************************
Probleminiz çözüldüğünde sonucu burada paylaşırsanız,
sizin ile aynı problemi yaşayanlar için yardım etmiş olursunuz.
Eğer sorununuz çözüldü ise "çözüldü" olarak işaretlerseniz
diğer üyeler için çok büyük kolaylık sağlayacaktır.
************************************************************

CevapAlıntı
Gönderildi : 09/01/2020 15:05
barisballi
(@barisballi)
Üye

@recepyuksel

Düzeltme yapayım. Outlook 2010, 2013, 2016 kullanılan clientlerda hata alınıyor. Bu hesaplar ile owa'dan mail gönder al yapılabiliyor. Sıfır bir makine kurarak, yeni bir kullanıcı oluşturdum ve domaine dahil  ettim. Bu clienta ofis 2013 kurdum ancak hata devam etti. Exchange servera bağlanamadım ve mail hesabını kuramadım. son durum budur. 

CevapAlıntı
Gönderildi : 09/01/2020 19:48
Recep YÜKSEL
(@recepyuksel)
Kıdemli Üye Forum Yöneticisi

@barisballi

Baris bey IIS üzerinde gözden kaçan bir yerde eski veya silinmiş kullanılamayan birisi duruyor https servisi ile ilgili hizmet için diye düşünüyorum.

IIS tarafını daha detaylı inceleyebilirseniz yakalayabilirsiniz diye düşünüyorum. 

Saygılarımla.

************************************************************
Probleminiz çözüldüğünde sonucu burada paylaşırsanız,
sizin ile aynı problemi yaşayanlar için yardım etmiş olursunuz.
Eğer sorununuz çözüldü ise "çözüldü" olarak işaretlerseniz
diğer üyeler için çok büyük kolaylık sağlayacaktır.
************************************************************

CevapAlıntı
Gönderildi : 10/01/2020 09:19
Hakan Uzuner
(@hakanuzuner)
Kıdemli Üye Yönetici

Merhaba,

Son durum nedir?

Aşağıdaki komutların çıktılarını paylaşır mısın lütfen?

get-ClientAccessService | fl Server,name,*Uri*
get-webservicesvirtualdirectory | fl Server,name,*Url*
get-oabvirtualdirectory | fl Server,name,*Url*
get-owavirtualdirectory | fl Server,name,*Url*
get-ecpvirtualdirectory | fl Server,name,*Url*
get-ActiveSyncVirtualDirectory | fl Server,*Url*
get-Outlookanywhere | fl Identity, *hostname*
get-MapiVirtualDirectory | fl server, internalurl, externalurl

 

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 13/01/2020 21:10
barisballi
(@barisballi)
Üye

@hakanuzuner Merhaba

Hafta sonu bir arkadaşım ile birlikte Sertifkayı Self-signed olarak oluşturduk. Arkadaşım bazı komutlar kullandı ve outlooklar çalışır duruma geldi. Hangi komutlar ile işlem yaptığını bilmiyorum. Şuan outlook üzerinden mail gönder al yapabiliyoruz. Ben daha önce sertifikayi CA'den oluşturuyordum. 

Ayrıca sormak istediğim bir konu var. Bu hata oluşturktan sonra bu server üzerinde yayınladığım bir web sitesi görüntülenemez oldu. Mailler düzeldi ama bu sorun düzelmedi. Ayrıca  localhost yazdığım zaman iis default web page'de görünmüyor. İlgisi olabilir mi?

İstediğiniz çıktılar aşağıdadır. get-ClientAccessService | fl Server,name,*Url* komutunu çalıştıramadım.

Teşekkür ederim.

 

[PS] C:\Windows\system32>get-webservicesvirtualdirectory | fl Server,name,*Url*

Server : DC01
Name : EWS (Default Web Site)
InternalNLBBypassUrl :
InternalUrl : https://mail.sirketim.com.tr/ews/exchange.asmx
ExternalUrl :

 

[PS] C:\Windows\system32>get-oabvirtualdirectory | fl Server,name,*Url*

Server : DC01
Name : OAB (Default Web Site)
InternalUrl : https://mail.sirketim.com.tr/oab
ExternalUrl :

 

[PS] C:\Windows\system32>get-owavirtualdirectory | fl Server,name,*Url*

Server : DC01
Name : owa (Default Web Site)
Url : {}
SetPhotoURL :
Exchange2003Url :
FailbackUrl :
InternalUrl :
ExternalUrl : https://mail.sirketim.com.tr/owa

 

[PS] C:\Windows\system32>get-ecpvirtualdirectory | fl Server,name,*Url*

Server : DC01
Name : ecp (Default Web Site)
InternalUrl :
ExternalUrl :

 

[PS] C:\Windows\system32>get-ActiveSyncVirtualDirectory | fl Server,*Url*

Server : DC01
MobileClientCertificateAuthorityURL :
InternalUrl : https://DC01.sirketim.com.tr/Microsoft-Server-ActiveSync
ExternalUrl :

 

[PS] C:\Windows\system32>get-Outlookanywhere | fl Identity, *hostname*

Identity : DC01\Rpc (Default Web Site)
ExternalHostname : mail.sirketim.com.tr
InternalHostname : mail.sirketim.com.tr

 

[PS] C:\Windows\system32>get-MapiVirtualDirectory | fl server, internalurl, externalurl

Server : DC01
InternalUrl : https://DC01.sirketim.com.tr/mapi
ExternalUrl :

 

 

CevapAlıntı
Gönderildi : 14/01/2020 18:52
Hakan Uzuner
(@hakanuzuner)
Kıdemli Üye Yönetici

URL adresleri yanlış yapılandırılmış, öncelikle onları düzenlemeniz gerekli.

Ancak sorun şimdilik çözüldü ise bence çok uğraşmayın çünkü gördüğüm kadarı ile çok uzman değilsiniz. Şimdi URL adreslerini düzeltemeye çalışırken yine outlook bağlantısı gidebilir.

Exchange kurulduğunda iki tane web site oluşturur, IIS de bunun dışında yeni bir web sitesi mi eklediniz? 

Localhost yazarsanız default web site gelir bu normal, eğer herhangi bir yönlendirme yapmamış iseniz normal bir durum.

/owa veya /ecp yazmalısınzı ancak ecp url adres bölümü boş.

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 14/01/2020 22:11
Paylaş: