Anasayfa » Cisco Packet Tracer CPT ile VLAN Konfigürasyonu

Makaleyi Paylaş

Cisco

Cisco Packet Tracer CPT ile VLAN Konfigürasyonu

Makalemizin ilk bölümünde CPT ( Cisco Packet Tracer )  ile ilgili genel bilgi vermiştik ve temel seviyede bir senaryo üzerinde uygulama gerçekleştirmiştik. Bu makalemizde de CPT ile VLAN konfigürasyonu üzerinde çalışmalar yapacağız. Öncelikle “ VLAN nedir, neden kullanılır? “ gibi soruların cevaplarını kısaca verelim.

VLAN nedir?

VLAN ( Virtual Local Area Network ) Sanal yerel alan ağı anlamına gelen VLAN, yerel ağ içerisinde çalışma grupları oluşturmak, yerel ağı anahtarlarla bölmektir.

Neden Kullanılır?

Sponsor

VLAN kullanılması durumunda broadcast trafiği azaltılmış olur. Bu durum bant genişliğinin artmasını sağlar. Yerel ağın performansını arttırdığı gibi Firewall ile kullanıldığında güvenlik konusunda geliştirim sağlayabilir.

Test Senaryosu

Yukarıdaki kısa bilgilendirmeden sonra test ortamında pratik yaparak ilerleyeceğiz. Senaryomuza göre Layer 2 seviyesinde çalışan 1 adet Cisco Switch bulunmaktadır. Bu switch üzerinde 3 adet VLAN oluşturulacak ve VLAN’lar arasında iletişim olmayacaktır. Yapımızın detayları aşağıdaki gibidir.

Switch   è 1 adet Cisco 2960 Layer 2 Switch 24 Fast Ethernet / 2 Gigabit Ethernet

VLAN Yapısı; IT, Finans, İnsan Kaynakları

Sunucu  è Her VLAN için 1 adet Sunucu ( Toplam 3 Sunucu )

Roller; DHPC, Web Server

İstemci  è Her VLAN için 4 adet İstemci ( Toplam 12 İstemci )

Senaryomuzda sırası ile aşağıdaki adımlar gerçekleştirilecektir.

1 ) Switch konfigürasyonu.

2 ) Sunucu konfigürasyonu.

3 ) Fiziksel bağlantılar.

4 ) Genel kontroller.

1)     Switch Konfigürasyonu

Uygulama Alanı’nda bulunan Switch’e tıklıyoruz ve CLI bölümüne geçiyoruz. Bu aşamada Switch bizi “ disable “ mod’da karşılayacak. “ enable “ komutu ile Ayrıcalıklı Mod’a geçiş yapıyoruz ve adım adım konfigürasyonumuzu gerçekleştiriyoruz.

NOT : Konfigürasyon sırasında kullanılan komutlar ve açıklamaları ( Kırmızı renk ile ) aşağıda paylaşılmıştır.

 

clip_image002

 

Switch>enable è Disable Mod’dan Privileged ( Ayrıcalıklı ) Mod’a geçiş için kullanılır.

Switch#conf terminal è Global Configuration Mod’a geçiş için kullanılır.

Switch(config)#service password-encryption è Konfigürasyon dosyasında şifrelerin kodlanmış olarak gösterilmesini sağlar.

Switch(config)#enable password cisco è Switch’e “ cisco “ şifresini atar.

Switch(config)#hostname testsw è Switch’in adını “ testsw “ olarak değiştirir.

testsw(config)#do show vlan è Mevcut VLAN yapısını gösterir.

 

VLAN Name                             Status    Ports

—- ——————————– ——— ——————————-

1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4

                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8

                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12

                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16

                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20

                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24

                                                Gig0/1, Gig0/2

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

 

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2

—- —– ———- —– —— —— ——– —- ——– —— ——

1    enet  100001     1500                                 0      0

1002 fddi  101002     1500                                  0      0  

1003 tr    101003     1500                                  0      0  

1004 fdnet 101004     1500                      ieee –        0      0  

1005 trnet 101005     1500                      ibm          0      0  

 

Remote SPAN VLANs

——————————————————————————

 

Primary Secondary Type              Ports

——- ——— —————– ——————————————

testsw(config)#vlan 10 è VLAN için ID ataması yapar.

testsw(config-vlan)#name IT è VLAN’a isim verir.

testsw(config-vlan)#exit è Çıkış için kullanılır.

testsw(config)#interface range Fa0/1-5 è Belirtilen port aralığını seçmek için kullanılır.

testsw(config-if-range)#switchport mode access è Seçilen portların çalışma modunu belirtir.

testsw(config-if-range)#switchport access vlan 10 è Seçilen portların hangi VLAN’da hizmet vereceğini belirtir.

testsw(config-if-range)#exit è Çıkış için kullanılır.

testsw(config)#interface vlan 10 è VLAN’a ait sanal interface devreye alınır.

testsw(config-if)#ip address 192.168.1.1 255.255.255.0 è Sanal Int. için IP ve SM değeri tanımlar.

testsw(config-if)#no shutdown è Aktif duruma getirir.

testsw(config-if)#exit è Çıkış için kullanılır.

testsw(config)#vlan 20

testsw(config-vlan)#name FIN

testsw(config-vlan)#exit

testsw(config)#interface range Fa0/6-10

testsw(config-if-range)#switchport mode access

testsw(config-if-range)#switchport access vlan 20

testsw(config-if-range)#exit

testsw(config)#interface vlan 20

testsw(config-if)#ip address 192.168.2.1 255.255.255.0

testsw(config-if)#no shutdown

testsw(config-if)#exit

testsw(config)#vlan 30

testsw(config-vlan)#name IK

testsw(config-vlan)#exit

testsw(config)#interface range Fa0/11-15

testsw(config-if-range)#switchport mode access

testsw(config-if-range)#switchport access vlan 30

testsw(config-if-range)#exit

testsw(config)#interface vlan 30

testsw(config-if)#ip address 192.168.3.1 255.255.255.0

testsw(config-if)#no shutdown

testsw(config-if)#exit

testsw(config)#do wr mem è Yapılan değişiklikleri kaydeder.

Building configuration…

[OK]

testsw(config)#do show vlan è Mevcut VLAN’ları listeler.

 

VLAN Name                             Status    Ports

—- ——————————– ——— ——————————-

1    default                          active    Fa0/16, Fa0/17, Fa0/18, Fa0/19

                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23

                                                Fa0/24, Gig0/1, Gig0/2

10   IT                               active    Fa0/1, Fa0/2, Fa0/3, Fa0/4

                                                Fa0/5

20   FIN                              active    Fa0/6, Fa0/7, Fa0/8, Fa0/9

                                                Fa0/10

30   IK                               active    Fa0/11, Fa0/12, Fa0/13, Fa0/14

                                                Fa0/15

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

 

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2

—- —– ———- —– —— —— ——– —- ——– —— ——

1    enet  100001     1500                                  0      0

10   enet  100010     1500                                  0      0

20   enet  100020     1500                                  0      0

30   enet  100030     1500                                  0      0

1002 fddi  101002     1500                                  0      0  

1003 tr    101003     1500                                  0      0  

1004 fdnet 101004     1500                      ieee –        0      0  

1005 trnet 101005     1500                      ibm          0      0  

 

Remote SPAN VLANs

——————————————————————————

 

 

Primary Secondary Type              Ports

——- ——— —————– ——————————————

testsw(config)#exit

testsw#copy running-config startup-config

Destination filename [startup-config]?

Building configuration…

[OK]

 

clip_image004

 

Yukarıdaki resimde Switch üzerindeki VLAN’ların “ do show vlan “ komut ile listelendiği görülmektedir. 10 ID’si ile IT,  20 ID’si ile FIN ve 30 ID’si ile IK VLAN’ları oluşturulmuştur.

Port ataması ise aşağıdaki gibidir.

VLAN IT    è Fa0/1 – 5 ( Fa – Fast Ethernet’i ifade etmektedir. )

VLAN FIN è Fa0/6 – 10

VLAN IK   è Fa0/11 – 15

 

NOT : 1 ID’sine sahip “ default “ isimli VLAN, switch’in standart konfigürasyonu ile gelmektedir.

VLAN oluşturma aşamasını tamamladık ve Sunucu konfigürasyonuna geçiş yapıyoruz.

2)     Sunucu Konfigürasyonu

Alt Araç Çubuğu’ndan IT bölümüne hizmet verecek Sunucu’yu ( IT_SRV ) Uygulama Alanı’na taşıyoruz.

 

clip_image006

Sonrasında IP – SM vb. bilgileri tanımlıyoruz ve DHCP konfigürasyonuna geçiyoruz.

clip_image008

 

clip_image010

 

Yukarıdaki resimde DHCP servisinin aktif edilmiş halini görebilirsiniz. Konfigürasyon detaylarına göre; Gateway olarak VLAN’in IP’si olan 192.168.1.1, DNS olarak da Sunucu’nun IP’si 192.168.1.2 verilmiştir. Sunucu, 192.168.1.5 ~ 15 aralığında 10 adet C sınıfı IP dağıtacaktır. Benzer Sunucu konfigürasyonu Finans ve İnsan Kaynakları bölümleri için de yapılacaktır. Buna göre;

Finans Sunucusu                                   è FIN_SRV

                                                     GW – 192.168.2.1,  IP –  192.168.2.2 / 24, IP Aralığı – 192.168.2.5 ~ 15

İnsan kaynakları Sunucusu è IK_SRV                                              

         GW – 192.168.3.1,  IP –  192.168.3.2 / 24, IP Aralığı – 192.168.3.5 ~ 15

clip_image012

3)     Fiziksel Bağlantılar

Sunucu konfigürasyonlarını takiben yapımızda bulunan tüm bileşenlerin fiziksel bağlantılarını yapıyoruz. Bu aşamada daha önce belirttiğimiz gibi IT bölümü Switch üzerinde bulunan portlardan Fa0/1~5 aralığını, Finans bölümü Fa0/6~10 aralığını, İnsan Kaynakları bölümü de Fa0/11~15 aralığını kullanacaktır.

clip_image014

 

Fiziksel bağlantıları tamamladıktan sonra istemciler için IP ayarlarını gerçekleştireceğiz. Uygulama standartlarına göre statik IP’nin aktif olduğu istemcileri DHCP’den IP alacak şekilde uyarlıyoruz.

IT’nin 1. İstemcisi ( ITPC0 ) DHCP’den ilk IP olan 192.168.1.5’i kiralamıştır.

clip_image016

Finans bölümünün 1. İstemcisi ( FIN_PC4 ) DHCP’den ilk IP olan 192.168.2.5’i kiralamıştır.

clip_image018

Son olarak İnsan Kaynakları bölümünün istemcilerini ayarlıyoruz. İnsan Kaynakları bölümünün 1. İstemcisi ( IK_PC8 ) DHCP’den ilk IP olan 192.168.3.5’i kiralamıştır.

clip_image020

              

Böylece yapımızda bulunan 12 istemci, aynı VLAN’da bulundukları DHCP Sunucusu’nda IP alarak ağa dahil olmuşlardır. Artık yavaş yavaş son kontrollerimizi yapacağımız bölüme geçiş yapabiliriz.

4)     Genel Kontroller

Senaryomuzun başında bahsettiğimiz gibi Switch üzerinde VLAN’lar oluşturuldu, Sunucular ve İstemciler konfigüre edildi, fiziksel bağlantılar gerçekleştirildi ve son kontroller aşamasına geldik. Şimdi Sunucular ve İstemciler arasındaki iletişimi kontrol edeceğiz.

Bu işlemi komut satırından Ping komutu ile gerçekleştirebiliriz. Ancak pratik olması açısından CPT’nin “ Add Simple PDU ” özelliğini kullanacağız.

Yaptığımız kontrollerde Sunucular ve İstemciler arasındaki iletişimin sorunsuz olduğu görülmektedir.

IT bölümü için;

clip_image022

Finans bölümü için;

clip_image024

İnsan Kaynakları bölümü için;

clip_image026

Yukarıda yapılan işlemi kısaca açıklayacak olursak; kaynak IP’den hedef IP’ye ICMP paketi gönderiliyor ve aradaki iletişim kontrol ediliyor. Eğer sonuç olumlu ise Last Status bölümünde “ Successful “ beliriyor. Ancak sonuç olumsuz ise yani iletişim yoksa Last Status bölümünde aşağıdaki gibi “ Fail “ belirecektir.

clip_image028

Takip eden makalelerde Cisco Packet Tracer ile yeni senaryolar üzerinde çalışmalar yapılacaktır.

Bu döküman’a eklenecekler;

1)      Router ile WAN bağlantıları.

2)      Layer 3 Switch ile InterVLAN Routing.

Makalemin bu bölümünün sonuna geldik, umarım faydalı olmuştur.

Makaleyi Paylaş

Cevap bırakın