Anasayfa » Cisco Packet Tracer CPT – InterVLAN Routing

Makaleyi Paylaş

Cisco

Cisco Packet Tracer CPT – InterVLAN Routing

Serimizin son makalesinde L3 Switch üzerinde bulunan VLAN’ların birbirleri ile haberleşmeleri için bir senaryo geliştireceğiz. Bu işlem için de “ Inter VLAN Routing “ kavramından bahsedeceğiz. Normal şartlarda bu işlemi yapabilmemiz için Router kullanmamız gerekmektedir. Ancak L3 Switch kullanarak da bu işlemi gerçekleştirebiliriz. Bu makalede aynı lokasyonda farklı VLAN’da bulunan Sunucu, İstemci, Yazıcı vb. cihazların Router kullanmadan da iletişime geçebileceğini göstereceğiz. Bu yöntem ile ekstra Router gereksiniminden ve oluşacak bütçeden sıyrılabiliriz.

Senaryomuzda L3 Switch üzerinde 2 VLAN oluşturulacaktır. Sonrasında ise Depolama Sunucuları ayrı bir VLAN’da, İstemciler, Yazıcılar ve IP Telefonlar ayrı bir VLAN’da konumlandırılacaktır. Tüm bileşenler L3 seviyesinde hizmet veren Omurga Switch’e L2 Kenar Switch’ler üzerinden ulaşacaktır. Ekipman listemiz aşağıdaki gibidir.

clip_image001

Genel bilgi kısmından sonra senaryomuza bileşenlerin Uygulama Alanı’nda konumlandırılması ile devam ediyoruz. Öncelikli olarak Omurga ve Kenar Switch rolünü üstelenecek bileşenlerimizi sürükle-bırak mantığıyla taşıyoruz.

clip_image003

Omurga ve Kenar Switch olmak üzere 3 adet bileşeni Uygulama Alanı’nda konumlandırdık. Bunlardan Kenar_Switch_1 olarak isimlendirilen Swicth, Sunucular’a hizmet verirken, Kenar_Switch_2 ise İstemciler’e ve diğer bileşenlere hizmet verecektir. Sırası ile Omurga ve Kenar Switchler’in konfigürasyonuna geçebiliriz.

Sponsor

Omurga Switch Konfigürasyonu

osw#conf terminal

osw(config)#vlan 10

osw(config-vlan)#name Sunucu

osw(config-vlan)#exit

osw(config)#interface Gig0/1

osw(config-if)#switchport mode trunk

osw(config-if)#switchport access vlan 10

osw(config-if)#exit

osw(config)#interface vlan 10

osw(config-if)#ip address 192.168.1.1 255.255.255.0

osw(config-if)#exit

osw#conf terminal

osw(config)#vlan 20

osw(config-vlan)#name Ofis

osw(config-vlan)#exit

osw(config)#interface Gig0/2

osw(config-if)#switchport mode trunk

osw(config-if)#switchport access vlan 20

osw(config-if)#exit

osw(config)#interface vlan 20

osw(config-if)#ip address 192.168.2.1 255.255.255.0

osw(config-if)#exit

osw(config)#ip routing

osw(config)#do wr mem

Building configuration…

[OK]

 

Kenar Switch 1 Konfigürasyonu

kenar1#conf terminal

kenar1(config)#vlan 10

kenar1(config-vlan)#name kenar1

kenar1(config-vlan)#exit

kenar1(config)#interface range Fa0/1-24, Gig0/2

kenar1(config-if-range)#switchport mode access

kenar1(config-if-range)#switchport access vlan 10

kenar1(config-if-range)#exit

kenar1(config)#interface Gig0/1

kenar1(config-if)#switchport mode access

kenar1(config-if)#switchport mode trunk

kenar1(config-if)#exit

kenar1(config)#interface vlan 10

kenar1(config-if)#ip address 192.168.1.2 255.255.255.0

kenar1(config-if)#exit

kenar1(config)#do wr mem

Building configuration…

[OK]

 

Kenar Switch 2 Konfigürasyonu

kenar2#conf terminal

kenar2(config)#vlan 20

kenar2(config-vlan)#name kenar2

kenar2(config-vlan)#exit

kenar2(config)#interface range Fa0/1-24, Gig0/2

kenar2(config-if-range)#switchport mode access

kenar2(config-if-range)#switchport access vlan 20

kenar2(config-if-range)#exit

kenar2(config)#interface Gig0/1

kenar2(config-if)#switchport mode access

kenar2(config-if)#switchport mode trunk

kenar2(config-if)#exit

kenar2(config)#interface vlan 20

kenar2(config-if)#ip address 192.168.2.2 255.255.255.0

kenar2(config-if)#exit

kenar2(config)#do wr mem

Building configuration…

[OK]

 

NOT : Omurga Switch üzerinde bulunan Gig0/1 ve Gig0/2 portları Trunk Mod’da ayarlanmıştır. Aynı şekilde Kenar Switchler’in Gig0/1 portları da Trunk Mod’da konfigüre edilmiştir.

Switch konfigürasyonlarımızı tamamladık ve cihazları Trunk Mod’a uyarlanmış portlar üzerinden birbirlerine bağlıyoruz.

clip_image005

Bu işlemi takiben Sunucularımızı ve İstemcilerimizi konumlandırıp, IP ayarlarını gerçekleştireceğiz. Sunucular ile başlayabiliriz.

clip_image006

“ srv1 ~ srv4 “ olarak tüm Sunucularımızı konumlandırdık ve 192.168.1.0 IP bloguna uygun olarak IP, SM ve GW değerlerini tanımladık. Burada dikkat etmemiz gereken en önemli nokta GW tanımlamalarında Omurga Switch üzerindeki VLAN’a verilen IP’nin tanımlanmasıdır. Örneğin Sunucuların bulunduğu VLAN’ın IP’si 192.168.1.1 / 24 ise buna göre Sunucular’a aynı sınıfta bir IP adresi, GW olarak da VLAN’a atanan IP adresi tanımlanmalıdır. Aşağıdaki 1. resimde Omurga Switch üzerinde Sunucular için tanımlanan VLAN’ın IP’si 192.168.1.1 görülmektedir. 2. resimde ise “ srv1 “ isimli Sunucu’nun IP, SM ve GW değerleri bulunmaktadır.

clip_image008

 

clip_image010

Sunucular üzerindeki işlemlerimizi tamamlamış bulunuyoruz. Şimdi de diğer VLAN üzerinde bulunan bileşenleri konumlandırıp, konfigüre edeceğiz.

clip_image012

Ofis tarafında bulunan İstemci, Yazıcı ve Telefonları da konumlandırdık ve “ srv5 “ isimli DHCP Sunucusu üzerinden diğer bileşenlere IP, SM, GW vb. değerleri atadık. Öncelikli olarak aynı VLAN’da bulunan Sunucu ve İstemcilerin iletişim durumlarını kontrol edeceğiz.

NOT : Diğer VLAN’da olduğu gibi burada da GW değeri Omurga Switch üzerinde tanımlı VLAN’ın IP değeri ( 192.168.2.1 ) olarak belirtilimiştir.

Sunucu VLAN’ı için;

“ srv1 – srv2 – srv3 – srv4 “ arasındaki iletişim “ Add Simple PDU “ yöntemi ile kontrol edildi ve gönderilen ICMP’lerin hedeflerine sorunsuz ulaştığı gözlemlendi.

clip_image014

 

Ofis VLAN’ı için;

“ srv5 – PC0 – PC2 – PC4 – PC1 “ arasındaki iletişimi de aynı yöntem ile kontrol ediyoruz ve haberleşmede herhangi bir sorun olmadığı görülüyor.

clip_image016

 

Her iki VLAN’da da bulunan aygıtlar birbirleri ile sorunsuz haberleşebiliyorlar. Şimdi ise VLAN’lar arası iletişimi kontrol edeceğiz. Bu işlem sırasında  Add Simple PDU’nun yanı sıra “ Ping “ komutunu da kullanacağız.

 

Kontrol sürecine Sunucu VLAN’ı üzerinde bulunan “ srv2 “ ile başlıyoruz. Önce Ping komutu ile kontrollerimizi yapacağız. CPT’de bir Sunucu ya da İstemci ile komut satırında işlem yapabilmek için bileşenin üzerine 1 defa tıklıyoruz ve açılan pencereden “ Desktop “ sekmesi seçerek “ Command Prompt “ uygulamasını açıyoruz. Yapacağımız kontroller öncesinde “ ipconfig “ komutu ile Sunucu’nun IP, SM vb. bilgilerini kontrol ediyoruz. Böylece ekran çıktımızda IP adreslerinin ne olduğu daha anlamlı duruma geliyor. “ Ping “ komutu ile Ofis VLAN’ı üzerinde bulunan “ srv5 “ isimli Sunucu’ya erişimi kontrol ediyoruz.

clip_image018

Aynı işlemi daha pratik olan “ Add Simple PDU “ ile yapıyoruz ve sonucun değişmediğini gözlemliyoruz.

clip_image020

Şimdi de Ofis VLAN’ı üzerinde bulunan “ PC4 “ isimli İstemci’den diğer VLAN’da bulunan “ srv1 “ isimli Sunucu’ya erişelim. Yukarıda belirttiğimiz yöntemle komut satırını açıyoruz ve Ping komutu ile erişimi kontrol ediyoruz.

clip_image022

Aynı işlemi diğer yöntem ile gerçekleştiriyoruz.

clip_image024

Gerek “ Ping “ komutu gerekse de “ Add Simple PDU “ yöntemi ile yaptığımız testler gösteriyor ki VLAN’lar arası iletişimde herhangi bir sorun bulunmamaktadır.

VLAN’lar arası iletişim olduğuna göre İstemciler, ortak veri tabanı üzerinde işlemler yapabilirler, paylaşımlara erişebilirler. Ayrıca farklı VLAN’lar üzerinde bulunan Sunucular’ın ve İstemciler’in ağ trafiği birbirlerini etkilemeyecektir. Böylece daha hızlı işlem yapılabilmesi sağlanmış, olası dar boğazlar engellenmiştir.  

Bu makale ile 4 bölümden oluşan serimizi tamamlamış oluyoruz, umarım faydalı olmuştur. Yeni makalelerde görüşmek dileklerimle.

NOT : Serinin yayımlanmış olan ilk 3 makalesine aşağıdaki linkler ile ulaşabilirsiniz.

Cisco Packet Tracer – Bölüm 1

Cisco Packet Tracer – Bölüm 2

Cisco Packet Tracer – Bölüm 3

 

 

Makaleyi Paylaş

Cevap bırakın