Anasayfa » Cisco Packet Tracer CPT – Router ile WAN Konfigürasyonu

Makaleyi Paylaş

Cisco

Cisco Packet Tracer CPT – Router ile WAN Konfigürasyonu

Serimizin 1. bölümünde Cisco Packet Tracer ile ilgili genel bilgi vermiştik. 2. bölümünde ise teorik bilgimizi pratiğe dökerek VLAN Konfigürasyonu’ndan bahsetmiştik. Bu bölümde ise farklı şehirlerde bulunan şubelerin Router üzerinde birbirine bağlanması ve farklı bölgelerde bulunan bileşenlerin birbirleri ile haberleşmesini sağlayacağız.

Test senaryomuza göre;

Merkez şubesi İstanbul’da bulunan bir firmanın Kırklareli ve Tekirdağ şubeleri WAN üzerinden birbirine bağlanacaktır. Bağlantı sonrasında merkez ve yan şubeler ortak veri tabanı üzerinden çalışmalar yapacak ve tüm bilgiler merkez şubede bulunan Sunucular’da toplanacaktır. Bu bağlamda yapımızda aşağıdaki bileşenler kullanılacaktır.

 

İstanbul Şubesi

Kırklareli Şubesi

 

Tekirdağ Şubesi

 

1 adet Cisco 1841 Router

1 adet Cisco 3560 24 Port L3 Switch

1 adet AP

5 adet Sunucu ( DHCP, File, Web )

10 adet İstemci

2 adet Yazıcı

1 adet Cisco 1841 Router

1 adet Cisco 3560 24 Port L3 Switch

1 adet AP

1 adet Sunucu ( DHCP, File, Web )

5 adet İstemci

1 adet Yazıcı

 

1 adet Cisco 1841 Router

1 adet Cisco 3560 24 Port L3 Switch

1 adet AP

1 adet Sunucu ( DHCP, File, Web )

5 adet İstemci

1 adet Yazıcı

 

 

Temel bilgileri paylaştıktan sonra senaryomuzu uygulamaya başlıyoruz. Öncelikli olarak her şube için 1 adet Router konumlandırıyoruz. Bu işlem için Router bölümünden Cisco 1841 modelini sürükle-bırak yöntemi ile uygulama alanımıza getiriyoruz.

Sponsor

clip_image002

 

clip_image004

 

Resimde de görebileceğiniz gibi her şube için Router’lar seçildi ve topolojideki isimleri bulundukları şehirlere göre verildi. İstanbul için “ ist “, Kırklareli için “ keli “ ve Tekirdağ için “ tdag “ isimleri atandı. Artık router ayarlarına geçiş yapabiliriz. Sırasıyla İstanbul, Kırklareli ve Tekirdağ router’ı konfigüre edilecektir.

NOT : Belirtilen isimler sadece topoloji üzerinde görsel olarak geçerlidir. Router’ların asıl isimleri ( hostname ) konfigürasyon sırasında verilecektir.

 

İstanbul Şubesi Router Konfigürasyonu

Bu işlem için CPT’nin biz kullanıcılara sağladığı esneklikten faydalanarak Config bölümünden de yapabiliriz. Ancak gerçek bir Router üzerinde çalışıyor gibi CLI’dan işlem yapmamız kendimizi geliştirmemiz adına faydalı olacaktır.

clip_image006

Aşağıdaki adımları Router üzerinde uygulayarak gerekli konfigürasyonu gerçekleştiriyoruz. Komutların açıklamaları kırmızı ile belirtilmiştir.

Router>enable Ayrıcalıklı Mod’a geçiş yapar.

Router#conf terminal Global Configuration Mod’a geçiş yapar.

Router(config)#service password-encryption Type 7 ile tanımlanan şifrelerin gösterimini gizler.

Router(config)#enable password ist34router01 Router’a “ ist34router01 “ olarak şifre atar.

Router(config)#hostname istrouter01 Router’ın adını “ istrouter01 “ olarak değiştirir.

istrouter01(config)#interface Fa0/0 Fa0/0 için IP / SM vb. ayarları başlatır.

istrouter01(config-if)#ip address 192.168.1.1 255.255.255.0 Fa0/0’a IP ve SM atar.

istrouter01(config-if)#no shutdown Portu aktif duruma getirir.

istrouter01(config-if)#exit Çıkış.

istrouter01(config)#interface Serial0/1/0 Serial0/1/0 için IP / SM vb. ayarları başlatır.

istrouter01(config-if)#ip address 192.168.4.2 255.255.255.0 Serial0/1/0’a IP / SM atar.

istrouter01(config-if)#no shutdown Portu aktif duruma getirir.

istrouter01(config-if)#exit Çıkış.

istrouter01(config)#interface serial0/1/1 Serial0/1/1 için IP / SM vb. ayarları başlatır.

istrouter01(config-if)#ip address 192.168.5.2 255.255.255.0 Serial0/1/1’e IP / SM atar.

istrouter01(config-if)#no shutdown Portu aktif duruma getirir.

istrouter01(config-if)#exit Çıkış.

istrouter01(config)#router rip RIP’i aktif duruma getirir.

istrouter01(config-router)#network 192.168.1.0  192.168.1.0 için yönlendirme yapar.

istrouter01(config-router)#network 192.168.4.0  192.168.4.0 için yönlendirme yapar.

istrouter01(config-router)#network 192.168.5.0  192.168.5.0 için yönlendirme yapar.

istrouter01(config-router)#do wr mem → Değişiklikleri kaydeder.

Building configuration…

istrouter01#copy running-config startup-config → Değişiklikleri kaydeder. ( Diğer yöntem )

Destination filename [startup-config]?

Building configuration…

[OK]

 

Özet olarak; İstanbul şubesinde bulunan Router konfigüre edildi ve iç bacak ( Fa0/0 ), dış bacaklara ( Serial0/1/0 –  Serial0/1/1 ) IP – SM tanımları yapıldı ve yönlendirmeler gerçekleştirildi. Bu adımda ise Kırklareli ve Tekirdağ şubelerinde bulunan Router’lar için konfigürasyona geçiyoruz. Konfigürasyon adımlarında tekrar olmaması nedeniyle açıklamalara yer verilmeyecektir. Kırklareli ve Tekirdağ şubeleri için direkt CLI ekranı paylaşılacaktır. 

Kırklareli Şubesi Router Konfigürasyonu

clip_image008

 

Tekirdağ Şubesi Router Konfigürasyonu

clip_image010

               Konfigürasyon işleminden sonra Router’ları birbirine bağlıyoruz ve şubeler arasındaki iletişimi kontrol ediyoruz.

clip_image012

 

Bu işlemi takiben “ Add Simple PDU “ ile şubeler arası iletişimi kontrol ediyoruz ve sonuçları gözlemliyoruz. Aynı işlemi CLI’dan “ ping “ ile gerçekleştireceğiz ve “ sh ip route “ ile yönlendirme haritasını göreceğiz.

“ Add Simple PDU “ işleminin sonucuna göre;

               Şubeler arası gönderilen ICMP’lerin sorunsuz olarak hedefe ulaştığı görülmektedir.

clip_image014

 

“ Ping “ işleminin sonucuna göre;

İstanbul şubesinden Kırklareli ( 192.168.5.1 ) ve Tekirdağ ( 192.168.4.1 ) şubelerine erişim sorunsuz görünmektedir.

clip_image016

 

 

Kırklareli şubesinden İstanbul ( 192.168.5.2 ) ve Tekirdağ ( 192.168.4.1 ) şubelerine erişim sorunsuz görünmektedir.

clip_image018

Tekirdağ şubesinden İstanbul ( 192.168.4.2 ) ve Kırklareli ( 192.168.5.1 ) şubelerine erişim sorunsuz görünmektedir.

clip_image020

 “ sh ip route “ komutunun sonucuna göre;

İstanbul şubesinden diğer şubelere erişim detayları.

clip_image022

Kırklareli şubesinden diğer şubelere erişim detayları.

clip_image024

Tekirdağ şubesinden diğer şubelere erişim detayları.

clip_image026

C ile başlayan satır direkt bağlantıyı ifade ederken, R ile başlayan satır ise başka bir Router üzerinden geçerek erişim yapıldığını ifade eder. Yukarıdaki resimde Tekirdağ şubesi İstanbul şubesine ( 192.168.4.0 ) direkt erişirken, Kırklareli şubesine ( 192.168.5.0 ) erişim ise İstanbul şubesi üzerinden yapılmaktadır.

Tüm şubelerdeki router konfigürasyonunu tamamladık ve artık Switch konfigürasyonuna geçiş yapıyoruz.

 

 

 

Switch Konfigürasyonu

Ekipman listesinde belirttiğimiz üzere yapımızda Cisco 3560-24PS L3 ( 24 Port Fast Ethernet – 2 Port Gigabit ) Switch kullanılacaktır.

clip_image028

Switch’leri sürükle-bırak yöntemi ile uygulama alanına taşıyoruz ve konfigürasyona başlıyoruz.

clip_image030

 

İstanbul Şubesi Switch Konfigürasyonu

NOT : 1. ve 2. bölümlerde Switch konfigürasyonuna detaylı yer verilmesi nedeniyle bu makalede komutlar ile ilgili herhangi bir açıklama yapılmayacaktır.

clip_image032

CLI’da;

Switch>enable

Switch#conf terminal

Switch(config)#service password-encryption

Switch(config)#enable password ist34switch01

Switch(config)#hostname istosw

istosw(config)#vlan 100

istosw(config-vlan)#name istvlan1

istosw(config-vlan)#exit

istosw(config)#interface range Fa0/1-24, Gig0/1-2

istosw(config-if-range)#switchport mode access

istosw(config-if-range)#switcport access vlan 100

istosw(config-if-range)#switchport access vlan 100

istosw(config-if-range)#exit

istosw(config)#interface vlan 100

istosw(config-if)#ip address 192.168.1.2 255.255.255.0

istosw(config-if)#no shutdown

istosw(config-if)#exit

istosw(config-if)#ip default-gateway 192.168.1.1

istosw(config)#do wr mem

Building configuration…

[OK]

Yukarıdaki komutlar ile İstanbul şubesinde bulunan Switch’in konfigürasyonunu tamamlamış oluyoruz. CLI’dan ping atarak Switch’in diğer şubeler ile irtibata geçebildiğini görüyoruz. Şimdi diğer şubelerdeki Switch’leri konfigüre edeceğiz.

clip_image034

Kırklareli Şubesi Switch Konfigürasyonu

“ sh run” komutunun sonucuna göre Switch konfigürasyonumuzun sorunsuz olarak tamamlandığı görülüyor.

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

service password-encryption

!

hostname keliosw

enable password 7 082A4942004A5C0405021807227B75

spanning-tree mode pvst

interface FastEthernet0/1

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/2

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/3

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/4

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/5

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/6

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/7

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/8

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/9

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/10

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/11

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/12

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/13

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/14

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/15

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/16

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/17

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/18

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/19

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/20

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/21

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/22

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/23

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/24

 switchport access vlan 100

 switchport mode access

!

interface GigabitEthernet0/1

 switchport access vlan 100

 switchport mode access

!

interface GigabitEthernet0/2

 switchport access vlan 100

 switchport mode access

!

interface Vlan1

 no ip address

 shutdown

!

interface Vlan100

 ip address 192.168.3.2 255.255.255.0

ip default-gateway 192.168.3.1

ip classless

ip flow-export version 9

line con 0

line aux 0

line vty 0 4

 login

end

Tekirdağ Şubesi Switch Konfigürasyonu

“ sh run” komutunun sonucuna göre Switch konfigürasyonumuzun sorunsuz olarak tamamlandığı görülüyor.

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

service password-encryption

!

hostname tdagosw

enable password 7 0835484F0E4C5C0405021807227B75

!

spanning-tree mode pvst

!

interface FastEthernet0/1

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/2

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/3

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/4

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/5

 switchport access vlan 100

 switchport mode access

interface FastEthernet0/6

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/7

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/8

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/9

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/10

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/11

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/12

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/13

 switchport access vlan 100

 switchport mode access

interface FastEthernet0/14

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/15

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/16

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/17

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/18

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/19

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/20

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/21

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/22

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/23

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet0/24

 switchport access vlan 100

 switchport mode access

!

interface GigabitEthernet0/1

 switchport access vlan 100

 switchport mode access

!

interface GigabitEthernet0/2

 switchport access vlan 100

 switchport mode access

!

interface Vlan1

 no ip address

 shutdown

interface Vlan100

 ip address 192.168.2.2 255.255.255.0

ip default-gateway 192.168.2.1

ip classless

ip flow-export version 9

line con 0

line aux 0

line vty 0 4

 login

end

Router ve Switch konfigürasyonlarımızı tamamladık ve şubelerin birbirleri ile iletişime geçebildiklerini kontrol ettik. Bu aşamadan sonra Sunucu, İstemci ve diğer bileşenlerimizi konumlandıracağız.

clip_image036

 

Merkez şube olan ve aynı zamanda Sunucu sistemlerinin ağırlıkta olduğu İstanbul şubesinden başlıyoruz. Makalemizin başında paylaştığımız ekipman listesine göre şubemizde 5 adet Sunucu, 10 adet İstemci, 1 adet AP ve 2 adet Yazıcı konumlandırılacaktır.

clip_image038

 

Merkez şubede bulunan tüm bileşenler uygulama alanı’nda konumlandırıldı. “ istsrv1 “ isimli Sunucu için DHCP rolünü uyarladık ve İstemciler’e IP dağıtmasını sağladık.  Benzer işlemleri yan şubeler için de uygulayacağız ve asıl konumuz olan şubeler arası iletişimi kontrol edeceğiz.

 

 

 

clip_image040

Yukarıda gördüğünüz gibi tüm şubeler için bileşenler konumlandırıldı ve son ayarları yapıldı. Artık Sunucular ve İstemciler üzerinden şubeler arası iletişimi kontrol edebiliriz. Bu işlem için en pratik çözüm olan Add Simple PDU yönetimini kullanacağız.

 

İstanbul Şubesi – Kırklareli Şubesi Erişim Kontrolü

Aşağıdaki resimde   istsrv1 ” isimli Sunucu’dan “ kelisrv1 “ Sunucusu’na, “ kelipc1 “ İstemcisi’nden “ istsrv1 “ Sunucusu’na erişim sağlanabildiği görülmektedir. Aynı işlemi diğer şubeler için de gerçekleştireceğiz.

clip_image042

 

İstanbul Şubesi – Tekirdağ Şubesi Erişim Kontrolü

Aşağıdaki resimde   istsrv3 ” isimli Sunucu’dan “ tdagsrv1 “ Sunucusu’na,   istsrv3 ” isimli Sunucu’dan “ tdagpc4 “ İstemcisi’ne ve “ tdagpc1 “ İstemcisi’nden “ istsrv4 “ Sunucusu’na erişim sağlanabildiği görülmektedir.

clip_image044

 

 

Kırklareli Şubesi – Tekirdağ Şubesi Erişim Kontrolü

Aşağıdaki resimde   kelisrv1 ” isimli Sunucu’dan “ tdagsrv1 “ Sunucusu’na,   tdagpc1 ” isimli İstemci’den “ kelipc2 “ İstemcisi’ne erişim sağlanabildiği görülmektedir.

clip_image046

Özet olarak;

Farklı noktalarda bulunan Router’lar konfigüre edildi ve şubelerin birbirleri ile irtibata geçmesi sağlandı. Bu işlemi takiben Switch’ler konfigüre edildi ve bileşenler konumlandırıldı. Ardından şubelerde bulunan Sunucular ve İstemciler’in iletişim durumları kontrol edildi. Yaptığımız tüm işlemler neticesinde makalemizin başında belirttiğimiz gibi her şube kendi içerisinde diğer şubeler ile iletişime geçebilmektedir.

 

NOT : Şubelere ait IP bilgileri aşağıdaki gibidir.

 

İstanbul

Tekirdağ

Kırklareli

IP Grubu ( Lokal Ağ )

192.168.1.0 / 24

192.168.2.0 / 24

192.168.3.0 / 24

IP Aralığı

192.168.1.1 ~ 40

192.168.2.1 ~ 40

192.168.3.1 ~ 40

Router Fa0/0 ( İç Bacak )

192.168.1.1

192.168.2.1

192.168.3.1

Router Serial 0/1/0 ( Dış Bacak )

192.168.4.2

192.168.4.1

192.168.5.1

Router Serial 0/1/1 ( Dış Bacak )

192.168.5.2

– – – – – – – – –

– – – – – – – – –

Switch

192.168.1.2

192.168.2.2

192.168.3.2

 

Takip eden makalelerde Cisco Packet Tracer ile yeni senaryolar üzerinde çalışmalar yapılacaktır.

Bu döküman’a eklenecekler;

1)      Layer 3 Switch ile InterVLAN Routing.

 

Makaleyi Paylaş

Cevap bırakın