ADFS 3.0 - IIS prob...
 
Bildirimler
Hepsini Temizle

ADFS 3.0 - IIS problemi  

  RSS
Zafer Balkan
(@zaferbalkan)
Üye

Merhaba, 

Server 2012 R2 üzerinde ADFS 3.0 Kurulumu sonrası ilk kontrol olan https://sunucu.local/FederationMetadata/2007-06/FederationMetadata.xml sayfasını 5. kez baştan kuruluma rağmen göremiyorum.

ADFS 3.0 IIS kullanmasa da browser'a doğru xml cevabını verecek, /adfs/fs/ sayfasını görüntüleyecek bir servis olmalı.

 

Bazı kaynaklarda IIS üzerinde Default Web Site altında oluşturulmuş ve HTTP + HTTPS üzerinden yayın yapan bir site gördüm. Kurulumda hiç adı geçmediği halde söz konusu site ve application pool kurulduğuna göre bunun ADFS'in kurulumu esnasında kurulduğuna kanaat getirdim ama teyit edemedim.

Ek bilgi olarak veritabanını SQL Express ile kendi üzerine değil, network ve veritabanı üzerinde yetkili bir servis kullanıcısı ile bir başka sunucuda çalışan SQL Server instance'ı üzerine kurduğumu belirteyim.Veri bağlantısı konusunda hiç hata almadım, zira her defasında iki veritabanı oluştu. Kaldırırken veritabanını da sildim.

Tek yapmadığım şey ADSI Edit ile AD üzerinde yapılmış değişiklikleri kontrol etmek. Ama onu da yerelde web hizmetinin çalışmasıyla alakası yoktur diye gözardı ettim.

 

Bir fikri olan var mı? 

Alıntı
Gönderildi : 11/04/2019 17:45
Engin Kosova
(@enginkosova)
Üye Forum Yöneticisi

Merhaba,

Adresi aşağıdaki sekilde cağırmayı deneyebilir misiniz?

Https://sunucu.local:30091/FederationMetadata/2007-06/FederationMetadata.xml

****************************************************************
Probleminiz çözüldüğünde sonucu burada paylaşırsanız,
sizin ile aynı problemi yaşayanlar için yardım etmiş olursunuz.
Eğer sorununuz çözüldü ise "çözüldü" olarak işaretlerseniz
diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 11/04/2019 20:59
Zafer Balkan
(@zaferbalkan)
Üye

Merhaba Hocam,

Şu an bilgisayarın başında değilim ama yarın sabah ilk iş deneyeceğim.

Söylediğim gibi, IIS üzerinde portların bind edildiği bir yer yok. Bu portu ADFS servisi doğrudan kendisi mi karşılıyor? İlk kez kurduğum için benim için fazlasıyla yeni bir konu şu an.

CevapAlıntı
Gönderildi : 11/04/2019 21:06
Engin Kosova
(@enginkosova)
Üye Forum Yöneticisi

Import ettiğiniz sertifika türü nedir?

Endpoint url bilgisini aşağıdaki powershell ile çekebilirsiniz.

Get-AdfsEndpoint | select fullurl

Ayrıca aşağıdaki şekilde localhost olarak gitmeyi de dener misiniz?

https://localhost/FederationMetadata/2007-06/FederationMetadata.xml

https://localhost/adfs/fs/federationserverservice.asmx

****************************************************************
Probleminiz çözüldüğünde sonucu burada paylaşırsanız,
sizin ile aynı problemi yaşayanlar için yardım etmiş olursunuz.
Eğer sorununuz çözüldü ise "çözüldü" olarak işaretlerseniz
diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 11/04/2019 21:59
Zafer Balkan
(@zaferbalkan)
Üye

Son durumu bildireyim. Toplamda 5 kez baştan ADFS, 2 kez baştan Windows kurulumu sonrasında, her defasında bire bir aynı şeyleri yaptığımız halde çalışmayan şey nihayet çalıştı. Öncesinde neden çalışmadığını bulamadık. Sonrasında neden çalıştığını bulamadık. Ama oldu. @EnginKosova, ilginiz için teşekkürler hocam.

CevapAlıntı
Gönderildi : 12/04/2019 19:36
Engin Kosova beğendi
Engin Kosova
(@enginkosova)
Üye Forum Yöneticisi

Problemin çözülmesine sevindim. Geçmiş olsun.

****************************************************************
Probleminiz çözüldüğünde sonucu burada paylaşırsanız,
sizin ile aynı problemi yaşayanlar için yardım etmiş olursunuz.
Eğer sorununuz çözüldü ise "çözüldü" olarak işaretlerseniz
diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 15/04/2019 14:50
Zafer Balkan beğendi
Paylaş: