Forum

Server 2012 R2 Fail...
 
Bildirimler
Hepsini Temizle

Server 2012 R2 Failover Cluster Kurulum Sorunu

onur pekdag
(@onurpekdag)
Üye

Selamlar,

 VmWare ortamında bir DC  ve cluster için 2 adet node bulunmakta.Cluster kurulumu için gerekli tüm adımları kontrol ederek rol kurulumları, diskleri bağlama gibi işlemlerin tamamını gerçekleştirdim.Cluster create işlemine başlamadan önce validate check işleminde herhangi bir error ile karşılaşmadığım halde kurulum sırasında aşağıdaki hata mesajı ile karşılaştım.Konu ile ilgili yardımlarınızı ve önerilerinizi beklerim.

Create İşlemi sırasında aldığım hata iletisi şu şekilde ; 

There was an error cleaning up the cluster nodes. Use Clear-ClusterNode to manually clean up the nodes.

An error occurred while creating the cluster.

An error occurred creating cluster 'FailClass'.

This operation returned because the timeout period expired

To troubleshoot cluster creation problems, run the Validate a Configuration wizard on the servers you want to cluster.

 Event'a düşen ileti ise şu şekilde;

EVENT ID 1569 

Network 'Cluster Network 1' which has been disabled for failover cluster use, was found to be the only currently possible network that node 'NODE1' can use to communicate with other nodes in the cluster. This may impact the node's ability to participate in the cluster. Please verify network connectivity of node 'NODE1' and enable at least one network for cluster communication. Run the Validate a Configuration wizard to check your network configuration. 

İyi Çalışmalar.

Onur PEKDAĞ 

Alıntı
Konu başlatıcı Gönderildi : 26/09/2014 13:42
Efe Sülükçü
(@efesulukcu)
Üye

cluster kurulumları için kullanıcıların kullanmadığı sunucuların birbirleriyle iletişime geçebileceği bir heartbeat kart atamanız önerilir. siz sanırım tek network kartı ile bu işlemi yapıyorsunuz ve bu kartın diğer nodelarla iletişiminde sorun olacağı yazılmış.

 cluster validation check kısmında mutlaka bir hata ile karşılaşıyor olmanız lazım. daha önce deneme yanılma yapılmış gibi de duruyor hata. çünkü cluster nodelar evict edilmeden cluster silinmiş gibi bir hata var.

powershell üzerinden import-module failoverclusters komutundan sonra Clear-ClusterNode SUNUCUADI -Force komutunu her iki sunucuda da uygulayın. daha sonra tekrar validation yapın.

 ek olarak cluster tek node ile kurulabiliyor. tek node için kurulumunuzu tamamlayıp, network kartı sorunlu olan nodeu daha sonra ekleyebilirsiniz. 

 

CevapAlıntı
Gönderildi : 26/09/2014 14:05
onur pekdag
(@onurpekdag)
Üye

Efe Bey Merhaba,

Cluster kurulumu tamamlandı.Sizin önerilerinizle birlikte biraz  farklı bir durumda gerçekleşti.Şöyle ki, node1 ve node2 sunucularımı aynı anda cluster yapısına dahil ederken yukarıda yardım talep ettğim hata iletisi ile karşılaşıyorum.Üstelik bu hata iletisi öncesinde yaptığım validate check işlemini hata almadan bitirdiğim halde.Bu nokta bana tuhaf gelmişti.Fakat cluster create ederken nodelarımı tek tek cluster yapısına eklediğimde nodelar üzerinde hiçbir değişiklik yapmadan cluster yapımı oluşturabildim.Bu konuda fikrinizi merak ederim.

Yardımlarınız için ayrıca teşekkür ederim.İnce ayrıntı sayesinde kurulum tamamlandı. 

İyi Çalışmalar 

CevapAlıntı
Konu başlatıcı Gönderildi : 26/09/2014 20:15
Paylaş: