Forum

mailenable webmail ...
 
Bildirimler
Hepsini Temizle

mailenable webmail ekranı gelmiyor?

Erdem Yağlıkara
(@erdemyaglikara)
Üye

arkadaşlar merhaba 2003 server üzerine kurulu mailenable kullanıyoruz 2-3 gündür webmail ekranına giriş yapamaktayız servislere baktım herhangi bir problem yok mailenable içersindeki webmail i tekrar yapılandırdım ama değişen birşey yok sorun ne olabilir?

Alıntı
Konu başlatıcı Gönderildi : 08/03/2012 19:18

Özgür MAZLUM
(@ozgurmazlum)
Kıdemli Üye

[quote user="askerdem"]

arkadaşlar merhaba 2003 server üzerine kurulu mailenable kullanıyoruz 2-3 gündür webmail ekranına giriş yapamaktayız servislere baktım herhangi bir problem yok mailenable içersindeki webmail i tekrar yapılandırdım ama değişen birşey yok sorun ne olabilir?

[/quote]

Her hangi bir hata mesajı alıyormusunuz. IIS teki siteler yanıt veriyor webmail açılmıyorsa Mailenable servislerini kontrol etmenizi öneririm. Yada IIS üzerinde ilgili kayıt için bir sorun olmuş olabilir.

CevapAlıntı
Gönderildi : 08/03/2012 19:21

Erdem Yağlıkara
(@erdemyaglikara)
Üye

Hocam selam iis servislerini tekrardan restart ettim ama değişen bişey yok http://localhost/  olarak denediğinde ekrana hiç bişey gelmiyor..mail enable servislerindende bir sorun gözükmüyor 1 ay önceki mailenable backupları mevcut restore işlemi yapsam düzelirmi acaba?

CevapAlıntı
Konu başlatıcı Gönderildi : 08/03/2012 19:56

Özgür MAZLUM
(@ozgurmazlum)
Kıdemli Üye

[quote user="askerdem"]

Hocam selam iis servislerini tekrardan restart ettim ama değişen bişey yok http://localhost/  olarak denediğinde ekrana hiç bişey gelmiyor..mail enable servislerindende bir sorun gözükmüyor 1 ay önceki mailenable backupları mevcut restore işlemi yapsam düzelirmi acaba?

[/quote]
Öncesinde varolan yedeklerinizi de almanızda fayda var.

CevapAlıntı
Gönderildi : 12/03/2012 11:20

Tahsin Kandamar
(@TahsinKandamar)
Üye

Merhaba,

Server 2003 Standart Edi. sp2 üzerine Entrenix panel ve Mail Enable kurdum.  http://www.cozumpark.com/blogs/3party/archive/2012/01/01/mail-enable-standart-kurulumu-ve-standart-g-venlik-ayarlar.aspx

makalede olduğu gibi webmail.domain.com diyerek webmaile ulaşamıyorum. www.domain.com/webmail ile ulaşabiliyorum ancak bu seferde aşağıdaki hatayı alıyorum. 

 

security=true; $smarty->secure_dir=array("./"); $smarty->compile_dir = $temporary_directory; $smarty->assign("umLanguageFile",$selected_language.".txt"); $smarty->assign("umEmail",$f_email); $jssource = " "; //$smarty->debugging = true; $smarty->assign("umServerType",strtoupper($mail_server_type)); switch(strtoupper($mail_server_type)) { case "DETECT": break; case "ONE-FOR-EACH": $aval_servers = count($mail_servers); $smarty->assign("umAvailableServers",$aval_servers); if(!$aval_servers) die("You must set at least one server in \$mail_servers, please review your config.php"); if ($aval_servers == 1) { $strServers = "@".$mail_servers[0]["domain"]." "; } else { $strServers = "\r"; for($i=0;$i<$aval_servers;$i++) { $sel = ($i == $six)?" selected":""; $strServers .= "@".$mail_servers[$i]["domain"]."\r"; } $strServers .= "\r"; } $smarty->assign("umServer",$strServers); break; case "ONE-FOR-ALL": break; default: die("Unknown server mode, please see config.php"); } $smarty->assign("umUser",$f_user); $smarty->assign("umPass",$f_pass); $smarty->assign("umJS",$jssource); $avallangs = count($languages); if($avallangs == 0) die("You must provide at least one language"); $avalthemes = count($themes); if($avalthemes == 0) die("You must provide at least one theme"); $smarty->assign("umAllowSelectLanguage",$allow_user_change_language); $func($textout); if($allow_user_change_language) { $def_lng = (is_numeric($lid))?$lid:$default_language; $langsel = "\r"; for($i=0;$i<$avallangs;$i++) { $selected = ($lid == $i)?" selected":""; $langsel .= "".$languages[$i]["name"]."\r"; } $langsel .= "\r"; $smarty->assign("umLanguages",$langsel); } $smarty->assign("umAllowSelectTheme",$allow_user_change_theme); if($allow_user_change_theme) { $def_tem = (is_numeric($tid))?$tid:$default_theme; $themsel = "\r"; for($i=0;$i<$avalthemes;$i++) { $selected = ($tid == $i)?" selected":""; $themsel .= "".$themes[$i]["name"]."\r"; } $themsel .= "\r"; $smarty->assign("umThemes",$themsel); } $smarty->display("$selected_theme/login.htm"); 

CevapAlıntı
Gönderildi : 30/07/2012 21:33

Özgür MAZLUM
(@ozgurmazlum)
Kıdemli Üye

Host Header tanımlarınızı kontol edin iki şekilde yapabilirsiniz. Birincisi mailenable webmail IIS kaydı üzerinde her domain için bir tanım yaparsınız ikinciside 80. ci porta gelen webmail.* şeklindeki istekleri bu dizine gönderebilirsiniz.

CevapAlıntı
Gönderildi : 31/07/2012 12:04

Tahsin Kandamar
(@TahsinKandamar)
Üye

Üzülerek bir-iki soruyla anlamaya ve açıklamaya çalışayım hocam, müsaadenizle.

Öncelikle faydası olması umuduyla belirteyim. Sunucuyu firmada kurduğum ESXi 5 sunucuda barındırıyorum. Hosting ve maili tek ip üzerinden çalıştırmak zorundayım. Sanırım bu yüzdendir webmail.alanadi.com şeklinde değil de www.alanadi.com/webmail dediğimde webmaile ulaşabiliyorum. http://alanadi.com web sitesini görüntülüyor. www yerine entrenix'in varsayılan ayarlarında panel.alanadi.com/webmail şeklindeydi.

Webmaile yukarıdaki ayardan sonra ulaştım. Ancak önceki gönderide yer alan hata ile karşılaşıyordum. Hali hazırda firmanın kullandığı sunucudan php dosyalarını alıp çaşıştırmayı denedim ve düzeldi. Bu sefer de Mail Enable webmail yerine firmanın sunucusunda olmayan "uebimiau" webmail geliyor. Oturum açtığımda ise aşağıdaki hatayı alıyorum.

Warning: fsockopen() [function.fsockopen]: php_network_getaddresses: getaddrinfo failed: Bilinen böyle bir ana makine yok. in c:\entrenix\Entrenix\webmail\inc\class.uebimiau_mail.php on line 66

Warning: fsockopen() [function.fsockopen]: unable to connect to ..:110 (Unknown error) in c:\entrenix\Entrenix\webmail\inc\class.uebimiau_mail.php on line 66

Warning: Cannot modify header information - headers already sent by (output started at c:\entrenix\Entrenix\webmail\inc\class.uebimiau_mail.php:66) in c:\entrenix\Entrenix\webmail\msglist.php on line 21

 

66. satır :

$this->mail_connection = fsockopen($this->mail_server, $this->mail_port, $errno, $errstr, 15); 

 21. Satır :

if(!$UM->mail_connect()) { Header("Location: error.php?err=1&sid=$sid&tid=$tid&lid=$lid\r\n"); exit; }   

 

Kısaca süreci özet geçmeye çalıştım.Sanırım tam da dediğiniz host header tanımları hatası budur. Mail Enable kurduğumda iis içerisinde bir kayıt mı oluşturması gerekiyordu?Gerekiyorsa oluşturmadı. Bu sorunu yeniden yükleyerek çözebilir miyim? Şu anda iis üzerinde sadece alanadi.com, Entrenix, SharePoint ve Varsayılan Web Bölgesi kayıtları var.

 

CevapAlıntı
Gönderildi : 31/07/2012 20:48

Özgür MAZLUM
(@ozgurmazlum)
Kıdemli Üye

Önceliklwe siteadi.com /webmail yazınca açılıyor webmail.siteadi.com şekilde açılmıyorsa bu sorunun tek ip olması ile pek bir alakası yok. İkinci script ile ilgili bir bilgim yok o nedenle yönlendirme yapamam. Sorununu en pratik yoldan şu şekilde çözebilirsin. Webmail için açılmış olan IIS kaydı üzerinde webmail.alanadi.com şekilde bir header oluştur. Bunun için DNS üzerinde de bir kayıt aç sorunsuz açılması gerekiyor.

CevapAlıntı
Gönderildi : 01/08/2012 12:19

Paylaş: