IIS'de authenticati...
 
Bildirimler
Hepsini Temizle

IIS'de authentication sorunu  

  RSS
Teoman Efendi
(@TeomanEfendi)
Üye

 Web sitemizden intranete bir link verdim. Yani personel dışarıdayken içerdeki bir kaç kaynağa ulaşsın diye. Intranetin IIS görüntüsü aşağıda. Anonymous Authenticationu disable yapınca domaindeki kullanıcıların user name ve passwordu işe yaramıyor. Aşağıdaki ayarlardan hangilerini düzenlemem gerekir ki domain kullanıcıları login olabilsin.

  

Alıntı
Gönderildi : 05/01/2010 14:40
Bugra KESKIN
(@bugrakeskin)
Saygın Üye

Eğer kullanıcı dışarıdan bağlanıyorsa domain user olduğunu IIS anlayamaz. Bu durumda default web site üzerinde Anonymous authentication işaretli olmalıdır.

Exchange Server da yani OWA içinde aynı durum geçerlidir. Default Web Site üzerinde anonymous işaretli olmalı, altında ki directory lerde ise sadece Windows Authentication olmalıdır.

CevapAlıntı
Gönderildi : 05/01/2010 15:57
Teoman Efendi
(@TeomanEfendi)
Üye

Hocam öncedende anonymous seçili değildi orda nasıl çalışıyordu? Ben bu intraneti eski 2003 makineden yeni 2008 R2 makineye kopyaladım. Aynı ayarları taklit ettim, işin ilginç yanı ilk gün çalışıyrodu. Dün bir öğretmen login olamıyorum deyince farkettim. Altta halen aktif olan 2003 serverin görüntüsü var hocam. Web sitemizden bu servera yönlenmiş linke tıklayınca browser kullanıcı adı ve şifre soruyordu. Bizde domainde kullandığımız user name ve password ile giriş yapıyorduk. Ve ayarlar hemen alttaki gibiydi yani anonymousa kapalıydı.

Ben yinede dediğiniz şekilde denedim ancak bu sefer login kısmına cancel deyince siteye erişim yinede oluyordu.

 

 

CevapAlıntı
Gönderildi : 05/01/2010 23:31
Bugra KESKIN
(@bugrakeskin)
Saygın Üye

Son postunuzu çok iyi anlayamadım açıkçası.

Aynı network den yani içeriden bu internal site a ulaşabiliyor musunuz?

CevapAlıntı
Gönderildi : 05/01/2010 23:53
Teoman Efendi
(@TeomanEfendi)
Üye

Ozurdilerim hocam ben izah ederken biraz karistirdim. Isterseniz icb.qld.edu.au adresini girin ve orda ICB Intranet adresine tiklayin. Normalde bu anda sifre sormasi lazim ancak anonymousu kapatinca hic bir sifreyi kabul etmiyor. Icerden ayni sayfanin kopyasini farkli site olarak calistiriyoruz, yani teknik olarak farkli site olmus oluyor. Benim istedigim ICb Intanet linkine tiklayinca sifre sorgusunun tekrar gelmesi.

I

CevapAlıntı
Gönderildi : 06/01/2010 00:38
Teoman Efendi
(@TeomanEfendi)
Üye

Hocam simdi IISten default web site`in Anonymous unu tekrar disable ettim ve simdi calisiyor. Bunun sebebi ne olabilir ki? Simdi ayni siteye tekrar girerseniz goreceksiniz sifre soracak.

PDC`deki Endpointin Network Protectionunu disable ettim ve tekrar enable ettim. Hic bir degisiklikte yapmadim bunun haricinde.

CevapAlıntı
Gönderildi : 06/01/2010 01:21
Teoman Efendi
(@TeomanEfendi)
Üye

Al burdan yak tekrar eski haline döndü bu nedir hocam böyle. Böyle bir duruma ne sebebiyet verebilir?

CevapAlıntı
Gönderildi : 06/01/2010 10:21
Bugra KESKIN
(@bugrakeskin)
Saygın Üye

Yapıda ISA Server var mı?

CevapAlıntı
Gönderildi : 06/01/2010 12:29
Teoman Efendi
(@TeomanEfendi)
Üye

Hayır hocam ISA serverim yok. Linux serverin NATından direk olarak bu servera link verdim. Önceden aynı link ve aynı port eski 2003 serverima gidiyordu ve aynı website açılıyordu. O serveri kaldıaracğım için herşeyi yeni 2008 servera taşımaya başladım. Bundada böyle bir durumla karşılaştım.

CevapAlıntı
Gönderildi : 06/01/2010 13:08
Bugra KESKIN
(@bugrakeskin)
Saygın Üye

Şimdi IIS 6 ile IIS 7 arasında mimari biraz değiştiği için farklılıklar var.

Mutlaka bir yerde atladığın bişeyler olmalı ancak bazı şeyleri bakmadan anlayamıyoruz malesef.

Normalde Basic Authentication seçtiğiniz zaman parola sorup girişe izin veriyor. 

CevapAlıntı
Gönderildi : 07/01/2010 01:19
ugur pek
(@ugurpek)
Üye

bir inceleyin belki yardımı olur


http://support.microsoft.com/kb/324274

CevapAlıntı
Gönderildi : 07/01/2010 02:03
Teoman Efendi
(@TeomanEfendi)
Üye

[quote user="Bugra KESKIN"]

Şimdi IIS 6 ile IIS 7 arasında mimari biraz değiştiği için farklılıklar var.

Mutlaka bir yerde atladığın bişeyler olmalı ancak bazı şeyleri bakmadan anlayamıyoruz malesef.

Normalde Basic Authentication seçtiğiniz zaman parola sorup girişe izin veriyor. 

[/quote]

 

Bugra hocam bu mesajinizda dediginiz gibi sadece Basic Authentication`i sectim (windows Authentication`u Disable yaptim) ve simdlilk calisiyor gibi gorunuyor 🙂 Umarim aynen boyle gider:))

 

 Ugur Pek dostum verdiginiz linkide okudum sanirim mevzuyu kavramaya basladim..

 

Cok sagolun[Y]

CevapAlıntı
Gönderildi : 07/01/2010 03:07
Paylaş: