Forum

sql bağlantısı ile ...
 
Bildirimler
Hepsini Temizle

[Çözüldü] sql bağlantısı ile ilgili garip bir problemim var çözüm bulamıyorum

11 Yazılar
4 Üyeler
8 Likes
1,506 Görüntüleme
Ramazan AYDIN
(@RamazanAYDIN)
Gönderiler: 8
Active Member
Konu başlatıcı
 

Merhaba

Çok garip bir problem yaşıyorum bu konuda daha önce karşılaşan varsa lütfen desteğinizi bekliyorum.

Problemimi şöyle acıklayayım,

müşterime kurmuş olduğum sql servera dışardan bağlantı yaparak sorgular çekiyorum, Kendi bilgisayarımdan sorgu çekiyorum bir problem yaşamıyorum, cep telefonunun internetini ile bağlanıyorum sorgu çekiyorum hiç bir problem yok gayet güzel. 

natrodaki servera bağlanıyorum oradan bağlantı kurmaya çalışıyorum timeout hatasına düşüyorum, sadecehostingdeki servera bağlanıyorum oradan sorgu çekmeye çalışıyorum timeout alıyorum.

böyle bir problemi daha önce yaşadınız mı ?

 
Gönderildi : 28/04/2021 03:50
Konu Etiketleri

Aytaç ARSLAN
(@aytacarslan)
Gönderiler: 788
Noble Member
 

ilgili portlara natroda izin verilip verilmediğini sorun isterseniz. belki belli kısıtlamaları vardır.

 
Gönderildi : 28/04/2021 08:28

Aytaç ARSLAN
(@aytacarslan)
Gönderiler: 788
Noble Member
 

bir ek bilgi daha dışarıdan sql sunucuya direk eriştiğinizi ilettiniz umarım kısıtlıdır bu. portu farkeden biri kurcalamaya başladığında başınıza iş açabilir

 
Gönderildi : 28/04/2021 08:29

Hakan Uzuner
(@hakanuzuner)
Gönderiler: 32114
Illustrious Member Yönetici
 

Arkadaşlar yıl 2021, dışarıya any source için rdp, sql portu filan açmayın lütfen, göz göre göre davetiye çıkarıyorsunuz.

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

 
Gönderildi : 28/04/2021 12:11

Ramazan AYDIN
(@RamazanAYDIN)
Gönderiler: 8
Active Member
Konu başlatıcı
 

@aytacarslan

teşekkür ederim. normalde sadece natro ipsinden erişim olacak , test için actim. kullanıcıları yetkilerini kaldırdım. kurcalamak isteyen olur

 
Gönderildi : 28/04/2021 12:36

Ramazan AYDIN
(@RamazanAYDIN)
Gönderiler: 8
Active Member
Konu başlatıcı
 

natro ile görüştüm onlar bizde bir soru yok diyor bir kısıtlama yapmadık diyor. 

 
Gönderildi : 28/04/2021 12:37

Hakan Uzuner
(@hakanuzuner)
Gönderiler: 32114
Illustrious Member Yönetici
 
Gönderen: @RamazanAYDIN

@aytacarslan

teşekkür ederim. normalde sadece natro ipsinden erişim olacak , test için actim. kullanıcıları yetkilerini kaldırdım. kurcalamak isteyen olur

Anladım şimdi, tamam süper o zaman.

Yani SQL Server müşteride, sen sorguyu natro üzerindeki bir sunucudan çekiyorsun, bu durumda basit olarak müşteri firewall loglarından eğer senin sorgun görünmüyor ise paket natrodan çıkmıyordur, natroya firewall üzerinden geçen trafiğin ekran görüntüsünü ister misin?

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

 
Gönderildi : 28/04/2021 13:23

Ramazan AYDIN
(@RamazanAYDIN)
Gönderiler: 8
Active Member
Konu başlatıcı
 

@hakanuzuner

iki ekran gönderdim sol taraftaki benim kendi bilgisyarım sağ taraftaki natro

HATA

 

 
Gönderildi : 28/04/2021 13:38

Hakan Uzuner
(@hakanuzuner)
Gönderiler: 32114
Illustrious Member Yönetici
 

Dediğim gibi natro madem paketin çıktığını söylüyor ekran görüntüsü atsın.

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

 
Gönderildi : 28/04/2021 14:14

ibrahim yildiz
(@ibrahimyildiz)
Gönderiler: 3748
Üye
 

Muhtemelen TLS gibi güncel şeylerden sorun yaşıyorsunuzdur TLS portlarınızı kontrol etmek bir fikirdir.

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

 
Gönderildi : 28/04/2021 17:16

Ramazan AYDIN
(@RamazanAYDIN)
Gönderiler: 8
Active Member
Konu başlatıcı
 

@ibrahimyildiz

Çok teşekkür ederim, dediğiniz gibi TLS ilgili bir problem. internete araştırırken register ile ilgili bir kod buldum uygulayınca problemim çözüldü.

 SQL 2017

 

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 2.0\Client]
"Enabled"=dword:00000000
"DisabledByDefault"=dword:00000001
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 2.0\Server]
"Enabled"=dword:00000000
"DisabledByDefault"=dword:00000001
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 3.0\Client]
"Enabled"=dword:00000000
"DisabledByDefault"=dword:00000001
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 3.0\Server]
"Enabled"=dword:00000000
"DisabledByDefault"=dword:00000001
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Client]
"Enabled"=dword:00000000
"DisabledByDefault"=dword:00000001
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Server]
"Enabled"=dword:00000000
"DisabledByDefault"=dword:00000001
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Client]
"Enabled"=dword:00000000
"DisabledByDefault"=dword:00000001
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Server]
"Enabled"=dword:00000000
"DisabledByDefault"=dword:00000001
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client]
"Enabled"=dword:00000001
"DisabledByDefault"=dword:00000000
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Server]
"Enabled"=dword:00000001
"DisabledByDefault"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319]
"SchUseStrongCrypto"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319]
"SchUseStrongCrypto"=dword:00000001

 
Gönderildi : 29/04/2021 00:29

Paylaş: