Sql 2008r2 tempdb
 
Bildirimler
Hepsini Temizle

Sql 2008r2 tempdb  

  RSS
 Anonim

Merhaba;

 

Patent firmamızda yayınlanan markaları karsılastırarak benzer markaları bulmak icin bir yazılım kullanıyoruz. Daha once SQL 2005 te kullandığımızda bi problem almıyorduk. Ancak ne zamanki sunucumuzu değiştirdik (server 2008 r2 ve sql 2008 r2) bu yazılım işlem yapmaya basladiktan bi süre sonra "Attempt to fetch logical page (1:236) in database 2 failed.It belongs to allocation unit 48........ not to 47...." gibi bir hata alınmaktayız.

 

Yazılımcılarımız baktığında hata veren database'in tempdb olduğunu görmekte ancak sebebini bulamamaktayiz. Yardımlarınızı rica ediyorum

 Bir takım incelemelerde, tempdb'in farklı bir diskte ve boyutu, otomatik genişleme orani arttırılmasının sorunu cözeceği söylendi. Bu nedenle farklı bir virtualdisk olusturup oraya tasidik boyutunu 500mb ye cikarip %30 büyüme orani belirledik. Ancak sorun cozulemedi.

 

 

NOT: server 2008r2 standart e. ve sql2008r2 standart e. kullanilmakta. Bu sistem Citrix Xen Server üzerinde VM olarak calismakta. Aynı zamanda SQL de CRM içinde database var ve CRM sorun cikarmamakta. Sadece bu karşılaştırma yapan yazılımda olmakta. 

Alıntı
Gönderildi : 05/08/2010 17:34
Turgay Sahtiyan
(@turgaysahtiyan)
Üye

Service Pack ve Cumulative Update bilginizi alabilir miyim?

select @@VERSION komutunu kullanabilirsiniz.

CevapAlıntı
Gönderildi : 05/08/2010 20:35
Turgay Sahtiyan
(@turgaysahtiyan)
Üye

Biraz araştırma yapınca aşağıdaki bilgilere eriştim. 

Microsoft yetkilisi bu hata aşağıdaki URL de SP ile sorunun giderildiğini duyurmuş ama bazı kullanıcılar SP1 de hala bu hatayı almaya devam ettiklerini belirtiyorlar.

http://connect.microsoft.com/SQLServer/feedback/details/469811/attempt-to-fetch-logical-page-in-database-2-failed-it-belongs-to-allocation-unit-not-to

Bir başka Kb article da hatanın nedeninin çok fazla sayıda temp tablo create edilip drop edilmesi olarak gösterilmiş ve bazı çözüm yolları önerilmiş. 2008 kullanan ve bu hatayı yaşayan bir kullanıcı bu workaround u uygulayarak sonucu gitmiş.

KB Article >>   http://support.microsoft.com/?scid=kb;en-us;916086&x=8&y=14

workaround

Method 1: Use permanent tables (Daha zahmetli yol)

Use permanent tables in user databases instead of using temporary tables in the tempdb database. 

Method 2: Disable the Auto Update Statistics option and the Auto Create Statistics option (Daha hızlı yol)

Disable the Auto Create Statistics option and the Auto Update Statistics option in the tempdb database. For more information about SQL Server 2005 query optimizer statistics, visit the following Microsoft TechNet Web site:
http://technet.microsoft.com/en-us/library/cc966419.aspx  

 

Bu tavsiyeleri deneyip sonucu bildirir misiniz?

 

CevapAlıntı
Gönderildi : 05/08/2010 20:50
Paylaş: