EXCEL 2 sütund...
 
Bildirimler
Hepsini Temizle

EXCEL 2 sütunda filtreleme yapma  

  RSS
Burçin Kara
(@BurcinKara)
Üye

Merhabalar,

15 sütun 5000 satırlık kaydımız mevcut. Müşterilerin kullandığı cihaz bilgisi, 2 sütunda da mevcut olabiliyor. Şu şekilde yani;
1.sütun A MÜŞTERİSİ 2.sütun B LOKASYONDA Z CİHAZI KULLANIYOR 3.sütun C LOKASYONDA Y CİHAZI KULLANIYOR.

1.sütun D MÜŞTERİSİ 2.sütun E LOKASYONDA Y CİHAZI KULLANIYOR 3.sütun F LOKASYONDA Z CİHAZI KULLANIYOR

Bize lazım olan ben Z cihazı kullananları seçtiğimde hem 2 hem 3. sütunda cihazı kullananlar listelensin.

Nasıl yapıcam çözemedim. Yardımcı olursanız çok sevinirim 

Alıntı
Gönderildi : 24/02/2015 11:30
Yasar KIYAK
(@yasarkiyak)
Üye

Merhaba,

 Filtreleme ile vb malesef çözemiyorsunuz. Yeni bir sütuna aşağıdaki kodu düzenleyerek ekleyerek çözebilirsiniz.

TR      =EĞER(YADA(EĞERHATA(BUL("z";B3;1);0)>0;EĞERHATA(BUL("z";C3;1);0)>0);"var";"yok")

EN      =IF(OR(IFERROR(FIND("z";b2;1);0)>0;IFERROR(FIND("z";c2;1);0)>0);"var";"yok")

Burada ;

z= bulunacak metin

b3= ilk aradığınız hücre

c3 = ikinci aradığınız hücredir.

Bu formülü uygulayın ve ikisinde birinde aradığınız var ise size var der sonra o sütunda var ları filtreleyin.

Bu işinizi görecektir. Kolay gelsin. 

 

CevapAlıntı
Gönderildi : 24/02/2015 13:25
Burçin Kara
(@BurcinKara)
Üye

Çok teşekkürler. Gerçekten de işe yarıyor. Fakat geliştirmek adına birkaç şey sormak istiyorum. 3000-4000 satır için yeni sütunumuza yazmış olduğumuz bu formülü sürükle bırak yapmak biraz meşakkatli olacak. Bunun için de bir kısayol vs. bilgisi var mıdır?

CevapAlıntı
Gönderildi : 26/02/2015 13:36
Yasar KIYAK
(@yasarkiyak)
Üye

Var, hücrenin sağ altına geldiğinizde + işareti çıkar, orada iken çift tıklayınız, ya da CRTL ile aynı durumda çift tıklayınız olacaktır. Bir solundaki hücreyi boş göresiye kadar aynı formulu güncelleyip alttaki satırlara da yazacaktır.

CevapAlıntı
Gönderildi : 26/02/2015 13:45
Burçin Kara
(@BurcinKara)
Üye

Allah razı olsun ya 🙂 Çok teşekkür ederim. Ellerinize emeğinize sağlıkkkkk 🙂

CevapAlıntı
Gönderildi : 26/02/2015 16:56
Paylaş: