Anasayfa » Forum

Sunucu Dışına Mail ...
 
Bildirimler

Sunucu Dışına Mail Gönderilmiyor  

  RSS
R. Selim Siliğ
(@R.SelimSilig)
Üye

Merhaba,

Linux sunucumuzdaki web domainleri arası mail alışverişinde problem yok.

Herhangi bir domainden sunucu dışındaki bir domaine mail gönderirken hiçbir hata alınmamasına rağmen mail alıcının mailbox' ına bir türlü düşmüyor. ( Mail alınabiliyor. )

--

Bahsi geçen sunucumuz uzak makinede sanal Linux' tır. Makineye bağlanıp ssh ile misal veriyorum telnet smtp.gmail.com 25 komutu ile başarılı şekilde yanıt aldık, dolayısı ile sunucu tarafından bir sorun göremiyoruz. Bunu da dipnot olarak belirtmek istedim.

Bilgilerinize sunar, iyi çalışmalar dilerim.

Çözüm önerileriniz için şimdiden teşekkürler.

Alıntı
Gönderildi : 11/07/2012 03:29
Mehmet YAYLA
(@mehmetyayla)
Üye

Sunucu?

CevapAlıntı
Gönderildi : 11/07/2012 03:44
R. Selim Siliğ
(@R.SelimSilig)
Üye

Linux.

CevapAlıntı
Gönderildi : 11/07/2012 03:46
Hakan Uzuner
(@hakanuzuner)
Kıdemli Üye Yönetici

Merhaba

Linux uzmanlık alanım değil ama bence telnet ile bir mail göndermeyi denerseniz sorun ortaya çıkar.

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 11/07/2012 13:45
R. Selim Siliğ
(@R.SelimSilig)
Üye

MAIL FROM' u yazıp enter dediğimiz anda aşağıdaki satırla karşılaşıyoruz. Ardından işlem timeout oluyor zaten.

530 5.7.0 Must issue a STARTTLS command first.

CevapAlıntı
Gönderildi : 11/07/2012 14:14
Vasvi UYSAL
(@vasviuysal)
Saygın Üye Forum Yöneticisi

hangi mta'yi (postfix/exim/sendmail gibi) kullaniyor iseniz onun üzerinde TLS security kullanımına zorlayan konfigurasyon satirini degistirmeniz yada disable etmeniz gerek .

CevapAlıntı
Gönderildi : 11/07/2012 14:20
R. Selim Siliğ
(@R.SelimSilig)
Üye

Vasvi Bey bu telnet ile mail gönderirken alınan hataya yanıt sanırım değil mi, asıl soruna değil?

CevapAlıntı
Gönderildi : 11/07/2012 14:42
Hakan Uzuner
(@hakanuzuner)
Kıdemli Üye Yönetici

ÇözümPark için dener misin bu sanki karşı taraf sana TLS istiyor gibi, misal biz istemiyoruz bize telnet yapmayı dener misin?

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 11/07/2012 18:12
R. Selim Siliğ
(@R.SelimSilig)
Üye

Hakan hocam her ne olduysa çözüldü sorun sanırım şimdilik fakat sadece gmail' e düşmüyor mailler. Hiçbir hata almadan gönderiliyor başarılı şekilde, fakat gmail alıcısına hiçbir şekilde düşmüyor mail.

 

Bu sorun neden kaynaklanabilir bilginiz var mı?

CevapAlıntı
Gönderildi : 12/07/2012 21:27
Hakan Uzuner
(@hakanuzuner)
Kıdemli Üye Yönetici

gmail için telnet denedin mi ?

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 13/07/2012 13:31
R. Selim Siliğ
(@R.SelimSilig)
Üye

Denedim fakat yukarıda belirttiğim gibi aşağıdaki hatayı aldım MAIL FROM' dan sonra.

530 5.7.0 Must issue a STARTTLS command first.

Sanırım biraz daha çözemezsem google ı arayıp çözüm talep edeceğim.

CevapAlıntı
Gönderildi : 13/07/2012 19:01
Hakan Uzuner
(@hakanuzuner)
Kıdemli Üye Yönetici

Sizin mail server nedir sanki sizin derlediğiniz bir smtp server gibime geldi 🙂

 

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 14/07/2012 00:41
Hakan Uzuner
(@hakanuzuner)
Kıdemli Üye Yönetici

bu sorun TLS ile ilgili sanki sizin sunucunun TLS ayarlarında varsayılan olarak TLS encryption açık

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 14/07/2012 00:43
R. Selim Siliğ
(@R.SelimSilig)
Üye

TLS hakkında bilgim yok ancak smtp server Qmail.

Hotmail' e spam düşüyor tüm domainler, gmail' e hiç gitmiyor. Tuhaf bir şey bu, az önce SPF kaydını değiştirdim bir etkisi olur mu bilmiyorum ama.

Yeni kayıdı da şu şekilde açtım;

v=spf1 mx ptr ip4:46.20.6.104/24 ~all

Hakan hocam bu arada bir şey soracağım, gmail tarafında bizim sunucunun ip' si blacklist' e alınmış olsa vs. her halukarda otomatik bir yanıt alırız değil mi?

CevapAlıntı
Gönderildi : 14/07/2012 02:09
Hakan Uzuner
(@hakanuzuner)
Kıdemli Üye Yönetici

sorun senin session açamıyor olman bana göre tls ayarlı sende yapılmış gibi yada gmail senden tls istiyor sende tls yok olay tls de bitiyor


telnet en iyi çözüm sen denedin ben aldığın cevabı kontrol edince bu hata ya senin tls kullanmak istemen ve karşı tarafın bunu istemiyor olması yada karşı tarafın senden tls istemesi ancak senin tls den anlamıyor olman ile ilgili bir durum black list vb ile alakalı bir durum değil yani sorun mta konfigürasyonundaki bir yanlışlık ile ilgili, qmail bilen birine bir göster derim sistemini

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 14/07/2012 15:38
R. Selim Siliğ
(@R.SelimSilig)
Üye

TLS hakkında bilgim olmadığı için tam olarak anlayamadım söylediklerinizi ama şimdi daha iyi aydınlandım sanırım. Teşekkürler.

--

Qmail bilen birisi var mıdır aramızda?

CevapAlıntı
Gönderildi : 14/07/2012 16:44
R. Selim Siliğ
(@R.SelimSilig)
Üye

Konuyu yeniliyorum.

Sunucumuz üzerindeki hiçbir domainden gmail alıcısına e-posta gönderemiyoruz. Hata da almıyoruz, gayet normal şekilde gönderiliyor fakat gmail alıcısının mailbox ına düşmüyor.

Konu hakkında yardımcı olabilecek birileri var mıdır?

CevapAlıntı
Gönderildi : 17/07/2012 20:31
R. Selim Siliğ
(@R.SelimSilig)
Üye

Qmail olan mail server Postfix ile değiştirildi. Sorun çözüldü. Herkese iyi çalışmalar.

CevapAlıntı
Gönderildi : 19/07/2012 13:48
Hakan Uzuner
(@hakanuzuner)
Kıdemli Üye Yönetici

[quote user="Selim Siliğ"]

Qmail olan mail server Postfix ile değiştirildi. Sorun çözüldü. Herkese iyi çalışmalar.

[/quote]

geçmiş olsun

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 19/07/2012 14:38
Paylaş: