Anasayfa » Forum

cisco 3560 hp 5406 ...
 
Bildirimler
Hepsini Temizle

cisco 3560 hp 5406 switch değişim problemi  

  RSS
LeventOk
(@LeventOk)
Üye

Selam arkadaşlar,

yakın bir zamanda cisco 3650 switch ile hp 5406 switchleri değiştirmem gerekti. 3560 üzerindeki konfigürasyonu neredeyse birebir olarak 5406 ya uyarladım ve cihazı 3560 ile değiştirdim. 5406 yı açtığımda networkün bir kısmının , diğer kısımla haberleşemediğini gördük. konfigürasyon üzerinden bir kaç kere geçtim ancak bir yanlış bulamadım. Daha sonra haberleşemeyen kısmın kullanıcılar olduğunu ve  başka bir switch (hp 4204) üzerinden geldiklerini ve 4204 ün bir uplink ile 5406 ya bağlandığını fark ettim. 4204 ün konfigürasyonuna baktığımda vlan 3 (client vlan) olmadığını fakat 5406 ya yada eski cisco 3560 üzerinde vlan 3 access portu olarak ayarlanmış bir port üzerinden bağlı olduğunu gördüm. Bu durum biraz ilginç ama cisco ile çalışan sistem hp ile çalışmadı. Her ne kadar her iki switch te (3560 ve 5406 ) aynı vlan protokolünü kullansa da, bu durumun cisco ve hp arasındaki çalışma mantığının farklılığından kaynaklandığını düşünüyorum. Merak ettiğim, 4204 ve arkasındaki switchlerin konfigürasyonunu değiştirmeden 5406 switch i çalıştırabilirmiyim. Şimdiden teşekkürler. Aşağıda 3 ayrı switchin de konfigürasyonunu bulabilirsiniz (maalesef biraz uzun )

         değiştirmeden önce
       
           HP 4204   (port a4) <----------->   (port gi0/19) Cisco 3560

         değiştirdikten sonra

           Hp 4204   (port a4) <----------->   (port c14) HP 5406zl

 

 

---------------------------------------------
CISCO SW 3560 CONFIGURATION

XXXXXXX01#sh run
Building configuration...

Current configuration : 7118 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime
no service password-encryption
service sequence-numbers
!
hostname XXXXXXXX
!
boot-start-marker
boot-end-marker

no aaa new-model
clock timezone UTC 2
clock summer-time UTC recurring last Sun Mar 3:00 last Sun Oct 4:00
system mtu routing 1500
udld aggressive

ip subnet-zero
ip routing
!
ip dhcp pool guest
   network xx.xx.xx.xx 255.255.255.0
   default-router xx.xx.xx.xx
   dns-server xxx.xxx.xx.xx xxx.xx.xx.xx
!
!
mls qos map cos-dscp 0 8 16 26 32 46 46 56

!

errdisable recovery cause link-flap
errdisable recovery interval 60
!
!
macro global description cisco-global
!
spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface GigabitEthernet0/1
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet0/2
 switchport mode access
!
interface GigabitEthernet0/3
 switchport mode access
!
interface GigabitEthernet0/4
 switchport mode access
!
interface GigabitEthernet0/5
 switchport mode access
!
interface GigabitEthernet0/6
 switchport mode access
!
interface GigabitEthernet0/7
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 4,7,9,10
 switchport mode trunk
 speed 100
!
interface GigabitEthernet0/8
 switchport access vlan 8
 switchport mode access
!
interface GigabitEthernet0/9
 switchport access vlan 7
 switchport mode access
!
interface GigabitEthernet0/10
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet0/11
 switchport access vlan 3
 switchport mode access
 shutdown
!
interface GigabitEthernet0/12
 switchport mode access
!
interface GigabitEthernet0/13
 switchport access vlan 2
 switchport mode access
 speed 1000
 duplex full
!
interface GigabitEthernet0/14
 switchport access vlan 2
 switchport mode access
!
interface GigabitEthernet0/15
 switchport access vlan 9
 switchport mode access
!
interface GigabitEthernet0/16
 switchport access vlan 10
 switchport mode access
!
interface GigabitEthernet0/17
 switchport access vlan 4
 switchport mode access
!
interface GigabitEthernet0/18
 switchport access vlan 4
 switchport mode access
!
interface GigabitEthernet0/19
 switchport access vlan 3
 switchport mode access
!
interface GigabitEthernet0/20
 switchport mode access
!
interface GigabitEthernet0/21
 switchport access vlan 6
 switchport mode access
!
interface GigabitEthernet0/22
 switchport access vlan 5
 switchport mode access
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
 switchport trunk allowed vlan 1
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface Vlan1
 ip address 192.168.XX.XX 255.255.255.0
!
interface Vlan2
 no ip address
!
interface Vlan3
 ip address 192.168.4.1 255.255.255.0
 ip helper-address xxx.xxx.x.xx
!
interface Vlan4
 no ip address
!
interface Vlan5
 ip address xx.xx.xx.xx 255.255.255.0
 ip access-group guest in
!
interface Vlan6
 ip address XXX.XXX.XX.XX 255.255.255.0
 ip helper-address XXX.XXX.XXX.XXX
!
interface Vlan8
 ip address 192.168.XX.XX 255.255.255.0
 ip helper-address 192.168.XX.XX
!
ip default-gateway 192.168.XX.XX
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.XX.XX
ip http server
ip http authentication local
ip http secure-server
!
!
ip access-list extended guest
 deny   ip 10.0.45.0 0.0.0.255 192.168.0.0 0.0.255.255
 permit ip any any
!
!
control-plane
!
!
line con 0
line vty 0 4
 password
 login
 length 0
line vty 5 15
 password
 login
!
!
monitor session 1 source interface Gi0/1
monitor session 1 destination interface Gi0/6 encapsulation replicate
monitor session 2 source interface Gi0/17
monitor session 2 destination interface Gi0/18 encapsulation replicate
end

--------------------------------------------
--------------------------------------------
5406 CONFIGURATION
--------------------------------------------

ProCurve Switch 5406zl# wr mem
ProCurve Switch 5406zl# sh run

Running configuration:

; J8697A Configuration Editor; Created on release #K.15.02.0005

hostname "ProCurve Switch 5406zl"
ip access-list extended "GUEST"
   160 permit udp 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 eq 67
   170 permit udp 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 eq 68
   180 deny ip 10.0.45.0 0.0.0.255 192.168.0.0 0.0.255.255
   190 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
   exit
module 1 type J9550A
module 2 type J9550A
module 3 type J9550A
trunk C21-C24 Trk1 LACP
ip default-gateway XXX.XXX.XXX.XXX
ip routing
vlan 1
   name "DEFAULT_VLAN"
   untagged A1-A24,B1-B24,Trk1
   ip address XXX.XXX.XXX.XXX 255.255.255.0
   no untagged C1-C20
   exit
vlan 2
   untagged C1-C6
   no ip address
   exit
vlan 3
   untagged C14
   ip helper-address 192.168.XXX.XXX
   ip address 192.168.4.1 255.255.255.0
   exit
vlan 4
   untagged C7-C11
   tagged C20
   no ip address
   exit
vlan 5
   untagged C12
   ip address 10.0.45.1 255.255.255.0
   ip access-group "GUEST" in
   exit
vlan 6
   untagged C13
   ip helper-address 192.168.XXX.XXX
   ip address 192.168.XXX.XXX 255.255.255.0
   exit
vlan 7
   untagged C15
   tagged C20
   no ip address
   exit
vlan 8
   untagged C16
   ip helper-address 192.168.XX.XXX
   ip address 192.168.XXX.XXX 255.255.255.0
   exit
vlan 9
   untagged C17
   tagged C20
   no ip address
   exit
vlan 10
   untagged C18-C19
   tagged C20
   no ip address
   exit
mirror 1 port A2
mirror 2 port C8
ip route 0.0.0.0 0.0.0.0 192.168.XXX.XXX
interface A1
   monitor all both mirror 1
   exit
interface C7
   monitor all both mirror 2
   exit
snmp-server community "XXXX" unrestricted
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree force-version rstp-operation
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager

------------------------------------
------------------------------------
4204 CONFIGURATION
------------------------------------

Running configuration:

; J8770A Configuration Editor; Created on release #L.11.20

hostname "XXXXXXXXXXX"

no telnet-server
module 1 type J9033A
module 2 type J8765B
module 3 type J8765B
module 4 type J8765B
snmp-server community "XXXX" Unrestricted
vlan 1
   name "DEFAULT_VLAN"
   untagged A1-A19,A21-A24,B1-B24,C1-C24,D1-D24
   ip address 172.16.XX.XX 255.255.255.0
   no untagged A20
   exit
vlan 2
   name "VLAN2"
   untagged A20
   tagged A1-A19,A21-A24
   exit
ip authorized-managers XXX.XXX.XXX.XXX
ip authorized-managers XXX.XXX.XXX.XXX

spanning-tree
spanning-tree force-version RSTP-operation
ip ssh
ip ssh port XXXX
password manager

---------------------------------------------------------------

Alıntı
Gönderildi : 01/08/2012 15:47
Volkan KULALAR
(@volkankulalar)
Üye

Selamlar,


İlk olarak şunu belirtmekte fayda var, HPProcurve ile Cisco arasındaki tek farklı syntax bunun dışında hiçbir fark yok.


Senden cisco da "show vlan brief" diyerek onuda post' a eklemeni rica edeceğim.


Birde ufaktan yapmak istediğin topolojiyi daha iyi anlayabilmem için bana çizip gönderirsen olmadı sana konfigleri hazırlayıp göndereyim.


Kolay gelsin.

CevapAlıntı
Gönderildi : 01/08/2012 19:54
LeventOk
(@LeventOk)
Üye

selam, zaman ayırdıgın için cok tesekkürler

maalesef su anda o cihazlardan herhangi birine ulasma sansım yok. Ancak her ne kadar sh vlan br daha kolay anlasılır olsa da sw run cıktısından da hangı vlanların olusturuldugunu hangi portların hangi vlan lar ile ilişkilendirildiğini anlamak mümkün. Bu arada amacım herhangi bir topoloji kurmak değil, bir noktada bulunan cisco switch i hp switch ile degistirmek. Hp 5046 switch i cisco 3560 a göre konfigure ettim ve sanırım konfigurasyon dogru. Asıl ilginc olan cisco switchin gig 0/19 undan (yanı vlan 3 access port) herhangi bir trunk konfigurasyonu olmadan hp 4204 switch e bir uplink var. HP 4024 switch üzerinde ise vlan 3 konfigurasyonu bile yok. Buna ragmen switchler birbirleri ile haberleşiyor. Ama ben cisco switch i çıkarıp yerine hp 5406 switch i taktıgımda haberleşme kesiliyor. Portları kontrol ettim. onlar up durumda. Konfigurasyonu kontrol ettim ve bildigim kadarı ile dogru. Benim aklıma tek gelen cisco switch kendi gig0/19 una tag sız olarak gelen paketleri vlan 3 tagı ile paketliyor ve sonra kendi üzerinde gereken yerlere gonderiyor. yani 4204 üzerindeki vlan 1 bulunan bütün untagged portlardan gelen paketler cisco switchin portuna girerken vlan 3 ile taglanıyor. Ama hp 5406 bunu bu şekilde yapmıyor. hp 5406 nın c14 portuna gelen paketler taglanmadan devam ediyor veya drop ediliyor.

dediğim gibi 4204 switchin konfigurasyonunu değiştirerek yani untagged portları vlan 3 e alıp a4 portunu vlan 1 ve 2 için tagged vlan 3 için untagged yaparak bu sorunu çözebilirim sanırım. Ama benim 4204 üzerinde herhangi bir değişiklik yapmadan bu sorunu halletmem gerekiyor. Cunku 4204 arkasında ne calıstıgını bilmiyorum. eğer 4204 üzerinde boyle bir değişiklik yaparsam arkasında olan her switchte değişiklik yapmam gerekecek.

 

CevapAlıntı
Gönderildi : 02/08/2012 13:09
Paylaş: