W2K7 Restore Proble...
 
Bildirimler
Hepsini Temizle

W2K7 Restore Problemi  

  RSS
 Anonim

Selamlar,

Bu sıkıntımı daha önce 2003tede yaşıyordum.1 aydırda 2007 ile ilgili yapılabilecek tüm testleri uygulmaları yaptım ama yine aynı yerde takılıp kalıyorum.Restoreye gelince failed yazısıyla karşılaşıyorum sürekli.

Makalede yazılan şekilde, biraz mail trafiğine sahip userın oldugu db yi yedekliyorum.daha sonra dismount yapıp db yi manual siliyorum ve this database can be.. kısmını işaretliyorum.sonrasında restore dediğimde -10 uygulamanın 8inde-  failed uyarısı alıyorum.

Hocam makalelerinizle alakalı recovery storage ile ilgili uygulamalar lcr makalesi hepsinde sorunsuz işlem yapabiliyorum ama sadece restore işleminde sıkıntı yaşıyorum.iş yerinde günlük yedek alınıyor ve inanın bu konuda korkuyorum.haftalıkta C:\ imajı alınıyor.en kötü ordan dönerim ama neden failed uyarısı aldıgımı çözemedim.technette hata kodlarına kadar baktım defalarca.restore sonrası DB nin mount olmamasıda ayrı bir gariplik.. (ilgili alanı restore yaparken işaretlememe rağmen)

 

o kadar garipleştiki işlemlerim, mail dolu bir db yi yedekliyorum.sonra db deki user için biraz daha mail trafiği oluşturuyorum.bir önceki günün yedeğinden dönüyorum ama en son attığım maillerde mailbox ta duruyor.yani restore completed diyor,mount oluyor db ama bir gün öncenin mailleri artı en son atılanlarda oluyor.

birde artık C:\Program Files\Microsoft\ kısmından sonrasını yedekliyorum çekindiğimden.NTBackup ile 960MB tuttu, Acronis ile 391 aynı yer..

 

inanın tak demese yazmazdım ama bu restore işini neden yapamadıgımı çözemiyorum.

Alıntı
Gönderildi : 02/05/2009 06:04
Bugra KESKIN
(@bugrakeskin)
Saygın Üye

Merhaba

mümkünse aldığınız hatayı paylaşsanız bizde bir bakıp anlamaya çalışsak?

Ayrıca sorunlardan en bıktığınız anda bize yazabilirsiniz. Yardımcı olabilirsek ne mutlu.

CevapAlıntı
Gönderildi : 03/05/2009 06:44
 Anonim

Merhaba,

malesef bir haftadır internet erişiminin olmadıgı bir yerde oldugumdan anca yazabiliyorum.Event viewerdaki kodlar şu şekilde.Az önce 3 defa daha denedim fakat hepsinde failed uyarısı alıyorum.

Sıfırdan 2k3 r2 yi kurdum, exchange 2007 tekrar kurdum ve yine olmadı.Nerede hata yaptıgımı çözemiyorum.

mailboxında bir miktar mail olan kullanıcının oldugu storage group'u dismount edip db nin adını değiştiriyorum/siliyorum, sonra this database can be.. kısmını işaretleyip aldıgım yedekten dönmek istediğimde bu hataları veriyor.DB yi düzgün göstermeme rağmen hata kodlarında failed to find demeside ilginç.

** işlemi first storage group üzerindeki DB de uyguladım şuan.Gerçi extra bir group oluşturdugumdada almıştım hatayı.

 

9635 :

Failed to find a database to restore to from the Microsoft Active Directory.
 Storage Group specified on the backup media is aebde22f-5bba-476f-b341-6ae04c1b8f1c.
 Database specified on backup media is Mailbox Database, error is 0xc7fe1f42. 

 9638 :

Function 'EcGetRestoreDestination' failed with error 0xc7fe1f42.

 904 :

Information Store (684) Callback function call ErrESECBRestoreGetDestination ended with error 0xC7FE1F42 Database not found.

 8003 : End Restore to 'CELTIC\Microsoft Information Store\First Storage Group' 'Failed'

 8019 : End Operation: Warnings or errors were encountered. 
Consult the backup report for more details.

4001 : bu baya uzun oldugundan eklemedim..

CevapAlıntı
Gönderildi : 11/05/2009 06:20
Bugra KESKIN
(@bugrakeskin)
Saygın Üye

Merhaba

aldıgınız backup da bir problem olabilir mi? backup aldıktan sonra doğruluyor musunuz aldıgınız yedeği?

CevapAlıntı
Gönderildi : 11/05/2009 13:25
 Anonim

Merhaba,


Peki bu Backup ile Recovery Storage Group kullanmayı denediz mi?Bu çalışıyor mu?Yani RSG içerisine döndüğünüz backup ile te kbir mbx veya birden fazla mbx'i restore edebiliyormusunuz.

CevapAlıntı
Gönderildi : 11/05/2009 13:58
 Anonim

Buğra hocam evet yedekleri doğruluyorum.Ayrıca birden fazla yedek alıp diğerlerindede denedim.Hepsinde aynı

 

Serhad hocam RSG üzerinden dönebiliyorum.Onda sorun yok.Direk üzerine DB yazdırmada failed alıyorum.Yani RSG kullanmadanda bunu yapabilmeliyim değilmi ?

CevapAlıntı
Gönderildi : 15/05/2009 05:06
 Anonim

Evet RSG olmadanda normal aldığın bir backup'ı restore edebilmen lazım.Peki baştan bir göz atalım o zaman.


1)İlk olarak bir backup al.


2)DB Dismount et ve bütün her şeyi sil.(DB,Transaction Log,vs...)


3)DB'nin özelliklerinde Overwrite özelliğini seç


4)Backup'ı restore ederken Replace'i seç.


Ben şimdi tekrardan yaptım.Eğer olmazsa Backup'ında problem var demektir.

CevapAlıntı
Gönderildi : 15/05/2009 14:18
 Anonim

Merhaba tekrar,

Aynen dediğiniz şekilde yaptım.Bu zamana kadar yazdıgınız maddeler içerisinde 2. şıkta DB yi siliyordum yada rename yapıyordum.tamamen loglarla beraber silince sorunsuz halloldu.3-4 defada ayrı loglarla denedim ve sonuç başarılı.çok teşekkür ederim desteğiniz için.

CevapAlıntı
Gönderildi : 18/05/2009 05:27
 Anonim

[quote user="flibe"]

Merhaba tekrar,


Aynen dediğiniz şekilde yaptım.Bu zamana kadar yazdıgınız maddeler içerisinde 2. şıkta DB yi siliyordum yada rename yapıyordum.tamamen loglarla beraber silince sorunsuz halloldu.3-4 defada ayrı loglarla denedim ve sonuç başarılı.çok teşekkür ederim desteğiniz için.


[/quote]


[Y]

CevapAlıntı
Gönderildi : 18/05/2009 14:56
Paylaş: