Forum

Server 2008R2 ve iS...
 
Bildirimler
Hepsini Temizle

Server 2008R2 ve iSCSI disk problemi ...

7 Yazılar
3 Üyeler
0 Likes
577 Görüntüleme
(@OzcanSAHIN)
Gönderiler: 198
Estimable Member
Konu başlatıcı
 

Arkadaslar merhaba,

Vmware ESXi 5.5 uzerinde ki Windows Server 2008 R2 file server 'da Synology NAS uzerinde yarattigim iSCSI lun kullaniyorum.

iSCSI Initiator'da bu diski otomatik mount olacak sekilde ayarladim fakat server restart edildiginde bu disk otomatik baglanmiyor, açilista bi hayli uzun suruyor.(manuel yaparsam sorun yok)

Muhtemelen açilista baglanti timeout' a dusuyor

Ancak vmtools 'u kaldirdigim' da herhangi bir sorun yok, disk otomatik mount oluyor.

Vmware Support ile gorustum, onlar bu problemi için bir çozum oneremeyecekleri çunku problem'in Isletim sistemi ile NAS arasinda oldugunu soyleyip topu Microsoft' a attilar.

 Yardimlariniz için simdiden tesekkur ederim.

Iyi çalismalar

 

 
Gönderildi : 29/10/2014 18:14

(@recepyuksel)
Gönderiler: 1893
Üye
 

Ozcan bey,

Yeni bir network kartını farklı bir tipte tanımlayıp o kart üzerinden bağlanmayı deneyebilirmisiniz? Atıyorum E1000 kullanıyorsanız VMXNET3 deneyin yada tam tersi. Gerci VMware tools kaldırıp denediğinizde çalıştığını söylemişsiniz büyük ihtimalle E1000 kullanıyorsunuz.

Saygılarımla. 

************************************************************
Probleminiz çözüldüğünde sonucu burada paylaşırsanız,
sizin ile aynı problemi yaşayanlar için yardım etmiş olursunuz.
Eğer sorununuz çözüldü ise "çözüldü" olarak işaretlerseniz
diğer üyeler için çok büyük kolaylık sağlayacaktır.
************************************************************

 
Gönderildi : 29/10/2014 19:42

(@OzcanSAHIN)
Gönderiler: 198
Estimable Member
Konu başlatıcı
 

Recep bey,

Geri donusunuz için tesekkur ederim.

Problem vmtools yukledikten sonra oluyor.

Ancak yine de vmtools yukleyip onerinizi deneyecegim.(kullandigim network karti E1000)

 

 

 

 
Gönderildi : 29/10/2014 19:52

(@OzcanSAHIN)
Gönderiler: 198
Estimable Member
Konu başlatıcı
 

Yeni bir network karti ekledim VMXNET3 ama degisen birsey yok.

Log' larda su iki hatayi goruyorum :

Source iScsiPrt
Event id : 10
Login request failed

Source : MSiSCSI
Event id : 103
Timeout waiting for iSCSI persistently bound volume.

Timeout degerini arttirdim 120 sn den 160 yukselttim simdilik çalisiyor gorunuyor ama hem kesin bir çozum degil hemde açilista çok bekletiyor.

vmtools servisini manuel'e çekip logon sonrasinda start edecek bi script eklicem.

Eger baska bi oneriniz varsa hala arayistayim.

 
Gönderildi : 29/10/2014 21:01

(@bulentsonmez)
Gönderiler: 276
Reputable Member
 

Vmware ESXi 5.5 uzerinde ISCSI Adapter eklimi yoksa sadece Server 2008 R2 üzereinden mi iscsi bağlantısı kuruyorsunuz.

 
Gönderildi : 30/10/2014 12:12

(@OzcanSAHIN)
Gönderiler: 198
Estimable Member
Konu başlatıcı
 

Hayir simdilik sadece Synology 'deki iscsi lun dogrudan server 2008 R2' da iscsi initiator' da tanimlanmis durumda.
Ama muhtemelen iSCSI uzerinden ESX5.5' e baglayip ya VMDK yaratacagim yada RDM kullanacagim.
Ama bu seçenek suan için mumkun degil.

 
Gönderildi : 30/10/2014 13:08

(@OzcanSAHIN)
Gönderiler: 198
Estimable Member
Konu başlatıcı
 

Arkadaslar,

Registery' den iscsi timeout süresini arttirip, vmtools servisini startup script ile açılış sonrasında başlatıyorum.
Bu şekilde sorun gözükmüyor ama production için bir çözüm değil, bu ayarlar servis devamlılığını ne kadar garanti eder tartışılır.

NAS'ı direk ESX'e bağlamak istemiyorum çünkü NAS baglantısının kopması durumunda yada NAS'ta bır sorun olması durumunda ESX'teki tum VM'ler kilitleniyor ve ESX' ı restart etmeden duzelmiyor.

File server'daki datalari için NAS kullan var mı ? VMDK' dami tutuyorsunuz yoksa bu sekilde direk iscsi lun içerisindemi ?

 
Gönderildi : 30/10/2014 18:02

Paylaş: