Forum

DNS Server subnetle...
 
Bildirimler
Hepsini Temizle

DNS Server subnetlerden biri icin cozumleme yapmiyor

11 Yazılar
3 Üyeler
0 Likes
1,037 Görüntüleme
(@OrhanAslan)
Gönderiler: 278
Reputable Member
Konu başlatıcı
 

Agimiz; 192.168.0.1  192.168.10.1  192.168.20.1 seklinde 3 subnete sahip. 0 ve 10 subnetlerinden birbirlerine ve 20`ye makine adi ile ping atmasinda hic bir problem yok ancak subnet 20`den 0 ve 10`e ait hic bir makineye bilgisayar adi ile ping atamiyorum. Ip adresi ile ping atmada problem yok. Belliki DNS Serverda problem var. DNS Serverda nereleri kontrol etmem lazim ki bu sorunu cozeyim?

Ortamda Windows 2003 Enterprise var ve 2 tane DNS server mevcut. DNS Serverin loglarina baktigimda herhangi bir problem gorunmuyor.

 
Gönderildi : 07/09/2009 11:53

(@fatihkaraalioglu)
Gönderiler: 3040
Illustrious Member
 

Merhaba;


Bir kaç kontrol önereceğim;



  1. 2 farklı DNS serverdan bahsedilmiş. Master DNS server' dan Secondery DNS Servera kayıtlar gitmektemidir ? yoksa iki farklı DNS Server mı bulunmakta. ve bu DNS Serverların bulunmuş olduğu networkler

  2. Networkler Arasında DNS portları (53 TCP ve UDP) için geçiş izinleri var mı ?

  3. Master' den Secondery DNS yapısı kullanılıyorsa, DNS clientların yapılandırılmasında girilen DNS server adresi hangisidir.

  4. kullanıcıların Host (a) kayıtları DNS Server üzerinde oluşturulmuş mu ? Manuel Kayıt girdiğiniz zaman isim çözümlemesi yapılıyorm uu ?

ve buna benzer kontrolleri gerçekleştirebilirmisiniz.

 
Gönderildi : 07/09/2009 16:56

(@OrhanAslan)
Gönderiler: 278
Reputable Member
Konu başlatıcı
 

Merhaba Fatih hocam,

 

1-DNS Serverler aynı ve aynı subnetteler. Birbirlerine kayıtlar sorunsuz gitmekte. Bir değşiiklik yapınca diğerinde kayıt sorunsuz görünüyor.

2-End POint'i kontrol ettim hocam orda "Enable Smart DNS" seçeneği aktif ve açıklamasında DNS ile ilgili trafik otomatik olarak kabul edilecek diyor.

3-Primary DNS adresimiz PDCnin üstünde olan ve bunu kullanıyoruz. Manuel olarak client üzerinde ikinci DNS Serveri seçtiğimidede durum aynı.

4-Kullanıcıların host kayıtları host altında oluşmuş durumda. Subnet 20'ye ait kullancılar bile orada.

 

Aşağıya bir kaç noktanın ekranlarını ekledim bir ihtimal yardımcı olabilir.

Ayrica asagidaki event ile sik karsilasiyorum.

Event Type:    Warning
Event Source:    NETLOGON
Event Category:    None
Event ID:    5802
Date:        8/09/2009
Time:        11:48:35 AM
User:        N/A
Computer:    ICB21
Description:
None of the IP addresses (192.168.0.21) of this Domain Controller map to the configured site 'Default-First-Site-Name'. While this may be a temporary situation due to IP address changes, it is generally recommended that the IP address of the Domain Controller (accessible to machines in its domain) maps to the Site which it services. If the above list of IP addresses is stable, consider moving this server to a site (or create one if it does not already exist) such that the above IP address maps to the selected site. This may require the creation of a new subnet object (whose range includes the above IP address) which maps to the selected site object.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
 

 

 

 

 

 
Gönderildi : 07/09/2009 23:14

(@OrhanAslan)
Gönderiler: 278
Reputable Member
Konu başlatıcı
 

Interneti kurcalarken soyle bir bilgi buldum ancak adamin bahsettigi isleri nasil yapacagimi ve bir riski olup olmadigini bilmiyorum. Bu islemleri eger cozum ise biraz daha basitce anlatabilir misiniz?

 

You need to add all physical subnets in your environment to AD.  You then
create sites and add the subnets to those sites.  Multiple subnets can be
associated with a single site.  You don't have to have a DC in a site.  In
this scenario you either create a site and don't have a DC, or you add the
subnet to a site with a DC.  The options will vary depending on environment,
requirements and understanding.  Personally, for what you describe, create
sites for each physical site in your environment and map subnets
accordingly.  Multiple VLANs or whatever are the same physical site so they
map to the same AD site.

The DCs will then automatically cover the DC-less sites based on your site
links (or more specifically the costs of these links).  You should create
site links between each site if you wish to have a hub and spoke topology
with correct auto-coverage.

As an example, you have three physical sites A, B, and C and six subnets
we'll call s1...s6 two subnets per site.  Create like this:

Sites and subnets:

A : s1, s2
B : s3, s4
C : s5, s6

Site lniks:

B-A (contains sites A and B)
C-A (contains sites A and C)

  http://www.servernewsgroups.net/group/microsoft.public.windows.server.active_directory/topic17771.aspx

 

 
Gönderildi : 08/09/2009 11:01

(@OrhanAslan)
Gönderiler: 278
Reputable Member
Konu başlatıcı
 

Arkadaşlar anlatması mı zor yoksa çözüm yoluna mı vakıf değiliz?

 
Gönderildi : 09/09/2009 02:32

(@bugrakeskin)
Gönderiler: 5088
Illustrious Member
 

Merhaba

AD Sites and Services açın --> Sites --> Subnet kısmına gelin. Burada subnetleri görebiliyor musunuz? her network ün subneti burada ekli olmalı yoksa routing olmaz. Eğer yoksa sağ klik New Subnet deyip ekleyip dener misiniz.

 
Gönderildi : 09/09/2009 02:43

(@OrhanAslan)
Gönderiler: 278
Reputable Member
Konu başlatıcı
 

 Hocam söylediğiniz yere baktım orda hiç subnet görünmüyor.Bu sahneyi görünce aklıma geldi, DELL managable switch üzerindeki portlara subnetler dağıtılmış durumda (1-12 port arası Subnet 0, 13-18 arası portlar subnet 10 ve 19-20 portları ise subnet 20). Acaba bu yüzden mi AD Sites and Services altında hiç subnet görünmüyor?

Managable swithce rağmen yinede söylediğiniz yere subnet oluşturmalı mıyım?

 

 

 

 

 
Gönderildi : 09/09/2009 13:09

(@bugrakeskin)
Gönderiler: 5088
Illustrious Member
 

Hayır, siz buraya varolan subnetleri ekleyin.

 
Gönderildi : 09/09/2009 15:08

(@OrhanAslan)
Gönderiler: 278
Reputable Member
Konu başlatıcı
 

Subnetleri ekledikten sonrada ayni sorun devam ediyor. Yalniz bir sey farkettim bugun, reverse lookup zone`da subnetlere ait bilgisayarlari artik gorebilmekteyim ancak forward lookup zone`da sadece subnet 0`a ait bilgisayarlar gorulmekte. Subnet 10 ve 20`ye ait bilgisyarlar orada yok. Bu bilgi sizlere bir fikir verdimi cozum icin?

 
Gönderildi : 29/09/2009 04:19

(@bugrakeskin)
Gönderiler: 5088
Illustrious Member
 

Peki şuanda dns de bir uyarı / hata var mı?

 
Gönderildi : 30/09/2009 17:44

(@OrhanAslan)
Gönderiler: 278
Reputable Member
Konu başlatıcı
 

Hayır DNS'te hiç bir uyarı yok. Ancak system altında netlogon hataları her bir kaç saatte bir geliyor ve IP Mapping yapmamı söylüyor. Bunu nasıl yapacağımı bilmiyorum. Reverse Lookup Zone'da subnetler oluşturdum (eğer bu IP Mapping ise) ve clientleri görebilmekteyim ancak halen aynı uyarı tekrarlıyor.

 
Gönderildi : 01/10/2009 01:03

Paylaş: