SCCM uzerinde WSUS ...
 
Bildirimler
Hepsini Temizle

[Çözüldü] SCCM uzerinde WSUS client update sorunu  

Erkan GULMEZ
(@erkangulmez)
Üye

Merhaba

 

2 sene once kurdugum ve 1 hafta oncesine kadar sorunsuz calisan SCCM server client guncellemelerinde hata vermeye basladi. Win10 20H2 windows versiyonu var client makinelerde ve 1-2 tanede de 1-2 surum alt calisiyor. Hic bir client hic bir windows guncellemesini almiyor. Software centerda ki Updates sekmesinde hic bir sey yok. Test amacli v1909 kurdum onu guncellemek istedim, o da ayni. 

WUAHendler.log dosyasi der ki: 
OnSearchComplete - Failed to end search job. Error = 0x80244017
Scan failed with error = 0x80244017

Yine client makinede windowsupdate.log dosyasina bakinca, bir cok update file'in eklendigini goruyorum. Yani diyro ki, added update xxxx-xxx-xxx-xxxx to search result vs vs ama log dosyasinin sonunda:
FAILED 80244017 Web Service Call hatasi var.

Server, Microsoftun windows update serverlariyla sync oluyor sorun yok. RuleEngine.log'a baktigimda ise sadece 1 tane hat goruyorum ve o da diyor ki:
CRuleHandler::CreateFailureALert - Alert ID = 16778301
WCM.log temiz, onda sorun gorunmuyor. 

 

Arastirdigimda bu 0x80244017 hatasinin proxy ya da daha genel olarak erisim izni sorunu oldugunu soyluyor. NTFS permissionlarda sorun yok, IIS de wsus icin anonymous authentication enable. Cozum olacagini bilsem, SUP'u kaldirip tekrar kuracagim ama zannetmiyorum ki cozum olsun. Proxy serverimiz var, lighspeed ama serverlar proxy kullanmiyor. Ne SCCM console icinde ne de serverin kendi proxy ayarlarinda her hangi bir proxy ayari yok. 

SCCM'i guncelledim ve server 2016 uzerinde calisiyor ki o da guncel. 
Bu nedir, niyedir bilen cikar mi acaba? 

Ve bir de bu sayfayi acabilmem gerekir mi? Acmaya calisitigmda: Unable to complete request, access denied uyarisi aliyorum.
http://wsusserverFQDN:8530/SimpleAuthWebService/SimpleAuth.asmx

 

Tesekkurler

 

Alıntı
Topic starter Gönderildi : 06/01/2021 21:16
Erkan GULMEZ
(@erkangulmez)
Üye

SCCM consoleda deployment monitoring kismindaki hatayi yazmayi unutmusum.

Same as HTTP status 401 - the requested resource requires user authentication.

CevapAlıntı
Topic starter Gönderildi : 07/01/2021 12:29
Erkan GULMEZ
(@erkangulmez)
Üye

Problem cozuldu.

Arastirmalairmin sonucunda client makinelerin servera port 8530 uzerinden erisiminin olmadigini gordum.

Client makineden asagidaki sayfalara erisebiliyor olmalisiniz, erisemiyorsaniz bir blokaj ya da DNS sorununuz var demektir.
http://WSUSServerFQDNname:8530/Selfupdate/wuident.cab
http://WSUSServerFQDNname:8530/ClientWebService/wusserverversion.xml
http://WSUSServerFQDNname:8530/SimpleAuthWebService/SimpleAuth.asmx

Benim durumumda patron 1 ay once, proxyde ve filteringde degisiklikler yapmis ve port 8530u blocklamis. 2 hafta once sordugumda oyle bir sey yok demisti musteri ama bugun tekrar sordum, varmis.

Internette cok bilgi yok bu hatayla ilgili, ihtiyaci olan olursa burada dursun.

CevapAlıntı
Topic starter Gönderildi : 08/01/2021 01:18
Hakan Uzuner
(@hakanuzuner)
Kıdemli Üye Yönetici

Güzel tecrübe, geçmiş olsun. Geri dönüş ve bilgi için teşekkürler.

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 08/01/2021 22:31
Paylaş: