Anasayfa » Forum

Sql Server 2008 110...
 
Bildirimler

Sql Server 2008 1105 hatası  

  RSS
recep dağ
(@recepdag)
Üye

merhabalar Nebim Winner isimli programı kullanmaktayız. iki haftadır 1105 - [Microsoft][ODBC SQL Server Driver][SQL Server]Could not allocate space for object  bu hatayı almaktayım. Sql Server 2008 express kurulu data boyutu 4026 Mb Yazmakta sql 2008 maxmimum boyut olarak 10Gb olarak belirtilmiş. 3 tane aynı boyutta veritabanı açtım sorun yok ama veri girildikçe hata veriyor. geçici olarak programda bulunan veri tabanı indexlerini onarı kullanıyorum.

bu konuda yardımlarınızı rica ediyorum 

Teşekkürler

Alıntı
Gönderildi : 10/04/2017 00:15
oldmember
(@yavuzfilizlibay)
Üye

Merhaba

Bir object içinde bu hatayı veriyor olabilir, indexleri rebuild etmek gerekebilir, express edition da 10 gb ı geçmediyse sql server a ait object dediği (indeks olur büyük ihtimalle) bozulmuş olabilir.

CevapAlıntı
Gönderildi : 10/04/2017 14:42
recep dağ
(@recepdag)
Üye

Açıklama :
1105 - [Microsoft][ODBC SQL Server Driver][SQL Server]Could not allocate space for object 'dbo.tbStokFisiDetayi'.'tbStokFisiDetayi_index2a' in database 'Dnrm' because the 'PRIMARY' filegroup is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup.
SQL : Insert Into tbStokFisiDetayi values (2043965, -2147482517, '19/03/2017' , 19, 0, 'T' , '19/03/2017' , 1, 3, '100' , 0, '' , '' , '' , '' , '19/03/2017' , 0, 0, 0, 0, 0, 42, 0, 0, 0, '' , 0, 0, 0, 0, 0, 0, 0, '' , 0, Null, 0, 2043966, '1200' , 0, 0, 'ayakkabı çeşit' , '' , 0, 'dogan' , getdate (), '' , 0, 0, '' , 0, 0, 0, 3, Null , 16745, Null, '' , 'T' , 0, 0, 0, 0, 'dogan' , getdate () )

Hatayı aldığım transef fişinde ki hata kodu

CevapAlıntı
Gönderildi : 10/04/2017 22:38
oldmember
(@yavuzfilizlibay)
Üye

Database üzerinde sağ klik yapın properties e girin. Files sekmesinde, database in auto growth özelliği kapalı kalmış olabilir, bunu otomatiğe getirin. Bir de database ın boyutunu ordaki değer ne ise daha yüksek bir değer yazarak büyütün, şu anda data file da yer olmadığı için veri yazamıyorum uyarısı veriyor.

CevapAlıntı
Gönderildi : 11/04/2017 12:45
recep dağ
(@recepdag)
Üye

[quote user="Yavuz Filizlibay"]

Database üzerinde sağ klik yapın properties e girin. Files sekmesinde, database in auto growth özelliği kapalı kalmış olabilir, bunu otomatiğe getirin. Bir de database ın boyutunu ordaki değer ne ise daha yüksek bir değer yazarak büyütün, şu anda data file da yer olmadığı için veri yazamıyorum uyarısı veriyor.

[/quote]

 

Merhaba

http://hizliresim.com/X0l0jO

http://hizliresim.com/M0R0b7

http://hizliresim.com/qbybaV

 

 

Merhaba Resimler Ekte enable yazıyor ama bi bakarsanız sevinirim

Teşekkürler

CevapAlıntı
Gönderildi : 11/04/2017 23:44
oldmember
(@yavuzfilizlibay)
Üye

büyüme oranı 0 percent demiş orada, yüzde 0 büyüme olamayacağı için data dosyası büyüyemiyor.

CevapAlıntı
Gönderildi : 12/04/2017 02:08
recep dağ
(@recepdag)
Üye

Merhabalar 0 değil resimde bozuk çıkmış 100 yazıyor 

CevapAlıntı
Gönderildi : 12/04/2017 23:49
Paylaş: