Anasayfa » Forum

Sql Express 2005 ha...
 
Bildirimler
Hepsini Temizle

Sql Express 2005 hatası

 Anonim

Merhaba arkadaşlar sizlerden bir konu hakkında yardımlarınızı bekliyorum. Şöyleki şirkette kullanmış olduğum sql express 2005 otomatik günlük yedek aldırmak istiyorum. Sanal ortamda yaptığım çalışmalarda olumlu sonuç aldıktan sonra hayata geçirmeyi düşündüm fakat bir problemle karşılaştım.

Hata:

C:\Documents and Settings\Administrator>SQLCMD -S sunucu\SQLEXPRESS -E -i d:\veg
ayedek\gunluk.sql
HResult 0xFFFFFFFF, Level 16, State 1
SQL Network Interfaces: Error Locating Server/Instance Specified [xFFFFFFFF].
Sqlcmd: Error: Microsoft SQL Native Client : An error has occurred while establi
shing a connection to the server. When connecting to SQL Server 2005, this failu
re may be caused by the fact that under the default settings SQL Server does not
 allow remote connections..
Sqlcmd: Error: Microsoft SQL Native Client : Login timeout expired.

Herkese şimdiden teşekkürler kolay gelsin.

Alıntı
Topic starter Gönderildi : 09/06/2010 02:38
Hakan Uzuner
(@hakanuzuner)
Kıdemli Üye Yönetici

Merhaba

Kodu tek satır olarak yazıyorsunuz değil mi ? ayrıca remote connections özelliği açık mı sql in ?

 

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 09/06/2010 02:46
 Anonim

Hakan hocam

kullanmış olduğum kod bu şekilde: CD "D:\Backup\yedek"
DEl *.* /Q
CD "C:\Program Files\Microsoft SQL Server\90\Tools\Binn"
SQLCMD -S server2008\SQLEXPRESS -E -i d:\backup\autobackup.sql

 Surface areadan baktım remote connection açık görünüyor.

CevapAlıntı
Topic starter Gönderildi : 09/06/2010 02:56
Hakan Uzuner
(@hakanuzuner)
Kıdemli Üye Yönetici

başka bir makineden telnet makineipsi 1453 yapınca çalışıyor mu ?

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 09/06/2010 11:56
 Anonim

Hakan hocam 1453 yapınca bağlantı başarısız oluyor 1433 te bağlanıyor.

CevapAlıntı
Topic starter Gönderildi : 09/06/2010 12:00
Hakan Uzuner
(@hakanuzuner)
Kıdemli Üye Yönetici

pardon çok yoğunum ondan yanlış yazmışım 1433 olacak tabiki 🙂

o zaman başka bir sorun var bakalım google ne diyecek bu konuda , ben hatayı okuyup yorumladım.

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 09/06/2010 13:38
 Anonim

Hakan hocam sorunu çözdüm. Yardımların için teşekkürler kolay gelsin. -S yerine -s kullandım test edildi onaylandı.

CevapAlıntı
Topic starter Gönderildi : 09/06/2010 14:30
CozumPark
(@cozumpark)
Onursal Üye Yönetici

SQL Browser servisi de started durumda olmalı ve 1434 portu için de firewall açıksa izin veren bir rule yazılmalıydı diye hatırlıyorum ben.

CevapAlıntı
Gönderildi : 09/06/2010 14:41
 Anonim

İlginize teşekkür ederim Alper bey. Sadece komutta büyük S yerine küçük s kullandım ve şu anda otomatik şekilde yedek alıyor. Uzun zamandır uğraşıyordum çok şükür en sonunda çözüme kavuştu.


İyi çalışmalar kolay gelsin.

CevapAlıntı
Topic starter Gönderildi : 09/06/2010 14:53
CozumPark
(@cozumpark)
Onursal Üye Yönetici

Case-sensitive kurulmuş o halde, erişimlerinizde sıkıntı yokmuş, bize de iyi bilgi oldu.

CevapAlıntı
Gönderildi : 09/06/2010 15:03
Paylaş: