Forum

SQL Server 2008 R2 ...
 
Bildirimler
Hepsini Temizle

SQL Server 2008 R2 Tabloda Sütun oluşturma problemi

Serdar Demirbaş
(@SerdarDemirbas)
Üye

Arkadaşlar bilgisayarıma SQL server 2008 R2 kurdum ve eski veritabanımın mdf sini içerisine attach ettim.. Fakat bir tabloya sütun ekleyeceğim zaman resimlerdeki hataları veriyor sadece char(10) olarak kaydettiriyor.. Bazen kaydettirmiyorda.. int veya date time hiç oluşturamadım.. 2005 versiyonunda bu sorun yoktu.. Bunu nasıl çözebilirim.. Şimdiden teşekkürler..


 


Alıntı
Konu başlatıcı Gönderildi : 14/05/2010 21:20
İsmail ADAR
(@ismailadar)
Üye

Merhaba magement stdio da Tools | Options | Designer | kısmındaki


 Prevent saving change that require table re-creation yanındaki ticki kaldırısanız sorun cozulur.


Kolay gelsin

CevapAlıntı
Gönderildi : 14/05/2010 22:14
Serdar Demirbaş
(@SerdarDemirbas)
Üye

Allah razı olsun.. Çok teşekkür ederim.. Eski sürümde çıkan sorunlar yüzünden hem onları kaldırıp hemde R2 yi kurmaya çalıştım.. O sürede bir sürü hata ile uğraşıp bide burda takılınca sıkıntı olmuştu bana.. İnternette de bulamamıştım.. Tekrar çok teşekkür ederim..

CevapAlıntı
Konu başlatıcı Gönderildi : 15/05/2010 12:35
İsmail ADAR
(@ismailadar)
Üye

Önemli değil Kolay gelsin

CevapAlıntı
Gönderildi : 15/05/2010 12:49
CozumPark
(@cozumpark)
Onursal Üye Yönetici

Bence bu mesaj sabitlenmeli çünkü SQL Server 2008 ve sonrasında yaşanan bu problem yüzünden pek çok kullanıcı vakit kaybı yaşıyor.


Başlık da şöyle olabilir: SQL Server 2008 ve Sonrasında Veritabanında Değişiklik Yaparken Hata Alıyorsanız...

CevapAlıntı
Gönderildi : 15/05/2010 13:29
Hüseyin Sevin
(@huseyinsevin)
Üye

2008 serverda da olan çok basit bir sorun. Bu işlemi sunucu tarafında yaptıktan sonra kullanıcılar tarafında da aynı ayarı SQL Server Management Studio da da yapmanız gerekiyor.

 

Kolay gelsin.

CevapAlıntı
Gönderildi : 21/05/2010 12:23
CozumPark
(@cozumpark)
Onursal Üye Yönetici

[quote user="Hüseyin Sevin"]

2008 serverda da olan çok basit bir sorun. Bu işlemi sunucu tarafında yaptıktan sonra kullanıcılar tarafında da aynı ayarı SQL Server Management Studio da da yapmanız gerekiyor.


 


Kolay gelsin.


[/quote]


Hüseyin bey zaten sorun management ile ilgili; management kullanılan her PC'de bu ayar yapılmak zorunda yani server ile ilgili değil.


Şöyle açıklayayım: SQLSrv1 ve SQLSrv2 olsun (bunlar server). Management client ile SQLSrv1'e bağlanıp bu ayar yapıldı diyelim; SQLSrv2'ye bağlanırken bir ayar yapmak gerekmez. Çünkü ayar management studio'ya aittir yani server tarafında bir değişikliğe neden olmuyor. Hatta herhangi bir bağlantı gerçekleştirmeden de değişikliği yapabilirsiniz.


Herkese iyi çalışmalar; başarılar.

CevapAlıntı
Gönderildi : 21/05/2010 18:32
Hüseyin Sevin
(@huseyinsevin)
Üye

[quote user="MERT DOĞAN"][quote user="Hüseyin Sevin"]

2008 serverda da olan çok basit bir sorun. Bu işlemi sunucu tarafında yaptıktan sonra kullanıcılar tarafında da aynı ayarı SQL Server Management Studio da da yapmanız gerekiyor.

 

Kolay gelsin.

[/quote]

Hüseyin bey zaten sorun management ile ilgili; management kullanılan her PC'de bu ayar yapılmak zorunda yani server ile ilgili değil.

Şöyle açıklayayım: SQLSrv1 ve SQLSrv2 olsun (bunlar server). Management client ile SQLSrv1'e bağlanıp bu ayar yapıldı diyelim; SQLSrv2'ye bağlanırken bir ayar yapmak gerekmez. Çünkü ayar management studio'ya aittir yani server tarafında bir değişikliğe neden olmuyor. Hatta herhangi bir bağlantı gerçekleştirmeden de değişikliği yapabilirsiniz.

Herkese iyi çalışmalar; başarılar.

[/quote]

 

Bu sıkıntıdan yazılımcı arkadaşlar bahsedince ben ilk olarak SQL serverda bu ayarları yapmıştım ve sonra dediğiniz gibi sorun devam edince aynı ayarı Management Studio da yaptım. Sorun çözüldü. Yani her iki tarafta da yapmaya gerek yok sadece Management Studio'da yapmak yeterli oluyor o zaman şu haliyle.

 

Bilgi için teşekkür ederim.

CevapAlıntı
Gönderildi : 22/05/2010 22:09
CozumPark
(@cozumpark)
Onursal Üye Yönetici

[quote user="Hüseyin Sevin"][quote user="MERT DOĞAN"][quote user="Hüseyin Sevin"]

2008 serverda da olan çok basit bir sorun. Bu işlemi sunucu tarafında yaptıktan sonra kullanıcılar tarafında da aynı ayarı SQL Server Management Studio da da yapmanız gerekiyor.


 


Kolay gelsin.


[/quote]


Hüseyin bey zaten sorun management ile ilgili; management kullanılan her PC'de bu ayar yapılmak zorunda yani server ile ilgili değil.


Şöyle açıklayayım: SQLSrv1 ve SQLSrv2 olsun (bunlar server). Management client ile SQLSrv1'e bağlanıp bu ayar yapıldı diyelim; SQLSrv2'ye bağlanırken bir ayar yapmak gerekmez. Çünkü ayar management studio'ya aittir yani server tarafında bir değişikliğe neden olmuyor. Hatta herhangi bir bağlantı gerçekleştirmeden de değişikliği yapabilirsiniz.


Herkese iyi çalışmalar; başarılar.


[/quote]


 


Bu sıkıntıdan yazılımcı arkadaşlar bahsedince ben ilk olarak SQL serverda bu ayarları yapmıştım ve sonra dediğiniz gibi sorun devam edince aynı ayarı Management Studio da yaptım. Sorun çözüldü. Yani her iki tarafta da yapmaya gerek yok sadece Management Studio'da yapmak yeterli oluyor o zaman şu haliyle.


 


Bilgi için teşekkür ederim.


[/quote]


Evet aynen öyle. Yalnız şu cümleyi düzenleme ihtiyacı da var: "her iki tarafta da yapmaya gerek yok" cümlesi hatalı "ayar sadece client tarafı için var" demek daha doğru.


 Çünkü ayar SQL Server'a ait değil; management studio'ya ait.


İyi çalışmalar.

CevapAlıntı
Gönderildi : 25/05/2010 21:54
Paylaş: