Anasayfa » Forum

Oledb ve Native Cli...
 
Bildirimler
Hepsini Temizle

Oledb ve Native Client

Tuna Demirel
(@TunaDemirel)
Üye

Merhaba şirketimizde 2 adet sql server var. Bir tanesi lisanslı SQL 2008 STANDART diğeri SQL 2008 Express edition.

Sorum şu; satndart olan sql 2008 server'a bildiğimiz oledb ile bağlanabiliyorum. Fakat express edition olan server'a native client ile bağlanabiliyorum sadece. Oledb'yi (ODBC'de yüklü olan sql server) kabul etmiyor. Nerede hata yaptım yada başka bir ayarı filanmı var. Configiration toolda sql server'ın bütün tcp/ip ayarları yapılmış durumdadır.

Alıntı
Topic starter Gönderildi : 20/10/2009 19:50
Hatice AKGUL
(@haticeakgul)
Üye

   Sql server autentication mod mix mod yaparmısınız.


iyi çalışmalar.

CevapAlıntı
Gönderildi : 21/10/2009 15:13
Tuna Demirel
(@TunaDemirel)
Üye

[quote user="Hatice AKGUL"]

   Sql server autentication mod mix mod yaparmısınız.

iyi çalışmalar.

[/quote]

 

Zaten mix mod'da çalışıyor.

CevapAlıntı
Topic starter Gönderildi : 22/10/2009 11:48
Hatice AKGUL
(@haticeakgul)
Üye

  Merhaba;


  sql server instance name den kaynaklanıyor olabilir pc adı /sqlexpress  olarak server a bağlanmayı denermisiniz.


Örn= Benim makina adım hatice aşdaki ismi örnek alarak kendi isimleriniz için denermisiniz.


hatice/sqlexpress

CevapAlıntı
Gönderildi : 22/10/2009 13:43
Tuna Demirel
(@TunaDemirel)
Üye

[quote user="Hatice AKGUL"]

  Merhaba;

  sql server instance name den kaynaklanıyor olabilir pc adı /sqlexpress  olarak server a bağlanmayı denermisiniz.

Örn= Benim makina adım hatice aşdaki ismi örnek alarak kendi isimleriniz için denermisiniz.

hatice/sqlexpress

[/quote]

 

Bunuda deniyorum ama malesef isimden ulaşamıyorum. Management toolla bile bağlanamıyorum sizin dediğiniz şekilde. Ama sadece server adını management tool'a yazarsam bağlanıyor. Ado nesnesiyle yazdığım program içinden bağlanamıyorum. Bişeyler eksik sanki sqlexpress'de

CevapAlıntı
Topic starter Gönderildi : 22/10/2009 16:27
Gokhan DOGAN
(@GokhanDOGAN)
Üye

Merhaba

Hatice Hanım'a ek olarak tcp port nosunu 1433 değilde 9867 olarak değiştirip deneyin bağlanması gerek.

CevapAlıntı
Gönderildi : 02/11/2009 01:41
Paylaş: