Anasayfa » Forum

InfoPath DataConnec...
 
Bildirimler

InfoPath DataConnection Problemi  

  RSS
esref
(@esref)
Üye

İyi Günler Sharepoint 2010 üzerinde herhangi bir listeye gelip InfoPath CustomizeForm dediğimde herşey normal şifremi girip Form 'u görebiliyorum, fakat daha sonra DataConnection 'dan Sharepoint List > Data Receive dediğimde tekrar şifremi soruyor, yine kullanıcı adı şifremi giriyorum, fakat data 'ya ulaşmayı bir türlü başaramıyorum. The Could not be completed hatası verip kalıyor. Sorunu bir türlü çözemedim. 

Yardımlarını bekliyorum, teşekkürler. 

Alıntı
Gönderildi : 03/03/2011 16:55
Serkan Konak
(@serkankonak)
Üye

Şifrenizi kaç kere soruyor. 1 den fazla şifre soruyor ise data connection esnasında ondan sonra hata veriyor sa liste ile auth. sağlayamıyor demektir.Ona göre yönlendirelim.

CevapAlıntı
Gönderildi : 03/03/2011 17:44
esref
(@esref)
Üye

Serkan bey,

Customize Form diyorum. Infopath açılıyor şifremi giriyorum form' a ulaşabiliyorum buraya kadar sorunum yok daha sonrasında Data connection 'dan receive data dediğimde hiç şifre sormadan Could not complete veriyor. 

 

CevapAlıntı
Gönderildi : 03/03/2011 19:50
Serkan Konak
(@serkankonak)
Üye

receive data dedikten sonra size hangi yolla data alacağınızı sorması lazım buraya gelmeden mi hata veriyor ?

CevapAlıntı
Gönderildi : 03/03/2011 20:09
esref
(@esref)
Üye

Afedersiniz evet receive data diyorum,


SOAP


REST


Sharepoint Book or List


geliyor, ben burada Sharepoint List 'i seçiyorum. Next diyorum Adresi belirtip tekrar next diyorum alttaki hatayı alıyorum.

 

CevapAlıntı
Gönderildi : 03/03/2011 20:40
Serkan Konak
(@serkankonak)
Üye

Adres alanına alt site ismi yerine en üst siteyi yazarak denermisiniz.Örneğin http://sitecollection/altsite şeklinde değil, http://sitecollection yazıp geçmeyi deneyin eğer geçer ise bir sonraki menüde listeyi seçmeyi deneyin.

CevapAlıntı
Gönderildi : 03/03/2011 20:42
esref
(@esref)
Üye

Serkan Bey


dediğiniz uyguladım fakat malesef yine ulaşamıyorum. Sizin dediğiniz gibi gitmeye çalışınca "The Internet Adress http://****** is no valid hatası veriyor. Bunu halledebilirsem önümde beni bekleyen formlar var ama daha ilk adımda tıkandım. Sizce serveramı yoksa spesific başka bir yeremi yetkim olması gerekiyor. Local Win 7 üzerine kurduğumda hiç bir sorun yaşamadım. Teşekkürler.

CevapAlıntı
Gönderildi : 03/03/2011 21:35
Serkan Konak
(@serkankonak)
Üye

Bu işlemleri yaptığınız makinada http://sitecollection yazarak girebiliyor musunuz Sharepoint sunucusunuza ? (hosts dosyasında oynama yapmadan) .Sharepoint sunucunuzu algılamıyor infopath. IP adresi ile girmeyi deneyin sorunun bu olduğunu anlamamız açısından .

CevapAlıntı
Gönderildi : 03/03/2011 22:46
esref
(@esref)
Üye

Evet IP 'den gitmeye çalışınca yine şifre girmemi istiyor. Girmeye çalışıyorum fakat kabul etmiyor. 5 kez sordu şifreyi en son yine aynı hatayı verdi "http://****** is not valid" IP 'den IP 'den görüyor server 'ı benim Permission ile ilgili bir sıkıntım var sanırım.

CevapAlıntı
Gönderildi : 04/03/2011 10:53
Serkan Konak
(@serkankonak)
Üye

Yetki sorunu gibi görünmüyor. Eğer yetkiniz olmasa idi şifreyi tekrar tekrar sormaz yetkiniz olmadığına dair uyarı verir işlemi bitirirdi. Sizin sorununuz Auth. ve DNS çözümlemesi ile ilgili gibi görünüyor.

Şu sorulara cevap alırsak çözüme gidebiliriz;

1- Sharepoint 2010 web application ınız Auth. Metodunu ne seçtiniz. Kerberos NTLM ?

2- Bu işlemleri gerçekleştirmeye çalıştığınız kullanıcı adı şifre aynı zamanda sistem hesabı olarak kullandığınız hesabmıdır?

3- İşlemi gerçekleştirmeye çalıştığınız makina da http://intranetadresiniz şeklinde sharepointe giriş de sorun yaşıyormusunuz.

4- Herhangi bir address mapping yaptınız mı . Yani http://intranetadresim olan orjinal adı http://yeniintranetadresim gibi bir başka adresle açabilmek için ayarlama yapmaya çalıştınız mı.

5- Yeni bir infopath formu boş olarak açıp burada data connection denediniz mi .

CevapAlıntı
Gönderildi : 04/03/2011 11:11
esref
(@esref)
Üye

Birkaç testserver kurulumu yapıcam, bir bakayım neleri atlamışım geri dönüş yapıcam. Serkan bey zaman ayırdığınız için teşekkür ederim.

CevapAlıntı
Gönderildi : 04/03/2011 19:46
esref
(@esref)
Üye

Serkan Bey, 

1- Auth. Mode NTLM

2- Kullanıcı domain users + central administration 'a ekledim. Infopath 'te http://********:29026 yazarsam central administration site 'ındaki listler geliyor. Normal site 'taki listlere ulaşamıyorum. Bu bir servis eksikliği olabilir mi ? Anlayamadım.

3- Ulaşımda hiçbir problem yaşamıyorum.

4- Adress map etmedik

5- Boş formlar ilede ulaşamıyorum.

Kurduğum testserver üzerindede aynı prbolemi yaşıyorum. Artık bunu çözüp form oluşturmam gerekiyor. 

Teşekkürler. 

 

CevapAlıntı
Gönderildi : 07/03/2011 14:42
Emre BALCI
(@emrebalci)
Üye

Merhaba,

Bazı noktaları görmeden yorum yapmak çok zor oluyor. Sizinkide bu durumlardan biri. Eğer sizin için çok önem taşıyan bir durumsa profesyonel olarak destek almanızı tavsiye ederim.

İyi Çalışmalar.

CevapAlıntı
Gönderildi : 07/03/2011 16:40
esref
(@esref)
Üye

Problemin basit birşey olabileceğini düşünüyorum kurulumdan kaynaklanan acaba aklınıza gelen yerler varmıdır, şunu yada bunu kontrol ettinizmi gibi çünkü 3 server kurdum. Hiç birinde bağlanamıyorum bi yerde eksik birşey yapıyorum sanırım.

 Teşekkürler.

 

CevapAlıntı
Gönderildi : 07/03/2011 18:01
Paylaş: