Anasayfa » Forum

pfsense paket ve si...
 
Bildirimler

pfsense paket ve sistem güncelleme sorunu  

  RSS
Oğuzhan Solmaz
(@OguzhanSolmaz)
Üye

pfsense squid ve squidGuard paketlerini eklerken

>>> Installing pfSense-pkg-squid...
Updating pfSense-core repository catalogue...
pfSense-core repository is up-to-date.
Updating pfSense repository catalogue...
pfSense repository is up-to-date.
All repositories are up-to-date.

pfSense-kernel-pfSense-2.3.2 is locked and may not be modified
Checking integrity... done (0 conflicting)
The following 4 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
pfSense-pkg-squid: 0.4.36 [pfSense]
squid: 3.5.23 [pfSense]
squidclamav: 6.14 [pfSense]
c-icap-modules: 0.4.3 [pfSense]

Number of packages to be installed: 4

The process will require 10 MiB more space.
[1/4] Installing squid-3.5.23...
===> Creating groups.
Using existing group 'squid'.
===> Creating users
Using existing user 'squid'.
install: not found
pkg: PRE-INSTALL script failed
Failed

 

böyle bi hata alıyorum sebebi nedir. 

teşekkürler ..

 

Alıntı
Gönderildi : 07/03/2017 13:57
Hakan KAPLANOGLU
(@hakankaplanoglu)
Üye

system-user management kısmından squid isimli kullanıcıları ve grupları silip takrar dener misiniz ?

CevapAlıntı
Gönderildi : 07/03/2017 14:29
Oğuzhan Solmaz
(@OguzhanSolmaz)
Üye

sadece admin kullanıcısı mevcut

CevapAlıntı
Gönderildi : 07/03/2017 15:21
ibrahim yildiz
(@ibrahimyildiz)
Üye

"The process will require 10 MiB more space."

 

alan sorunu.

CevapAlıntı
Gönderildi : 07/03/2017 21:00
Turan COŞKUN
(@turancoskun)
Tecrübeli Üye Forum Yöneticisi

merhaba,

konsol üzerinde aşağıdaki komutu uygulayıp, kurulumu tekrar deneyin.

hatalıda olsa squid kurulu görünüyor ise, komuttan önce kaldırıp, komutu uygulayıp, kurulama geçin.

tar xv -C / -f /usr/local/share/pfSense/base.txz ./usr/bin/install

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 09/03/2017 00:39
Oğuzhan Solmaz
(@OguzhanSolmaz)
Üye

Merhaba yazdığınız çözümü uyguladıktan sonra sorunum giderildi ..

 

Teşekkür ederim 

 

İyi Çalışmalar. . 

CevapAlıntı
Gönderildi : 11/03/2017 20:44
Turan COŞKUN
(@turancoskun)
Tecrübeli Üye Forum Yöneticisi

rica ederim, faydalı olmasına sevindim.

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 12/03/2017 15:41
KARATEKİN Murat
(@karatekinmurat)
Üye

Merhaba 

PfSense komuttunda mysql paketini ekledikten sonra install kısmında 

pkg: missing dependency 'icu' hatası veriyor. 

çözümü nedir?

CevapAlıntı
Gönderildi : 08/01/2019 13:34
Turan COŞKUN
(@turancoskun)
Tecrübeli Üye Forum Yöneticisi

merhaba,

pfsense hangi versiyonu kullanıyorsunuz ?

servislerde mysql listede var mı ?

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 11/01/2019 02:24
KARATEKİN Murat
(@karatekinmurat)
Üye

PfSense 2.3.4 sürümünü yükledim. network ayarlarını yaptım. Freeeadıus ve pfSense dosyalarını "yes" yaptım. fakat konsolda shell komutuna "pkg update" yazınca - Shared opject "libssl.so.8" not found, required by "pkg" hatası verdi.

bunun sebebi nedir. Web kısmında da paketlerin hiç biri gözükmüyor.

 

CevapAlıntı
Gönderildi : 18/01/2019 14:44
KARATEKİN Murat
(@karatekinmurat)
Üye

[quote user="KARATEKİN Murat"]

PfSense 2.3.4 sürümünü yükledim. network ayarlarını yaptım. Freeeadıus ve pfSense dosyalarını "yes" yaptım. fakat konsolda shell komutuna "pkg update" yazınca - Shared opject "libssl.so.8" not found, required by "pkg" hatası verdi.

bunun sebebi nedir. Web kısmında da paketlerin hiç biri gözükmüyor.

 

[/quote]

biraz araştırdıktan sonra kurulumu hallettim. ama şimdi de Freeradius servisi çalışmıyor.

bu yüzden de web'e girerken captveportal ekranı gelmiyor.

3 kere aynı şekilde kurulum yaptım. sonuç hep aynı.

bu arada PfSense 2.3.2 sürümünü geri yükledim. 2.3.2-RELEASE (amd64) 
built on Tue Jul 19 12:44:43 CDT 2016 
FreeBSD 10.3-RELEASE-p5 

 

System loglarına baktığımda da Radius servisi şu hataları veriyor.

rlm_eap: SSL error error:02001002:system library:fopen:No such file or directory

rlm_eap_tls: Error reading certificate file /usr/local/etc/raddb/certs/server_cert.pem

rlm_eap: Failed to initialize type tls

/usr/local/etc/raddb/eap.conf[2]: Instantiation failed for module "eap"

/usr/local/etc/raddb/sites-enabled/default[331]: Failed to find "eap" in the "modules" section.

/usr/local/etc/raddb/sites-enabled/default[266]: Errors parsing authenticate section.

Failed to load virtual server <default> 

 

yardımcı olursanız sevinirim. 

Teşekkürler.

 

CevapAlıntı
Gönderildi : 18/01/2019 18:51
ihsan Öner
(@ihsanoner)
Üye

Merhaba,

 

Pfsense 2.4.4 versıyonu kurdum paket indirmek istediğim zaman ''Unable to retrieve package information '' hatasını alıyorum neden olabilir,

 

CevapAlıntı
Gönderildi : 19/01/2019 12:24
KARATEKİN Murat
(@karatekinmurat)
Üye

pfSense komut satırında pkg-static update yaz yükleme yapsın sonra exit yaz 5 bas restart yapsın sonra kontrol et

eğer yine aynı hatayı alırsan bu sefer komut satırında pkg-static upgrade yaz yükleme bitince tekrar restart yap

CevapAlıntı
Gönderildi : 19/01/2019 13:31
ihsan Öner
(@ihsanoner)
Üye

[quote user="KARATEKİN Murat"]

pfSense komut satırında pkg-static update yaz yükleme yapsın sonra exit yaz 5 bas restart yapsın sonra kontrol et

eğer yine aynı hatayı alırsan bu sefer komut satırında pkg-static upgrade yaz yükleme bitince tekrar restart yap

[/quote]

 

Merhaba,

 

Dediginz gibi işlemleri yaptım ve her hangi bir işlem olmadı,

Dns Ayarlarını google dns olarak düzelteme yaptım paket indirmede sorun yaşıyorum,

 

Aldığım Hata:

>>> Updating repositories metadata...
Updating pfSense-core repository catalogue...
pkg-static: Repository pfSense-core load error: access repo file(/var/db/pkg/rep o-pfSense-core.sqlite) failed: No such file or directory
pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-core/meta.txz: Network is unreachable
repository pfSense-core has no meta file, using default settings
pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-core/packagesite.txz: N etwork is unreachable
Unable to update repository pfSense-core
Updating pfSense repository catalogue...
pkg-static: Repository pfSense load error: access repo file(/var/db/pkg/repo-pfS ense.sqlite) failed: No such file or directory
pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-pfSense_v2_4_4/meta.txz : Network is unreachable
repository pfSense has no meta file, using default settings
pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-pfSense_v2_4_4/packages ite.txz: Network is unreachable
Unable to update repository pfSense
Error updating repositories!
pfSense - Netgate Device ID: 2d66606a02e395afb356

Yardımlarınızı bekliyorum;

Teşekkürler

CevapAlıntı
Gönderildi : 19/01/2019 17:01
Turan COŞKUN
(@turancoskun)
Tecrübeli Üye Forum Yöneticisi

[quote user="ihsan Öner"]

 

>>> Updating repositories metadata...
Updating pfSense-core repository catalogue...
pkg-static: Repository pfSense-core load error: access repo file(/var/db/pkg/rep o-pfSense-core.sqlite) failed: No such file or directory
pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-core/meta.txz: Network is unreachable
repository pfSense-core has no meta file, using default settings
pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-core/packagesite.txz: N etwork is unreachable
Unable to update repository pfSense-core
Updating pfSense repository catalogue...
pkg-static: Repository pfSense load error: access repo file(/var/db/pkg/repo-pfS ense.sqlite) failed: No such file or directory
pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-pfSense_v2_4_4/meta.txz : Network is unreachable
repository pfSense has no meta file, using default settings
pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-pfSense_v2_4_4/packages ite.txz: Network is unreachable
Unable to update repository pfSense
Error updating repositories!
pfSense - Netgate Device ID: 2d66606a02e395afb356[/quote]

merhaba,

mesajı içeriğine göre, sorun routing tarafında görünüyor.

pfsense'in internet erişimi olduğunuza emin misiniz ?

system/routing altında gateway ve monitoring ip seçiminizi kontrol edin.

 

 

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 19/01/2019 17:13
ihsan Öner
(@ihsanoner)
Üye

[quote user="Turan COŞKUN"]

[quote user="ihsan Öner"]

 

>>> Updating repositories metadata...
Updating pfSense-core repository catalogue...
pkg-static: Repository pfSense-core load error: access repo file(/var/db/pkg/rep o-pfSense-core.sqlite) failed: No such file or directory
pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-core/meta.txz: Network is unreachable
repository pfSense-core has no meta file, using default settings
pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-core/packagesite.txz: N etwork is unreachable
Unable to update repository pfSense-core
Updating pfSense repository catalogue...
pkg-static: Repository pfSense load error: access repo file(/var/db/pkg/repo-pfS ense.sqlite) failed: No such file or directory
pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-pfSense_v2_4_4/meta.txz : Network is unreachable
repository pfSense has no meta file, using default settings
pkg-static: https://pkg.pfsense.org/pfSense_v2_4_4_amd64-pfSense_v2_4_4/packages ite.txz: Network is unreachable
Unable to update repository pfSense
Error updating repositories!
pfSense - Netgate Device ID: 2d66606a02e395afb356[/quote]

merhaba,

mesajı içeriğine göre, sorun routing tarafında görünüyor.

pfsense'in internet erişimi olduğunuza emin misiniz ?

system/routing altında gateway ve monitoring ip seçiminizi kontrol edin.

 

 

[/quote]

Merhaba Turan Bey,

 

Pfsense internet erişimi var,

2 tane adsl hattı mevcut, 1 tanesi gateway ve monıtor ıp olarak şeçilmiş durumda,

dnsler ile ilgli bir sorun olabilirmi,

 

Teşekürler,

 

 

CevapAlıntı
Gönderildi : 19/01/2019 17:56
Turan COŞKUN
(@turancoskun)
Tecrübeli Üye Forum Yöneticisi

[quote user="ihsan Öner"]

Pfsense internet erişimi var,

2 tane adsl hattı mevcut, 1 tanesi gateway ve monıtor ıp olarak şeçilmiş durumda,

dnsler ile ilgli bir sorun olabilirmi,[/quote]

1 tanesi gateway derken, default gateway olarak seçtiniz mi ? bkz. system / routing / ilgili int.

system/general setup altında dns adresleriniz tanımlı mı ?

default gateway seçimi ve dns tanımı mevcut ise, diğer hattı devre dışı bırakarak tekrar test edin.

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 19/01/2019 18:11
Turan COŞKUN
(@turancoskun)
Tecrübeli Üye Forum Yöneticisi

merhaba,

öncelikle aşağıdaki komutları, shell üzerinde çalıştırıp, sistemi yeniden başlatarak tekrar test edin.

pkg-static clean -ay; pkg-static install -fy pkg pfSense-repo pfSense-upgrade

sorun devam ederse, üzerinde aktif olan harici servisleri devre dışı bırakarak test edin. örn. dnsbl,squid vb.

 

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 25/01/2019 02:20
Paylaş: