Bildirimler
Hepsini Temizle

Merhabalar, PHP mail hatası..  

  RSS
mehmet burak
(@mehmetburak)
Üye

Değerli Çözüm Park üyeleri , sorunum şu şekilde bağlı bulunduğum kuruma bir iletişim formu düzenledim.. lakin iletişim formu mail gönderirken sorunlarla karşılaşıyorum.. Şimdi den yardımlarınız için çok teşekkür ederim.. 

 

Kullandığım kod aşağıdaki gibidir, 

 

<?

require("class.phpmailer.php");

$mail = new PHPMailer();

$mail->IsSMTP();                                   // send via SMTP

$mail->Host     = "mail.ekolkoleji.com.tr"; // SMTP servers

$mail->SMTPAuth = true;     // turn on SMTP authentication

$mail->Username = "info@ekolkoleji.com.tr";  // SMTP username

$mail->Password = "Şifremi yazıyorum"; // SMTP password

$mail->From     = $_POST['mailad'];

$mail->Fromname = $_POST['isim'];

$mail->AddAddress("mehmetburak@ekolkoleji.com.tr","Online Randevu");

$mail->Subject  =  $_POST['baslik'];

$mail->Body     =  $_POST['mesaj'];

if(!$mail->Send())

{

   echo "Randevu isteğiniz bize ulaştı..<p>";

   echo "Mailer Error: " . $mail->ErrorInfo;

   exit;

}

echo "Mesaj Gönderildi";

?> 

 

Bu şekilde tamamladıktan sonra,

 

form üzerindeki "E-mail Adresiniz" kısmına , mehmetburak@ekolkoleji.com.tr yazarsam mail sorunsuz olarak gönderiliyor , lakin formu dolduracak olan kullanıcı farklı bir e-mail adresi belirttiğinde şu hatayı alıyorum..

 

Mailer Error: The following From address failed: burak@ekolkoleji.com.tr

 

ilginizden dolayı teşekkür ederim..  

Alıntı
Gönderildi : 27/01/2013 01:56
Tan Bora
(@TanBora)
Üye

smtp port tanımlaması olması gerekmiyor mu ?

CevapAlıntı
Gönderildi : 27/01/2013 13:49
mehmet burak
(@mehmetburak)
Üye

Şu şekilde göndereyim tüm dosyaları kullandığım ve ftp ye attığım , bileşenler smtp kontrlü var.. 587 olarak değiştirdim lakin aynı hatayı almaya devam ediyorum.. 

 

Dosyalar link içerisindedir , vereceğiniz kıymetli cevaplar için teşekkür ederim..

 

http://iletisim.ekolkoleji.com.tr/php.rar 

CevapAlıntı
Gönderildi : 28/01/2013 01:18
mehmet burak
(@mehmetburak)
Üye

Gerekli düzeltmeleri yapmama rağmen , port olarak da "587" giriyorum lakin hala problem yaşamaktayım.. 

CevapAlıntı
Gönderildi : 31/01/2013 14:08
mehmet burak
(@mehmetburak)
Üye

Değerli bilişim üyeleri, ilginiz için teşekkür ederim sorunumu çözdüm..

 

$mail->SMTPAuth = true;     // turn on SMTP authentication

 

SMTPAuts kısmını false olarak değiştirdim gönderebiliyorum.. 

 

Kalın sağlıcakla.. 

CevapAlıntı
Gönderildi : 06/02/2013 23:45
Paylaş: