Anasayfa » Forum

Centos'tan mail git...
 

Centos'tan mail gitmiyor/gelmiyor  

  RSS
Musa Alican
(@MusaAlican)
Üye

Merhaba,

Şirkete Centos 7 bir sunucu kurdum ve bunun içine de ManageEngine Service Desk Plus kurdum. Service Desk Plus'ı sorunsuz yapılandırdım ve çok iyi çalışıyor ama tek sorunumuz mail alıp vermiyor. Firmadan da bağlandılar ama nedenini anlayamadık (Anladığım kadarıyla onlarda benim gibi linux'e yabancı 🙂 ) Testlerim sonucu bir gmail hesabından veya komut satırından dahii mail gönderemediğimi fark ettim. Bir yazıda postfix engelliyordur yazıyordu kaldırdım, selinux engeller yazıyordu onuda kaldırdım. An itibariyle hala yazılımdan mail atamıyorum. ...222 ipli centos'un Exchange sunucumun ...247 ipli smtp 25 nolu portuna erişimii centosta nasıl engelliyordur? Veya neleri kontrol etmem gerekli? (Bu arada telnet exchangesunucu 25 'gidiyor)

Bu konuda bana yardımcı olursanız çok sevinirim.

Şimdiden destek ve yardımlarınız için teşekkürler

 

Alıntı
Gönderildi : 29/09/2017 11:23
Zülfü Mehmet ÖZÇİFÇİ
(@zulfumehmetozcifci)
Üye

Merhaba Musa bey,

Centos 6.x de güvenlik duvarı iptables komutu ile çalışırken Centos 7.x de default olarak firewalld komutu ile port açıp kapatabiliyorsunuz. 

İsterseniz komple kapatıp tüm portları açabilirsiniz. Bunun için komut satırına

systemctl status firewalld yada firewall-cmd --state diyerek firewall aktif mi pasif mi olduğunu öğreniniz. Aktif ise 

systemctl stop firewalld ardından systemctl disable firewalld komutunu kullanarak servisi komple devre dışıbırakabilirsiniz.

Geri çalıştırmak için de: 

systemctl start firewalld ardından systemctl enable firewalld komutlarını kullanabilirsiniz.

Port açmak ve kapatmak içinde size direk uygulayarak ekliyorum 

[root@zulfumehmet ~]# firewall-cmd --add-port=25/tcp --permanent    /Port eklemek için
success
[root@zulfumehmet ~]# firewall-cmd --reload /Ayarları kaydetmek için
success
[root@zulfumehmet ~]# firewall-cmd --list-all /Port ekli mi değil mi kontrol amaçlı
public
target: default
icmp-block-inversion: no
interfaces:
sources:
services: dhcpv6-client ssh
ports: 25/tcp /Port eklenmiş
protocols:
masquerade: no
forward-ports:
sourceports:
icmp-blocks:
rich rules:


[root@zulfumehmet ~]# firewall-cmd --remove-port=25/tcp /Port silmek için
success
[root@zulfumehmet ~]# firewall-cmd --list-all Listeleyelim
public
target: default
icmp-block-inversion: no
interfaces:
sources:
services: dhcpv6-client ssh
ports: /Port silindi.
protocols:
masquerade: no
forward-ports:
sourceports:
icmp-blocks:
rich rules:

[root@zulfumehmet ~]#  

Sizin şöyle bir sorununuz olabilir. Mail gönderebilmek ve alabilmek için sunucunuzun dışarı açık olması gerekmektedir, DMZ yada nat yapıp sunucuya puplic ip üzerinden ulaşmanız gerekmekte ve aynı zamanda BIND DNS yapısnı oluşturup bir mail sunucusu üzerinden mail trfiğini gerçekleştirebilirsiniz. Eğer iyi derecede bilgi sahibi değilseniz Bing DNS ayarlarını otomatik yapılandırabilmek ve mail sunucusunuda otomatik kurabilmek için Ücretsiz web paneller kullanabilirsiniz. Aşırı domain parındırmayacağınız için 5 domaine kadar ücretsiz olan Panlinux (Milli yazılım ) öneririm veya centos web panel yada vesta panel.

 

Bind DNS ile ilgili makaleyi inceleyebilirsiniz:

https://www.zulfumehmet.com/centos-7-nginx-ile-binddns-host-ve-ftp-kurulumu/

 

Kolay gelsin.

CevapAlıntı
Gönderildi : 29/09/2017 12:29
Musa Alican
(@MusaAlican)
Üye

Çok teşekkürler açıklama için Mehmet Bey,

Port açarak denedim olmadı 🙁

Benim anlamadığım uygulamanın mail atmasını neden engelliyor. Neyse en son yazdığınızı bir deneyeceğim. Umarım bu sefer olur 🙁 

Teşekkürler

CevapAlıntı
Gönderildi : 29/09/2017 20:41
Zülfü Mehmet ÖZÇİFÇİ
(@zulfumehmetozcifci)
Üye

Merhaba peki mail sunucusu centos üzerinde mi. Kullandığım bir program değil. Mail sunucunuz Centos üzerine mi kurulu.

CevapAlıntı
Gönderildi : 29/09/2017 20:44
Paylaş:

Lütfen Giriş yap yada Kayıt ol