Anasayfa » Forum

Bildirimler
Hepsini Temizle

Squid update  

  RSS
Volkan Çelebi
(@VolkanCelebi)
Üye

Artık Squid 2.4'ün hatalarından yılınca 2.6'yı yüklemek istedim. Bu sürüm Websense tarafından desteklenen en son kararlı sürüm olduğu için squid 3x kurma imkanım yok. Redhat 9'lu makineme putty ile bağlanıp:

rpm -Uvh squid-2.6.STABLE21-6.el5.x86_64.rpm komutu verince

warning: squid-2.6.STABLE21-6.el5.x86_64.rpm: V3 DSA signature: NOKEY, key ID e8562897

error: Failed dependencies:

        libc.so.6()(64bit) is needed by squid-2.6.STABLE21-6.el5

        libc.so.6(GLIBC_2.2.5)(64bit) is needed by squid-2.6.STABLE21-6.el5

        libc.so.6(GLIBC_2.3)(64bit) is needed by squid-2.6.STABLE21-6.el5

        libc.so.6(GLIBC_2.3.2)(64bit) is needed by squid-2.6.STABLE21-6.el5

        libc.so.6(GLIBC_2.3.4)(64bit) is needed by squid-2.6.STABLE21-6.el5

        libc.so.6(GLIBC_2.4)(64bit) is needed by squid-2.6.STABLE21-6.el5

        libcom_err.so.2()(64bit) is needed by squid-2.6.STABLE21-6.el5

        libcrypt.so.1()(64bit) is needed by squid-2.6.STABLE21-6.el5

        libcrypt.so.1(GLIBC_2.2.5)(64bit) is needed by squid-2.6.STABLE21-6.el5

        libcrypto.so.6()(64bit) is needed by squid-2.6.STABLE21-6.el5

        libdl.so.2()(64bit) is needed by squid-2.6.STABLE21-6.el5

        libgssapi_krb5.so.2()(64bit) is needed by squid-2.6.STABLE21-6.el5

        libgssapi_krb5.so.2(gssapi_krb5_2_MIT)(64bit) is needed by squid-2.6.STABLE21-6.el5

        libkrb5.so.3()(64bit) is needed by squid-2.6.STABLE21-6.el5

        liblber-2.3.so.0()(64bit) is needed by squid-2.6.STABLE21-6.el5

        libldap-2.3.so.0()(64bit) is needed by squid-2.6.STABLE21-6.el5

        libm.so.6()(64bit) is needed by squid-2.6.STABLE21-6.el5

        libm.so.6(GLIBC_2.2.5)(64bit) is needed by squid-2.6.STABLE21-6.el5

        libnsl.so.1()(64bit) is needed by squid-2.6.STABLE21-6.el5

        libnsl.so.1(GLIBC_2.2.5)(64bit) is needed by squid-2.6.STABLE21-6.el5

        libpam.so.0()(64bit) is needed by squid-2.6.STABLE21-6.el5

        libpam.so.0(LIBPAM_1.0)(64bit) is needed by squid-2.6.STABLE21-6.el5

        libpthread.so.0()(64bit) is needed by squid-2.6.STABLE21-6.el5

        libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by squid-2.6.STABLE21-6.el5

        libpthread.so.0(GLIBC_2.3.2)(64bit) is needed by squid-2.6.STABLE21-6.el5

        librt.so.1()(64bit) is needed by squid-2.6.STABLE21-6.el5

        libsasl2.so.2()(64bit) is needed by squid-2.6.STABLE21-6.el5

        libssl.so.6()(64bit) is needed by squid-2.6.STABLE21-6.el5

        libz.so.1()(64bit) is needed by squid-2.6.STABLE21-6.el5

        perl(URI::URL) is needed by squid-2.6.STABLE21-6.el5

        rtld(GNU_HASH) is needed by squid-2.6.STABLE21-6.el5

 glibc update istiyor ama bunun içinde kernel headerlara kadar bir çok paketi update istemekte. Yum kurayım dedim ama phyton versiyonu beğenmedi, phyton update edeyim dedim libdb filan bir çok paket istedi. Nasıl yapsam da ben bu squid'i güncellesem. 

 

Alıntı
Gönderildi : 23/01/2013 16:24
Volkan Çelebi
(@VolkanCelebi)
Üye

biraz kurcalayınca fatal: kernel too old aldım, rescue ile umarım düzeltebilirim.

CevapAlıntı
Gönderildi : 23/01/2013 18:54
Salih BiLGiN
(@SalihBiLGiN)
Üye

Volkan Bey,

Sürüm olarak çok eski bir dağıtım kullanıyorsunuz. Kernel'in çok eski olduğunu söylüyor sistem. Tavsiyem dağıtımıda yenilemeniz 🙂

CevapAlıntı
Gönderildi : 24/01/2013 11:33
Paylaş: