Bildirimler
Hepsini Temizle

iis 6 iis 8.5 geçiş  

Yılmaz Şimşek
(@YilmazSimsek)
Üye

Merhaba.

 

iis 6 üzerinde çalışan bir webservisimiz var. iis 6 win 2003 servera kurulu.

Win2012 server kurdum iss ayarlarını yaptım fakat iis 6 da bulunan webservisleri iis 8.5 de çalıştıramadım.

iis 6 dan iss 8.5 migrate işlemi ile de denedim. Migrate yaptığım siteyide çalıştıramadım. 

Nasıl bir yol izlemem gerekiyor. Visual studioda proje var. Visual studio dan deploy etsem sorun yaşarmıyım. 

Alıntı
Topic starter Gönderildi : 13/05/2014 15:18
Kenan İLGÜN
(@kenanilgun)
Saygın Üye Forum Yöneticisi

IIS 8.5 sürümünde aldığınız hataya dair bir bilgi aktarılabilirse konu üzerinde daha detaylı şekilde ilgilenebiliriz.

 

CevapAlıntı
Gönderildi : 13/05/2014 16:11
Yılmaz Şimşek
(@YilmazSimsek)
Üye

Aldığım bir hata yok aslında. Webserviste bulunan methodları çağırıyorum gelmiyor. 

 

CevapAlıntı
Topic starter Gönderildi : 13/05/2014 20:47
Kenan İLGÜN
(@kenanilgun)
Saygın Üye Forum Yöneticisi

Gelmiyor derken elbet bir cevap almanız gerekmektedir. Metotları nasıl çağırıyorsunuz?

CevapAlıntı
Gönderildi : 13/05/2014 20:55
Yılmaz Şimşek
(@YilmazSimsek)
Üye

metodları ie üzerinden örnek olarak

http://sunucu/webservis/deneme.asmx adresinden çağırıyorum.  

İe uzun süre yüklemeye çalışıyor. Sayfa bulunamadı hatası veriyor. 

 

Yaptığım işlemleri kısaca şöyle anlatayım.

Microsoftun Webdeploy toolu ile 2003 serverdan 2012 servera web servisi taşıdım. Metodları çağırırken sayfa bulunamadı hatası aldım.

 

2003 serverı 2008 servera yükseltip denedim yine aynı hatayı aldım.

Daha sonrada 2008 i 2012 ye yüksettim yine aynı hatayı almaya devam ediyorum.

Upgrade yaparken yetkilerde aktarıldığı için yetki problemim olmadığını düşünüyorum.

 

Tüm sunucularımı 2012 ye yükselteceğim. Webservisi çalıştıramadığım için diğer sunucular hazır olmasına rağmen geçemiyorum.

İnternette kaynakta bulamıyorum. Kontrol etmem gereken başka bir nokta varmı. Veya önerebileceğiniz farklı bir yöntem varmıdır.

2003 üzerinde çalışan haliyle yedeğim var. 

CevapAlıntı
Topic starter Gönderildi : 13/05/2014 22:48
Kenan İLGÜN
(@kenanilgun)
Saygın Üye Forum Yöneticisi

Şuandaki Windows 2012 sunucusunda IIS servisinde herhangi bir web sitesi açarak içerisine herhangi bir html dosyası attıktan sonra test işlemi sağladınız mı? Yani IIS servisin düzgün çalıştığına emin miyiz?

CevapAlıntı
Gönderildi : 14/05/2014 11:10
Yılmaz Şimşek
(@YilmazSimsek)
Üye

İis in default sayfasını çağırdığımda açılıyor. Bundan dolayıda iis düzgün çalışıyor diye düşünüyorum. 

Farklı bir web site denemedim. 

CevapAlıntı
Topic starter Gönderildi : 14/05/2014 12:35
Kenan İLGÜN
(@kenanilgun)
Saygın Üye Forum Yöneticisi

Lütfen basit örneklerle dener misiniz bu bir resim olabilir veya asp .net örnekleri olabilir. Tahminim IIS ayaklarınızla ilgili bir problem olacağını düşünüyorum.

CevapAlıntı
Gönderildi : 14/05/2014 12:58
Yılmaz Şimşek
(@YilmazSimsek)
Üye

Frontpage Server Extension 2002 diye bir eklentisi var microsoftun. 

Projede bu eklenti kullanıldığı için sorun çıkarıyormuş. Bu extension un yeni bir sürümü de yok. 3. parti olarak iis 8 için farklı bir firma yazmış fakat onu yüklememe rağmen sorunum devam etmekte.

İş yazılımcı arkadaşlara kalıyor. Bu extension kullanmadan projeyi tekrar yapmaları gerekecek.

Böyle bir problem ile karşılaştınız mı. 

CevapAlıntı
Topic starter Gönderildi : 15/05/2014 03:11
Kenan İLGÜN
(@kenanilgun)
Saygın Üye Forum Yöneticisi

Üzücü haber, böyle bir problemle ben hiç karşılaşmadım sanırım.

CevapAlıntı
Gönderildi : 15/05/2014 03:26
Paylaş: