Forum

Fortigate 60D Voip ...
 
Bildirimler
Hepsini Temizle

[Çözüldü] Fortigate 60D Voip ayarları

Serkan YILMAZ
(@SerkanYILMAZ)
Üye

Merhaba arkadaşlar,
Gebze fabrikamızda Turk Telekom Fiber internet hizmeti alıyoruz. Modem bridge modda ve Fortigate 60D firewall cihazı kullanıyoruz. IP kamera, Uzak Masaüstü gibi sistemlerin port yönlendirmeleri yapıldı sorunsuz çalışıyor.

İstanbul şubede Vigor Modem üzerinde bulunan ve fabrika ile sorunsuz iletişim kurduğumuz IP santralimizi, hatları ile birlikte fabrikaya taşıdık.

Firewall üzerinde aşağıda belirttiğim tüm portları açtık. Dış hatlardan telefon geliyor, fabrika içinde tüm dahililer çalışıyor. Fakat fabrikadan şubeye iletişim kuramıyoruz. Telefon çalıyor, açıldığında karşılıklı ses gelmiyor. Firewall cihazını kapatıp açtığımızda 1-2 görüşmeden sonra yeniden ses iletişimi kurulamıyor.

Yapılan işlemler;

SIP ayarları

config system settings / enter
set sip-helper disable / enter
end / enter

config system settings / enter
set sip-nat-trace disable / enter
end / enter

config system session-helper
show

config system session-helper / enter
delete 12 / enter
end / enter

reboot
----
Açılan portlar
2222 tcp&udp
5060 tcp&udp
9874-9880 tcp&udp
10000-55000 tcp&udp

Sanntral_Grup Policy oluşturuldu
Policy Type: Firewall
Policy Subtype: AddressUser
Incoming Interface : wan1
Source Address: all
Outgoing Interface: internal
Destination Address: Santral_Grup
Schedule: always
Service: ALL
Action: ACCEPT

Enable NAT (işaretli)

*****
Sorunu çözmek için birçok destek aldık başarılı olamadık. Ücretli olarak destek almaya razıyız. Yardımlarınız için şimdiden teşekkürler.

Alıntı
Konu başlatıcı Gönderildi : 18/08/2016 00:46

Turan COŞKUN
(@turancoskun)
Tecrübeli Üye Forum Yöneticisi

merhaba,

forti firmware versiyonu nedir ?

local -> public yöne snat kuralı oluşturun. source: santral adresi kullanarak, herhangi bir filter uygulamayın.

bu kuralı kendi int. içerisinde en üste taşıyın.

kullandığınız santral arayüzünde, nat arkasında çalıştığına dair başlık mevcut ise (behind nat ), aktif hale getirin.

referans adres içerisindeki adımları, cli üzerinde uygulayın.

http://www.3cx.com/blog/docs/disable-sip-alg-on-fortigate/

 

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 18/08/2016 01:34

Serkan YILMAZ
(@SerkanYILMAZ)
Üye

Merhaba Turan Bey,
Firmware versiyonu v5.0,build0323 (GA Patch 14) zaten yeni güncelleme yapıldı. Önerilerinizi deneyip bilgi vereceğim. Teşekkürler.

CevapAlıntı
Konu başlatıcı Gönderildi : 18/08/2016 02:08

Recep Zabun
(@RecepZabun)
Üye

Merhaba Arkadaşlar,

Bu konu hakkında çözüme ulaşan varmıdır acaba ?

CevapAlıntı
Gönderildi : 14/10/2016 12:12

Turan COŞKUN
(@turancoskun)
Tecrübeli Üye Forum Yöneticisi

Recep bey,

üst'te belirttiğim adımları uygulayarak, deneme şansınız oldu mu ?

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 14/10/2016 16:49

Recep Zabun
(@RecepZabun)
Üye

Merhaba Turan Bey,

Evet tüm adımları uyguladım sonuç yok malesef. Aramadığım kaynak forum kalmadı. Aynı sorun çok var ama çözülen yok. Çözen arkadaşlar var ise paylaşım yaparsalar çok yararlı olacak.

CevapAlıntı
Gönderildi : 14/10/2016 17:02

Yilmaz BARCIN
(@yilmazbarcin)
Saygın Üye

config system session-helper / enter
delete 12 / enter
end / enter

 

bu hatalı,

burada öncesinde show yaparsanız session-helper in 13 te oldugunu görebilirsiniz ( genellikle )

silmeniz gereken delete 13 tür.

ayrıca RTP i de disable etmeniz gerekiyor.

Disable RTP processing as follows:

  1. config voip profile
  2. edit default
  3. config sip
  4. set rtp disable

 

kolay gelsin. bunun dışında debug alarak inceleyebilirsiniz. Fortinet tarafında sorunlu bir konu değildir...

kolay gelsin.

CevapAlıntı
Gönderildi : 14/10/2016 19:57

Recep Zabun
(@RecepZabun)
Üye

Merhaba Yılmaz Bey,

Bu işlemlerin tümünü uygulamıştım ama çözülmedi. Bende artık fortinet tarafında bir problem olduğunu düşünmüyorum.

CevapAlıntı
Gönderildi : 15/10/2016 11:41

Mustafa TAŞCI
(@mustafatasci)
Saygın Üye Forum Yöneticisi

Merhaba 

Fortigatelerin kronik diyebilecegimiz bir sorunudur,

Policy cift yonlu yazmaniz gerekiyor. Yazdiginiz policy net paylasirsaniz daha fazla faydali olabiliriz.

 

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 16/10/2016 07:03

Yilmaz BARCIN
(@yilmazbarcin)
Saygın Üye

Merhaba,

en az 10 yerde Fortigate firewall arkasında SIP çalıştırıyoruz, hiçbirinde kronik bir sorun yok.

kronik olan SIP yapılandırmasına hakim olmamak dersek daha doğru bir tanımlama olur.

 

üreticinin bu konuyu derinlemesine anlattığı ve örneklediği şu http://docs.fortinet.com/uploaded/files/2813/fortigate-sip-54.pdf dokumanı inceleyebilirsiniz.

 

Konu ile ilgili bir debug çıktısı da paylaşırsanız problemi anlamak daha kolay olur.

 

kolay gelsin,

yB

CevapAlıntı
Gönderildi : 16/10/2016 13:55

necatigüner
(@necatiguner)
Üye
Gönderen: @yilmazbarcin

config system session-helper / enter
delete 12 / enter
end / enter

 

bu hatalı,

burada öncesinde show yaparsanız session-helper in 13 te oldugunu görebilirsiniz ( genellikle )

silmeniz gereken delete 13 tür.

ayrıca RTP i de disable etmeniz gerekiyor.

Disable RTP processing as follows:

  1. config voip profile
  2. edit default
  3. config sip
  4. set rtp disable

 

kolay gelsin. bunun dışında debug alarak inceleyebilirsiniz. Fortinet tarafında sorunlu bir konu değildir...

kolay gelsin.

Yılmaz Bey Selamlar;
Tecrübelerinize istinaden; Bu konu ile ilgili 2 işlem yapılması gerekiyor diyorsunuz?
1. session-helper daki 13 te yer alan Sip protokolunun silinmesi (Bende 13 de Sip 5060 portu var)

2. RTP nin kapatılması! 

image

 

Bunlara istinaden aşağıdaki komutları uyguladığımızda doğru sonuca ulaşır mıyız? Başka yapacağımız ek bir şey olur mu?

config system session-helper 
delete 13 
end 

config voip profile
edit default
config sip
set rtp disable
end

execute reboot

CevapAlıntı
Gönderildi : 15/01/2021 12:28

Yilmaz BARCIN
(@yilmazbarcin)
Saygın Üye

Merhaba,

paylaşım 5 sene önce  eski Forti OS sürümü içindi... 🙂

session-helper 'da şuan sip 13. sırada evet, ınu silmenin dışında aşağıdaki işlemleri de yapmanız gerekiyor.

1-

# config system settings
    set default-voip-alg-mode kernel-helper-based ---- bazı ip santrallerde proxy base çalışıyor, denemeniz gerekiyor.
    set sip-helper disable
    set sip-nat-trace disable
end

6.2.2 sonrası için

# config system settings
    set default-voip-alg-mode kernel-helper-based
    set sip-expectation disable
    set sip-nat-trace disable
end

 

reboot etmeyi unutmayın cihazı...

 

yB

CevapAlıntı
Gönderildi : 18/01/2021 00:01

serkanvargel
(@serkanvargel)
Üye

Merhaba;

 

yukarıda verilen configler doğru. bizimde bir çok müşterimizde sıkıntısız çalışıyor. internet servis sağlayıcınız metro ethernet gibi kurumsal bir hat değil ise ISP (internet servis sağlayıcı) 5060 portunu engeliyordur. bu durumu ben çok yasadım ISP arayıp 5060 portunun açık olup olmadığını kontrol ettirin.

 

selamlar

 

 

CevapAlıntı
Gönderildi : 26/03/2021 09:08
Hakan Uzuner beğendi

Paylaş: