Iphone ve Exchange ...
 
Bildirimler
Hepsini Temizle

Iphone ve Exchange 2003 Senkronizasyonu  

  RSS
Kaan Tekkol
(@kaantekkol)
Üye

Arkadaşlar Merhaba,

 Exchange 2003 Sp2 olan bir yapıdayız. Yeni Iphone aldık ve mail hesap tanımlaması yapıyorum.

1 - Iphone üzerine hesabı tanımladım. (Server kısmına owa adresini yazdım) Doğrulama yaptı ve geçti.

2 - Iphone üzerine senkron tuşuna bastığımda "Sunucuya bağlanma başarısız oldu" şeklinde hata veriyor.

3 - Exchange üzerindeki evet'a baktığımda aşağıdaki hatayı alıyorum.

Unexpected Exchange mailbox Server error: Server: [exchange.xxx.local] User: [kullaniciadi@xxx.com] HTTP status code: [501]. Verify that the Exchange mailbox Server is working correctly.

5 - Active Sync Tester programını indirerek çalıştırdım onun üzerinde de

Testing eposta.xxx.com (SSL, On LAN):

Communications:

Doing DNS lookup on owa_adresi ...

OK (dışbacak_ipadresi)

Testing TCP to dışbacak_ipadresi port 443 ....

OK

SSL Certificate

Receiving ................................

OK


Ensuring not Self-Signed .................

FAIL


Verifying certificate ....................

FAIL


ActiveSync:

Checking for application .................

OK


Checking version .........................

OK (6.5.7638.1)


Checking protocols ....................... OK (1.0,2.0,2.1,2.5)

User Permissions:

Checking "domainadi/kullaniciadi" ................

FAIL



Result:

ActiveSync detected, but not correctly configured. [HTTP 500: Forms-based auth enabled?]

şeklinde test sonucu ile karşılaştım.

Bu sorun karşısında yapılması gerektiğini düşündüğüm http://support.microsoft.com/kb/817379  makalesini buldum.

Bu makaleyi uygulayıp sorunu çözmüş arkadaş var mıdır?

 Teşekkürler.

(Not: Yazı düzeni için araç panelinde biçimlendirmeyi sıfırla seçeneği olmadığı için yazılar renkli renkli oldu. K.b.


Alıntı
Gönderildi : 26/04/2011 21:38
Ibrahim Akgül
(@IbrahimAkgul)
Üye

Bu sorunu bende android 1.6 telefonumda yaşadım. Sorun exchange authentication mekanizmasının NTLMv2 Signing olması idi. Bu modu geçici olarak eski haline çektiğimde authentication yapabiliyordu. Bende telefonu Ntlmv2 desteği olan Android 2.2 ye update ettim ve sorun çözüldü.

Bir başka arkadaşımda sizin gibi iphone'da sıkıntı yaşadı onda ise bağlı olduğu ou üzerinde yeralan exchange replication izinlerinin yukarıdan devralınmasını seçeneğini iptal ederek ve o access üzerinde full yetki vererek çözdük. 

 Yada farklı mail client programları kullanmanız yararlı olabilir.

CevapAlıntı
Gönderildi : 27/04/2011 00:38
Kaan Tekkol
(@kaantekkol)
Üye

[quote user="Ibrahim Akgül"]

Bir başka arkadaşımda sizin gibi iphone'da sıkıntı yaşadı onda ise bağlı olduğu ou üzerinde yeralan exchange replication izinlerinin yukarıdan devralınmasını seçeneğini iptal ederek ve o access üzerinde full yetki vererek çözdük. 

[/quote]

Bu adımı tarif edebilir misiniz?

Ek olarak;

1 - Iphone için System Manager - Global Settings - Mobile Services Properties - Outlook Mobile Access altındakileri Enable duruma getirdim.

2 - IIS üzerinde belirttiğim makalede belirtildiği gibi Virtual Directory oluşturdum.

Bunlardan sonra tekrar denedim, fakat yine bağlantı başarısız şeklinde hata mesajı aldım.

Ayrıca 1. adımı gerçekleştirdikten yaklaşık yarım saat sonra Exchange servislerinin durduğunu 2 defa tespit ettim. Servisler durunca da mail alış verişi durdu.

Yardımcı olabilecek arkadaşlardan yardım rica ediyorum. Bir Iphone ayarlamak bu kadar zor mu yahu 🙂

Teşekkürler.

CevapAlıntı
Gönderildi : 27/04/2011 17:08
Mustafa Doğan
(@mustafadogan)
Üye

bende 2003 kullanıyorken tanımlama yaparken zorlanmıştım.Iphone üzerinde Exchange seçeneği ile yapınca olmadı. Diğer seçeneklerden mail hesabı eklediğimde kabul etti ve mail gönderip almaya başlamıştı. birde böyle deneyebilirsiniz.

CevapAlıntı
Gönderildi : 27/04/2011 17:24
Kaan Tekkol
(@kaantekkol)
Üye

IIS - OMA - Browse dediğimde kullanıcı adı ve şifre yazdığımda "Collection was modified; enumeration operation may not execute." şeklinde hata başlığı ile kodlar karşıma geliyordu. Bunu çözmek için IIS - OMA - Properties - ASP.NET - ASP Net version kısmından 1.1.4322 yi seçtim.

OMA üzerinde Browse dediğimde tekrar, "

Your user account has not been enabled for wireless access. Please contact your system administrator for additional assistance.
"

şeklinde hata mesajı alıyorum. Sanırım bu da Exchange manager üzerinde OMA yı aktif etmediğimden kaynaklanıyor???

OMA yı aktif hale getirip son durumu vermeye devam edeceğim.

Bulmaca gibi 🙂

CevapAlıntı
Gönderildi : 27/04/2011 17:38
Ugur DEMIR
(@ugurdemir)
Onursal Üye

http://www.cozumpark.com/forums/thread/153666.aspx  incelediniz mi?

CevapAlıntı
Gönderildi : 27/04/2011 18:01
Kaan Tekkol
(@kaantekkol)
Üye

İnceledim fakat normal yollardan (Iphone üzerindeki Exchange Linki) bağlantı yapmaya özen gösteriyorum biraz.

Olmazsa bu yolu da muhakkak deneyeceğim.

CevapAlıntı
Gönderildi : 27/04/2011 19:14
Paylaş: