Anasayfa » Forum

Backbone Üzeri...
 

Backbone Üzerinden Vlan  

Sayfa 1 / 2
  RSS
metin parlak
(@metinparlak)
Yeni Üye

Merhabalar

çalıştığım kurum için resimde bulunan yapıdaki gibi bir vlan yapılandırması yapmaya çalışıyorum(tabi yapı çok daha büyük sadece örnek olması açısından). VTP kullanmadan yapı tasarlamak istiyorum.Fakat oluşturduğum yapıda dhcp scope vlan ayrımına göre ip dağıtması gerekirken tek scope üzerinden ip dağıtıyor. üzerinden çok uğraştım ama bir türrlü yapamadım şimdiden teşekkürler.

 

resim linki:

.html

 

örnek linki:

http://dosya.co/n9eg83srqse6/backbone_vlan.pkt.html

Alıntı
Gönderildi : 22/06/2018 12:48
Vasvi UYSAL
(@vasviuysal)
Saygın Üye Forum Yöneticisi

http://www.cozumpark.com/blogs/cisco_system/archive/2013/10/27/cisco-temelli-sistemlerde-farkli-vlanlara-ip-dagitilmasi.aspx

 

adresinde cisco üzerinden anlatımı mevcut

iyi çalışmalar

 

CevapAlıntı
Gönderildi : 22/06/2018 12:59
metin parlak
(@metinparlak)
Yeni Üye

vtp yaparak oluşturabiliyorum. Benim yapmak istediğim L3 switch üzerinde L3ün her bir portuna bağlı olan swicthi vlan yapmak.

Örneğin L3 1.porta bağlı L2 sw Vlan 10 a üye olsun L3 2. porta bağlı sw Vlan 20 ye üye olsun.

 

[quote user="Vasvi UYSAL"]

http://www.cozumpark.com/blogs/cisco_system/archive/2013/10/27/cisco-temelli-sistemlerde-farkli-vlanlara-ip-dagitilmasi.aspx

 

adresinde cisco üzerinden anlatımı mevcut

iyi çalışmalar

 

[/quote]

CevapAlıntı
Gönderildi : 22/06/2018 15:07
Zafer SEN
(@ZaferSEN)
Yeni Üye

omurgaya bağlı iki switch var, birini Vlan 10 diğerini vlan 20 olarak kullanmak istiyorsunuz,

örnek vermek gerekirse;

vlan20 olarak kullanmak istediğiniz switch uplink portunu access yapın ve default vlan 1 olsun, bu kenar switch üzerindeki tüm portlar default vlan 1 olacak. (L2 olarak da vlan 20 açmanıza gerek yok bu durumda)

L3 switch tarafındaki uplinki de access yapın ama switchport access vlan 20 deyin.

 

bu durumda kenar switch üzerinde vlan tag olmayacak, yani L2 kenar switche hiç vlan girmemiş olacaksınız, dummy switch bile kullanabilirsiniz burada.

 

L3 tarafında uplinki hangi vlana member ederseniz o switch o vlan için çalışacaktır.

 

yada uplink portları trunk yaparsınız ama trunk allowed vlan 20 dersiniz. bu durumda switch üzerinde L2 olarak vlan 20 açmalısınız ve tüm portları switchport access vlan 20 yaparak vlan 20 tag'i yollayacak şekilde config girmelisiniz.

 

her ikisinin de L3 switchiniz tarafında trafiğinin başında Vlan20 tag olacaktır.

CevapAlıntı
Gönderildi : 22/06/2018 18:03
metin parlak
(@metinparlak)
Yeni Üye

Hocam L3te uplinki switchport access vlan 20 deyince hata veriyor ama. Örneğe bakma şansınız oldu mu ? orda hatalı bir yer var mı acaba ?

 

[quote user="Zafer SEN"]

omurgaya bağlı iki switch var, birini Vlan 10 diğerini vlan 20 olarak kullanmak istiyorsunuz,

örnek vermek gerekirse;

vlan20 olarak kullanmak istediğiniz switch uplink portunu access yapın ve default vlan 1 olsun, bu kenar switch üzerindeki tüm portlar default vlan 1 olacak. (L2 olarak da vlan 20 açmanıza gerek yok bu durumda)

L3 switch tarafındaki uplinki de access yapın ama switchport access vlan 20 deyin.

 

bu durumda kenar switch üzerinde vlan tag olmayacak, yani L2 kenar switche hiç vlan girmemiş olacaksınız, dummy switch bile kullanabilirsiniz burada.

 

L3 tarafında uplinki hangi vlana member ederseniz o switch o vlan için çalışacaktır.

 

yada uplink portları trunk yaparsınız ama trunk allowed vlan 20 dersiniz. bu durumda switch üzerinde L2 olarak vlan 20 açmalısınız ve tüm portları switchport access vlan 20 yaparak vlan 20 tag'i yollayacak şekilde config girmelisiniz.

 

her ikisinin de L3 switchiniz tarafında trafiğinin başında Vlan20 tag olacaktır.

[/quote]

CevapAlıntı
Gönderildi : 22/06/2018 23:15
Zafer SEN
(@ZaferSEN)
Yeni Üye

merhaba

L3 uplink portları access yaparsanız, kenar switchlerde uplinkler hariç birşey yapmanıza gerek kalmaz, portlar default da kalabilir.

L3 switch da portları mode trunk yapmışsınız.

interface FastEthernet0/1

switchport access vlan 10

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/2

switchport access vlan 20

switchport trunk encapsulation dot1q

switchport mode trunk

!

 

yukarıdaki yerine aşağıdaki gibi switchport mode access olacak,

interface FastEthernet0/1

switchport access vlan 10

switchport mode access

switchport nonegotiate

spanning-tree portfast

!

interface FastEthernet0/2

switchport access vlan 20

switchport mode access

switchport nonegotiate

spanning-tree portfast

!

 

vlan 10 ve 20 kenar switchlerin de uplink portları trunk yapmışsınız bunu kaldırıp default bırakabilirsiniz, switchport mode access diyeceksiniz.

interface FastEthernet0/1

switchport mode trunk     yerine switchport mode access olacak.

!

 

 

 

 

 

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------

sizin yaptığınız şekilde uplink portlar trunk da olabilir o zaman aşağıdaki gibi config yapmalısınız.

çünkü uplink portlar trunk olursa diğer portları access yaparak portlara tag girmelisiniz.

 

L3 tarafında

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allow vlan 10

!

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

Switchport trunk allow vlan 20

 

L2 switchler tarafında:

interface FastEthernet0/1

switchport mode trunk

exit

 

vlan 10

exit

 

interface range fastethernet 0/2 - fastethernet 0/24

switchport mode access

switchport access vlan 10

 

 

diğer L2 switch tarafında:

 

interface FastEthernet0/1

switchport mode trunk

exit

 

 

vlan 20

exit

 

interface range fastethernet 0/2 - fastethernet 0/24

switchport mode access

switchport access vlan 20

 

 

CevapAlıntı
Gönderildi : 25/06/2018 16:01
metin parlak
(@metinparlak)
Yeni Üye

Native VLAN mismatch discovered on FastEthernet0/1 (10), with Switch FastEthernet0/1 (1).

 

bu hatayı verdi. 1.seçenekte sunduğunuz şekildeki gibi

interface FastEthernet0/1

switchport access vlan 10

switchport mode access

switchport nonegotiate

spanning-tree portfast

!

interface FastEthernet0/2

switchport access vlan 20

switchport mode access

switchport nonegotiate

spanning-tree portfast

!

 

bu şekilde

 

[quote user="Zafer SEN"]

merhaba

L3 uplink portları access yaparsanız, kenar switchlerde uplinkler hariç birşey yapmanıza gerek kalmaz, portlar default da kalabilir.

L3 switch da portları mode trunk yapmışsınız.

interface FastEthernet0/1

switchport access vlan 10

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/2

switchport access vlan 20

switchport trunk encapsulation dot1q

switchport mode trunk

!

 

yukarıdaki yerine aşağıdaki gibi switchport mode access olacak,

interface FastEthernet0/1

switchport access vlan 10

switchport mode access

switchport nonegotiate

spanning-tree portfast

!

interface FastEthernet0/2

switchport access vlan 20

switchport mode access

switchport nonegotiate

spanning-tree portfast

!

 

vlan 10 ve 20 kenar switchlerin de uplink portları trunk yapmışsınız bunu kaldırıp default bırakabilirsiniz, switchport mode access diyeceksiniz.

interface FastEthernet0/1

switchport mode trunk     yerine switchport mode access olacak.

!

 

 

 

 

 

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------

sizin yaptığınız şekilde uplink portlar trunk da olabilir o zaman aşağıdaki gibi config yapmalısınız.

çünkü uplink portlar trunk olursa diğer portları access yaparak portlara tag girmelisiniz.

 

L3 tarafında

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allow vlan 10

!

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

Switchport trunk allow vlan 20

 

L2 switchler tarafında:

interface FastEthernet0/1

switchport mode trunk

exit

 

vlan 10

exit

 

interface range fastethernet 0/2 - fastethernet 0/24

switchport mode access

switchport access vlan 10

 

 

diğer L2 switch tarafında:

 

interface FastEthernet0/1

switchport mode trunk

exit

 

 

vlan 20

exit

 

interface range fastethernet 0/2 - fastethernet 0/24

switchport mode access

switchport access vlan 20

 

 

[/quote]

CevapAlıntı
Gönderildi : 25/06/2018 18:41
Zafer SEN
(@ZaferSEN)
Yeni Üye

dikkatimden kaçmış, şöyle olması gerekiyor

L3 tarafı ok.

kenarlara sadece vlan 10 ve vlan 20 ile gidecekseniz uplink portlar access kalabilir.

ama başka vlan taşıyacaksanız o zaman uplink portları trunk yapabilirsiniz.

 

 

kenar switchlerde tüm portları vlan 10 ve vlan 20 yapmalısınız.

vlan 10 olan switch

interface range fastethernet 0/1 -fastethernet 0/24

switchport mode access

switchport access vlan 10

 

vlan 20 olan switch

interface range fasthethernet 0/1 - fastethernet 0/24

switchport mode access

switchport access vlan 20

 

 

denemek için interface vlan oluşturun örneğin

vlan 10 olan switch

interface vlan 10

ip address 10.106.96.10 255.255.255.0

no shutdown

 

vlan 20 olan switch

interface vlan 20

ip address 10.106.100.20 255.255.255.0

no shutdown

 

şimdi her iki switchten L3 switch tarafındaki ip adreslerine ping atabilirsiniz. böylece vlan 10 isimli switch üzerinde yalnızca vlan 10 çalışacaktır.

 

 

CevapAlıntı
Gönderildi : 26/06/2018 02:01
metin parlak
(@metinparlak)
Yeni Üye

hocam dediğiniz şekilde daha önce yaptım oluyor ama vtp ile yaptım. benim burda yapmak istediğim alan büyük olduğu için kenar swler ile hiç uğraşmadan sadece backbone üzerinden vlana alabilir miyim kenar swleri. çünkü kimi yerlerde kenar swlerden hub atlaması var ve çok sayıda kenar sw olduğu için o kadar kenar sw için tek tek swye gitmeden aşağıdaki ayarı backbone üzerinden basıl yapabilirim. teşekkür ederim cevaplarınız için

vlan 20 olan switch

interface range fasthethernet 0/1 - fastethernet 0/24

switchport mode access

switchport access vlan 20

 

CevapAlıntı
Gönderildi : 26/06/2018 16:50
Vasvi UYSAL
(@vasviuysal)
Saygın Üye Forum Yöneticisi

[quote user="metin parlak"]

hocam dediğiniz şekilde daha önce yaptım oluyor ama vtp ile yaptım. benim burda yapmak istediğim alan büyük olduğu için kenar swler ile hiç uğraşmadan sadece backbone üzerinden vlana alabilir miyim kenar swleri. çünkü kimi yerlerde kenar swlerden hub atlaması var ve çok sayıda kenar sw olduğu için o kadar kenar sw için tek tek swye gitmeden aşağıdaki ayarı backbone üzerinden basıl yapabilirim. teşekkür ederim cevaplarınız için

vlan 20 olan switch

interface range fasthethernet 0/1 - fastethernet 0/24

switchport mode access

switchport access vlan 20

 

[/quote]

 

Backbone üzerinden direk vlan basacaksanız yani kenar switche giden portu access olarak yapılandıracaksanız vtp ile konunun ilgisi yok 

vtp vlan bilgisini sadece trunk portlar üzerinden taşıyabilir.

 

 

CevapAlıntı
Gönderildi : 26/06/2018 17:27
metin parlak
(@metinparlak)
Yeni Üye

evet dediğiniz gibi backbone üzerinden vlan basmak istiyorum. kenar sw portlarını access yapınca native vlan hatası veriyor.trunk yapınca oluyor ama bu defa da dhcp scope ayrımı yapamıyor

 

[quote user="Vasvi UYSAL"]

[quote user="metin parlak"]

hocam dediğiniz şekilde daha önce yaptım oluyor ama vtp ile yaptım. benim burda yapmak istediğim alan büyük olduğu için kenar swler ile hiç uğraşmadan sadece backbone üzerinden vlana alabilir miyim kenar swleri. çünkü kimi yerlerde kenar swlerden hub atlaması var ve çok sayıda kenar sw olduğu için o kadar kenar sw için tek tek swye gitmeden aşağıdaki ayarı backbone üzerinden basıl yapabilirim. teşekkür ederim cevaplarınız için

vlan 20 olan switch

interface range fasthethernet 0/1 - fastethernet 0/24

switchport mode access

switchport access vlan 20

 

[/quote]

 

Backbone üzerinden direk vlan basacaksanız yani kenar switche giden portu access olarak yapılandıracaksanız vtp ile konunun ilgisi yok 

vtp vlan bilgisini sadece trunk portlar üzerinden taşıyabilir.

 

 

[/quote]

CevapAlıntı
Gönderildi : 26/06/2018 19:46
Vasvi UYSAL
(@vasviuysal)
Saygın Üye Forum Yöneticisi

[quote user="metin parlak"]

evet dediğiniz gibi backbone üzerinden vlan basmak istiyorum. kenar sw portlarını access yapınca native vlan hatası veriyor.trunk yapınca oluyor ama bu defa da dhcp scope ayrımı yapamıyor

 

[quote user="Vasvi UYSAL"]

[quote user="metin parlak"]

hocam dediğiniz şekilde daha önce yaptım oluyor ama vtp ile yaptım. benim burda yapmak istediğim alan büyük olduğu için kenar swler ile hiç uğraşmadan sadece backbone üzerinden vlana alabilir miyim kenar swleri. çünkü kimi yerlerde kenar swlerden hub atlaması var ve çok sayıda kenar sw olduğu için o kadar kenar sw için tek tek swye gitmeden aşağıdaki ayarı backbone üzerinden basıl yapabilirim. teşekkür ederim cevaplarınız için

vlan 20 olan switch

interface range fasthethernet 0/1 - fastethernet 0/24

switchport mode access

switchport access vlan 20

 

[/quote]

 

Backbone üzerinden direk vlan basacaksanız yani kenar switche giden portu access olarak yapılandıracaksanız vtp ile konunun ilgisi yok 

vtp vlan bilgisini sadece trunk portlar üzerinden taşıyabilir.

 

 

[/quote]

[/quote]

Backbone ve kenar swichleri trunk baglayıp kenar switchdeki tüm portları istediğiniz vlana member yaptıktan sonra

dhcp ayrı bir sunucuda ise ip helper ile istediğin vlana ip dağıtabilirsiniz.

http://www.cozumpark.com/blogs/cisco_system/archive/2013/10/27/cisco-temelli-sistemlerde-farkli-vlanlara-ip-dagitilmasi.aspx

 

iyi çalışmalar

 

 

 

CevapAlıntı
Gönderildi : 26/06/2018 20:14
Zafer SEN
(@ZaferSEN)
Yeni Üye

[quote user="metin parlak"]

hocam dediğiniz şekilde daha önce yaptım oluyor ama vtp ile yaptım. benim burda yapmak istediğim alan büyük olduğu için kenar swler ile hiç uğraşmadan sadece backbone üzerinden vlana alabilir miyim kenar swleri. çünkü kimi yerlerde kenar swlerden hub atlaması var ve çok sayıda kenar sw olduğu için o kadar kenar sw için tek tek swye gitmeden aşağıdaki ayarı backbone üzerinden basıl yapabilirim. teşekkür ederim cevaplarınız için

vlan 20 olan switch

interface range fasthethernet 0/1 - fastethernet 0/24

switchport mode access

switchport access vlan 20

 

[/quote]

kenarlarda unmanaged yani yönetilmeyen switch kullansanız istediğinizi yapabilirsiniz, sadece L3 switchi yönetirsiniz, hangi portuna switch takarsanız o portu istediğiniz vlana member yapmanız yeterli olur.

ama yönetilebilir switchlerde default vlan var, gönderdiği paketin başına vlan tag ekliyor.

 

vtp şöyle düşünebilirsiniz, merkezi olarak vlan yönetmek gibi, L3 üzerinde yarattığınız her vlan diğer tüm switchlere de dağıtılır.

 

sizin isteğiniz vtp değil aslında, anladığım kadarıyla kenarlara hiç karışmadan kenarlardaki switchleri istediğiniz vlanlara access şekilde kullanmak istiyorsunuz.

kenarlara hiç karışmamak benim bildiğim kadarıyla pek mümkün değil, doğru da değil, şu sebeple

kenar switch üzerinde en azından interface vlan açıp erişebilir durumda olması, username password oluşturulması, telnet gibi servislerin kapalı olması gibi,

 

bu nedenle benim aklıma gelen en basit yöntem, kenar switchte çalışmasını istediğiniz vlanı yaratıp tüm portları buna access etmelisiniz,

uplink portu access de olur trunk da olur. ama tüm portların istediğiniz vlana member olması şart diğer türlü paketin başında default vlan tag ekli geleceği için çalışmayacaktır.

 

hub varsa bu ve L3e bağlıysa bu da olur, hub bağlı olduğu porta göre istediğiniz vlana member olacaktır,

 

şöyle de bir durum var, kenar switchlerinizden bir veya birkaçı L3 switche uplink ile gelmiyor da olabilir, misal kenar switch üzerinden uplinkle geliyorsa ve üzerinden geçtiği switchten farklı bir vlan kullanmanız gerekiyorsa bu durumda ne yapacaksınız?

bunun için yine kenar switche erişmek durumunda kalacaksınız, L3 switch üzerinden trunk gelip, ilk switch örneğin vlan 20 olacaksa bunun tüm portları vlan 20 access olacak, ikinci switchin bağlı olduğu port trunk veya istediğiniz diğer vlana access olacak. ve ikinci switch üzerindeki tüm portları istediğiniz diğer vlana member olması için access vlan x yapacaksınız.

 

açıkcası switch sayınız fazlaysa muhtelen birkaç switch birbiri üzerinden uplink şeklinde bağlı durumdadır bunu da düşünmenizi öneririm.

CevapAlıntı
Gönderildi : 27/06/2018 12:12
metin parlak
(@metinparlak)
Yeni Üye

ben kenar switchlere gitmeden ayar yapmak istiyorum. kenar switchler hem farklı marka hem çok dağınık bu yüznden kısa yoldan backbone üzerinden halletmek istiyorum.

 

[quote user="Vasvi UYSAL"]

[quote user="metin parlak"]

evet dediğiniz gibi backbone üzerinden vlan basmak istiyorum. kenar sw portlarını access yapınca native vlan hatası veriyor.trunk yapınca oluyor ama bu defa da dhcp scope ayrımı yapamıyor

 

[quote user="Vasvi UYSAL"]

[quote user="metin parlak"]

hocam dediğiniz şekilde daha önce yaptım oluyor ama vtp ile yaptım. benim burda yapmak istediğim alan büyük olduğu için kenar swler ile hiç uğraşmadan sadece backbone üzerinden vlana alabilir miyim kenar swleri. çünkü kimi yerlerde kenar swlerden hub atlaması var ve çok sayıda kenar sw olduğu için o kadar kenar sw için tek tek swye gitmeden aşağıdaki ayarı backbone üzerinden basıl yapabilirim. teşekkür ederim cevaplarınız için

vlan 20 olan switch

interface range fasthethernet 0/1 - fastethernet 0/24

switchport mode access

switchport access vlan 20

 

[/quote]

 

Backbone üzerinden direk vlan basacaksanız yani kenar switche giden portu access olarak yapılandıracaksanız vtp ile konunun ilgisi yok 

vtp vlan bilgisini sadece trunk portlar üzerinden taşıyabilir.

 

 

[/quote]

[/quote]

Backbone ve kenar swichleri trunk baglayıp kenar switchdeki tüm portları istediğiniz vlana member yaptıktan sonra

dhcp ayrı bir sunucuda ise ip helper ile istediğin vlana ip dağıtabilirsiniz.

http://www.cozumpark.com/blogs/cisco_system/archive/2013/10/27/cisco-temelli-sistemlerde-farkli-vlanlara-ip-dagitilmasi.aspx

 

iyi çalışmalar

 

 

 

[/quote]

CevapAlıntı
Gönderildi : 27/06/2018 12:18
metin parlak
(@metinparlak)
Yeni Üye

evet dediğiniz gibi kenar switchlere karışmadan vlan oluşturmak isitiyorum. tüm switchlerde zaten vlan 1 default olarak var zaten buna ip ataması yapıp yine dediğniz servisleri kapatamaz mıyım. bunu oluşturmanın bir yolu var mı yok mu onu öğrenmek istiyorum aslında yoksa son çare tabiki kenar switchler üzerinden vlan oluşturmak ya da vtp yardımıyla backbone üzerinden vtp yapılandırmasını kenarlara gönderme seçeneklerini düşünecem. teşekkürler cevaplarınız için...

[quote user="Zafer SEN"]

[quote user="metin parlak"]

hocam dediğiniz şekilde daha önce yaptım oluyor ama vtp ile yaptım. benim burda yapmak istediğim alan büyük olduğu için kenar swler ile hiç uğraşmadan sadece backbone üzerinden vlana alabilir miyim kenar swleri. çünkü kimi yerlerde kenar swlerden hub atlaması var ve çok sayıda kenar sw olduğu için o kadar kenar sw için tek tek swye gitmeden aşağıdaki ayarı backbone üzerinden basıl yapabilirim. teşekkür ederim cevaplarınız için

vlan 20 olan switch

interface range fasthethernet 0/1 - fastethernet 0/24

switchport mode access

switchport access vlan 20

 

[/quote]

kenarlarda unmanaged yani yönetilmeyen switch kullansanız istediğinizi yapabilirsiniz, sadece L3 switchi yönetirsiniz, hangi portuna switch takarsanız o portu istediğiniz vlana member yapmanız yeterli olur.

ama yönetilebilir switchlerde default vlan var, gönderdiği paketin başına vlan tag ekliyor.

 

vtp şöyle düşünebilirsiniz, merkezi olarak vlan yönetmek gibi, L3 üzerinde yarattığınız her vlan diğer tüm switchlere de dağıtılır.

 

sizin isteğiniz vtp değil aslında, anladığım kadarıyla kenarlara hiç karışmadan kenarlardaki switchleri istediğiniz vlanlara access şekilde kullanmak istiyorsunuz.

kenarlara hiç karışmamak benim bildiğim kadarıyla pek mümkün değil, doğru da değil, şu sebeple

kenar switch üzerinde en azından interface vlan açıp erişebilir durumda olması, username password oluşturulması, telnet gibi servislerin kapalı olması gibi,

 

bu nedenle benim aklıma gelen en basit yöntem, kenar switchte çalışmasını istediğiniz vlanı yaratıp tüm portları buna access etmelisiniz,

uplink portu access de olur trunk da olur. ama tüm portların istediğiniz vlana member olması şart diğer türlü paketin başında default vlan tag ekli geleceği için çalışmayacaktır.

 

hub varsa bu ve L3e bağlıysa bu da olur, hub bağlı olduğu porta göre istediğiniz vlana member olacaktır,

 

şöyle de bir durum var, kenar switchlerinizden bir veya birkaçı L3 switche uplink ile gelmiyor da olabilir, misal kenar switch üzerinden uplinkle geliyorsa ve üzerinden geçtiği switchten farklı bir vlan kullanmanız gerekiyorsa bu durumda ne yapacaksınız?

bunun için yine kenar switche erişmek durumunda kalacaksınız, L3 switch üzerinden trunk gelip, ilk switch örneğin vlan 20 olacaksa bunun tüm portları vlan 20 access olacak, ikinci switchin bağlı olduğu port trunk veya istediğiniz diğer vlana access olacak. ve ikinci switch üzerindeki tüm portları istediğiniz diğer vlana member olması için access vlan x yapacaksınız.

 

açıkcası switch sayınız fazlaysa muhtelen birkaç switch birbiri üzerinden uplink şeklinde bağlı durumdadır bunu da düşünmenizi öneririm.

[/quote]

CevapAlıntı
Gönderildi : 27/06/2018 12:24
Vasvi UYSAL
(@vasviuysal)
Saygın Üye Forum Yöneticisi

[quote user="metin parlak"]

ben kenar switchlere gitmeden ayar yapmak istiyorum. kenar switchler hem farklı marka hem çok dağınık bu yüznden kısa yoldan backbone üzerinden halletmek istiyorum.

 

[quote user="Vasvi UYSAL"]

[quote user="metin parlak"]

evet dediğiniz gibi backbone üzerinden vlan basmak istiyorum. kenar sw portlarını access yapınca native vlan hatası veriyor.trunk yapınca oluyor ama bu defa da dhcp scope ayrımı yapamıyor

 

[quote user="Vasvi UYSAL"]

[quote user="metin parlak"]

hocam dediğiniz şekilde daha önce yaptım oluyor ama vtp ile yaptım. benim burda yapmak istediğim alan büyük olduğu için kenar swler ile hiç uğraşmadan sadece backbone üzerinden vlana alabilir miyim kenar swleri. çünkü kimi yerlerde kenar swlerden hub atlaması var ve çok sayıda kenar sw olduğu için o kadar kenar sw için tek tek swye gitmeden aşağıdaki ayarı backbone üzerinden basıl yapabilirim. teşekkür ederim cevaplarınız için

vlan 20 olan switch

interface range fasthethernet 0/1 - fastethernet 0/24

switchport mode access

switchport access vlan 20

 

[/quote]

 

Backbone üzerinden direk vlan basacaksanız yani kenar switche giden portu access olarak yapılandıracaksanız vtp ile konunun ilgisi yok 

vtp vlan bilgisini sadece trunk portlar üzerinden taşıyabilir.

 

 

[/quote]

[/quote]

Backbone ve kenar swichleri trunk baglayıp kenar switchdeki tüm portları istediğiniz vlana member yaptıktan sonra

dhcp ayrı bir sunucuda ise ip helper ile istediğin vlana ip dağıtabilirsiniz.

http://www.cozumpark.com/blogs/cisco_system/archive/2013/10/27/cisco-temelli-sistemlerde-farkli-vlanlara-ip-dagitilmasi.aspx

 

iyi çalışmalar

 

 

 

[/quote]

[/quote]

 

Tamam portları access ayarlamanız yeterli , yine ip-helper ile istediğiniz vlana ip dağıtabilirsiniz bu şekilde de

verdiğim linkteki makaleyi inceleseniz ne kadar basit olduğunu göreceksiniz zaten.

CevapAlıntı
Gönderildi : 27/06/2018 12:25
metin parlak
(@metinparlak)
Yeni Üye

pacet tracer üzerinden kenarları access yaptığımda native vlan hatası veriyor. link olarak yüklediğim örnekte portlar trunk ip helper adresi girmeme rağmen dhcp scope ayrımı yapmıyor. dediğim gibi kenarları access yapınca native vlan hatası veriyor.

 

[quote user="Vasvi UYSAL"]

[quote user="metin parlak"]

ben kenar switchlere gitmeden ayar yapmak istiyorum. kenar switchler hem farklı marka hem çok dağınık bu yüznden kısa yoldan backbone üzerinden halletmek istiyorum.

 

[quote user="Vasvi UYSAL"]

[quote user="metin parlak"]

evet dediğiniz gibi backbone üzerinden vlan basmak istiyorum. kenar sw portlarını access yapınca native vlan hatası veriyor.trunk yapınca oluyor ama bu defa da dhcp scope ayrımı yapamıyor

 

[quote user="Vasvi UYSAL"]

[quote user="metin parlak"]

hocam dediğiniz şekilde daha önce yaptım oluyor ama vtp ile yaptım. benim burda yapmak istediğim alan büyük olduğu için kenar swler ile hiç uğraşmadan sadece backbone üzerinden vlana alabilir miyim kenar swleri. çünkü kimi yerlerde kenar swlerden hub atlaması var ve çok sayıda kenar sw olduğu için o kadar kenar sw için tek tek swye gitmeden aşağıdaki ayarı backbone üzerinden basıl yapabilirim. teşekkür ederim cevaplarınız için

vlan 20 olan switch

interface range fasthethernet 0/1 - fastethernet 0/24

switchport mode access

switchport access vlan 20

 

[/quote]

 

Backbone üzerinden direk vlan basacaksanız yani kenar switche giden portu access olarak yapılandıracaksanız vtp ile konunun ilgisi yok 

vtp vlan bilgisini sadece trunk portlar üzerinden taşıyabilir.

 

 

[/quote]

[/quote]

Backbone ve kenar swichleri trunk baglayıp kenar switchdeki tüm portları istediğiniz vlana member yaptıktan sonra

dhcp ayrı bir sunucuda ise ip helper ile istediğin vlana ip dağıtabilirsiniz.

http://www.cozumpark.com/blogs/cisco_system/archive/2013/10/27/cisco-temelli-sistemlerde-farkli-vlanlara-ip-dagitilmasi.aspx

 

iyi çalışmalar

 

 

 

[/quote]

[/quote]

 

Tamam portları access ayarlamanız yeterli , yine ip-helper ile istediğiniz vlana ip dağıtabilirsiniz bu şekilde de

verdiğim linkteki makaleyi inceleseniz ne kadar basit olduğunu göreceksiniz zaten.

[/quote]

CevapAlıntı
Gönderildi : 27/06/2018 12:31
Zafer SEN
(@ZaferSEN)
Yeni Üye

L3 tarafındaki uplinkleri mode access yaptınız, int 0/1 vlan 10, int 0/20 vlan 20

 

0/1 bağlı olan switch tarafında 

int ran fa 0/1 - fa 0/24

sw mo acc

sw access vlan 10

 

0/2 bağlı olan switch tarafında

int ran fa 0/1 - fa 0/24

sw mo acc

sw acc vlan 20

yaparsanız 1. switch tüm portları vlan 10 member olmuş olacaktır bu nedenle uplink tarafında da sorun olmayacak.

2. switch de tüm portları vlan 20 member olmuş olacağından uplink tarafında sorun yaşamazsınız.

 

L3 tarafında ise interface vlan 10 ve interface vlan 20 altına girdiğiniz ip helper addressleri çalışacaktır.

CevapAlıntı
Gönderildi : 27/06/2018 16:28
metin parlak
(@metinparlak)
Yeni Üye

anladığım kadarıyla kenar switchlere gitmeden bu iş olmayacaktır. ben kenar switchler ile uğraşmak istemiyordum o yüzden böyle bir çözüm üretmek istedim ama mümkün görünmüyor. bahsettiğiniz bu configi daha önce yaptım çalıştı bir sıkıntı çıkmamıştı yani. teşekkür ederim cevaplarınız için.

 

[quote user="Zafer SEN"]

L3 tarafındaki uplinkleri mode access yaptınız, int 0/1 vlan 10, int 0/20 vlan 20

 

0/1 bağlı olan switch tarafında 

int ran fa 0/1 - fa 0/24

sw mo acc

sw access vlan 10

 

0/2 bağlı olan switch tarafında

int ran fa 0/1 - fa 0/24

sw mo acc

sw acc vlan 20

yaparsanız 1. switch tüm portları vlan 10 member olmuş olacaktır bu nedenle uplink tarafında da sorun olmayacak.

2. switch de tüm portları vlan 20 member olmuş olacağından uplink tarafında sorun yaşamazsınız.

 

L3 tarafında ise interface vlan 10 ve interface vlan 20 altına girdiğiniz ip helper addressleri çalışacaktır.

[/quote]

CevapAlıntı
Gönderildi : 27/06/2018 18:08
Sayfa 1 / 2
Paylaş:
  
Çalışıyor

Lütfen Giriş yap yada Kayıt ol