Forum

veeam v9.5 v2 backu...
 
Bildirimler
Hepsini Temizle

veeam v9.5 v2 backup sorunu hkk

16 Yazılar
5 Üyeler
0 Likes
2,605 Görüntüleme
Deniz Verman
(@DenizVerman)
Gönderiler: 1289
Noble Member
Konu başlatıcı
 

arkadaşlar merhaba veeam v9.5 v2 hyperv vm lerin yedeklerini alıyorum ama bir iki gündür oluşan bir hata var backup alınmaya çalışıldığında job start olduktan çok kısa bir süre sonunda direk fail oluyor detayda aşağıdaki hata düşüyor;

Unable to allocate processing resources. Error: Column, parameter, or variable #1: Cannot find data type uniqueıdentifier.

backup proxy sildim tekrar oluşturdum değişiklik yok,

bütün veeam servislerini start ve çalışır durumda.

 
Gönderildi : 28/08/2017 12:09

Turan COŞKUN
(@turancoskun)
Gönderiler: 4111
Üye
 

merhaba,

veeam'e ait olan, ilk olarak sql servisini ve devamında diğer bağlı servisleri yeniden başlatarak, tekrar deneyin.

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

 
Gönderildi : 28/08/2017 16:08

Evren Banger
(@evrenbanger)
Gönderiler: 2447
Üye
 

arkadaşlar merhaba veeam v9.5 v2 hyperv vm lerin yedeklerini alıyorum ama bir iki gündür oluşan bir hata var backup alınmaya çalışıldığında job start olduktan çok kısa bir süre sonunda direk fail oluyor detayda aşağıdaki hata düşüyor;

Unable to allocate processing resources. Error: Column, parameter, or variable #1: Cannot find data type uniqueıdentifier.

backup proxy sildim tekrar oluşturdum değişiklik yok,

bütün veeam servislerini start ve çalışır durumda.

Selamlar ;

Veeam sunucusunda dil ayarları ile ilgili birşey değiştirdiniz mi ? 

SQL server collation set tinin olması gerekiyor "SQL_Latin1_General_CP1_CI_AS"

Eger herhangi bir ayar değiştirdiyseniz regediteki SQLDB namini değiştirmeniz gerekiyor. Bu işlemden sonra otomatik olarak yeni bir DB oluşacaktır.

Veeam sunucusundaki bütün veeam servislerini durdurun. Daha sonra aşağıdaki register idaki aşağıdaki DB name yazan yerdeki ismi değiştirin

HKEY_LOCAL_MACHINE\SOFTWARE\ Wow6432Node\VeeaM\Veeam Backup and Replication\SqlDatabaseName

daha sonra servisleri tekrar çalıştırıp bir test backup alın muhtemelen sorununuz düzelicektir.

İyi çalışmalar.

 

 

 

 
Gönderildi : 28/08/2017 17:17

Deniz Verman
(@DenizVerman)
Gönderiler: 1289
Noble Member
Konu başlatıcı
 

arkadaşlar merhaba veeam v9.5 v2 hyperv vm lerin yedeklerini alıyorum ama bir iki gündür oluşan bir hata var backup alınmaya çalışıldığında job start olduktan çok kısa bir süre sonunda direk fail oluyor detayda aşağıdaki hata düşüyor;

Unable to allocate processing resources. Error: Column, parameter, or variable #1: Cannot find data type uniqueıdentifier.

backup proxy sildim tekrar oluşturdum değişiklik yok,

bütün veeam servislerini start ve çalışır durumda.

Selamlar ;

Veeam sunucusunda dil ayarları ile ilgili birşey değiştirdiniz mi ? 

SQL server collation set tinin olması gerekiyor "SQL_Latin1_General_CP1_CI_AS"

Eger herhangi bir ayar değiştirdiyseniz regediteki SQLDB namini değiştirmeniz gerekiyor. Bu işlemden sonra otomatik olarak yeni bir DB oluşacaktır.

Veeam sunucusundaki bütün veeam servislerini durdurun. Daha sonra aşağıdaki register idaki aşağıdaki DB name yazan yerdeki ismi değiştirin

HKEY_LOCAL_MACHINE\SOFTWARE\ Wow6432Node\VeeaM\Veeam Backup and Replication\SqlDatabaseName

daha sonra servisleri tekrar çalıştırıp bir test backup alın muhtemelen sorununuz düzelicektir.

İyi çalışmalar.

 

 

 

 

evet evren bey dediğiniz veeam kurulu olduğu servera mysql destekli bir program tool u kurmuştum ondan sonra oldu bu hata,

cp1 c1 as ayarı değişmemiş gözüküyor ama sizin dediğiniz gibi database name değiştirdiğimde dediğiniz gibi yeni bir database oluşturmadı,

sorunda dediğiniz veeam database probleminden kaynaklanmakta.

 
Gönderildi : 28/08/2017 17:39

Evren Banger
(@evrenbanger)
Gönderiler: 2447
Üye
 

Selam DB olarak Express mi kullanıyorsun ? Default kurulumlarda Express geliyor zaten.

 
Gönderildi : 28/08/2017 18:20

Deniz Verman
(@DenizVerman)
Gönderiler: 1289
Noble Member
Konu başlatıcı
 

evet default kurulum express kullanıyorum.

 
Gönderildi : 28/08/2017 20:12

Evren Banger
(@evrenbanger)
Gönderiler: 2447
Üye
 

O zaman hatalı birşey yapıyor olmalısın. Sen Database isimini değiştirdiğinde nereden anladın yeni bir DB oluşmadığını ?

 
Gönderildi : 28/08/2017 21:20

Deniz Verman
(@DenizVerman)
Gönderiler: 1289
Noble Member
Konu başlatıcı
 

database ismini sql management studio üzerinden baktım evren bey,

yeni database oluşturup oluşturmadığını nasıl anlarım acaba başka türlü,

ayrıca veeam  tamamen kaldırıp tekrar kurmayı düşünüyorum ayarlarım gitmemesi için neleri yedeklemem gerekli tekrar ayarları dönmek için.

 
Gönderildi : 28/08/2017 21:31

Evren Banger
(@evrenbanger)
Gönderiler: 2447
Üye
 

Registry deki o ekranın görüntüsünü yollayabilirmisin ?

 
Gönderildi : 28/08/2017 22:41

Deniz Verman
(@DenizVerman)
Gönderiler: 1289
Noble Member
Konu başlatıcı
 

Registry deki o ekranın görüntüsünü yollayabilirmisin ?

 

https://hizliresim.com/1gzrMY

 
Gönderildi : 28/08/2017 23:58

Deniz Verman
(@DenizVerman)
Gönderiler: 1289
Noble Member
Konu başlatıcı
 

ayrıca job hata verdikten sonra şu hatayıda düşürmekte;

Error: Access is denied.  RPC function call failed. Function name: [GetSvcVersion]. Target machine: [192.168.0.7].

 
Gönderildi : 29/08/2017 00:19

Deniz Verman
(@DenizVerman)
Gönderiler: 1289
Noble Member
Konu başlatıcı
 

çözüm kısaca komple kaldırıp sunucu üzerinden tekrar kurmakmı olur acaba,

 

teşekkürler..

 
Gönderildi : 29/08/2017 02:44

Evren Banger
(@evrenbanger)
Gönderiler: 2447
Üye
 

Bak yanlış yeri değiştiriyorsun sql server değil database ismini değiştircekain. sql server name tarafını duzelt butun servisleri kapat dbname degiştir servisleri ac. Sql server değil database.

 
Gönderildi : 29/08/2017 02:53

Deniz Verman
(@DenizVerman)
Gönderiler: 1289
Noble Member
Konu başlatıcı
 

Bak yanlış yeri değiştiriyorsun sql server değil database ismini değiştircekain. sql server name tarafını duzelt butun servisleri kapat dbname degiştir servisleri ac. Sql server değil database.

evren bey sql server değiştirmiyorum sadece onun üstü işaretli kalmış ben database name değiştirdim fakat değişiklik olmadı durum aynı.

 
Gönderildi : 29/08/2017 02:59

Onur VARGUN
(@OnurVARGUN)
Gönderiler: 157
Estimable Member
 

Çözüm şu şekilde ,

Öncelikli olarak Veeam sunucunuzun dil ve bölgesel ayarlarını english ve usa olarak ayarlayın yada ilk kurulumu bu şekilde yapın  .

Daha sonra Veeam destek ekibinden gelen bilgiyi paylaşıyorum .

Control Panel->Region and Language->Administrative->Copy Settings->check "welcome screen and system accounts"

This sets system account to use English language.

 

bunu uygulayınca problem çözülüyor .

 

 
Gönderildi : 06/10/2017 14:25

Fatih Şentürk
(@fatihsenturk-2)
Gönderiler: 81
Estimable Member
 

Eski bir konu fakat belki arayan olur diye sorunun kesin cozumunu yaziyorum

 

  1. Veeam veritabaninin yedegini alin
  2. Butun Veeam servislerini durdurun
  3. Veritabaninin full scriptini olusturun
  4. var olan Veeam Veritabaninin adini degistirin yada silin
  5.  olusturdugunuz  script icerisinde   Log On ve Go arasindaki yere  asagidaki kirmizi alani ekleyin

LOG ON 

( NAME = N'VeeamBackupReporting_log', FILENAME = N'c:\Program Files\Microsoft SQL Server\MSSQL11.VEEAMSQL2012\MSSQL\DATA\VeeamBackupReporting_log.ldf' , SIZE = 43968KB , MAXSIZE = 2048GB , FILEGROWTH = 10%)

COLLATE SQL_Latin1_General_CP1_CI_AS  (bu alani ekleyin)

GO

bu alani ekledikten sonra   scripti calistirin muhtemelen hata alicaksiniz

hata alirsaniz sqlcmd uzerinden calistirmaniz gerekiyor

kullanmaniz gereken kod:

sqlcmd -S <SqlServerName>\<SqlInstanceName> -d <SqlDatabaseName> -i PATHTOSCRIPT\script.sql -o c:\resetresult.txt -I


bu script calistirildiktan sonra veeam servislerini calistirabilirsiniz ve sorunsuz caliscaktir


Veeam Teknik Destek

 
Gönderildi : 19/11/2018 20:19

Paylaş: