MVC 4'te WebGrid yo...
 
Bildirimler
Hepsini Temizle

MVC 4'te WebGrid yok !  

  RSS
tarık_kara
(@tarik_kara)
Üye

Mvc 4 yükledim

bir progam yazarken var grid = new WebGrid(Model);  yazdım hemen WebGrid ifadesinin altı kırmızı çizgi oldy ve çalıştırdığımda da hata verdi tabii.oysa izlediğim bir videoda aynısını yazarken WebGrid ifadesi vardı ve mavi renk alıyordu.yüklemem mi lazım birşeyleri nasıl yapıcam bilemedim.

Alıntı
Gönderildi : 23/12/2012 17:59
Ragıp ÜNAL
(@RagipUNAL)
Üye

Merhabalar;

c# da örnekleme yaparken using i kullanarak kütüphaneyi syfaya ekliyorduk. Bunda aynı durum olabilir diye düşünüyorum. Bence bir kontrol edin derim. Mvc bilmediğim için aklıma gelen tek şey bu. Var olduğunu bildiğiniz bir yapı, studio da altı çizili geliyorsa mutlaka kütüphane eklimi diye bakmak lazım.

CevapAlıntı
Gönderildi : 24/12/2012 22:44
Ergin TIRAVOGLU
(@ErginTIRAVOGLU)
Üye

Selam,

Altı kırmızı kelimenin üzerine sağ tıklayıp açılan menüden "Resolve" u seçerseniz gerekli kütüphaneyi otomatik olarak sayfa başına ekleyecektir. Aynı şekilde kırmızı kelimene bitişik bi şekilde Ctrl+. (kontrol ve nokta) tuşlarına basarsanızda yine size eklenecek kütüphaneyi gösterir.

Sizin aradığınız kütüphaneyi ise;

using System.Web.Helpers;

şeklinde tanımlayabilirsiniz.

CevapAlıntı
Gönderildi : 27/12/2012 19:10
tarık_kara
(@tarik_kara)
Üye

.cs dosyası değil bu cshtml . bu yüzden de usingle birşey ekleyemem.

CevapAlıntı
Gönderildi : 03/01/2013 21:07
tarık_kara
(@tarik_kara)
Üye

yaptım ama eklemiyor.sağ tıklayınca da resolve diye bir seçenek çıkmıyor.sözüne ettiğiniz kütüphane de web.config de var ama hala aynı hatayı veriyor.

CevapAlıntı
Gönderildi : 03/01/2013 21:10
Mesut ÇAKIR
(@MesutCAKIR)
Üye
Referanslarınızı kontrol edin eğer yok ise ekleyin.
 
Var ise silin tekrar ekleme yapın.
 
aşağıda bulunan kodu çalıştırın. "@{}" içerinde bulunan kodları Action içerisinde de deneyin eğer o şekilde çalışıyorsa Projenize referans eklenmiş demektir.
 
sonrasında cshtml yani view dosyamızın içerisinde deniyoruz. Olmak zorunda. 
 
@{
    var lsit = new List<dynamic>();
    lsit.Add(new { Name = "Mesut", Surname = "ÇAKIR" });
    var wg = new System.Web.Helpers.WebGrid(lsit, new List<string> { "Name", "Surname" });
}
@wg.GetHtml()
 
 
Olmadığı taktirde mesut.cakir@hotmail.com.tr adresine yazabilirsiniz. Gerektiği taktirde team viewer ile destek verilecektir. 
CevapAlıntı
Gönderildi : 14/01/2013 00:10
Hilmi SARI
(@HilmiSARI)
Üye

Ayrıca

Reference' a System.Web.Helpers Ekledikten sonra Properties'den local Copy Özelliğini True Yapmak Lazım

 Bnede Sorun Böyle Çözüldü. diğer türlü çalışmıyor.

[quote user="Mesut ÇAKIR"]

Referanslarınızı kontrol edin eğer yok ise ekleyin.
 
Var ise silin tekrar ekleme yapın.
 
aşağıda bulunan kodu çalıştırın. "@{}" içerinde bulunan kodları Action içerisinde de deneyin eğer o şekilde çalışıyorsa Projenize referans eklenmiş demektir.
 
sonrasında cshtml yani view dosyamızın içerisinde deniyoruz. Olmak zorunda. 
 
@{
    var lsit = new List<dynamic>();
    lsit.Add(new { Name = "Mesut", Surname = "ÇAKIR" });
    var wg = new System.Web.Helpers.WebGrid(lsit, new List<string> { "Name", "Surname" });
}
@wg.GetHtml()
 
 
Olmadığı taktirde mesut.cakir@hotmail.com.tr adresine yazabilirsiniz. Gerektiği taktirde team viewer ile destek verilecektir. 

[/quote]

CevapAlıntı
Gönderildi : 14/01/2013 15:36
Paylaş: