name server oluştur...
 
Bildirimler
Hepsini Temizle

name server oluşturulması  

Sayfa 1 / 2
  RSS
mehmetbaytug
(@mehmetbaytug)
Üye

Arkadaşlar sorun aslında basit ama bir noktada takıldım kaldım. Yardımlarınızı talep ediyorum. Sorun şöyle

 nic.tr'den bir domain aldım. bu domaine evimden host sağlamak istiyorum. nic.tr'den domainin dns yönlendirmesini evde kullandığım adsl'in statik ip'sine yaptım ve name server olarak ns1.xxx.com ns2.xxx.com şeklinde tanımlar yaptım.

 Daha sonra evdeki bir makinaya windows 2003 standart server kurdum. Active directory kurulumu yaptım. (Almış olduğum domainden farklı bir domain adıyla kurdum) DNS kurulumu yaptım. Dns'de satın aldığım domain için bir kayıt oluşturdum. Ama name server kayıtları benim active directory domainimin ismiyle açıldı. Onlara dokunmadım ben kendim ns1 ve ns2.xxx.com şeklinde ve ip olarak da adsl statik ip'yi belirttim. fakat domaine ping attığımda ulaşamıyorum. Bu konfügrasyona göre hata yaptığım yer neresi olabilir.

Alıntı
Gönderildi : 02/08/2010 19:07
Rıza ŞAHAN
(@rizasahan)
Değerli Üye Forum Yöneticisi

Merhaba,


Dns portu ne alemde 53 ?

CevapAlıntı
Gönderildi : 02/08/2010 19:18
Ahmet Söyletir
(@AhmetSoyletir)
Üye

Selam,

telnet ip-adresin 53   ne döndürüyor?

ADSL modeminin firewall'unda ping'e izin vermediysen ping'i engelliyor olabilir.

CevapAlıntı
Gönderildi : 02/08/2010 19:43
mehmetbaytug
(@mehmetbaytug)
Üye

dns portu açık. 53 nolu port modem de dns'in kurulu olduğu bilgisayara nat yapılmış durumda. fakat telnet yapınca bağlantı başarısız hatası geliyor. firewall kapalı, antivirüs yazılımı kapalı.

CevapAlıntı
Gönderildi : 02/08/2010 21:30
Ahmet Söyletir
(@AhmetSoyletir)
Üye

nat işlermini tekrar kontrol etmelisin.

 birde windows üzerinde açık portları kontrol etmeni tavsiye ederim

netstat -an |find /i "listening"
komuıtuyla o anda dinlediği portları konrol edebilirsin. 

 

CevapAlıntı
Gönderildi : 02/08/2010 22:59
mehmetbaytug
(@mehmetbaytug)
Üye

 

ns1 ve ns2.xxx.com şeklinde pinglediğim zaman pinge cevap veriyor. ama açtığım A kayıtlarını pinglediğim zaman cevap vermiyor. bu normal mi??

 

netstat komutunun çıktısı aşağıdaki gibi

 

TCP    0.0.0.0:53             0.0.0.0:0              LISTENING
TCP    0.0.0.0:88             0.0.0.0:0              LISTENING
TCP    0.0.0.0:135            0.0.0.0:0              LISTENING
TCP    0.0.0.0:389            0.0.0.0:0              LISTENING
TCP    0.0.0.0:445            0.0.0.0:0              LISTENING
TCP    0.0.0.0:464            0.0.0.0:0              LISTENING
TCP    0.0.0.0:593            0.0.0.0:0              LISTENING
TCP    0.0.0.0:636            0.0.0.0:0              LISTENING
TCP    0.0.0.0:1026           0.0.0.0:0              LISTENING
TCP    0.0.0.0:1027           0.0.0.0:0              LISTENING
TCP    0.0.0.0:1044           0.0.0.0:0              LISTENING
TCP    0.0.0.0:1082           0.0.0.0:0              LISTENING
TCP    0.0.0.0:1734           0.0.0.0:0              LISTENING
TCP    0.0.0.0:3268           0.0.0.0:0              LISTENING
TCP    0.0.0.0:3269           0.0.0.0:0              LISTENING
TCP    0.0.0.0:3389           0.0.0.0:0              LISTENING
TCP    0.0.0.0:4114           0.0.0.0:0              LISTENING
TCP    10.0.0.1:139           0.0.0.0:0              LISTENING
TCP    127.0.0.1:30606        0.0.0.0:0              LISTENING
TCP    169.254.73.156:139     0.0.0.0:0              LISTENING
TCP    169.254.144.86:139     0.0.0.0:0              LISTENING

CevapAlıntı
Gönderildi : 03/08/2010 13:07
CozumPark
(@cozumpark)
Onursal Üye Yönetici

oluşturduğun host kayıtlarına bakabilir miyim? ns1 ' leri dns propertieste forwarders'lara ekleyip dns servisini restart edip dener misin? NAT ' ın doğru olduğundan emin ol. ns ' lere şu an ping atabilmen normal onlar nic' ten alıyorlar baglantilarini.

CevapAlıntı
Gönderildi : 04/08/2010 01:55
mehmetbaytug
(@mehmetbaytug)
Üye

DNS ekranı aşağıdaki gibi. Nat işleminde de bir sorun yok.

 

CevapAlıntı
Gönderildi : 04/08/2010 13:26
CozumPark
(@cozumpark)
Onursal Üye Yönetici

bence ping atamaman normal, icmp protokolüne de izin verme zaten.

CevapAlıntı
Gönderildi : 04/08/2010 22:36
mehmetbaytug
(@mehmetbaytug)
Üye

Ben hala domaine erişemiyorum. Sorun çözümsüz mü yani.

CevapAlıntı
Gönderildi : 05/08/2010 11:12
CozumPark
(@cozumpark)
Onursal Üye Yönetici

üstad ping atamamak ayrı, domaine ulaşamamak ayrı bir durum. Ping atamaman şu yüzden normal. Firewall bulunan her ortamda icmp, yani ping atabilmen için gerekli protokol kapalıdır, bu sebeple ping atamazsın zaten. Fakat domaine ulaşamamak derken neyi kastediyorsun? DNS' e forwarders olarak eklemeyi dene demiştim denedin mi? Host kayıtlarının senin kurduğun AD adıyla açılması da anormal değil. Sen satın aldığın domaine ulaşamıyor musun? Web sitesi olarak mı yapılandırdın? Web site olarak ulaşacaksan www olarak bir host kaydı daha açman ve sabit WAN IP' ni girmen gerekir ki dışardan ben www.x.com a ping attığımda senin IP'yi döndürsün. Yukarıdaki dns kayıtlarına göre ben sadece senin ns' lerine ulaşabilirim.

CevapAlıntı
Gönderildi : 05/08/2010 15:16
mehmetbaytug
(@mehmetbaytug)
Üye

firewall var ama kapalı durumda şu an. o yüzden gelen tüm paketlerin sorunsuz bir şekilde geçmesi gerekir diye düşünüyorum. aslında istediğim cevabı vermişsiniz sanırım. mail host edeceğim ben bu makinada onun için mx kaydının yanına bir host kaydı açıp wan ip'mi girdiğim zaman sanırım sorun çözülecek. web sayfası host etmeyi düşünmüyorum ama test olması açısından onu da deneyeceğim.

CevapAlıntı
Gönderildi : 05/08/2010 17:29
CozumPark
(@cozumpark)
Onursal Üye Yönetici

Firewall söylememden kasıt tüm clientların gateway' i, yani şirketin firewallu ve kapalı olması imkansız. Olumlu dönüşler bekliyoruz. Web için de aynı şekilde kayıtlar açılıyor bu kez mx yerine alias veya host(www şeklinde)

CevapAlıntı
Gönderildi : 06/08/2010 20:26
Recep YÜKSEL
(@recepyuksel)
Kıdemli Üye Forum Yöneticisi

Mehmet bey,


Merhaba, ben gönderdiğiniz resimde bir www kaydı görüyorum. sonu 181 ile biten makinadaki varsa iis ve onun üzerinde çalışan web sitesine erişemiyormusunuz şu durumda?

************************************************************
Probleminiz çözüldüğünde sonucu burada paylaşırsanız,
sizin ile aynı problemi yaşayanlar için yardım etmiş olursunuz.
Eğer sorununuz çözüldü ise "çözüldü" olarak işaretlerseniz
diğer üyeler için çok büyük kolaylık sağlayacaktır.
************************************************************

CevapAlıntı
Gönderildi : 07/08/2010 11:19
mehmetbaytug
(@mehmetbaytug)
Üye

Evet onu test için oluşturmuştum erişebiliyormuyum diye. Localde erişiyorum ama domain ile geldiğimde erişemiyorum.

CevapAlıntı
Gönderildi : 09/08/2010 11:15
Mesut SARIYAR
(@mesutsariyar)
Kıdemli Üye Forum Yöneticisi

Merhaba,


Alper yukarıda cevabı vermiş, www kaydı için girdiğiniz yerel ip, dışarıdan elbette erişemezsiniz.

CevapAlıntı
Gönderildi : 09/08/2010 11:55
mehmetbaytug
(@mehmetbaytug)
Üye

Mesut bey onu düzelttim. WAN ip'sini verdim. nic.tr'den de WAN ip'sine doğru kayıtlarını girdim. ama bir türlü erişemiyorum. mail server local ağ üzerinde ayrı bir sanal sistemde. DNS'e mail.xxx.com kaydını WAN ip'si ile açtığımda mail server yönlendirmesini nasıl yapacağım.

CevapAlıntı
Gönderildi : 09/08/2010 13:40
CozumPark
(@cozumpark)
Onursal Üye Yönetici

dns kayıtlarınızın son halini tekrar görelim.

CevapAlıntı
Gönderildi : 09/08/2010 22:45
mehmetbaytug
(@mehmetbaytug)
Üye

Son hali aşağıdaki gibi.

 

 

CevapAlıntı
Gönderildi : 11/08/2010 11:17
Sayfa 1 / 2
Paylaş: