Sonicwall Voip Habe...
 
Bildirimler
Hepsini Temizle

Sonicwall Voip Haberleşme sorunu  

  RSS
Abdullah Şimşek
(@AbdullahSimsek)
Üye

Merhaba,

Telesis santral ve Sonicwall firewall kullanmaktayız. Santral kurulumu ve tüm ayarları yapıldı. Local network üzerinde haberleşme normal sağlanıyor. Fakat dışardan içeriye doğru yapılan bir aramada çağrı gidiyor ama ses gidip gelmiyor.

Sonicwall ayarları:

NAT kuralları: 5060-5070 udp    ve   50000-50200 udp portları santral üzerine forward edildi.

[url= http://i.hizliresim.com/REP7DR.jp g" target="_blank">http://i.hizliresim.com/REP7DR.jp g"/> [/img][/url]

resimdeki VOIP ayarları yapıldı.

 

Ayrıca LOG monitor yaptığımda -->sip request paketinin nin hemen ardıdan gelen -->sip response paketinin yanında şu not yer almaktadır. (401 unauthorized)

teşekkür edeirm. 

Alıntı
Gönderildi : 11/08/2014 22:12
İbrahim DOĞAN
(@ibrahimDOGAN)
Üye

Merhaba,

RTP portları olarak 10000-40000 arası kulanılır genelde. bu şekilde denermisin. Birde alternatif olarak çalışdığın ses operatörü ile görüşerek rtp portlarını öğrenebilirsin. Sen kendi tarafında 50000-50200 açmışsın ama operatör rtp akışını farklı portlardan yapıyorsa sürekli değişiklik yapıp test etmen gerekebilir.

Detaylı kontrol için operatör tarafından trace isteyip paylaşırsan kontrol edebiliriz. 

CevapAlıntı
Gönderildi : 14/08/2014 13:33
Emrah Özgiray
(@EmrahOzgiray)
Üye

Merhaba;

Bizde Telesis VOIP santral + draytek firewall kullanıyoruz.

Gördüğüm kadarı ile firewall üzerinden bi takım SIP ayarları girmişsin bunlara gerek yok.

Santral tarafında SIP hesabını oluşturup uzak IP yi doğru girdikten sonra sadece Voip portlarını ilgili santralin iç IP sine natlarsan sıkıntı yaşamaman lazım. Mevcut portları telesisten öğrenebilirsin. büyük aralıkta portları aynı anda açmak güvenlik sıkıntısı oluşturabilir. (10000 -  30000 gibi)

Ayrıca bu ayarların aynısını uzak uçdaki Firewall dada yapmalısın.

 

CevapAlıntı
Gönderildi : 14/08/2014 18:07
Abdullah Şimşek
(@AbdullahSimsek)
Üye

Cevaplar için teşekkür ederim. 

CevapAlıntı
Gönderildi : 18/08/2014 13:02
Cenk Orhun
(@CenkOrhun)
Üye

 

Sonicwall da yeniyiz ve ip santral kullanıyoruz.

Sonicwall a geçince ip telefonlar arası konuşmalarda içerdeki
ip telefondan dışardan bağlanan IP telefona doğru ses gitmiyor.

 

Register portlarımız TCP/UDP 
5060-5070 arası

RTP Portlarımız  
6000-6300 arası hem LAN->WAN hem de WAN->LAN access rule olarak
tanımlı

 

Eksik kalan bir şeyler var sanki ama loglarda da rastlayamadık

Olası tüm imzaların bloklarını kontrol ettim ama sonuç alamadım.

Yardımcı olabilir misiniz

CevapAlıntı
Gönderildi : 18/11/2014 15:46
Onur Durmuş
(@OnurDurmus)
Üye

Merhaba,

Telesis santral ve sonicwall kullanıyoruz ancak internette baktığım ingilizce makalelerde sadece enable consistent NAT etkin olmalı diyor.
Santralda register olabiliyoruz ancak ses paketleriyle alakalı bi problem var.
Bu sorunu çözebilen olduysa yardım olabilir misiniz?

 

İyi çalışmalar, kolay gelsin.

CevapAlıntı
Gönderildi : 20/03/2018 19:51
Turan COŞKUN
(@turancoskun)
Tecrübeli Üye Forum Yöneticisi

merhaba,

referans adreste belirtilen adımları uygulayarak test ettiniz mi ?

https://community.spiceworks.com/topic/2072340-sonicwall-voip-configuration

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 21/03/2018 03:39
Onur Durmuş
(@OnurDurmus)
Üye

Merhaba Turan bey,

Vermiş olduğunuz linkteki makaleyi birebir uygulamamıza rağmen sorun yaşıyoruz.
Sonicwall dışındaki hatlarımızla santral sorunsuz çalışıyor  ancak sonicwall üstüne alınca kesiliyor.

 

Teşekkürler, iyi çalışmalar. 

CevapAlıntı
Gönderildi : 21/03/2018 11:29
Mustafa Akcin
(@mustafaakcin)
Üye

Merhaba,

SIP Server olarak görev yapan IP Santral Cihazınız Sonicwall LAN tarafından konumlandırılmışsa, o zaman SIP Transformation özelliği Disabled yapılmalıdır. eğer WAN tarafında, yani Internet’te yer alıyorsa, o zaman SIP Tranformation özelliği Enabled yapılmalıdır.

CevapAlıntı
Gönderildi : 22/03/2018 13:08
Onur Durmuş
(@OnurDurmus)
Üye

Merhaba Mustafa Bey,

Sonicwall cihazımız A network'ünde 
Sip serverda gshdsl ile B network'ünde
aralarında vpn bağlantısı bulunmuyor.
Sonicwall tarafında nat yapılarak sanal ip ile bağlantı sağladık.
Cihaz register oldu bi kaç lokasyonda bağlantıyı sağladık ancak sanal ipleri gösteremedik sadece metronun ip'sini gördüğü için çalışmadı.
Bide SIP Transformation özelliği kapalı onu açmalı mıyız?

 

Teşekkürler, iyi çalışmalar.

CevapAlıntı
Gönderildi : 23/03/2018 01:38
Turan COŞKUN
(@turancoskun)
Tecrübeli Üye Forum Yöneticisi

Mustafa bey'in üstte belirttiği üzere, sip server public tarafta olduğundan, sip transformation seçeneğini enable ederek test edin.

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 25/03/2018 02:56
Onur Durmuş
(@OnurDurmus)
Üye

Sorunum çözüldü ilginiz ve alakanızdan ötürü çok teşekkür ederim.

İyi çalışmalar dilerim.

CevapAlıntı
Gönderildi : 26/03/2018 11:24
Turan COŞKUN
(@turancoskun)
Tecrübeli Üye Forum Yöneticisi

[quote user="Onur Durmuş"]

Sorunum çözüldü ilginiz ve alakanızdan ötürü çok teşekkür ederim.

İyi çalışmalar dilerim.

[/quote]

hayırlı olsun, rica ederiz.

çözüm noktasınıda paylaşırsanız, benzer sorunu yaşayanlar için referans olacaktır.

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 28/03/2018 01:31
Onur Durmuş
(@OnurDurmus)
Üye

VOIP> Menüsünde

Consistant NAT
SIP Transformations
özellikleri unchecked yani seçili değil.

Firewall Settings> Menüsünde

Flood Protection>UDP Settings > Default UDP Connection Timeout (seconds): 300
olarak ayarlıyoruz.

Default değeri 30 iken konuşmalar kesiliyordu artık kesilmiyor.

Bir diğer konu biz WAN Failover özelliğini kullanıyorduk.
Türk Telekom ve Superonline şeklinde 2 hattımız mevcut.
Sanal iplerimiz Türk Telekom hattımızda tanımlı ancak santralin ağ geçidi Superonline üstünden çıkıyodu dolayısıyla sanal ipler tanımsız kalıyordu santralde bunu algılayamamıştı.
Birincil hattı Türk Telekoma çevirdiğimizde sorunumuz tamamen ortadan kalkmış oldu.

CevapAlıntı
Gönderildi : 29/03/2018 01:13
Paylaş: