Forum

Cyberoam SSO Proble...
 
Bildirimler
Hepsini Temizle

Cyberoam SSO Problemi

Emrah YILMAZ
(@emrahyilmaz-2)
Üye

Uzun süredir çözemediğim bir problemle karşı karşıyayım.

Cyberoam cihazımı ad ile bütünleşik olarak çalıştırıyorum. AD üzerinde yeni kullanıcı oluşturunca, herhangi bir makinadan oturum açtığında otomatik olarak kendi hesabı ile internete çıkış yapıyor. Özellikte çalışma konusunda bir problem yok. Güzel çalışıyor.

Fakat bir misafir gelip wifi ağına bağlandığında, genellikle ad üzerindeki bir kullanıcı ile internete çıkış yapıyor. Normalde captive portal ekranı gelip benim verdiğim şifre ile giriş yaptıktan sonra internete bağlanabilmeli. Cyberoam üzerinde Live users altında bağlandığı kullanıcıyı disconnect yapınca kullanıcı adı ve şifre ekranı geliyor ve bu şekilde bağlanabiliyor.

Bu sorun her zaman olmuyor ama çoğunlukla oluyor.

Fikirleriniz için şimdiden teşekkürler.

 

Alıntı
Konu başlatıcı Gönderildi : 29/01/2016 18:24
Vasvi UYSAL
(@vasviuysal)
Saygın Üye Forum Yöneticisi

daha önce o ip adresi ile yetkili bir kullanıcı bağlanmış olabilir

authentication timeout degerlerini araştırabilirsiniz

CevapAlıntı
Gönderildi : 29/01/2016 18:32
Emrah YILMAZ
(@emrahyilmaz-2)
Üye

Onu da kontrol etmiştim. Timeout değerinden sonra gelen misafirlerde de aynı durum var.

CevapAlıntı
Konu başlatıcı Gönderildi : 29/01/2016 18:54
Yasin Aktaş
(@YasinAktas)
Üye

Aynı durum bendede mevcut bir çok sayfayı araştırdım ancak bir çözüm önerisi yok çözen arkadaşlar varsa lütfen paylaşabilirse memnun oluruz  😉 Saygılar

CevapAlıntı
Gönderildi : 02/02/2016 13:59
irfan koçak
(@irfankocak)
Üye

Merhaba ;

Bende kullanıcılarımı wifi üzerinden internete çıkışlarında bu şekilde yönlendiriyorum.Aldığınız hatayı bende alıyordum fakat daha sonra kullanıcıların işlemlerini incelediğimde logout olmadıkları için captive portala yönlendirilmediklerini gördüm bunun içinde Authentication > Firewall altında bulunan captive portal ayarlarında User Inactivity Timeout bölümünü sınırsızdan 15 dk ya çektim eğer kullanıcı 15 dk hareketsiz kalırsa yeniden captive portala yönlendiriyor ve giriş yaptırıyor.

 

Bu sorunu yarın yeniden test eder farklı bir sonuç alırsam sizinle paylaşırım.

CevapAlıntı
Gönderildi : 02/02/2016 23:11
Emrah YILMAZ
(@emrahyilmaz-2)
Üye

[quote user="irfan koçak"]

Merhaba ;

Bende kullanıcılarımı wifi üzerinden internete çıkışlarında bu şekilde yönlendiriyorum.Aldığınız hatayı bende alıyordum fakat daha sonra kullanıcıların işlemlerini incelediğimde logout olmadıkları için captive portala yönlendirilmediklerini gördüm bunun içinde Authentication > Firewall altında bulunan captive portal ayarlarında User Inactivity Timeout bölümünü sınırsızdan 15 dk ya çektim eğer kullanıcı 15 dk hareketsiz kalırsa yeniden captive portala yönlendiriyor ve giriş yaptırıyor.

 

Bu sorunu yarın yeniden test eder farklı bir sonuç alırsam sizinle paylaşırım.

[/quote]

Bu da sorunu çözmedi. Çünkü bağlı olan misafir sso olarak bağlanmış gibi algılıyor. Örneğin bu sabah birisi geldi misafir olarak. Domainimde olmayan biri. Wifi ağına bağlandı ve live users altına baktığımda, misafirin ip adresi benim domain kullanıcılarımdan birisi ile bağlanmış gözüküyor. O kullanıcım ise şirkete pek uğramıyor, sahada çalışan bir arkadaş.  Yani  "kullanıcım bağlandı askıda kaldı ve bu misafir bağlandı", desek ki bu da değil.

Bir türlü bulamıyorum...

CevapAlıntı
Konu başlatıcı Gönderildi : 04/02/2016 13:52
Emrah YILMAZ
(@emrahyilmaz-2)
Üye

Sorunu çözmeye 1 adım daha yaklaştım. Domain sunucusu üzerine kurulan ctas yazılımında live users kısmında eskiden oturum açmış kişiler gözüküyor. Oturum açmış kişilerin ip adresini kullandığımda daha önce oturum açan kişiyle internete çıkıyor.

Ctas üzerinde enable logoff detection ping ayarı yapılmıştı daha önceden ama logoff yapmıyor.

CevapAlıntı
Konu başlatıcı Gönderildi : 04/02/2016 15:32
irfan koçak
(@irfankocak)
Üye

Merhaba ;

Bu sorunu aslında dhcp üzerindeki kira süresi ile oynayarakta çözmek mümkün olabilir diye düşünüyorum ama aşağıdaki linkleride inceleyebilirsin.Local Policy > Audit Policy  ilede oynanarak birşeyler çıkarılabilir.

http://kb.cyberoam.com/print.asp?id=1869

http://kb.cyberoam.com/default.asp?id=2753&Lang=1&SID=

http://kb.cyberoam.com/default.asp?id=3008

 

Bende şuan wifi ve local blogları farklı olduğu için pek sorun yaşamıyorum.

CevapAlıntı
Gönderildi : 04/02/2016 16:19
Emrah YILMAZ
(@emrahyilmaz-2)
Üye

Aslında dhcp çözmüyor. Kira süresi bitse de ctas üzerinde kullanıcı duruyor. Kira süresi çok uzun olsa da, kısa olsa da ctas üzerindeki live users kısmından kullanıcı düşmedikçe bu sorun devam edecek.

Fakat gönderdiğiniz ilk linkteki "dead entry" değerini 8 saat yapmak ve dhcp süresini çok uzun yapmak sorunu çözebilir belki. Bunu deneyeceğim. Bende dead entry default olarak disable (0) değerdeydi.

Bu arada memleketimde havalar nasıl İrfan Bey?

CevapAlıntı
Konu başlatıcı Gönderildi : 04/02/2016 16:39
Muharrem GÖKTAŞ
(@MuharremGOKTAS)
Üye

Emrah merhaba uzun zamandır cyberomu aynı düzende kullanıyorum bahsettiğin problemi yaşamadım yinede pazartesi tekrar kontrol edeceğim. Bence direk cyberoamdan destek alabilirsin bağlanıp yardımcı oluyorlar ve sorunu çözene kadar peşini bırakmıyorlar 😀 

 

 

CevapAlıntı
Gönderildi : 06/02/2016 13:35
Muharrem GÖKTAŞ
(@MuharremGOKTAS)
Üye

Bende dead entry değeri "2"  ve DHCP süresi uzun değil.

 

[quote user="Emrah YILMAZ"]

Aslında dhcp çözmüyor. Kira süresi bitse de ctas üzerinde kullanıcı duruyor. Kira süresi çok uzun olsa da, kısa olsa da ctas üzerindeki live users kısmından kullanıcı düşmedikçe bu sorun devam edecek.

Fakat gönderdiğiniz ilk linkteki "dead entry" değerini 8 saat yapmak ve dhcp süresini çok uzun yapmak sorunu çözebilir belki. Bunu deneyeceğim. Bende dead entry default olarak disable (0) değerdeydi.

Bu arada memleketimde havalar nasıl İrfan Bey?

[/quote]

 

 

CevapAlıntı
Gönderildi : 06/02/2016 13:50
Emrah YILMAZ
(@emrahyilmaz-2)
Üye

[quote user="Muharrem GÖKTAŞ"]

Bende dead entry değeri "2"  ve DHCP süresi uzun değil.

 

 

[/quote]

Sanırım dead entry değeri ile sorun çözülecek.

CevapAlıntı
Konu başlatıcı Gönderildi : 08/02/2016 12:03
Paylaş: