Forum

Cisco 3800 Router i...
 
Bildirimler
Hepsini Temizle

Cisco 3800 Router ile Hp Procurve 2610 Trunk + Dhcp

Muhammet ŞİMŞEK
(@MuhammetSiMSEK)
Üye

Merhabalar;

 Backbone arkasında, cisco router 3800 ve bunun arkasında hp procurve 2610 switchmiz var.

Yapmak istediğimiz şey;

Web server + database server bunun gibi bir kaç sunucumuz var.

Ayrıca 2 katlı bir iş merkezinde , 2 şirkete de ayrı ayrı hat gidiyor.

2 şirkettede layer2 hatta normal desktop switchler mevcut.

3 ayrı vlan yapıp,
vlan10 serverleri ,
vlan20 1.kat
vlan30 2.kat ıda dağıtmak istiyorum.

Aynı zamanda bunu yaparkende, Cisco router ile trunk halinde olsun, ve cisco router aynı zamanda dhcp özelliği ile vlan 20 ve vlan 30 a IP dağıtsın. Procurve ile vlan ları tanıyıp gelen iç networku benim verdiğim tek ip real Ip den çıkarsın.

Bu şekilde bir yapı mümkün olurmu, alternatifler ne olabilir ? Elimizdeki mevcut yapıyla.

Alıntı
Konu başlatıcı Gönderildi : 27/08/2011 02:30
cenk sasmaztin
(@cenksasmaztin)
Üye

Selmalar

aşağıdaki konfigleri yaparsan istemiş olduğun yapıyı çalıştırabilirsin.

CISCO

----------------------------------------------------------------------------------------------------------

Current configuration : 1189 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
ip dhcp pool office1
 network 10.0.20.0 255.255.255.0
 default-router 10.0.20.1
 dns-server 8.8.8.8
ip dhcp pool office2
 network 10.0.30.0 255.255.255.0
 default-router 10.0.30.1
 dns-server 8.8.8.8
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description insite
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 description server
 encapsulation dot1Q 10
 ip address 10.0.10.1 255.255.255.0
!
interface FastEthernet0/0.2
 description office1
 encapsulation dot1Q 20
 ip address 10.0.20.1 255.255.255.0
!
interface FastEthernet0/0.3
 description office2
 encapsulation dot1Q 30
 ip address 10.0.30.1 255.255.255.0
!
interface FastEthernet1/0
 description outsite
 ip address 212.122.122.122 255.255.255.252
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
!
interface Serial3/0
 no ip address
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end

HP SW

------------------------------------------------------------------------------------------------------------

vlan 10
   name "server"
   untagged 1-5
   tagged 25
   no ip address
   exit
vlan 20
   name "office1"
   untagged 6-15
   tagged 25
   no ip address
   exit
vlan 30
   name "office2"
   untagged 16-19
   tagged 25
   no ip address
   exit

CevapAlıntı
Gönderildi : 27/08/2011 14:39
Muhammet ŞİMŞEK
(@MuhammetSiMSEK)
Üye

Aşağıdaki şekilde girdim, fakat IP almıyor kullanıcılar.


Birde yukarıda tek real IP demişim, geri alıyorum kusura bakmayın, DHCP ile bağlananlar icin vlan altındakileri tek bir IP ' den çıkaracağım.


Web sunucularımız dolayısıyla, manuel real IP veriyoruz ve internete bağlı olacak olacaklar.


 


Current configuration : 1667 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service sequence-numbers
!
hostname xnetwork
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool PLAZA
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.1
   dns-server 195.175.39.39
!
!
ip name-server 195.175.39.39
!
!
!
policy-map SDM-QoS-Policy-1
!
!
!
interface GigabitEthernet0/0
 description backbone giden uc
 ip address 212.156.86.111 255.255.255.252
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
 !
interface GigabitEthernet0/1
 description ic network
 ip address 95.0.41.17 255.255.255.240
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
!
interface Virtual-TokenRing1
 no ip address
 ring-speed 16
!
ip default-gateway 212.156.86.110
ip classless
ip route 0.0.0.0 0.0.0.0 212.156.86.111
!
ip http server
ip http authentication local
ip nat inside source list 1 interface GigabitEthernet0/1 overload
!
control-plane
!
!
!
scheduler allocate 20000 1000
!
end

CevapAlıntı
Konu başlatıcı Gönderildi : 27/08/2011 19:05
cenk sasmaztin
(@cenksasmaztin)
Üye

yukarıda istediğiniz ve benim size göndermiş olduğum konfigrasyon ile yapmış olduğunuz konfigrasyonun hiç bir alakası yok.

tam olarak ne yapmaya çalıştığınızı anlatırsanız daha iyi yardımcı olabilirim.

CevapAlıntı
Gönderildi : 27/08/2011 19:43
Muhammet ŞİMŞEK
(@MuhammetSiMSEK)
Üye

Hocam şuanda DHCP ile makinelere aldırdım IP problem yok suanda.
Şimdi kalan tek problem, vlanları bir nat yapıp, internete tek ip den çıkarmak.

Yeni conf ;


 Current configuration : 1829 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service sequence-numbers
!
hostname xnetwork
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool PLAZA
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.1
   dns-server 195.175.39.39
!
ip dhcp pool Plaza
!
!
ip name-server 195.175.39.39
!
!
!
policy-map SDM-QoS-Policy-1
!
!
!
interface GigabitEthernet0/0
 description backbone giden dis bacak
 ip address 212.156.86.130 255.255.255.252
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
 service-policy output SDM-QoS-Policy-1
!
interface GigabitEthernet0/1
 description TrunkPort
 ip address 95.0.44.18 255.255.255.240
 ip access-group 190 in
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
!
interface GigabitEthernet0/1.10
 description PLAZA
 encapsulation dot1Q 10
 ip address 192.168.2.1 255.255.255.0
 no snmp trap link-status
!
interface Virtual-TokenRing1
 no ip address
 ring-speed 16
!
ip default-gateway 212.156.86.130
ip classless
ip route 0.0.0.0 0.0.0.0 212.156.86.131
!
ip http server
ip http authentication local
ip nat inside source list 1 interface GigabitEthernet0/1 overload
!
!
control-plane
!
!
!
scheduler allocate 20000 1000
!
end

CevapAlıntı
Konu başlatıcı Gönderildi : 27/08/2011 19:49
cenk sasmaztin
(@cenksasmaztin)
Üye

sanırım vlanların şu an  212.156.86.130  ipsinden internet e çıkıyor başka bir ip den mi çıkmalarını istiyorsun

CevapAlıntı
Gönderildi : 27/08/2011 19:55
Muhammet ŞİMŞEK
(@MuhammetSiMSEK)
Üye

Şuanda Vlanlarım hiç bir şekilde internete çıkmıyor. Sadece Ip Dhcp den alıyorlar.
Ben 95.0.49.18 ya da 19 olan bir route IP ile çıkarmak istiyorum.

Tam olarak yapmak istediğim, subinterface e bir nat tanımlayıp interface den xx.xx Ip si olarak internete çıkarmak, yanlış bir topoloji varsa düzeltin lütfen.


Web serverler ve burada kullanıcılar var

Kullanıcılara nat yapıp router üzerinden çıkarmak aynı zamanda web serverlereda direk Real Ip verip internetle buluşturmak istiyorum.
Real Ip verdiğim (95.0.49.xx) olan her bilgisayar dışardan ve içerden internete çıkabiliyor, ben natların da çıkmasını istiyorum.

Uzun oldu ama 🙁

CevapAlıntı
Konu başlatıcı Gönderildi : 27/08/2011 20:04
cenk sasmaztin
(@cenksasmaztin)
Üye

nat var zaten ama nat için olan acl i göremedim

şu acl i ekleyip denermisin

access-list 1 permit 192.168.0.0 0.0.255.255

CevapAlıntı
Gönderildi : 27/08/2011 20:17
cenk sasmaztin
(@cenksasmaztin)
Üye

birde bunu

bunların ikisini yazınca vlan 10 çıkıyormu bir bak

ip nat inside source list 1 interface GigabitEthernet0/0 overload

CevapAlıntı
Gönderildi : 27/08/2011 20:24
cenk sasmaztin
(@cenksasmaztin)
Üye

interface GigabitEthernet0/0
ip nat outsite

komutuda eklemen lazım

konfigin çok eksik baktıkça eksik çıkıyor 🙂

CevapAlıntı
Gönderildi : 27/08/2011 20:28
cenk sasmaztin
(@cenksasmaztin)
Üye

istersen hepsini silip beraber yeniden yapalım adım adım

CevapAlıntı
Gönderildi : 27/08/2011 20:31
Muhammet ŞİMŞEK
(@MuhammetSiMSEK)
Üye

Tskler vaktinizi aldım.
Harika oldu 🙂 Çalışıyor, aslında ne yapmak istenildiğini biliyorum ama 🙂 Uygulamada bir sürü şey deniyorum bir öncekiyle karışıyor...

Tekrar tşkler.

Şimdi ACL yazarken ben layer3 e mi yazsam, yoksa routerdaki ic bacak interface mi yazsam ?


Hangisi daha doğru olur ?

CevapAlıntı
Konu başlatıcı Gönderildi : 27/08/2011 20:35
cenk sasmaztin
(@cenksasmaztin)
Üye

acl i ne için yazacağınıza göre değişen bir durum bu .

source e en yakın interface de kesmelisin yada izin vermelisin.

acl yazarken cihazın içinde oturduğunu düşün hep bu şekilde hangi interface e in yada out kavramı hakkında doğru karar vermiş olursun

CevapAlıntı
Gönderildi : 27/08/2011 20:47
Muhammet ŞİMŞEK
(@MuhammetSiMSEK)
Üye

Hocam tekrar merhaba;

Aşağıdaki konfige göre, ben 95.0.48.18 olandan internete çıkmasını istiyorum, oysa bu konfige göre, 212. olan REAL ıp den çıkıyor.
95 olan da Real Route IP.
Yani şöyle bir şey olması lazım.
192.168.2.0 dan gelenleri 95.0.18. nat yapmam lazım değil mi ?

yani şöyle,

ip nat pool recep 95.0.45.18 95.0.45.18 netmask 255.255.255.240

gibi bir tanım ama tam nanım nedir acaba ?

 

 

 

Current configuration : 1900 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service sequence-numbers
!
hostname xnetwork
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool PLAZA
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.1
   dns-server 195.175.39.39
!
!
ip name-server 195.175.39.39
!
!
!
policy-map SDM-QoS-Policy-1
!
!
!
interface GigabitEthernet0/0
 description backbone gelen dis bacak
 ip address 212.156.85.150 255.255.255.252
 ip nat outside
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
 service-policy output SDM-QoS-Policy-1
!
interface GigabitEthernet0/1
 description TrunkPort
 ip address 95.0.46.17 255.255.255.240
 ip access-group 190 in
 ip nat outside
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
!
interface GigabitEthernet0/1.10
 description PLAZA
 encapsulation dot1Q 10
 ip address 192.168.2.1 255.255.255.0
 ip nat inside
 no snmp trap link-status
!
interface Virtual-TokenRing1
 no ip address
 ring-speed 16
!
ip default-gateway 212.156.85.150
ip classless
ip route 0.0.0.0 0.0.0.0 212.156.85.149
!
ip http server
ip http authentication local
ip nat inside source list 1 interface GigabitEthernet0/0 overload
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 212.156.85.148 0.0.0.3
access-list 1 permit 192.168.0.0 0.0.255.255
!
control-plane
!
!
!
scheduler allocate 20000 1000
!
end

 

CevapAlıntı
Konu başlatıcı Gönderildi : 28/08/2011 14:08
Paylaş: