Bildirimler
Hepsini Temizle

587 mail port sorunu (2008 server+plesk)  

  RSS
Mustafa Güney
(@MustafaGuney)
Üye

Merhabalar,

Yeni kiraladığımız sunucu için mail port ayarını 587 olarak ayarlamak istiyorum fakat ne kadar yöntem bulduysam deniyorum olmuyor. yardımcı olursanız sevinirim.. 

Kullanılan sistem;

Windows 2008 Server  - Plesk Panel 10.4  - Mail Enable Standart Edition version 6.5 

Öncelikle denediğim yöntemleri anlatiyim ; 

-- Windows Güvenlik duvarından inbound rules bölümünden 587 numaralı portu tcp olarak açık hale getirdim.  

-- Mail Enable açarak smtp connector bölümünden properties bölümündeki inbound tabından 587 alternatif port olarak belirledim. 

internette araştırdığım kadarıyla hep bu yöntemi söylemişler ama çalışmadı bende..   mail giden port olarak 587 yi seçtiğimde ve mail gönder dediğimde şöyle bir mesaj alıyorum . (thunderbird) 

bu arada port olarak 25 i kullandığımda hiç bir sorun yaşamıyorum gönderim yapılıyor... fakat başka bir host firmasından kendi sunucuma geçiş yapmak istediğimden ve diğer sunucudaki yaklaşık 50 site ve aktif kullanılan onlarca mail..  webmail.domainadi.com ve 587 portu kullandığından siteleri ve mailleri aktarırken bu bilgilerle kullanmaya devam etmemiz gerekiyor.. 

 

Bir forumda da IIS bölümünden ayar yapmamızı söylemişler aşağıdaki bölümden ayarı yaptım ondada aynı sonuç oldu aynı mesajı geri dönderiyor. 

 

Başka bir yerdede şöyle bir çözüm söylemişler.. Pleskin içinde Mail Server Ayarlarında Switch On Message Submission seçeneğini işaretleyin diye.. fakat bende o bölüm not supported yazıyor.. işaretleyip kaydettiğimdede etkin olmuyor.. .. 

 

 

Nmap ile kontrol ettiğimde portlar için şöyle yazıyor ;

25/tcp open smtp MailEnable smptd 6.5--
| smtp-commands: domainadi.net [111.111.111.111], this server offers 4 extensions, AUTH LOGIN, SIZE 5120000, HELP, AUTH=LOGIN,
|_ 211 Help:->Supported Commands: HELO,EHLO,QUIT,HELP,RCPT,MAIL,DATA,RSET,NOOP

587/tcp open pop3 MailEnable POP3 Server
|_pop3-capabilities: USER UIDL TOP
|_smtp-commands: SMTP: EHLO -ERR Unknown command

 

Bunların dışında birde şöyle bir olay oldu.. Bir arkadaşıma bu konu hakkında danıştığımda sunucudan  "mail.domainadi.com"   olarak bir mail atıp sunucuyu tekrar webmail.domainadi.com ve 587 portla aldı daha sonradan gönderim sağladık birsüre.. geçenlerde sunucuya güncelleme gelmiş onu yaptıktan sonra tekrar ayarlar gitti sanırım.. ama arkadaşın tam ne ayarı yaptığını hatırlamıyorum ve o zaman bana bu windows 2008 ile ilgili bi bug sanırım ilk maili gönderirken bu ayarlarla gönderip aktif etmek gerekiyor gibi birşey demişti...   deidğim gibi güncelleme yapınca oda uçtu sanırım ve arkadaşta yurtdışına çıktığı için erişemiyorum.. 

başıma gelenler bunlar arkadaşlar kaç gündür gezmediğim denemediğim yer kalmadı fakat beceremedim, sunuculardan çok anlamıyorum fakat bir yerden başlamak lazım diye kendi sunucuma geçmek istedim fakat iyimi ettim kötümü bilemedim.. yardımlarınızı bekliyorum teşekkürler iyi çalışmalar.. 

 

Alıntı
Gönderildi : 07/10/2015 17:31
Okan Özbey
(@okanozbey)
Saygın Üye Forum Yöneticisi

Merhaba,

Öncelikle şunu belirtmek istiyorum. Bir portu sadece bir servis dinleyebilir. Yani hem IIS üzerindeki SMTP'yi aktif ederseniz hem mailenable smtp aktif ederseniz çakışma yaşarsınız ve 587 üzerinden atamazsınız. 

Windows 2008 üzerinde böyle bir bug bulunmamaktadır.  

Öncelikle yapmanız gereken işlemleri sıralarsak ; 

MailEnable.com sitesi üzerinden mailenable 9 versiyonunun standart edition indirin.  MailEnable 6x standart kullanıyorsunuz bu versiyonda IMAP desteği bulunmuyor. Mailenable 8x standart ile birlikte imap özelliğini standart edition'a ekledi. Ayrıca 6x versiyonu oldukça eski bir versiyon.

Mailenable 9 standart indirdikten sonra update seçeneğini seçerek kurun. Ayarları override olarak yüklemeyin 2. seçeneği kullanın. 

Kurulum tamamlandıktan sonra SMTP port ayarını ilk resimdeki gibi ayarlayın ve 2008 firewall üzerinden 587 portuna izin verin. Eğer çalışmazsa sunucuyu aldığınız yer ile irtibata geçin bir UTM veya fiziksel firewall olabilir sunucunun önünde bu cihaz üzerindende 587 portunu açmaları gerekiyor. 

Ayrıca telnet yaparakta 587 portunun çalışıp çalışmadığını öğrenebilirsiniz. 

Kolay gelsin.

www.okanozbey.com

CevapAlıntı
Gönderildi : 07/10/2015 18:12
Mustafa Güney
(@MustafaGuney)
Üye

Merhabalar, 

İlginiz için teşekkürler. Bahsettiklerinizi yapıp sonucu bildiririm. Bahsettiğim arkadaş sunucuyu güncellememem konusunda bana uyarıda bulundu bana mantıklı gibi gelmedi.. "Zaten güncellediklerine bak hep gereksiz şeyler" gibi birşey söyledi birde güncellersen ayarlarının kaybolma ihtimali var dedi.. Bu konuda ne diyorsunuz ? 

 

Teşekkürler. 

CevapAlıntı
Gönderildi : 07/10/2015 19:53
Okan Özbey
(@okanozbey)
Saygın Üye Forum Yöneticisi

🙂 Sizce güncellemeler gereksiz oysaydı özellikle critical ve security güncellemeleri microsoft neden oturup bu güncellemelere zaman ayırsın ki ? 

www.okanozbey.com

CevapAlıntı
Gönderildi : 07/10/2015 20:00
Mustafa Güney
(@MustafaGuney)
Üye

Merhabalar,

Bahsettiğiniz gibi mail enable 9. sürümü indirip kurdum fakat sondaki seçeneği yanlış yaptım.. web server seçmemi söyledi orada default site yazıyordu o bölümü ellemedim... menüyü açtığımızda plesk ve diğer seçeneklerde vardı... şuan mevcut sitelerin mailleri durdu.. webmail.domainadi.com olarakta erişemiyorum ?  25. portta çalışmıyor .. 

 

şöyle bir ekrandı .. 

neden kaynaklanıyodur ? 

 

Teşekkürler

CevapAlıntı
Gönderildi : 07/10/2015 20:12
Okan Özbey
(@okanozbey)
Saygın Üye Forum Yöneticisi

Default seçili olarak bıraktıysanız Default.com altına binding etmiştir webmaili. MailEnable açarak webmail bölümünden ayarlarınızı yapabilirsiniz. Olmadı tekrardan kurulumu çalıştırın ve webmail ile webadmin seçeneklerinde işareti kaldırın.  Direkt olarak site şeklinde ekler böylece. 

www.okanozbey.com

CevapAlıntı
Gönderildi : 07/10/2015 20:15
Mustafa Güney
(@MustafaGuney)
Üye

Tekrar kurulum yaptım fakat birşey değişmedi sitelerede erişim sağlayamıyorum. pleskten bir ayar yapmamız gerekiyormu ? 

 

ip ye erişim sağlanıyor fakat hiç bir domaine erişim sağlanamıyor.. pleskte herşey normal görünüyor... başka bi değişiklik yapmadan bu nasıl oldu şimdi.. onu anlamadım..  

 

CevapAlıntı
Gönderildi : 07/10/2015 20:39
Okan Özbey
(@okanozbey)
Saygın Üye Forum Yöneticisi

IIS üzerinden kontrol edin binding çakışmasından durmuş siteler var mı ? Malesef bu şekilde pek fazla bir yorum yapma imkanım yok. örnek bir domain belirtirip ekran goruntusu eklermisiniz o domaine ait.

www.okanozbey.com

CevapAlıntı
Gönderildi : 07/10/2015 23:25
Mustafa Güney
(@MustafaGuney)
Üye

Tekrar selamlar Ziya bey, 

Öncelikle ilgilendiğiniz için tekrar teşekkür ederim, domain erişememe sorunum belli bir süre sonra düzeldi sanırım geçici bir mx veya ns kayıtları ile ilgili bir sorundu anlayamadım ama şuan herşey normal eski haline döndü.. Fakat ilk başta yazdığım hata aynen devam ediyor.. mail enable 9 kurulu ve dediğiniz gibi aşağıdaki ayarı yaptım... IIS te ayarladığım o bölümleride tekrar eskisi gibi 25 olarak ayarladım yeniden başlattım sunucuyu fakat sonuç aynı....  aklınıza başka bir çözüm geliyor mu veya başka yardımcı olacak arkadaşlar varmı ? .. 

anlayamadım 587 portu ayarlamak bu kadar karışık bir işlemmidir yoksa benim şansıma mı oldu.. korkmaya başladım iyice bu sunucu işinden..

CevapAlıntı
Gönderildi : 08/10/2015 00:04
Okan Özbey
(@okanozbey)
Saygın Üye Forum Yöneticisi

587 portunu girdikten sonra sunucuyu yeniden başlatmanıza gerek yok, mailenable tarafında son gönderdiğiniz resmi ayarladıktan sonra smtp servisini yeniden başlatmanız yeterli. 

( Yalnız belirtmek istiyorum sunucu üzerinde 587 portunu kullanan başka bir servis olmadığından emin olunuz ) 

Bu işlemleri tamamladıktan sonra ;

netsh advfirewall firewall add rule name="587" protocol=TCP localport=587 dir=in action=allow enable=yes remoteip=any localip=any profile=domain,public,private,any

Yukarıdaki komutu çalıştırın ve sorun devam ediyorsa sunucuyu barındırdığınız yer ile irtibata geçin networktaki varsa başka firewalllar üzerinden port açılması gerekebilir.  

www.okanozbey.com

CevapAlıntı
Gönderildi : 08/10/2015 12:00
Mustafa Güney
(@MustafaGuney)
Üye

Merhabalar,

Ziya bey, servisleri yeniden başlatıp verdiğiniz komut satırını çalıştırdıktan sonra 587 porttan geri döndürülen mesaj düzeldi.. Şuan port çalışıyor mail gönderimide yapabiliyorum, sorun çözüldü. Yardımlarınız için çok teşekkür ederim. 

 

CevapAlıntı
Gönderildi : 08/10/2015 15:52
Mustafa Güney
(@MustafaGuney)
Üye

Çok ilginç ya... server ı yeniden başlatınca yine gitti. 587 port 🙁  şaka gibi ya. 

CevapAlıntı
Gönderildi : 08/10/2015 18:02
Okan Özbey
(@okanozbey)
Saygın Üye Forum Yöneticisi

Daha önce söylediğim gibi 587'yi kullanan başka bir servis vardır, Windows SMTP kaldırın, kurduğunuz başka smtp varsa onları kaldırın. 

www.okanozbey.com

CevapAlıntı
Gönderildi : 08/10/2015 20:01
Paylaş: