Exchange 2016 Kurul...
 
Bildirimler
Hepsini Temizle

[Çözüldü] Exchange 2016 Kurulum sırasında hata  

  RSS
Tevfik Ceydeliler
(@tevfikceydeliler)
Üye

Merhaba, Exchange 2016 kurarken hata aldım:

[08/20/2019 15:20:29.0461] [2] [ERROR] Couldn't find recipient "root.grp/Users/SystemMailbox{bb558c35-97f1-4cb9-8ff7-d53741dc928c}". Reason: root.grp/Users/SystemMailbox{bb558c35-97f1-4cb9-8ff7-d53741dc928c} isn't a mailbox user.
[08/20/2019 15:20:29.0461] [2] Ending processing Get-OfflineAddressBook
[08/20/2019 15:20:29.0461] [2] Ending processing Set-OfflineAddressBook
[08/20/2019 15:20:29.0461] [1] The following 1 error(s) occurred during task execution:
[08/20/2019 15:20:29.0461] [1] 0. ErrorRecord: Couldn't find recipient "root.grp/Users/SystemMailbox{bb558c35-97f1-4cb9-8ff7-d53741dc928c}". Reason: root.grp/Users/SystemMailbox{bb558c35-97f1-4cb9-8ff7-d53741dc928c} isn't a mailbox user.
[08/20/2019 15:20:29.0461] [1] 0. ErrorRecord: Microsoft.Exchange.Configuration.Tasks.ManagementObjectNotFoundException: Couldn't find recipient "root.grp/Users/SystemMailbox{bb558c35-97f1-4cb9-8ff7-d53741dc928c}". Reason: root.grp/Users/SystemMailbox{bb558c35-97f1-4cb9-8ff7-d53741dc928c} isn't a mailbox user.
at Microsoft.Exchange.Configuration.Tasks.DataAccessTask`1.GetDataObject[TObject](IIdentityParameter id, IConfigDataProvider session, ObjectId rootID, OptionalIdentityData optionalData, Func`2 notFoundError, Func`2 multipleFoundError, ExchangeErrorCategory errorCategory)
at Microsoft.Exchange.Management.SystemConfigurationTasks.OfflineAddressBookTaskUtility.ValidateGeneratingMailbox(IConfigDataProvider session, MailboxIdParameter generatingMailboxId, CategorizedGetDataObjectDelegate getAdUser, OfflineAddressBook target, TaskWarningLoggingDelegate writeWarning, TaskErrorLoggingDelegate writeError)
at Microsoft.Exchange.Management.SystemConfigurationTasks.SetOfflineAddressBookInternal.StampChangesOn(IConfigurable dataObject)
at Microsoft.Exchange.Configuration.Tasks.SetObjectTaskBase`2.PrepareDataObject()
at Microsoft.Exchange.Configuration.Tasks.SetTaskBase`1.InternalValidate()
at Microsoft.Exchange.Configuration.Tasks.SetSystemConfigurationObjectTask`3.InternalValidate()
at Microsoft.Exchange.Management.SystemConfigurationTasks.SetOfflineAddressBookInternal.InternalValidate()
at Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__91_1()
at Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)
[08/20/2019 15:20:29.0461] [1] [ERROR] The following error was generated when "$error.Clear();
if ($RoleIsDatacenter -ne $true -and $RoleIsDatacenterDedicated -ne $true)
{
if (Test-ExchangeServersWriteAccess -DomainController $RoleDomainController -ErrorAction SilentlyContinue)
{
$sysMbx = $null;
$name = "SystemMailbox{bb558c35-97f1-4cb9-8ff7-d53741dc928c}";
$dispName = "Microsoft Exchange";
Write-ExchangeSetupLog -Info ("Retrieving mailboxes with Name=$name.");
$mbxs = @(Get-Mailbox -Arbitration -Filter {name -eq $name} -IgnoreDefaultScope -ResultSize 1 );
if ($mbxs.Length -eq 0)
{
Write-ExchangeSetupLog -Info ("Retrieving mailbox databases on Server=$RoleFqdnOrName.");
$dbs = @(Get-MailboxDatabase -Server:$RoleFqdnOrName -DomainController $RoleDomainController);
if ($dbs.Length -ne 0)
{
Write-ExchangeSetupLog -Info ("Retrieving users with Name=$name.");
$arbUsers = @(Get-User -Filter {name -eq $name} -IgnoreDefaultScope -ResultSize 1);
if ($arbUsers.Length -ne 0)
{
Write-ExchangeSetupLog -Info ("Enabling mailbox $name.");
$sysMbx = Enable-Mailbox -Arbitration -Identity $arbUsers[0] -DisplayName $dispName -database $dbs[0].Identity;
}
}
}
else
{
if ($mbxs[0].DisplayName -ne $dispName )
{
Write-ExchangeSetupLog -Info ("Setting DisplayName=$dispName.");
Set-Mailbox -Arbitration -Identity $mbxs[0] -DisplayName $dispName -Force;
}
$sysMbx = $mbxs[0];
}

# Set the Organization Capabilities needed for this mailbox
if ($sysMbx -ne $null)
{
# We need 1 GB for uploading large OAB files to the organization mailbox
Write-ExchangeSetupLog -Info ("Setting mailbox properties.");
set-mailbox -Arbitration -identity $sysMbx -UMGrammar:$true -OABGen:$true -GMGen:$true -ClientExtensions:$true -MailRouting:$true -MessageTracking:$true -PstProvider:$true -MaxSendSize 1GB -Force;

Write-ExchangeSetupLog -Info ("Configuring offline address book(s) for this mailbox");
Get-OfflineAddressBook | where {$_.ExchangeVersion.CompareTo([Microsoft.Exchange.Data.ExchangeObjectVersion]::Exchange2012) -ge 0 -and $_.GeneratingMailbox -eq $null} | Set-OfflineAddressBook -GeneratingMailbox $sysMbx.Identity;
}
else
{
Write-ExchangeSetupLog -Info ("Cannot find arbitration mailbox with name=$name.");
}
}
else
{
Write-ExchangeSetupLog -Info "Skipping creating E15 System Mailbox because of insufficient permission."
}
}
" was run: "Microsoft.Exchange.Configuration.Tasks.ManagementObjectNotFoundException: Couldn't find recipient "root.grp/Users/SystemMailbox{bb558c35-97f1-4cb9-8ff7-d53741dc928c}". Reason: root.grp/Users/SystemMailbox{bb558c35-97f1-4cb9-8ff7-d53741dc928c} isn't a mailbox user.

Hatanın neyden dolayı kaynaklandığını anlayamadım.

Sorun ne olabilir?

Ayrıca, Instal işlemine baştan başlamak için ne yapmalıyım?

Bu konu 12 ay önce Tevfik Ceydeliler tarafından düzenlendi
Alıntı
Gönderildi : 21/08/2019 12:51
Konu Etiketleri
Engin Kosova
(@enginkosova)
Üye Forum Yöneticisi

Merhaba,

Test ortamınızda mı işlem yapıyorsunuz?

****************************************************************
Probleminiz çözüldüğünde sonucu burada paylaşırsanız,
sizin ile aynı problemi yaşayanlar için yardım etmiş olursunuz.
Eğer sorununuz çözüldü ise "çözüldü" olarak işaretlerseniz
diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 22/08/2019 12:29
Hakan Uzuner
(@hakanuzuner)
Kıdemli Üye Yönetici

Uygun olmayan bir soru tipi, 18 yıldır Exchange Server ile ilgilenince ne yapmaya çalıştığınızı anlıyorum ama bu şekilde soru sorarsanız case dahi açsanız insana bir sorarlar, ne yapmaya çalışıyorsunuz? Örneğin child olan ortamda Exchange kurmaya çalışıyorsunuz, bu durumda tüm domainler için domainprep yaptınız mı?

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 24/08/2019 14:55
Hakan Uzuner
(@hakanuzuner)
Kıdemli Üye Yönetici

Ayrıca cevap burada var

https://blogs.technet.microsoft.com/mahuynh/2017/06/16/setup-of-first-exchange-2016-server-fails-in-a-child-domain-due-to-ad-replication/

Danışman - ITSTACK Bilgi Sistemleri
****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 24/08/2019 15:05
Paylaş: