Anasayfa » Forum

exchange server 201...
 
Bildirimler

exchange server 2013 hata  

  RSS
ibrahim bas
(@ibrahimbas)
Üye

Arkadaşlar exchange server 2013 kurulumu yapacam çözümpark makaesinden yola çıkarak powershel i yönetici olarak çalıştırdım ilk iki komut sıkıntısız kullandım ancak aşağıdaki 3. komutu kullanınca böyle bi hata aldım acaba sıkıntı nedi

 

PS C:\Users\administrator.BASPA> setup /PrepareAD /OrganizationName:"Organizasyon Adı" /IacceptExchangeServerLicenceTerms
setup : The term 'setup' is not recognized as the name of a cmdlet, function, script file, or operable program. Check
the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ setup /PrepareAD /OrganizationName:"Organizasyon Adı" /IacceptExchangeServerLicence ...
+ ~~~~~
    + CategoryInfo          : ObjectNotFound: (setup:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

bu şekilde ata alma sebebi nedir

 

ayrıca kurulum sonrası aldığım hata aşağıda ekran resmini ekledim

 

https://www.flickr.com/gp/152289935@N07/wT0F3m

Alıntı
Gönderildi : 21/02/2017 05:08
Recep YÜKSEL
(@recepyuksel)
Kıdemli Üye Forum Yöneticisi

Merhaba,

Unified Cominication yüklü değil sanki resimdeki hata onu söylüyor önce bunu yüklemeniz lazım diyor.

Scriptte aldığınız hatanın sebebi 2 şey olabilir, organizasyon adı doğru degildir yada komutu copy past ile kullanıyorsanız tırnak işaretleri sorun çıkartıyordur, komutu yapıştırdıktan sonra çift tırnak işretini silip yeniden yazarsanız siyah ekranda komut çalışacaktır büyük ihtimalle. 

Saygılarımla.

 

************************************************************
Probleminiz çözüldüğünde sonucu burada paylaşırsanız,
sizin ile aynı problemi yaşayanlar için yardım etmiş olursunuz.
Eğer sorununuz çözüldü ise "çözüldü" olarak işaretlerseniz
diğer üyeler için çok büyük kolaylık sağlayacaktır.
************************************************************

CevapAlıntı
Gönderildi : 21/02/2017 12:40
Bugra KESKIN
(@bugrakeskin)
Saygın Üye

[quote user="ibrahim bas"]

Arkadaşlar exchange server 2013 kurulumu yapacam çözümpark makaesinden yola çıkarak powershel i yönetici olarak çalıştırdım ilk iki komut sıkıntısız kullandım ancak aşağıdaki 3. komutu kullanınca böyle bi hata aldım acaba sıkıntı nedi

 

PS C:\Users\administrator.BASPA> setup /PrepareAD /OrganizationName:"Organizasyon Adı" /IacceptExchangeServerLicenceTerms
setup : The term 'setup' is not recognized as the name of a cmdlet, function, script file, or operable program. Check
the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ setup /PrepareAD /OrganizationName:"Organizasyon Adı" /IacceptExchangeServerLicence ...
+ ~~~~~
    + CategoryInfo          : ObjectNotFound: (setup:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

bu şekilde ata alma sebebi nedir

 

ayrıca kurulum sonrası aldığım hata aşağıda ekran resmini ekledim

 

https://www.flickr.com/gp/152289935@N07/wT0F3m

[/quote]

 

en başta ki setup a .exe yazarsan yani setup.exe /PrepareAD /OrganizationName:"Organizasyon Adı" /IacceptExchangeServerLicenceTerms çalışacaktır

Exchange kuran birisinin bunu anlaması lazım, komut yanlış diyor 🙂

CevapAlıntı
Gönderildi : 21/02/2017 12:45
ibrahim bas
(@ibrahimbas)
Üye

iyi günler ben komutu elle yazdım olmadı daha sonra setup.exe ile yazdım yine olmadı bu hata acaba exchange server yüklemesini yaptıktan sonramı bu komutu girmem gerek

CevapAlıntı
Gönderildi : 22/02/2017 12:28
Devrimer Sercan Duman
(@DevrimerSercanDuman)
Üye

[quote user="ibrahim bas"]

Arkadaşlar exchange server 2013 kurulumu yapacam çözümpark makaesinden yola çıkarak powershel i yönetici olarak çalıştırdım ilk iki komut sıkıntısız kullandım ancak aşağıdaki 3. komutu kullanınca böyle bi hata aldım acaba sıkıntı nedi

 

PS C:\Users\administrator.BASPA> setup /PrepareAD /OrganizationName:"Organizasyon Adı" /IacceptExchangeServerLicenceTerms
setup : The term 'setup' is not recognized as the name of a cmdlet, function, script file, or operable program. Check
the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ setup /PrepareAD /OrganizationName:"Organizasyon Adı" /IacceptExchangeServerLicence ...
+ ~~~~~
    + CategoryInfo          : ObjectNotFound: (setup:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

bu şekilde ata alma sebebi nedir

 

ayrıca kurulum sonrası aldığım hata aşağıda ekran resmini ekledim

 

https://www.flickr.com/gp/152289935@N07/wT0F3m

[/quote]

Merhaba komutunu kurulumun bulundugu klasorde calistirmayi deneyebilirsin. Ve en onemlisi exchange kuracagim server a doamin administrator hesabinla giris yapmayi sakin unutma.

Ve ayrica resimdeki hata icinde  https://www.microsoft.com/en-us/download/details.aspx?id=34992  bu adresteki dosyayi indirim exchange kurulumundan once kurup serveri yeniden baslatmani ve ardindan exchange kurulumuna gecmeni tavsiye ederim.

 

komut da hatali soyle olmali:

Setup.exe /PrepareAD /OrganizationName:"<organization name>" /IAcceptExchangeServerLicenseTerms

iyi gunler.
CevapAlıntı
Gönderildi : 22/02/2017 13:53
ibrahim bas
(@ibrahimbas)
Üye

iyi günler neyi denediysem olumuyor bu konuda yaptığım yanlış nedir acaba öncelikle biraz yapı hakkında bilgi vereyim.

 

Fiziksel server üzerine kurulu sanal windoıws server 2012 r2 üzerinde exchange server 2013 kurmaya çalışıyorum makalelerde bulunan komutların hepsini makalede olduğu gibi gerek elle gerek ise yazarak yaptım. Hiç hata almıyorum ve gereken dosyaları yükledim. ( Microsoft Unified Communations Manager API 4.0 Core Runtime 64 bit Microsoft office 2010 filterpack ve SP1) bunalrıda kuruyorum buna rağmen aşağıdaki kodu

setup /PrepareAD /OrganizationName: "Organizasyon adı" /IacceptExchangeServerLicenseTerms  

setup.exe /PrepareAD /OrganizationName: "Organizasyon adı" /IacceptExchangeServerLicenseTerms

yukardaki iki kodu yazınca aşağıda hatayı alıyorum

 

setup : The term 'setup' is not recognized as the name of a cmdlet, function, script file, or operable program. Check
the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ setup /PrepareAD /OrganizationName: "Organizasyon adı" /IacceptExchangeServerLic ...
+ ~~~~~
+ CategoryInfo : ObjectNotFound: (setup:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException

 

kurulum yapıyorum kurulum sonunda da bu hatayı alıyorum bağlantılı oldukları belli ancak ben kodu ayzarken neden hata alıyorum yaptığım eksiklik nedir acaba

 

 

Error:
Active Directory must be prepared with 'Setup /PrepareAD' before domains can be prepared for Exchange 2010.
For more information, visit: http://technet.microsoft.com/library(EXCHG.150)/ms.exch.setupreadiness.DomainPrepWithoutADUpdate.aspx

CevapAlıntı
Gönderildi : 27/02/2017 14:37
ibrahim bas
(@ibrahimbas)
Üye

yardımcı olacak kimse yok mu acaba

CevapAlıntı
Gönderildi : 28/02/2017 13:39
Sezgin Yılan
(@sezginyilan)
Üye

[quote user="ibrahim bas"]

iyi günler neyi denediysem olumuyor bu konuda yaptığım yanlış nedir acaba öncelikle biraz yapı hakkında bilgi vereyim.

 

Fiziksel server üzerine kurulu sanal windoıws server 2012 r2 üzerinde exchange server 2013 kurmaya çalışıyorum makalelerde bulunan komutların hepsini makalede olduğu gibi gerek elle gerek ise yazarak yaptım. Hiç hata almıyorum ve gereken dosyaları yükledim. ( Microsoft Unified Communations Manager API 4.0 Core Runtime 64 bit Microsoft office 2010 filterpack ve SP1) bunalrıda kuruyorum buna rağmen aşağıdaki kodu

setup /PrepareAD /OrganizationName: "Organizasyon adı" /IacceptExchangeServerLicenseTerms  

setup.exe /PrepareAD /OrganizationName: "Organizasyon adı" /IacceptExchangeServerLicenseTerms

yukardaki iki kodu yazınca aşağıda hatayı alıyorum

 

setup : The term 'setup' is not recognized as the name of a cmdlet, function, script file, or operable program. Check
the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ setup /PrepareAD /OrganizationName: "Organizasyon adı" /IacceptExchangeServerLic ...
+ ~~~~~
+ CategoryInfo : ObjectNotFound: (setup:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException

 

kurulum yapıyorum kurulum sonunda da bu hatayı alıyorum bağlantılı oldukları belli ancak ben kodu ayzarken neden hata alıyorum yaptığım eksiklik nedir acaba

 

 

Error:
Active Directory must be prepared with 'Setup /PrepareAD' before domains can be prepared for Exchange 2010.
For more information, visit: http://technet.microsoft.com/library(EXCHG.150)/ms.exch.setupreadiness.DomainPrepWithoutADUpdate.aspx

[/quote]

 

 

[quote user="ibrahim bas"]

Arkadaşlar exchange server 2013 kurulumu yapacam çözümpark makaesinden yola çıkarak powershel i yönetici olarak çalıştırdım ilk iki komut sıkıntısız kullandım ancak aşağıdaki 3. komutu kullanınca böyle bi hata aldım acaba sıkıntı nedi

 

PS C:\Users\administrator.BASPA> setup /PrepareAD /OrganizationName:"Organizasyon Adı" /IacceptExchangeServerLicenceTerms
setup : The term 'setup' is not recognized as the name of a cmdlet, function, script file, or operable program. Check
the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ setup /PrepareAD /OrganizationName:"Organizasyon Adı" /IacceptExchangeServerLicence ...
+ ~~~~~
    + CategoryInfo          : ObjectNotFound: (setup:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

bu şekilde ata alma sebebi nedir

 

ayrıca kurulum sonrası aldığım hata aşağıda ekran resmini ekledim

 

https://www.flickr.com/gp/152289935@N07/wT0F3m

[/quote]

 

setup.exe /PrepareAD /OrganizationName: "Organizasyon adı" /IacceptExchangeServerLicenseTerms

 

komut aynen bu şekildemi? şayet böyleyse  domain adı  "Organizasyon adı" değilse yanlış komut. ilk mesaja bakarsak domain adı BASPA.

 

Komutu birde böyle denermisiniz

setup.exe /PrepareAD /OrganizationName: BASPA /IacceptExchangeServerLicenseTerms

 

CevapAlıntı
Gönderildi : 28/02/2017 14:37
Devrimer Sercan Duman
(@DevrimerSercanDuman)
Üye

[quote user="ibrahim bas"]

iyi günler neyi denediysem olumuyor bu konuda yaptığım yanlış nedir acaba öncelikle biraz yapı hakkında bilgi vereyim.

 

Fiziksel server üzerine kurulu sanal windoıws server 2012 r2 üzerinde exchange server 2013 kurmaya çalışıyorum makalelerde bulunan komutların hepsini makalede olduğu gibi gerek elle gerek ise yazarak yaptım. Hiç hata almıyorum ve gereken dosyaları yükledim. ( Microsoft Unified Communations Manager API 4.0 Core Runtime 64 bit Microsoft office 2010 filterpack ve SP1) bunalrıda kuruyorum buna rağmen aşağıdaki kodu

setup /PrepareAD /OrganizationName: "Organizasyon adı" /IacceptExchangeServerLicenseTerms  

setup.exe /PrepareAD /OrganizationName: "Organizasyon adı" /IacceptExchangeServerLicenseTerms

yukardaki iki kodu yazınca aşağıda hatayı alıyorum

 

setup : The term 'setup' is not recognized as the name of a cmdlet, function, script file, or operable program. Check
the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ setup /PrepareAD /OrganizationName: "Organizasyon adı" /IacceptExchangeServerLic ...
+ ~~~~~
+ CategoryInfo : ObjectNotFound: (setup:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException

 

kurulum yapıyorum kurulum sonunda da bu hatayı alıyorum bağlantılı oldukları belli ancak ben kodu ayzarken neden hata alıyorum yaptığım eksiklik nedir acaba

 

 

Error:
Active Directory must be prepared with 'Setup /PrepareAD' before domains can be prepared for Exchange 2010.
For more information, visit: http://technet.microsoft.com/library(EXCHG.150)/ms.exch.setupreadiness.DomainPrepWithoutADUpdate.aspx

[/quote]

 

merhaba ibrahim,

AD kurulu sunucunun uzerine exchange kurulumu yapiyorsan, direk olarak setup yazarak dener misin. tahmin ediyorum hatanin sebebi bu. genelde bu Setup /PrepareAD AD rolu kurulu sunucusu ile exchange sunucu farkli windows server olunca yapilmasi gerekmektedir diye hatirliyorum.

ve belki de cmdlet yapisi bozuk oldugundan dolayi calistirmiyordur. bazi modulleri yuklemen gerekebilir.

iyi gunler.

CevapAlıntı
Gönderildi : 28/02/2017 14:58
ibrahim bas
(@ibrahimbas)
Üye

stup ile denedim olmadı ancak daha önceleri sanal üzerinde kurduğumu ve sıkıntı yaşamadığımı hatırlıyorum acaba hangi modülleri yüklemem gerek 

CevapAlıntı
Gönderildi : 28/02/2017 15:35
ibrahim bas
(@ibrahimbas)
Üye

gerçekten çözümparkta bana yardım edecek kimse yokmu. Buna inanamıyorum

CevapAlıntı
Gönderildi : 07/03/2017 04:28
Sezgin Yılan
(@sezginyilan)
Üye

Tekrar soruyorum İbrahim bey komutu aynen bu şekilde mi yazıyorsunuz organizasyon kısmına domain adını yazıyormusunuz? yazdığınız postlardaki powershell çıktısına bakarsak domain adı yazmadan direk aşağıdaki gibi yazıyorsunuz komutu.

"setup.exe /PrepareAD /OrganizationName: "Organizasyon adı" /IacceptExchangeServerLicenseTerms"

 

komutu bu şekilde denedinizmi?

setup.exe /PrepareAD /OrganizationName: BASPA /IacceptExchangeServerLicenseTerms

CevapAlıntı
Gönderildi : 07/03/2017 12:06
ibrahim bas
(@ibrahimbas)
Üye

organizasyon adını "Bmail" olarak yazıyorum

CevapAlıntı
Gönderildi : 10/03/2017 02:43
 Anonim

Selamlar ;

 

Setup.exe nin olduğu  dizinde kurulumu  yapmıyorsunuz galiba  setup.exe  komutunu Exchange  kurulum medyası veya  dizininde  çalıştırmanız  gerekmektedir.

 

[quote user="ibrahim bas"]

Arkadaşlar exchange server 2013 kurulumu yapacam çözümpark makaesinden yola çıkarak powershel i yönetici olarak çalıştırdım ilk iki komut sıkıntısız kullandım ancak aşağıdaki 3. komutu kullanınca böyle bi hata aldım acaba sıkıntı nedi

 

PS C:\Users\administrator.BASPA> setup /PrepareAD /OrganizationName:"Organizasyon Adı" /IacceptExchangeServerLicenceTerms
setup : The term 'setup' is not recognized as the name of a cmdlet, function, script file, or operable program. Check
the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ setup /PrepareAD /OrganizationName:"Organizasyon Adı" /IacceptExchangeServerLicence ...
+ ~~~~~
    + CategoryInfo          : ObjectNotFound: (setup:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

bu şekilde ata alma sebebi nedir

 

ayrıca kurulum sonrası aldığım hata aşağıda ekran resmini ekledim

 

https://www.flickr.com/gp/152289935@N07/wT0F3m

[/quote]

CevapAlıntı
Gönderildi : 10/03/2017 05:26
ibrahim bas
(@ibrahimbas)
Üye

kurulumu medya klasöründe yapıyorum sanıyorum hatayı tahmin ediyorum ancak nasıl düzeltileceği konusunda bilgim yok ben anlatayım.

 

1 adet windows 2012 server r2 standart fiziksel makina üzerinde exchange server kurmak için sanal windows 2012 server r2 sanal makina var daha önce sanal makinaya kurulum yaptım. ancak çok fazla denemden sonra baaşrılı olunca sanal makinayı silip tekrar kurdum. Önceki kurulumda verdiği organizasyon adını hatırlamadığımdan bu hatayı veriyor olabilir sonuçta domain fiziksel makina üzerine kurulu acaba önceki yüklemede vermiş olduğum organizayon adını fiziksel makinanın bi yerde kaydediyo olabilirmi böyle bir sorun mümkünmü acaba

 

ayrıca şu anda aşağıdaki komutu yaazdığımda

 

PS C:\exchange> ./setup /PrepareAD /OrganizationName: "Baspa Exc" /IacceptExchangeServerLicenseTerms

 

Welcome to Microsoft Exchange Server 2013 Cumulative Update 15 Unattended Setup
Copying Files...
File copy complete. Setup will now collect additional information needed for installation.
The organization name, Baspa,Exc, can't be used because it contains invalid characters. For more information, run setup
 /help.
The Exchange Server setup operation didn't complete. More details can be found in ExchangeSetup.log located in the
<SystemDrive>:\ExchangeSetupLogs folder.
 
 
bu hatayı alıyorum
 
bir başka denediğim komut var onu da ekliyim
 
./setup /PrepareAD /IacceptExchangeServerLicenseTerms
 
 
Welcome to Microsoft Exchange Server 2013 Cumulative Update 15 Unattended Setup
Copying Files...
File copy complete. Setup will now collect additional information needed for installation.
Performing Microsoft Exchange Server Prerequisite Check
    Prerequisite Analysis                                                                             COMPLETED
Configuring Microsoft Exchange Server
    Organization Preparation                                                                          FAILED
     The following error was generated when "$error.Clear();
        initialize-ExchangeUniversalGroups -DomainController $RoleDomainController -ActiveDirectorySplitPermissions $Rol
eActiveDirectorySplitPermissions
" was run: "Microsoft.Exchange.Management.Tasks.InvalidWKObjectException: The well-known object entry B:32:C262A929D691B
74A9E068728F8F842EA:CN=Organization Management\0ADEL:0432df8f-b269-468f-87b3-234d46dedfb0,CN=Deleted Objects,DC=baspa,DC
=local on the otherWellKnownObjects attribute in the container object CN=Microsoft Exchange,CN=Services,CN=Configuration
,DC=baspa,DC=local points to an invalid DN or a deleted object.  Remove the entry, and then rerun the task.
   at Microsoft.Exchange.Configuration.Tasks.Task.ThrowError(Exception exception, ErrorCategory errorCategory, Object ta
rget, String helpUrl)
   at Microsoft.Exchange.Management.Tasks.InitializeExchangeUniversalGroups.CreateGroup(ADOrganizationalUnit usgContaine
r, String groupName, Int32 groupId, Guid wkGuid, String groupDescription, GroupTypeFlags groupType, Boolean createAsRole
Group)
   at Microsoft.Exchange.Management.Tasks.InitializeExchangeUniversalGroups.CreateRoleGroup(ADOrganizationalUnit usgCont
ainer, RoleGroupDefinition roleGroup)
   at Microsoft.Exchange.Management.Tasks.InitializeExchangeUniversalGroups.CreateAndValidateRoleGroups(ADOrganizational
Unit usgContainer, RoleGroupCollection roleGroups)
   at Microsoft.Exchange.Management.Tasks.InitializeExchangeUniversalGroups.InternalProcessRecord()
   at Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b()
   at Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePip
elineIfFailed)".
The Exchange Server setup operation didn't complete. More details can be found in ExchangeSetup.log located in the
<SystemDrive>:\ExchangeSetupLogs folder.
CevapAlıntı
Gönderildi : 10/03/2017 20:11
ibrahim bas
(@ibrahimbas)
Üye

arkadaşlar bu soruna bakabilirmisiniz

CevapAlıntı
Gönderildi : 13/03/2017 01:14
ibrahim bas
(@ibrahimbas)
Üye

yardım edebilecek kimse !!!!!

CevapAlıntı
Gönderildi : 14/03/2017 17:51
cem kılıç
(@cemkilic)
Üye

[quote user="ibrahim bas"]

yardım edebilecek kimse !!!!!

[/quote]

su makaleyı ıncelermısınız kullandıgınız powershell de eksıklık var

https://social.technet.microsoft.com/wiki/contents/articles/22284.exchange-server-2013-kurulum-ve-konfigurasyonu-bolum-1-tr-tr.aspx

CevapAlıntı
Gönderildi : 14/03/2017 19:02
ibrahim bas
(@ibrahimbas)
Üye

[quote user="cem kılıç"]

[quote user="ibrahim bas"]

yardım edebilecek kimse !!!!!

[/quote]

su makaleyı ıncelermısınız kullandıgınız powershell de eksıklık var

https://social.technet.microsoft.com/wiki/contents/articles/22284.exchange-server-2013-kurulum-ve-konfigurasyonu-bolum-1-tr-tr.aspx

[/quote]

 

teşekkkürederim ilginiz için ancak aldığım hatalardan anlaşılıyorki bu yapıda başka bir organizasyon ismi var önceki  kurulumumdan kalan bunu çözmek için ADSIedit te yaptığım aramalarda bir şey bulamadım en azından bilgisi olan arkadaşalr organizasyon ismi veya exchange önceki yapısını silmek için powershell de bi komut varmı ne yapmam gerekiyor bunu nasıl çözerim

CevapAlıntı
Gönderildi : 15/03/2017 02:09
Paylaş: