Exchange 2010 da ek...
 
Bildirimler
Hepsini Temizle

Exchange 2010 da ekli mail gönderim limitinin ayarlanması  

  RSS
Cem Yılmaz
(@CemYilmaz)
Üye

Arkadaşlar merhaba,

Exchange server 2010 da genel bazda kullanıcıların mail gönderim limitini 20 mb'a çıkarmak istiyorum. Bunun için aşağıdaki komutları set etmeme rağmen 14 mb mail gönderimi esnasında hata alıyorum. Başka şekilde tetikleme gibi bir durum var mı?

Mevcut durumu görüntülemek için;

Get-TransportConfig

Daha sonra;

Set-TransportConfig -ExternalDsnMaxMessageAttachSize 20Mb

Set-TransportConfig -InternalDsnMaxMessageAttachSize 20Mb

Set-TransportConfig -MaxSendSize 20Mb 

Alıntı
Gönderildi : 10/12/2013 13:15
Ufuk TATLIDIL
(@ufuktatlidil)
Saygın Üye

http://www.cozumpark.com/forums/thread/408080.aspx

CevapAlıntı
Gönderildi : 10/12/2013 13:27
Vasvi UYSAL
(@vasviuysal)
Saygın Üye Forum Yöneticisi

Bir kullanıcının özelliklerine gidip “Mail Flow Settings” içerisindeki “Message Size Restrictions” kısmını kontrol edebilirmisiniz

kullanıcıya özel tanımlamalar yapılmış olabilir.

CevapAlıntı
Gönderildi : 10/12/2013 13:43
Cem Yılmaz
(@CemYilmaz)
Üye

[quote user="Ufuk TATLIDİL"] http://www.cozumpark.com/forums/thread/408080.aspx[/quote]

 

Ufuk bey,

Yapımızda DAG var. Göndermiş olduğunuz linkteki komutları kendi yapıma göre set ettim. Yine gönderemiyoruz.

[PS] C:\Windows\system32>Get-Mailbox cem.yilmaz | fl MaxSendSize,MaxReceiveSize

MaxSendSize    : unlimited
MaxReceiveSize : unlimited

[PS] C:\Windows\system32>Get-TransportConfig | fl max*

MaxDumpsterSizePerDatabase : 18 MB (18,874,368 bytes)
MaxDumpsterTime            : 7.00:00:00
MaxReceiveSize             : 35 MB (36,700,160 bytes)
MaxRecipientEnvelopeLimit  : 1000
MaxSendSize                : 35 MB (36,700,160 bytes)

[PS] C:\Windows\system32>Get-TransportConfig

ClearCategories                     : True
ConvertDisclaimerWrapperToEml       : False
DSNConversionMode                   : UseExchangeDSNs
ExternalDelayDsnEnabled             : True
ExternalDsnDefaultLanguage          :
ExternalDsnLanguageDetectionEnabled : True
ExternalDsnMaxMessageAttachSize     : 20 MB (20,971,520 bytes)
ExternalDsnReportingAuthority       :
ExternalDsnSendHtml                 : True
ExternalPostmasterAddress           :
GenerateCopyOfDSNFor                : {}
HygieneSuite                        : Standard
InternalDelayDsnEnabled             : True
InternalDsnDefaultLanguage          :
InternalDsnLanguageDetectionEnabled : True
InternalDsnMaxMessageAttachSize     : 20 MB (20,971,520 bytes)
InternalDsnReportingAuthority       :
InternalDsnSendHtml                 : True
InternalSMTPServers                 : {}
JournalingReportNdrTo               : <>
LegacyJournalingMigrationEnabled    : False
MaxDumpsterSizePerDatabase          : 18 MB (18,874,368 bytes)
MaxDumpsterTime                     : 7.00:00:00
MaxReceiveSize                      : 35 MB (36,700,160 bytes)
MaxRecipientEnvelopeLimit           : 1000
MaxSendSize                         : 35 MB (36,700,160 bytes)
MigrationEnabled                    : False
OpenDomainRoutingEnabled            : False
Rfc2231EncodingEnabled              : False
ShadowHeartbeatRetryCount           : 12
ShadowHeartbeatTimeoutInterval      : 00:15:00
ShadowMessageAutoDiscardInterval    : 2.00:00:00
ShadowRedundancyEnabled             : True
SupervisionTags                     : {Reject, Allow}
TLSReceiveDomainSecureList          : {}
TLSSendDomainSecureList             : {}
VerifySecureSubmitEnabled           : False
VoicemailJournalingEnabled          : True
HeaderPromotionModeSetting          : NoCreate
Xexch50Enabled                      : True

CevapAlıntı
Gönderildi : 10/12/2013 14:05
Ufuk TATLIDIL
(@ufuktatlidil)
Saygın Üye

Transport servisini restart etmeniz gerekebilir. Ayrıca Outlook ve owa üzerinden kontrol edebilir misiniz.

CevapAlıntı
Gönderildi : 10/12/2013 14:19
Cem Yılmaz
(@CemYilmaz)
Üye

[quote user="Ufuk TATLIDİL"]Transport servisini restart etmeniz gerekebilir. Ayrıca Outlook ve owa üzerinden kontrol edebilir misiniz.
[/quote]

 

Transport servisini restart edip outlook ve owa üzerinden test ettim olmadı. Gönderdiğim mail 14 mb içeride bir sıkıntı yok, dışarıya gönderirken problem oluyor.

 

CevapAlıntı
Gönderildi : 10/12/2013 14:27
Ufuk TATLIDIL
(@ufuktatlidil)
Saygın Üye

CAS üzerinde yapıyorsunuz değil mi?

CevapAlıntı
Gönderildi : 10/12/2013 14:30
Cem Yılmaz
(@CemYilmaz)
Üye

[quote user="Ufuk TATLIDİL"]CAS üzerinde yapıyorsunuz değil mi?
[/quote]

Exchange server yapımız aşağıdaki gibidir. Mailbox sunucuları arasında DAG yapısı mevcut. CAS sunucuları arasında CASArray mevcuttur.

EXHUBCAS01 
EXHUBCAS02
EXMB01
EXMB02

Komutları mevcut olan EXHUBCAS01 ve EXHUBCAS02 sunucularının herhangi birisi üzerinde set ediyorum. Fakat test ettiğimde 14 MB maili gönderemiyorum.


 

CevapAlıntı
Gönderildi : 10/12/2013 14:41
MuratKINAY
(@muratkinay)
Üye

Organization Conf. - Hub Transport - Send Connectors

içerisindeki connector lerinizin properties

Max Messaage Size kısmında checkbox işaretli ve genel limit belirlenmiş olabilir.

 

CevapAlıntı
Gönderildi : 10/12/2013 15:32
Cem Yılmaz
(@CemYilmaz)
Üye

[quote user="MuratKINAY"]

Organization Conf. - Hub Transport - Send Connectors

içerisindeki connector lerinizin properties

Max Messaage Size kısmında checkbox işaretli ve genel limit belirlenmiş olabilir.

 

[/quote]

Murat bey,

O kısmı da 35840 olarak değiştirmiştim. Anlamış değilim... 

CevapAlıntı
Gönderildi : 10/12/2013 15:57
Ufuk TATLIDIL
(@ufuktatlidil)
Saygın Üye

Biraz bekleyip, test edin.

CevapAlıntı
Gönderildi : 10/12/2013 15:58
Cem Yılmaz
(@CemYilmaz)
Üye

[quote user="Ufuk TATLIDİL"]Biraz bekleyip, test edin.
[/quote]

Ufuk bey,

Ben bu işlemi dün yaptım ve bugüne kadar değişen bir şey göremedim. Daha ne kadar bekleyeceğimi de bilmiyorum 🙂 Evet, kontrol edildiğinde her şey olması gerektiği gibi gözüküyor. Fakat henüz sonuç almış değilim.

CevapAlıntı
Gönderildi : 10/12/2013 16:10
Ufuk TATLIDIL
(@ufuktatlidil)
Saygın Üye

Arada bir antispam gateway olabilir ve üzerinde ayar yapmak gerekebilir mi?

CevapAlıntı
Gönderildi : 10/12/2013 16:13
Cem Yılmaz
(@CemYilmaz)
Üye

[quote user="Ufuk TATLIDİL"]Arada bir antispam gateway olabilir ve üzerinde ayar yapmak gerekebilir mi?
[/quote]

Exchange'in önün de inbound ve outbound mailleri tarayan Symantec Messaging Gateway ürünü var. Bu kısmı da kontrol ettim. Ama herhangi bir şey göremedim. 

CevapAlıntı
Gönderildi : 10/12/2013 16:21
Cem Yılmaz
(@CemYilmaz)
Üye

Bu işin başka bir çözümü yok mu? 

CevapAlıntı
Gönderildi : 10/12/2013 17:30
Cem Yılmaz
(@CemYilmaz)
Üye

Arkadaşlar;

Sorunun çözümünü buldum. Detaylı olarak anlatıyorum...

Inbound ve Outbount maillerin taranması için Exchange Server'ın önünde SMG (Symantec Messaging Gateway) Brightmail ürününü konumlandırmıştım. Organization Configuration > Hub Transport > Send Connectors kısmında oluşturmuş olduğum "Internet" isimli Send Connector'ün Properties > Network tabına gelerek "Route mail through the following smart host" kısmında herhangi bir smart host tanımlama yapılıp yapılmadığını kontrol ettim. Akabinde SMG Brigtmail'i tanımlanmış olduğunu gördüm.

Öncesinde CAS üzerinde ekli mail gönderim limitlerini ayarlamak için aşağıdaki komutları set etmiştim.

(Alım / Gönderim boyutlarını siz istediğiniz gibi değiştirebilirsiniz.)

Öncelikle Get-TransportConfig komutu ile Transport ayarlarını görüntüledim. 

Set-TransportConfig -ExternalDsnMaxMessageAttachSize 25Mb
Set-TransportConfig -InternalDsnMaxMessageAttachSize 25Mb
Set-TransportConfig -MaxSendSize 25Mb
Set-TransportConfig -MaxReceiveSize 20MB -MaxSendSize 25MB -MaxRecipientEnvelopeLimit 1000

Get-TransportConfig | fl max*  ile komutların işleyip işlemediğini kontrol ettim. Akabinde Restart-Service MSExchangeTransport komutu ile Transport servisini restart ettim. 

Daha sonra SMG Brightmail üzerinde Administration > Configuration > Host Configuration'ı Edit leyerek SMTP tabına geldim. Advanced Settings'e tıkladım. Inbound ve Outbound kısmında Maximum message size in bytes kımını 25Mb olarak düzenledim ve Continue tıkladım ve Save ettim.

Test ettiğimde 14 Mb'lık dosyanın gönderildiğini gördüm.

Desteğiniz için teşekkür ederim arkadaşlar...

 

CevapAlıntı
Gönderildi : 10/12/2013 19:01
Ufuk TATLIDIL
(@ufuktatlidil)
Saygın Üye

🙂 iyiymiş. Geçmiş olsun.

CevapAlıntı
Gönderildi : 10/12/2013 19:03
Cem Yılmaz
(@CemYilmaz)
Üye

[quote user="Ufuk TATLIDİL"]:) iyiymiş. Geçmiş olsun.
[/quote]

Teşekkür ederim 🙂

CevapAlıntı
Gönderildi : 10/12/2013 19:04
Paylaş: