Exchange 2010 serve...
 
Bildirimler
Hepsini Temizle

Exchange 2010 server sp1 kurulum hatası  

  RSS
Mithat YILMAZER
(@MithatYILMAZER)
Üye

Değerli Üstadlarım ve hocalarım;


 Sizlere takıldığım bir yerde soru sormak isterim. VMware 7 üzerine windows 2008 r2 (64bit) server kurulu. ve bunun üzerine exchange 2010 sp1 server kurulumu yaparken hata alıyorum çok araştırdım forumdaki herşeyi okudum uyguladım. her seferinde sıfırdan başladım ama olmadı. tüm güncelleştirmeleride şimdiden teşekkürler.


 hata ayrıntısı:


 önce şöyle bir uyarısı var;


Warning:


Setup is going to prepare the organization for exchange 2010 by using


Setup/PrepareAD No exchange 2007 servers roles have been detected in this topology. after this opretion you will not be able to any exchange 2003 or exchange 2007 servers


Kurulum Aşamasında;


Organization Preparation
Failed


Error:
The following error was generated when "$error.Clear();
          $acceptedDomains = @{};
          Get-AcceptedDomain | foreach {
              $domainName = $_.DomainName.ToString();
              if ($acceptedDomains.Contains($domainName)) {
                  Write-ExchangeSetupLog -Warning "Duplicate AcceptedDomain found.  '$($acceptedDomains[$domainName])' and '$($_.Name)' both reference domain '$domainName'";
              } else {
                  $acceptedDomains.Add($domainName, $_.Name);
              };
          };


          function getSmtpTemplates ([string]$property)
          {
              $input |
                  Select-Object -ExpandProperty $property |
                  Where-Object {$_.PrefixString -eq "SMTP"} |
                  Foreach-Object {$_.AddressTemplateString -replace ".*@", ""};
          }



          function addDomains ([Microsoft.Exchange.Data.Directory.SystemConfiguration.AcceptedDomainType]$domainType)
          {
              $domain = $null;
              $input |
                  Where-Object {-not $acceptedDomains.ContainsKey($_)} |
                  Where-Object {[Microsoft.Exchange.Data.SmtpDomainWithSubdomains]::TryParse($_, [ref] $domain)} |
                  Foreach-Object {
                      $name = $domain.ToString();
                      if ($name.Length -gt 64) { $name = $name.Substring(0, 64) };
                      if ($acceptedDomains.ContainsValue($name) ) {$name = [System.Guid]::NewGuid().ToString()};


                      new-AcceptedDomain -Name:$name -DomainName:$domain -DomainType:$domainType;
                      $acceptedDomains[$domain.ToString()] = $name;
                  };
          }


          $emailAddressPolicies = Get-EmailAddressPolicy;
          $emailAddressPolicies | getSmtpTemplates "NonAuthoritativeDomains" | addDomains "InternalRelay";
          $emailAddressPolicies | getSmtpTemplates "EnabledEmailAddressTemplates" | addDomains "Authoritative";
        " was run: "The accepted domain yilmazer.com already exists.".


The accepted domain yilmazer.com already exists.

Alıntı
Gönderildi : 11/10/2010 14:53
Ufuk TATLIDIL
(@ufuktatlidil)
Saygın Üye

Vm yapınızda Exchange 2007 var sanırım. Test ortamınız ise 2007 kapatıp dener misiniz.

CevapAlıntı
Gönderildi : 11/10/2010 15:27
Mithat YILMAZER
(@MithatYILMAZER)
Üye

Öncelikle ilginiz için çok teşekkür ederim.


 VM de sadece 2008 server var başka bir OS yok. yani EXC 2007 ile ilgili bir kurulum yok

CevapAlıntı
Gönderildi : 11/10/2010 16:55
inancturkyilmaz
(@inancturkyilmaz)
Üye

Merhabalar,


 bu sorun ile ilgili yardımcı olabilecek var mıdır?

CevapAlıntı
Gönderildi : 16/03/2011 18:46
Bugra KESKIN
(@bugrakeskin)
Saygın Üye

VM in bulunduğu network de başka bir exchange server mı var ?

exchange i kurmaya çalıştığınız bu domain yeni bir domain mi?

hata da aynı accepted domain i kullanıyorsunuz diyor. kurduğunuz domain ismiyle çakışan networkde başka bir domain adı daha var.

CevapAlıntı
Gönderildi : 16/03/2011 18:54
inancturkyilmaz
(@inancturkyilmaz)
Üye

active directory ve dns.i kaldırarak farklı server adı ve domain ile yeniden kurulum yaptım. sorun düzeldi.


teşekkürler.

CevapAlıntı
Gönderildi : 16/03/2011 19:51
Hüseyin Sevin
(@huseyinsevin)
Üye

Sadece bu başlık için belirtmiyorum genel olarak belirtme ihtiyacı duyduğum bir konuyu hazır yeri gelmişken bu başlık altında belirtmek istiyorum. Bazı arkadaşlarımızın sanal sistemler üzerinde kendilerini geliştirmek için oluşturdukları test ortamlarında karşılaştıkları bir sorun karşısında onu inatla çözmek yerine sistemi yeniden kurma yoluna gitmeleri ve bu işlem içinde "sistemi yeniden kurdum sorun düzeldi" demeleri son derece yanlıştır ve mesleki gelişimlerine bu tür işlemlerin bir katkısı olmayacaktırda. Ayrıce bu bahsedilen bir çözüm değildir.

 

Sorunlar sanal ortamlarda sizin belirttiğiniz gibi bu şekilde çözülebilir ama gerçek bir dünyada bir AD olan sunucuyu sil baştan kurma şansınız pek olmayabilir.  Sanal ortamlarda bir sorunla karşılaşmış iseniz ne güzel, çünkü gerçek dünyada da karşınıza bu sorunun çıkma olasılığı çok yüksek olabilir ve siz onu daha öncesinde çözebilmiş olduğunuz için bir tecrübe edinirsiniz, fakat ilk sorunda sorunu çözmek yerine sistemi tekrar baştan kurarsanız bunun size bir katkısı olmayacaktır. Çünkü gerçek dünyada böyle bir şansınız yada hakkınız pek olmayacak belkide hiç olmayacaktır.

 

Saygılar.

CevapAlıntı
Gönderildi : 17/03/2011 12:52
Huseyin BILEN
(@HuseyinBILEN)
Üye

Arkadaşlar aynı hatayı bende alıyorum çözüm önerisi olan varmıdır ? teşekkürler.

CevapAlıntı
Gönderildi : 14/04/2013 21:49
Paylaş: