Anasayfa » Forum

E-beyanname VE E-im...
 

E-beyanname VE E-imzayı aynı makinada kullanma sorunu  

  RSS
Emre Saglam
(@EmreSaglam)
Üye

merhaba

 

E-beyanname VE E-imzayı aynı makinada kullanma sorunu yaşıyoruz ikiside farlı java uygulaması ile çalışıyoruz internette ve forumlarda tam olarak bir çözümü yok daha önce bu işlemi yapmış olan varmı

 

iyi çalışmalar dilerim

Alıntı
Gönderildi : 17/11/2015 3:57 pm
Resul SOYDAŞ
(@resulsoydas)
Üye

Yok abi. Türkcell e-imza farklı bir java kullanır. Sanayi Bakanlığının uygulaması farklı bir versiyon, e-fatura, ebyn farklı bir versiyon. Devlet uygulamaları zaten Allah'a emanet. 10 sene önce yazılan bir programı ne güncellerler ne de adam gibi desteğini verirler. Uğraş dur. Javayı güncellersin çalışmaz vs. vs.

Benim çözümüm her uygulamayı kullanıcılara paylaştırarak kullandırtmak oldu. :-). Mükemmel bir çözüm değil mi?

CevapAlıntı
Gönderildi : 17/11/2015 5:57 pm
Ayhan Özdemir
(@ayhanozdemir)
Üye

Merhaba,

C:\Program Files (x86)\Java\jre1.8.0_45\bin altındaki java.dll,java,java_crw_demo.dll,javacpl,javaw ve  javaws,jawt.dll dosyalarını kopyalayıp ebeyannamenin kurulu olduğu klasöre yapıştırın.Sorun düzelir.

CevapAlıntı
Gönderildi : 19/11/2015 10:16 am
Rıza ŞAHAN
(@rizasahan)
Değerli Üye Forum Yöneticisi

Resul hocam güzelmiş ama bazen mesela bizde olduğu gibi güncel javada kullanması gerekiyor. EBYN için eski javada. Artık bu işlere bir el atıp güncellemeleri lazım.

CevapAlıntı
Gönderildi : 19/11/2015 11:27 pm
okan rumeli
(@okanrumeli)
Üye

Merhaba,

E-beyannameye yeni güncelleme yapıldı artık javanın son versiyonunu kullanabiliyoruz.

CevapAlıntı
Gönderildi : 25/11/2015 6:04 pm
Resul SOYDAŞ
(@resulsoydas)
Üye

Şimdi baktımda halen Java v1.4.2.05 var.

CevapAlıntı
Gönderildi : 25/11/2015 6:08 pm
Rıza ŞAHAN
(@rizasahan)
Değerli Üye Forum Yöneticisi

EBYN oldumu mecbur 🙂 Hocam sanırım programı yazan Hakkın rahmetine kavuştu o yüzden böyle kaldı.

CevapAlıntı
Gönderildi : 26/11/2015 4:52 pm
Resul SOYDAŞ
(@resulsoydas)
Üye

Merhaba

Konuyu hortlatmak gibi olacak ama bu soruna çözüm bulundu mu? Var mı bir püf noktası. Halen java versiyonlarındaki farklılık nedeni ile EBYN ve diğer Java kullanan uygulamaları(e-imza,e-defter vb) ayrı makinalarda çalıştırıyoruz.

Rıza Hocamın dediği gibi. programı yazan Hakkın rahmetine kavuşmuş galiba 🙂

Bu devlet kurumları ne kadar ilgililer

CevapAlıntı
Gönderildi : 11/06/2019 1:05 pm
Rıza ŞAHAN
(@rizasahan)
Değerli Üye Forum Yöneticisi

Hocam aynı makina da çalıştırıyoruz 3 yıldır. Rafet bey sağolsun. 

Normalde kullanıcımızda java kullanan uygulama gereksinimleri karşılamak güncel java var. Ayrıca ebyn için gerekli versiyon var.

Yapmanız gereken aşağıdaki adımları uygulamak.

 

*********** E-Beyanname için Bat File Değişikliği ************************************************

 

**** orjinalda yer alan java komutu yerine java exeyi aşağıdaki gibi çalıştırmak

**** çalıştırılacak versiyonun yoluna göre değişkenlik gösterir

 

rem 01.10.2005

"C:\Program Files (x86)\Java\jdk1.6.0_37\bin\java" -Xmx256m -Dcom.cs.uid.renderer.java.runtime.UIBeanClassCache.packageName= -Dcom.cs.uid.renderer.java.runtime.UIBeanClassCache.checkForModification=false -classpath beydef.jar;bdp.jar;csfc.jar;debugger.jar;cs_mdi.jar;lf.jar;javarenderer.jar;ice-5_06_3.jar bdp_mf

**************************************************************************************************

CevapAlıntı
Gönderildi : 13/06/2019 8:28 am
Kerim CANTÜRK
(@kerimcanturk)
Üye Forum Yöneticisi

Biz de zamanında böyle bir  şey yaşamıştık en son clientın imajını almıştık.

Java security ayarlarınıda inceleyin hocam çok çözdük ordan.

CevapAlıntı
Gönderildi : 13/06/2019 10:27 am
Resul SOYDAŞ
(@resulsoydas)
Üye

Hocam işte nasıl çalıştırdınız o lazım.

@Rıza Şahan, çözümü deneyeceğim.

32Bit Java ile mi çalıştıracağız?

CevapAlıntı
Gönderildi : 13/06/2019 11:24 am
Rıza ŞAHAN
(@rizasahan)
Değerli Üye Forum Yöneticisi

32/64 fark etmez path ayarını ona göre yapmak yeterli.

CevapAlıntı
Gönderildi : 16/06/2019 12:58 am
Paylaş:
  
Çalışıyor

Lütfen Giriş yap yada Kayıt ol