Network

BGP Protokolü Temelleri Bölüm 3

 

Bu makalemizde sizlerle BGP protokolünün son serisi olarak BGP protokolü uygulaması ve BGP ve OSPF protokolü beraber çalışabilirliğini paylaşıyor olacağım.

 

Makalemin ilk iki bölümüne aşağıdaki linklerden ulaşabilirsiniz;

 

BGP Protokolü Temelleri Bölüm 2

BGP Protokolü Temelleri Bölüm 1

 

BGP Konfigürasyonu

 

                Basit BGP Konfigürasyonu;

 

Router (config)# router bgp  autonomous-system komutu ile bgp”AS” bilgisi yönlendiriciye atanır.

 

Router (config-router)# neighbor  ip-address | peer-group-name  remote-as autonomous-system    komut seti ile komşu network’e ait “AS” bilgisi tamamlanarak next-AS bilgisi tanımlanır.

 

Örnek olarak yukarıdaki iki komutu özetleyecek olursak;

 

Router (config)#  router bgp 65100

Router (config-router)# neighbor 10.1.1.2 remote-as 65101

Router (config-router)# neighbor 10.1.1.2  65001 shutdown  komutu ile yönetimsel olarak bakım yapılması gereken veya istenen routerlarda  “shutdown” komutu kullanılır.

Router (config-router)#no neighbor 10.1.1.2 65001 shutdown  komutu ile ilgili “AS” için komşuluk bilgisi komple kaldırılır.

Router(config-router)# neighbor  10.1.1.2 update-source interface-type interface-number   komutu ile  update’lerin yapılacağı loopback interface router üzerinde tanımlanır.

 

Bu komut kullanım amacı IBGP içerisinde BGP konuşan router’ların updatelerini Loopback interface’ler üzerinden yapaak fiziksel interface’leri update bilgisi için meşgul etmemesi için yapılır.

 

Bu durumun amacı IBGP networklerinde update bilgisini zenginleştirmek, bu komut yalnızca direkt birbirlerine bağlı olan router’larda ve IBGP networklerde çalışırlar, EBGP networklerde çalışmazlar.

 

Aşağıdaki topolojide  Loopback source tanımlamasını detaylı uygulamaya yarayacak bilgi paylaşılmıştır.

 

 

image001

 

 

 

Aşağıdaki Topoloji üzerinden sizlerle Frame Relay devresi üzerinden Multi Area BGP ve OSPF Single area konfigürasyonlarının Redistribute uygulamasının Router çıktılarını paylaşıyor olacağım.

 

 

 

image002

 

 

 

Aşağıdaki show running çıktılarında sıralı olarak Router’ların konfigürasyonlarının çıktılarını paylaşıyor olacağım ardından Test işlemi,IP Tablolarını kontrol edeceğiz ve son olarak Debug işlemi ile BGP protokolü update’leri hakkında bilgi veriyor olacağım.

 

 

R1,R2,R3,R4 ve R5 Routerlarının show running-config çıktıları ÖZET HALİ sırası ile aşağıda yer almaktadır.

R1# show running-config      —- Enter

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface Serial0/0

ip address 192.168.1.1 255.255.255.252

serial restart-delay 0

!

interface Serial0/1

no ip address

encapsulation frame-relay

serial restart-delay 0

frame-relay lmi-type ansi

!

interface Serial0/1.1 point-to-point

ip address 172.16.1.1 255.255.255.252

frame-relay interface-dlci 181 

!

interface Serial0/1.2 point-to-point

ip address 172.16.2.1 255.255.255.252

frame-relay interface-dlci 182 

!

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

default-information originate

!

router bgp 65003

no synchronization

bgp log-neighbor-changes

network 1.1.1.1 mask 255.255.255.255

network 172.16.1.0 mask 255.255.255.252

network 172.16.2.0 mask 255.255.255.252

redistribute ospf 1

neighbor 172.16.1.2 remote-as 65001

neighbor 172.16.2.2 remote-as 65002

no auto-summary

R2# show running-config      —- Enter

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface Serial0/0

ip address 192.168.1.2 255.255.255.252

serial restart-delay 0

!

interface Serial0/1

no ip address

shutdown

serial restart-delay 0

!

interface FastEthernet1/0

ip address 10.1.2.1 255.255.255.0

duplex auto

speed auto

!

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

R3# show running-config      —- Enter

frame-relay switching

!

interface Serial0/0

no ip address

encapsulation frame-relay

serial restart-delay 0

clock rate 128000

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 181 interface Serial0/1 811

frame-relay route 182 interface Serial0/2 821

!

interface Serial0/1

no ip address

encapsulation frame-relay

serial restart-delay 0

clock rate 128000

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 811 interface Serial0/0 181

frame-relay route 881 interface Serial0/2 882

!

interface Serial0/2

no ip address

encapsulation frame-relay

serial restart-delay 0

clock rate 128000

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 821 interface Serial0/0 182

frame-relay route 882 interface Serial0/1 881

!

interface Serial0/3

no ip address

shutdown

serial restart-delay 0

!

R4# show running-config      —- Enter

interface Loopback0

ip address 3.3.3.3 255.255.255.255

!

interface Serial0/0

no ip address

encapsulation frame-relay

serial restart-delay 0

frame-relay lmi-type ansi

!

interface Serial0/0.1 point-to-point

ip address 10.1.1.1 255.255.255.252

frame-relay interface-dlci 881 

!

interface Serial0/0.2 point-to-point

ip address 172.16.1.2 255.255.255.252

frame-relay interface-dlci 811 

!

interface Serial0/3

no ip address

shutdown

serial restart-delay 0

!

router bgp 65001

no synchronization

bgp log-neighbor-changes

network 0.0.0.0

network 3.3.3.3 mask 255.255.255.255

network 10.1.1.0 mask 255.255.255.252

network 172.16.1.0 mask 255.255.255.252

neighbor 10.1.1.2 remote-as 65002

neighbor 172.16.1.1 remote-as 65003

no auto-summary

!

ip http server

no ip http secure-server

ip route 0.0.0.0 0.0.0.0 Null0

R5# show running-config      —- Enter

interface Loopback0

ip address 4.4.4.4 255.255.255.255

!

 

interface Serial0/0

no ip address

encapsulation frame-relay

serial restart-delay 0

frame-relay lmi-type ansi

!

interface Serial0/0.1 point-to-point

ip address 10.1.1.2 255.255.255.252

frame-relay interface-dlci 882 

!

interface Serial0/0.2 point-to-point

ip address 172.16.2.2 255.255.255.252

frame-relay interface-dlci 821 

!

router bgp 65002

no synchronization

bgp log-neighbor-changes

network 0.0.0.0

network 4.4.4.4 mask 255.255.255.255

network 10.1.1.0 mask 255.255.255.252

network 172.16.2.0 mask 255.255.255.252

neighbor 10.1.1.1 remote-as 65001

no auto-summary

!

ip http server

no ip http secure-server

ip route 0.0.0.0 0.0.0.0 Null0

 

Aşağıdaki Router çıktılarında ise IP Tabloları yer almaktadır.

Router 4 cihaznının IP Tablosu aşağıdaki gibidir.

image003

 

Router 2 cihaznının IP Tablosu aşağıdaki gibidir.

 

image004

 

IP Tablolarını görüntüledikten sonra  Router 2 cihaz üzerinden tüm uç noktadaki IP adreslerine erişimin olup olmadığını doğrulamak adına aşağıdaki gibi sırası ile uç loopback ip adreslerine ping atarak test edebilirsiniz.

 

image005

 

 

Son olarak Router 4 cihazı üzerinde Sorun giderme veya cihazın şu an konuşmuş olduğu protokol üzerinde, herhangi bir olumlu- olumsuz durumu takip edebilmek adına “Debug” komutu ve alt parametrelerinden yardım alabiliriz.

 

Aşağıdaki ekran çıktısında, “debug” komutuna bir örnek verilmiştir, soru işaretini kullanarak, “debug” komutu kombinasyonları sayesinde sorun çözme durumlarına da ışık tutmuş olursunuz.

 

 

image006

 

BGP protokolü ile alakalı detaylı olarak konuların işlenmiş olduğu uzun soluklu bir makale oldu, umarım herkese faydalı olmuştur.

İlgili Makaleler

Bir cevap yazın

E-posta hesabınız yayımlanmayacak.

Başa dön tuşu

Reklam Engelleyici Algılandı

ÇözümPark Bilişim Portalı gönüllü bir organizasyon olup tek gelir kaynağı reklamlardır. Bu nedenle siteyi gezerken lütfen reklam engelleme eklentinizi kapatın veya Çözümpark web sitesi için izin tanımı yapın. Anlayışınız için teşekkürler.