Haberler

Aruba ve Avaya Switch’lerde RCE Zafiyeti Tespit Edildi

Güvenlik araştırmacıları, Aruba (HP) ve Avaya (ExtremeNetworks) ağ ekipmanlarında, kötü niyetli kişilerin cihazlarda uzaktan kod yürütmesine izin verebilecek beş güvenlik açığı keşfetti. Başarılı bir saldırı veri ihlali ve cihazın tamamen ele geçirilmesinden yanal harekete ve izole edilmiş ağ bölümlerine erişime kadar gidebiliyor.

Analistler, diğer satıcıların cihazlarının aynı güvenlik risklerine sahip olduğunu tespit etti ve etkilenen ürünlerin bir listesini yayınladı:

  • Avaya ERS3500
  • Avaya ERS3600
  • Avaya ERS4900
  • Avaya ERS5900
  • Aruba 5400R Series
  • Aruba 3810 Series
  • Aruba 2920 Series
  • Aruba 2930F Series
  • Aruba 2930M Series
  • Aruba 2530 Series
  • Aruba 2540 Series

Sorun External libraries kullanımında

External libraries kullanmak genellikle uygun ve maliyet tasarrufu sağlayan bir çözümdür ancak bazen bu, uygulama hataları ve güvenlik sorunlarıyla birlikte gelir. Bu uygulama, bilgisayar korsanlarını potansiyel olarak istismar edilebilir kusurları bulmak için bu küçük yapı taşlarına bakmaya motive eder. TLStorm 2.0 durumunda, sorunun nedeni satıcılar tarafından kullanılan “glue logic” kodunun NanoSSL yönergeleriyle uyumlu olmaması ve potansiyel RCE’ye (uzaktan kod yürütme) yol açmasıdır. Aruba’da NanoSSL, Radius kimlik doğrulama sunucusu ve ayrıca sabit portal sistemi için kullanıyor. Uygulanma şekli verilerinin heap overflows’a neden olabilir. Avaya’da ise TLS reassembly heap overflow, an HTTP header parsing stack overflow, an HTTP POST request handling overflow zafiyetlerine neden olabiliyor.

Saldırı senaryoları

Armis’in güvenlik araştırmacıları, her ikisi de yüksek etkili siber saldırılara yol açan, sabit bir portaldan kaçmaya veya ağ segmentasyonunu kırmaya izin veren iki ana istismar için saldırı senaryosu hazırladı.

Captive portal senaryosunda, saldırgan kimlik doğrulama, ödeme veya başka bir sınırlı bir ağ kaynağının web sayfasına erişiyor. Captive portallar genellikle otel ağlarında, havaalanlarında ve iş merkezlerinde bulunur. Saldırgan, TLStorm 2.0’dan yararlanarak, Captive portalın kısıtlamalarını atlayarak veya hatta tamamen devre dışı bırakarak switch üzerinde uzaktan kod yürütebiliyor.

İkinci senaryoda, bir saldırgan ağ segmenini kırmak ve BT ağının herhangi bir bölümüne erişmek için güvenlik açıklarını kullanabilir ve “misafir” alanından “kurumsal” bölüme serbestçe geçebilir. Tehdit analistleri müşterilerin bilgilendirildiğini ve güvenlik açıklarının çoğunu gideren yamalar yayınlandığını söyledi. Switchlerinizi güncellemekte fayda var.

Kaynak: bleepingcomputer.com

İlgili Makaleler

Bir cevap yazın

E-posta hesabınız yayımlanmayacak.

Başa dön tuşu

Reklam Engelleyici Algılandı

ÇözümPark Bilişim Portalı gönüllü bir organizasyon olup tek gelir kaynağı reklamlardır. Bu nedenle siteyi gezerken lütfen reklam engelleme eklentinizi kapatın veya Çözümpark web sitesi için izin tanımı yapın. Anlayışınız için teşekkürler.