Haberler

Python, Yeni Güncelleme ile Güvenlik Açığının Önüne Geçmeye Çalışıyor

Ancak henüz endişeye gerek yok. Python geliştiricileri, saldırganların uzaktan erişimle sistemleri istismar etme imkanları olsa bile bu yolla sadece makineniniz durdurabileceğini açıkladı.

Python Yazılım Vakfı (PSF), uzaktan sömürülen ancak pratik anlamda yalnızca bir makineyi çevrimdışı duruma getirmek için kullanılabilen bir açık da dahil olmak üzere iki önemli güvenlik açığının önüne geçmek Python 3.9.2 ve 3.8.8’i geliştirme sürecini hızlandırdı.

PSF, Python kullanıcılarını, özellikle CVE-2021-3177 olarak işaretlenen uzaktan kod yürütme (RCE) güvenlik açığını ele almak için sistemleri Python 3.8.8 veya 3.9.2’ye yükseltmeye çağırıyor.

Proje, güvenlik açığından endişe duyan bazı kullanıcılardan baskı gördükten sonra sürümün çıkışını hızlandırdı.

Python yayın ekibi yayınlanma süreci hızlandırılan sürümler hakkında açıklama yaptı. “3.9.2 sürüm adaylarının 3.8.8’de duyurulmasından bu yana, son kullanıcılardan, özellikle CVE-2021-3177 olmak üzere güvenlik içeriği nedeniyle son sürümlerin çıkarılmasını hızlandırmaya yönelik talepler aldık.”

Python 3.x’den 3.9.1’e kadar, PyCArg_repr’de ctypes / callproc.c’de bir arabellek taşması var, bu da uzaktan kod yürütülmesine yol açmakta.

Bu, “floating-point sayıları c_double.from_param için 1e300 bağımsız değişkeninin gösterdiği gibi güvenilmeyen girdi olarak kabul eden” Python uygulamalarını etkiler.

Hata, “sprintf” güvenli olmayan bir şekilde kullanıldığı için oluşuyor. Python birden çok Linux dağıtımı ve Windows 10 ile önceden yüklendiği için etki alanı geniş.

Debian gibi çeşitli Linux dağıtımları, Python’un yerleşik sürümlerinin korumalı olmasını sağlamak için güvenlik yamalarını arka plana atıyor.

Güvenlik açığı, yaygın bir bellek kusuru. RedHat başına, Python’un ctypes modülündeki yığın tabanlı bir arabellek taşması, kendisine iletilen girdiyi yanlış bir şekilde doğruladı. “Bu, saldırganın yığındaki bir arabelleği taşmasına ve uygulamayı çökertmesine izin verir.”

Açıktan faydalanmak pek mümkün değil

RedHat, uzaktan kod yürütme güvenlik açığı kötü haber olsa da, “bu güvenlik açığından kaynaklanan en büyük tehdidin sistem kullanılabilirliği olduğunu” belirtiyor. Başka bir deyişle, bir saldırgan muhtemelen yalnızca bir hizmet reddi saldırısı gerçekleştirebilir.

PSF yetkilileri söz konusu açığı istismar etmenin pek olası olmadığını açıkladı. “Anladığımız kadarıyla, CVE “uzaktan kod yürütme” olarak listelenirken, başarılı bir RCE için aşağıdaki koşulların karşılanması gerektiğinden, bu güvenlik açığı ile bu tür istismarlar pek olası değil.”

“Elbette, kötü niyetli girdiler yoluyla hizmet reddi de ciddi bir sorundur. Bu nedenle, sürüm adayının yetersiz kaldığı topluluk üyelerine yardımcı olmak için bugün 3.9.2 ve 3.8.8’in son sürümlerini yayınlıyoruz.”

Kaynak: zdnet.com

Diğer Haberler

Yeni Truva Atı Varyantı MassLogger Geri Döndü!
WhatsApp, Tepkilere Rağmen Değişiklik Yapmakta Israrcı
Florida’da Su Arıtma Tesisine Sızan Hackerlar Şehir Suyu Şebekesini Zehirlemeye Çalıştı

İlgili Makaleler

Bir cevap yazın

E-posta hesabınız yayımlanmayacak.

Başa dön tuşu

Reklam Engelleyici Algılandı

ÇözümPark Bilişim Portalı gönüllü bir organizasyon olup tek gelir kaynağı reklamlardır. Bu nedenle siteyi gezerken lütfen reklam engelleme eklentinizi kapatın veya Çözümpark web sitesi için izin tanımı yapın. Anlayışınız için teşekkürler.