Dell Technologies

DELL OS10 – VLT Uygulamalı Anlatım

Virtual Link Trunking Kurulumu

Virtual Link Trunking veri merkezlerinde tercih edilen sanal bağlantı kanalı şeklinde düşünebilirsiniz. VLT yapısı, bağlı cihazlara mantıksal tek anahtar görünümü sağlayan iki düğümden oluşur. Ancak, VLT eşlerinin her biri ayrı kontrol ve veri düzlemleri sağlar ve bir bağlantı noktası, protokol ve yönetim için ayrı ayrı yapılandırılabilir. Diğer markalarda buna benzer protokol VSS veya VPC gibi isimler ile geçiyor.  Burada amaç aktif aktif yedekliliği sağlamaktır. Dell EMC OS10 işletim sistemini kullanan network cihazlarında Spine-Leaf mimarisi yapılırken veya 2 switchi yedekli omurga gibi konumlandırdığımızda bu yöntemi uygularız.

VLT uygulamasına genel olarak baktığımızda bir kaç basit komutu var. Fakat ince ayarlarını da katarsak bu makalede geniş anlamda ele alacağız. Önceki makalemizde anlattığımız GNS3 similutator üzerinde VLT uygulamalı anlatacağız.

Özet olarak hangi komutların kullanıldığını aşağıdaki 2 tabloda görebilirsiniz. Aralarında VLT bağlantısı olacak cihazlara bu komutları ayrı ayrı girmemiz gerekir.

OS10# configure terminal Ayarların uygulaması için configuration mode geçilir
OS10(config)# interface range ethernet 1/1/8-1/1/9Hangi port interfacelerine uygulacanaksa VLT bu portlar içine girilir.
OS10(conf-range-eth1/1/8-1/1/9)# no switchportBu VLT portları switchport mode dan çıkartılır.
OS10(config)# vlt-domain 100Bir VLT domaini oluşturulur. Aynı şekilde diğer switchte aynı olmalı.  
OS10(conf-vlt-100)# discovery-interface ethernet 1/1/8  VLT portlarını keşif kontrolü için belirlenen bağlantılı portları
OS10(conf-vlt-100)# discovery-interface ethernet 1/1/9 VLT portlarını keşif kontrolü için belirlenen bağlantılı portları
OS10# configure terminal Ayarların uygulaması için configuration mode geçilir
OS10(config)# vlt-domain 100  VLT domaini içine girilir.
OS10(conf-vlt-100)# primary-priority 4096 (primary peer)
OS10(conf-vlt-100)# primary-priority 8192 (secondary peer)  
Switch önceliklendirme ayarları. VLT domaini içinde hangi switch 1. Olacaksa öncelik numarası buna uygun belirlenir. Düşük olan daha öncedir.
OS10(conf-vlt-100)# vlt-mac 00:11:22:33:44:55   VLT domaini için ortak bir MAC adresi belirlenir.
OS10(conf-vlt-100)# backup destination 1.1.1.2 (ilk switch)
OS10(conf-vlt-100)# backup destination 1.1.1.1 (ikinci switch)  
Switchlerin out of band management üzerinden birbirlerinin sağlık durumunu (Heartbeat) kontrol etmesi içindir. Switchlerin birbirlerine karşılıklı olarak management port IP adresleri backup destination olur.

Tüm ayarları sıfırlamak için :  Factory reset

Farkli uygulamalar yapıldıysa en baştan sıfırlamakta fayda var. İlk kez config yapılıyorsa bu adımı geçebilirsiniz.

Sıfırlama komutu Default modda komutu uygulamalıyız. Configure modda çalışmıyor.

*** Router1# Delete startup-configuration *** : bu komut ile startup tarafındaki komutlar silinir fakat show running-configutarion dersek hali hazırda çalışan komut satırlarının silinmediğini görürüz. Reload olduktan sonra geçerli olacaktır.

***Reload*** : komutunu verdiğiniz de running config de komutları yeni gibi algılayarak bu değişiklikleri kaydetmek istiyormusun şeklinde sorar. Hayır (:no) komutunu vermeliyiz ki startup config ile temiz açılsın. 

En son system reboot edilecek yeniden başlatılacak eminmisin diyor. Evet (:yes) komutunu vererek sistemi reboot etmiş oluyor. Yani switch ayarlarını fabrika ayarlarına döndürmüş oluyoruz.

  • OS10#delete startup-configuration
  • Proceed to delete startup-configuration [yes/no(default)]:yes
  • OS10#reload
  • System configuration has been modified. Save? [yes/no]:no
  • Proceed to reboot the system? [confirm yes/no]:yes

The switch reboots with default configuration settings.

Örnek : 2 VLT switch ve kenar switchler üzerindeki tüm ayarları sıfırlarız.

Adım adım VLT uygulanışı

  • VLT Topoloji – OS10

GNS3 de oluşturduğumuz topoloji aşağıdaki şekilde olacak

VLT Topoloji

Daha önceki makalemizde GNS3 ayarları ve Dell OS10 işletim sistemini nasıl çalıştıracağımızı anlatmıştık.

Switchlerimiz Topolojide görüldüğü gibi yaptığınızı varsayarak adım adım başlıyoruz.

1. Login bilgileri (DELL OS 10 için default)

Kullanıcı : admin

Password :  admin

2. Hostname ile cihazlara isim verme

configure terminal

hostname Router1,

hostname Router2 ,

hostname Switch1, 

hostname Switch2,  

şeklinde tüm cihazlara birer birer isim veririz.

3. disable STP and save config: loop oluşturacak bir durum yoksa Spanning tree nin disable edilmesi.

Ve kayıt etme komutu write memory gösterimi aşağıda.

Configure terminal : komutu ile config moda giriş yapılır

spanning-tree disable  : komutu ile STP pasif duruma getiririz.

Kayıt etme komutu olarak

write memory veya config modda ise do write memory  komutları kullanılır.

Örnek :

4. Reboot  : yeniden başlatmak içinreload komutu kullanılır.

reload

5. SET management ip address:  Cihazları yönetmek maksadıyla bir management ip adresi ayarlarız (out of band management)

management interface lerine de IP adresleri vermeliyiz. Örnek olarak Router1: 1.1.1.1 ve Router2: 1.1.1.2 ip adresleri verildi

Her cihazda management interface mgm 1/1/1 olarak geçer

Dhcp yi kaldırıyoruz ki ayrı bir IP yi biz manuel verelim.

Daha sonra VLT kısmında önem arzedecek . VLT domainindeki switchlerin birbirini sağlık kontrolü için backup destination protokolünü kullanacağız.

ROUTER1

configure terminal

interface mgmt 1/1/1

no ip address dhcp

ip address 1.1.1.1/24

ROUTER2

configure terminal

interface mgmt 1/1/1

no ip address dhcp

ip address 1.1.1.2/24

Test için OS10 router1 ve 2 arası ping atabilirsin.

6. VLAN ların oluşturulması 10,20,30 :   Ip sonlarına dikkat.1,.2,.3,.4

Vlan (Virtual Local Area Network  )Nedir : Vlan bir sanal ağdır. Farklı fiziksel gibi sanal LAN’lardan oluşur ve birçok aygıt ve cihazı gruplandırarak güvenli bir ağ kurar. Özellikle kurumsal şirketlerde vlan protokolü kullanır. Bunun sebebi de şirket ağları üzerinde meydana gelen trafiği dengelemek ve şirket ağları üzerinde güvenliği sağlamaktır. Örnek olarak 10,20,30 vlanlarını oluşturacağız.

ROUTER1
configure terminal
interface vlan 10
ip add 10.0.0.1/24
no shut
exit
interface vlan 20
ip add 20.0.0.1/24
no shut
exit
interface vlan 30
ip add 30.0.0.1/24
no shut
end
ROUTER2
configure terminal
interface vlan 10
ip add 10.0.0.2/24
no shut
exit
interface vlan 20
ip add 20.0.0.2/24
no shut
exit
interface vlan 30
ip add 30.0.0.2/24
no shut
end
SWITCH1
configure terminal
interface vlan 10
ip add 10.0.0.3/24
no shut
exit
interface vlan 20
ip add 20.0.0.3/24
no shut
exit
interface vlan 30
ip add 30.0.0.3/24
no shut
end
SWITCH2
configure terminal
interface vlan 10
ip add 10.0.0.4/24
no shut
exit
interface vlan 20
ip add 20.0.0.4/24
no shut
exit
interface vlan 30
ip add 30.0.0.4/24
no shut
end

KONTROL ETMEK İÇİN aşağıdaki show komutlarını kullanabiliriz

show vlan

show int vlan

show ip int bri

show ip route

NOT : ilk 6 adım normal OS10 switch üzerindeki basit ayarlar gibi düşünebilirsiniz. Her switch üzerinde yapılması gereken basit ayarlar.

7. VLT Ayarlarının yapılması: Router1=Router2 arasında

Bu adımda VLT ayarlarını yapacağız. Sonrasında (8. Madde) Port Channel ayarlarına geçeceğiz kenar switchler için.

  • Vlt oluşturmak için önce bir VLT domain oluşturulur. (her VLT olacak switche gidip uygulanmalı)

OS10#configure terminal

Os10#(config)#Vlt-domain 100

VLT olacak portlar no switchport olmalı. 8 ve 9 nolu interface girip no switchport yazılmalı.

Os10(config)#Interface ethernet 1/1/8 Os10(conf-if-eth1/1/8)#No switchportVLT portlarında No switchport komutu uygulanır. (Her iki switch içinde)
Os10(config)#Interface ethernet 1/1/9 Os10(conf-if-eth1/1/9)No switchportVLT portlarında No switchport komutu uygulanır. (Her iki switch içinde)
  • Discovery interfaceleri ayarlarız, VLT portlarının switchler arası keşif etmesi için belirlenen bağlantılı portları discovery komutu ile ayarlanır. 1. ve 2. Switch ayrı ayrı girilir.

Topolojide 8 ve 9 nolu portları VLT portu olarak ayarlayıp GNS3 üzerinde bu portları birbirine bağladık. Fiziksel cihazlarda bu bağlantı genelde 40G veya 100G uplink portları üzerinden bağlanır switchler birbirine.

OS10(conf-vlt-100)# discovery-interface ethernet 1/1/8  VLT portlarını keşif kontrolü için belirlenen bağlantılı portları
OS10(conf-vlt-100)# discovery-interface ethernet 1/1/9  VLT portlarını keşif kontrolü için belirlenen bağlantılı portları
  • Ayrıca birbirlerini her olasılığa karşı kontrol etme amaçlı out of band management portu üzerinden görmesi için backup destination ip adresleri girilir. (bunlar daha önce verdiğimiz management IP adresleri) Heartbeat atıp sağlık kontrolü yapar. Backup destination olarak birbirlerinin management ip adreslerini veririz.
OS10(conf-vlt-100)# backup destination 1.1.1.2 (Router1)
OS10(conf-vlt-100)# backup destination 1.1.1.1 (Router2)
Switchlerin out of band management üzerinden birbirlerinin sağlık durumunu (Heartbeat) kontrol etmesi içindir.
  • VLT Mac Adresi : Bunun amacı da tek bir cihaz gibi görünmesi için her iki cihazada aynı MAC adresi verilir. Bu herhangi multicast olmayan bir MAC adresi verebilirsiniz.
OS10(conf-vlt-100)# vlt-mac 00:11:22:33:44:55   VLT domaini için ortak bir MAC adresi belirlenir.
  • Hangi switchin primary (master) olmasını istiyorsanız aşağıdaki şekilde önceliklerini ayarlayabilirsiniz. Hangisi düşük olursa o master olur. Ayarlamazsanız otomatik olarak düşük olan MAC adresi olanı primary seçer. eğer siz aşağıdaki priority komutunu kullanırsanız switch i restart yapmanızda fayda var.
OS10(conf-vlt-100)# primary-priority 4096 (primary peer)
OS10(conf-vlt-100)# primary-priority 8192 (secondary peer)  
Switch önceliklendirme ayarları. VLT domaini içinde hangi switch 1. Olacaksa öncelik numarası buna uygun belirlenir. Düşük olan daha öncedir.

Not: yaptığınız değişiklikleri “write memory” komutu ile kaydetmeyi unutmayın.

ÖZETLE HER İKİ CİHAZDA YAPILMASI GEREKENLER:

ROUTER1ROUTER2NOTLAR
configure terminal
int e 1/1/8
no sw
exit
int e 1/1/9
no sw
exit
vlt 10
backup dest 1.1.1.2
discovery-interface ethernet 1/1/8
discovery-interface ethernet 1/1/9
vlt 00:11:22:33:44:55   
pri 4096
peer-routing
do wr mem  
configure terminal
int e 1/1/8
no sw
exit
int e 1/1/9
no sw
exit
vlt 10
backup dest 1.1.1.1
discovery-interface ethernet 1/1/8
discovery-interface ethernet 1/1/9
vlt 00:11:22:33:44:55   
pri 8192
peer-routing
do wr mem  
  -VLT port ayarlarına giriş (8 ve 9 nolu interfaceler)
Karşılıklı olarak portlarını doğru ayarlamlıyız
-VLT portlarını no switchport


  
-VLT domain ID veririz (100)
– Bakup destination ayarladığımız management Ip lerimiz birbirini kontrol eder. Heartbeat

– discovery interface 8  ve 9 portlarından keşif için
-Ortak bir MAC adresi veririz
-Primary olarak – HANGİSİ ÖNCELİK ADMIN olacak.
-Peer routing açarız – routing paylaşması için.
-En son değişiklikleri kayıt ederiz

KONTROL

show vlt 100                   hangisi primary – secondary kontrol et

show vlt 100 backup     heartbeat logu düşer peer is up

NOT : Zorunlu değil ama bir reboot yapılırsa iyi olur VLT nin düzgün oturması için. Reload komutu ile tekrar başlatabilirsiniz. (Wr mem)

8. Port gruplarının ayarlanması : 4 link LACP between VLTs

PORT CHANNEL GROUP OLUŞTUR

Port Channel Nedir : Bilgisayar ağlarında, bağlantı birleştirme terimi, tek bir bağlantının devam edebileceğinin ötesinde verimi artırmak(band genişliği artışı)  ve bağlantılardan birinin başarısız olması durumunda fazlalık sağlamak için birden çok ağ bağlantısını paralel olarak birleştirmenin çeşitli yöntemleri uygulanır.

ROUTER1ROUTER2
configure terminal
interface port-channel 10
switchport mode trunk
switchport trunk all vlan 10,20,30
vlt-port-channel 10
no shut
exit
int po 11
sw mode trunk
sw trunk all vlan 10,20,30
vlt-port-channel 11
no shut
exit
configure terminal
interface port-channel 10
switchport mode trunk
switchport trunk all vlan 10,20,30
vlt-port-channel 10
no shut
exit
int po 11
sw mode trunk
sw trunk all vlan 10,20,30
vlt-port-channel 11
no shut
exit
SWITCH1SWITCH2
conf t
int po 10
sw mode trunk
sw trunk all vlan 10,20,30
no shut
exit
conf t
int po 11
sw mode trunk
sw trunk all vlan 10,20,30
no shut
exit

KONTROL:

Show port-channel summary

9.  Port Gruplarının altında interfacelerin alınması :  İNTERFACELERİ tanımladığımız 10 ve 11 nolu PORT CHANNEL ALTINA ALACAĞIZ.

Ilk sayfada topolojide gösterildiği üzere sol taraf port-channel 10 sağ taraf port-channel 11 olacak şekilde.

ROUTER1ROUTER2
interface ethernet 1/1/1
channel-group 10 mode active
no shut
exit
int e 1/1/2
channel-group 11 mode active
no shut
end
write memory
int e 1/1/1
channel-group 10 mode active
no shut
exit
int e 1/1/2
channel-group 11 mode active
no shut
end
write memory
SWITCH1SWITCH2
configure terminal
int e 1/1/1
chann 10 mode active
no shut
exit
int e 1/1/2
chann 10 mode active
no shut
end
configure terminal
int e 1/1/1
chann 11 mode active
no shut
exit
int e 1/1/2
chann 11 mode active
no shut
end

KONTROL

show port-channel summary

show int port-c 10

show lacp port-channel interface port-channel 10

10. Kenar switch üzerinde olan sanal PC bağlantısı Virtual PC1 & PC2

Configure access port for VPC1 (switch1)
 
conf t
interface ethernet 1/1/7
switchport mode access
switchport access vlan 10
no shut
end
Configure access port for VPC2 (switch2)
 
conf t
interface ethernet 1/1/7
switchport mode access
switchport access vlan 20
no shut
end
Kenar switch üzerinde 7 nolu porta virtual PC leri bağladık. VRRP kurulmadan önce Layer 3 üzerinden farklı vlana ping atamıyor.

11. VRRP ayarları :

VRRP (Virtual Router Redundancy Protocol ) )Nedir: Network dilinde L3 yedeklilik deriz.  iki adet internet hattımız olduğunu düşünelim. Client sistemlere gateway olarak birini kullandırabilir, bir problem durumunda manuel tüm gatewayleri değiştirmek zorunda kalırsınız. VRRP multicast bir mac adresi ile ortak ip tanımı yapmanızı her iki ip yi’de aynı anda kullanmanızı sağlar. Kısacası, Router’lar arası Cluster mantığıdır.

ROUTER 1 VE 2 de VRRP ayarı

conf t

int vlan 10

vrrp-group 10

priority 100

virtual-address 10.0.0.254

no preempt

exit

exit

int vlan 20

vrrp-group 20

priority 100

virtual-address 20.0.0.254

no preempt

exit

exit

int vlan 30

vrrp-group 30

priority 100

virtual-address 30.0.0.254

no preempt

exit

KONTROL:

show vrrp brief

show run int vlan 10

show vrrp brief

show vrrp 10

12. Bağlanti testi pc ler arası

PC1>ping 20.0.0.100

PC2>ping 10.0.0.100

13. Primary router’ın devreden çıkartılarak test edilmesi.

Sistemin devam edip etmediğini anlamak için admin router’ı sileriz.

Ping testi bir süre sonra devam eder. GNS3 sebebi ile bir süre ping kaybı gözükür.

Virtual PC AYARLARI (gns3) :

KOMUT

PC-1> ip 10.0.0.100 255.255.255.0 10.0.0.254

Checking for duplicate address…

PC1 : 10.0.0.100 255.255.255.0 gateway 10.0.0.254

PC-1> show ip

NAME        : PC-1[1]

IP/MASK     : 10.0.0.100/24

GATEWAY     : 10.0.0.254

DNS         :

MAC         : 00:50:79:66:68:00

LPORT       : 10084

RHOST:PORT  : 127.0.0.1:10085

MTU:        : 1500

————————————————————–

KOMUT

PC-2> ip 20.0.0.100 255.255.255.0 20.0.0.254

Checking for duplicate address…

PC1 : 20.0.0.100 255.255.255.0 gateway 20.0.0.254

PC-2> show ip

NAME        : PC-2[1]

IP/MASK     : 20.0.0.100/24

GATEWAY     : 20.0.0.254

DNS         :

MAC         : 00:50:79:66:68:01

LPORT       : 10106

RHOST:PORT  : 127.0.0.1:10107

MTU:        : 1500

4 Yorum

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Başa dön tuşu

Reklam Engelleyici Algılandı

ÇözümPark Bilişim Portalı gönüllü bir organizasyon olup tek gelir kaynağı reklamlardır. Bu nedenle siteyi gezerken lütfen reklam engelleme eklentinizi kapatın veya Çözümpark web sitesi için izin tanımı yapın. Anlayışınız için teşekkürler.