Forum

Bildirimler
Hepsini Temizle

Hyper-v server 2008 (Ücretsiz Kurulum)

21 Yazılar
2 Üyeler
0 Reactions
957 Görüntüleme
(@SelahattinOKUMUS)
Gönderiler: 76
Estimable Member
Konu başlatıcı
 

hocalar ve arkadaşlar kolay gelsin

Hyper-v ücretsiz sürümünü kurdum Serhat hocanın makalelerinden yardım aldım. server kurulumunu yaptım workgruop olarak çalışacak. kendi makinem vista business sp1 kurulu ve tüm updateler yapılmış durumda. hyper-v manager konsol ile ilgili update yüklendi o da sorunsuz çalışıyor. fakat server'a bir türlü bağlanamıyorum rdp ile  bağlanmada sorun yok. console'den bağlantı olmuyor. birde serhat hocanın bahsettiği Windows Firewall with Advanced Security diye bir seçenek yok bende. ayrıca yine serhat hocanın bahsetmiş olduğu " netsh advfirewall firewall set rule group=”Windows Management Instrumentation (WMI)” new enable=yes" komutunu yazdığımda bana "grup,  diğer tanımlama koşullarıyla birlikte belirtilemez" diye hata veriyor.

Yardımlar için şimdiden teşekkür ediyorum.

 
Gönderildi : 12/03/2009 18:09

(@serhatakinci)
Gönderiler: 4117
Famed Member
 

Merhaba.

Aşağıdaki adamıları uygularsanız bağlanabilirsiniz.

http://www.serhatakinci.com/?p=1084

 
Gönderildi : 12/03/2009 18:35

(@SelahattinOKUMUS)
Gönderiler: 76
Estimable Member
Konu başlatıcı
 

serhat hocam zaten bende bu linkdeki yolları izleyerek kurumu yapmaya çalışıyorum. linkin ana sayfasındaki kurulum komutları ilgili bir problem yok buraları aştım. sayfanın içindeki kurulum ile ilgili linklerin birinci bölümü ile ikinci bölümünde sorunlar yaşıyorum. ilk sorumdada bilirtiğim gibi mesela firewall bendeki firewall seçeneğinde (makine full update yapıldığı halde) inbound ve outbound seçenekleri ile ilgili bir bölüm yok ve netsh ile ilgili komutta hata veriyor. aynı hata server komut satırındada veriyor. ben sanallaştırma olarak vmware esxi kullanıyorum şu anda bir problem yaşamadım. dün kü web eğitiminde siz anlatınca meraklandım ve ücretsiz olunca ayrıca usb diskleride tanıması açısından hyper-v kurmak istedim. eğer bu sorunları aşabilirsem bende hyper-v'li olayım.. yardımlarınız için şimdiden teşekkürler..

 
Gönderildi : 12/03/2009 19:30

(@serhatakinci)
Gönderiler: 4117
Famed Member
 

Hyper-V Server 2008 üzerinde aşağıdaki komutu koşturarak firewall disable edip denermisiniz

netsh firewall set opmode disable

 

 
Gönderildi : 12/03/2009 20:02

(@SelahattinOKUMUS)
Gönderiler: 76
Estimable Member
Konu başlatıcı
 

valla hocam süpersin diyorum... oldu server'a bağlandım.. çok teşekkür ederim. şimdi işletim sistemi kurup deneyeyim. ilginize tekrar teşekkürler...

 
Gönderildi : 12/03/2009 20:05

(@serhatakinci)
Gönderiler: 4117
Famed Member
 

Rica ederim.

 

Şunuda hatırlatmak isterim. Şimdi biz bu komutla Hyper-V Server üzerindeki firewall'ı kapattık.

Eğer firewall açıkken Remote Hyper-V Manager konsolu ile yönetim yapmak istiyorsanız, Hyper-V Server 2008 üzerinde aşağıdaki komutu uygulayın.

 

netsh firewall set portopening ALL 137 “Hyper-V Management”

 

Artı olarak dosya paylaşımı için tanım (Sunucu üzerine ağdan bişeyler atarken ihtiyacınız olacak)

netsh firewall set portopening ALL 139 “Sharing 01″

netsh firewall set portopening ALL 445 “Sharing 02″

 

 

 

 
Gönderildi : 12/03/2009 21:08

(@SelahattinOKUMUS)
Gönderiler: 76
Estimable Member
Konu başlatıcı
 

çok teşekkürler

 
Gönderildi : 12/03/2009 21:25

(@SelahattinOKUMUS)
Gönderiler: 76
Estimable Member
Konu başlatıcı
 

hocam yine takıldım..


yükleme tamam portları da yaptım hyper-v yöneticisinden sunucunun ip numarası ile bağlanıyorum fakat şimdide sanal makineler penceresinde "erişim reddedildi. 192.168.1.4 ile notebook arasında iletişim kurulamıyor" diye hata mesajı veriyor. yeni sanal makine kurulum işlemlerinde ilerliyorum fakat tam sanal disk oluşturacağı sırada "erişim reddedildi" diye tekrar hata veriyor.. benim işledim sistemi vista business bundan kaynaklarınıyor olabilirmi çünkü siz makalelerinizde vista ultimate'e göre anlatmışsınız. bu nedenle firewall ile ilgili komutlardada sorun yaşıyorum.

 
Gönderildi : 16/03/2009 04:22

(@serhatakinci)
Gönderiler: 4117
Famed Member
 

Hayır. İşletim sistemi versiyonu ile ilgili değil.

Hyper-V Server üzerindeki Firewall'u tekrar açtınızmı bilemiyorum ama eğer açık ise, fw'a takılıp takılmadığını anlamak için kapatıp denermisiniz.

Ayrıca client üzerinde oturum açtığınız hesap,  hyper-v server üzerinde local admin olmalı (aynı pass ile) Bu şekilde eklediniz mi?

 

 
Gönderildi : 16/03/2009 12:42

(@SelahattinOKUMUS)
Gönderiler: 76
Estimable Member
Konu başlatıcı
 

hocam firewall kapalı. user hatta iki tane ekledim farklı makinelerden denemek için iki user'ında admin hesabı var var iki farklı bilgisayardanda bağlandığımda aynı hatayı veriyor.

 
Gönderildi : 16/03/2009 14:49

(@serhatakinci)
Gönderiler: 4117
Famed Member
 

Peki sanal diskin yaratıldığı path'i değiştirip farklı bir path ile denermisin. Mümkünse farklı bir partition.

 
Gönderildi : 16/03/2009 15:10

(@SelahattinOKUMUS)
Gönderiler: 76
Estimable Member
Konu başlatıcı
 

hocam olmadı... hata olarak tam diski oluştururken "sunucu 2003server üzerindeki sabit diski yapılandırırken bir hatayla karşılaştı


sihirbaz, oluşturulan sanal makineyi geri alamadı lütfen daha sonra el ile silin" diyor. sonra erişim reddedildi. mesajı veriyor.


ben ne olur ne olmaz diye server'ı tekrar kurdum. bu arada kurulumu yaptığım server hp ml150 4 gb ram 140 gb disk ayrıca sata


raid olarak 160'lık diskler takılı.

 
Gönderildi : 16/03/2009 17:10

(@serhatakinci)
Gönderiler: 4117
Famed Member
 

Yeni kurulmuş sistemde de aynı hatayı alıyormusunuz?

 
Gönderildi : 16/03/2009 20:18

(@SelahattinOKUMUS)
Gönderiler: 76
Estimable Member
Konu başlatıcı
 

evet. tekrar yine kurdum bu üçüncü oldu ama yine aynı hatayı verdi. sanal makine kurulumuna geldik buradan sonra ilerliyemiyoruz.

 
Gönderildi : 16/03/2009 23:27

(@SelahattinOKUMUS)
Gönderiler: 76
Estimable Member
Konu başlatıcı
 

serhat hocam ne diyorsun bu sorunu halledebilecekmiyiz. tıkandım kaldım burada...

 
Gönderildi : 18/03/2009 03:05

(@serhatakinci)
Gönderiler: 4117
Famed Member
 

Merhaba.

Uygulama adımlarında atladığınız birşeyler olduğunu düşünüyorum.

Sistemi yeniden kurduktan sonra yaptığınız işlemleri sırası ile yazar mısınız. Bakalım atladığınız bir nokta var mı.

 
Gönderildi : 18/03/2009 14:20

(@SelahattinOKUMUS)
Gönderiler: 76
Estimable Member
Konu başlatıcı
 

Serhat hocam server özellikleri önceden yazmıştım o nedenle bir daha yazmıyorum..


hyper-v dvdsinden kurulumu gerçekleştiriyorum. menü ekranı açıldığında ip ayarlarını yapıyorum, workgroup olarak çalışacak, user ekliyorum, makalenizde belirmiş olduğnuz serverda hv klasörü içine attığım "cscript hvremote.wsf /mode:server /add:selo" komutunu sonra client tarafında vista sp1 tüm updateleri yapılmış yine hv klasörü içindeki


cscript hvremote.wsf /mmc:enable
cscript hvremote.wsf /mode:client /AnonDCOM:grant
cscript hvremote.wsf /mode:client /FirewallHyperVClient:Enable
komutlarını uyguluyorum ve hyper-v manager uptade dosyanısını yüklüyorum (bu üç komutu çalıştırmazsam bu uptade dosyası sisteminize uygun değildir diyor ve yüklemiyor bunuda  2 tane vista yüklü makinede denedim.) sizin yazmış olduğunuz "netsh firewall set opmode disable"komutu ile serverda firewallı kapatıyorum "aksi taktirde hiç bağlanmıyor" sonra hyper-v manager'ı çalıştırıp server'a bağlanıyorum server'ın c rootdaki dosyalarını görüyorum taktığım external diski görüyorum fakat yinede ekranda bağlantı kurulamadı diyor.

 
Gönderildi : 18/03/2009 15:25

(@serhatakinci)
Gönderiler: 4117
Famed Member
 

1. Selo hesabının bir parolası var dimi?

2. Parola complex mi?

3. Bu hesabı Hyper-V Server da eklerken herhangi bir tool kullanmadan direk HV Configuration ile ekliyoruz ve eklerken aynı parolayı giriyoruz. Bu şekilde mi?

Ekleme işlemini 4 numaralı komutla yapıyoruz.

4. Vista Business da workgroup çalışıyor olmalı ?

5. Tüm ayarlardan sonra Hyper-V Server'ı restart ettiniz mi?

 

 
Gönderildi : 18/03/2009 15:43

(@SelahattinOKUMUS)
Gönderiler: 76
Estimable Member
Konu başlatıcı
 

1- selo kullanıcıasın parolası var


2- parolayı bütük küçük harm ve rakamdan oluşmakta


3- kullanıcıyı dediğiniz gibi oluşturuyorum. sonra tool işlemi yapılıyor.


4- vista business de work groupta


5- restart yapıldı.


bende bu düzende yapmıştım zaten tekrar server bu sabah kuruldu ama hala düzelen birşey yok. 

 
Gönderildi : 18/03/2009 16:57

Sayfa 1 / 2
Paylaş: