Hyper-V Sanal makin...
 
Bildirimler
Hepsini Temizle

[Çözüldü] Hyper-V Sanal makine ağır çalışıyor.  

  RSS
Uğur TAŞLI
(@tslugr)
Üye

Merhaba Arkadaşlar.

HP-DL380P GEN8 Sunucum var .

Makineme HyperV olarak Mikro programının ve sql bulunduğu sanal makine mevcut .

Sanal makinemde 30 GB RAM ve 32 işlemci kullanması için ayarladım fakat şöyle bir problemim mevcut

Aynı sanal makineyi 8 gb ram olan bir leptoba kurulu hyperv ye 4 gb ram vererek çalıştırıyorum %70 ram kullandığı halde mikro programı 11 saniyede acılıyor.

Fakat sunucum da özellikleri yüksek verilmesine rağmen 22 30 saniyede açılıyor.

Daha önce sunucumun iki adet işlemcisinin sadece birinde 64 gb ram vardı ben diğer işlemcinin olduğu slota da

64 gb ram taktım . 

Daha önce sunucum da server 2012 yüklüydü 2016 kurulumu yaptım acaba sorun ramlerle ilgilimi sanki sanal makinelerde de kendi kullandığım leptoba göre biraz yavaşlık seziyorum aşağıda ramler ile alaklı görsel bulunmakta konu hakkında yardımcı olabilirmisiniz ?

ram

ilginiz için şimdiden teşekkür ederim.

Bu konu 5 ay önce Uğur TAŞLI tarafından düzenlendi
Alıntı
Gönderildi : 21/05/2020 00:33
Turan COŞKUN
(@turancoskun)
Tecrübeli Üye Forum Yöneticisi

Merhaba,

VM üzerinde yaşadığınız sorunun birden fazla sebebi olabilir.

İlk olarak vm'e atadığınız vcpu sayısını 8'e ve ram'i 16'ya düşürerek test edin.

Sorun devam ediyor ise server üzerindeki raid yapılandırmanızı kontrol etmelisiniz.

Yeterli disk var ise raid10, yok ise raid5 ile ilerleyin.

https://www.cozumpark.com/disk-i-o-test-nasil-yapilir/

Sanallaştırma teknolojilerinde fazla kaynak ayırmak, yüksek performans alacağınız anlamına gelmez.

Kaynakları düşük değerlerden, kademeli olarak yükseltin.

Ram tarafında sistem en düşük frekans'a göre çalışacaktır.

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 21/05/2020 01:31
Uğur TAŞLI
(@tslugr)
Üye

@turancoskun Merhaba Hocam,

Server üzerinde 4 adet sas ve 4 adet ssd disk mevcut ayrıca saslar ve ssdler raid 10 olarak yapılandırılmış durumda. İşletim sistemin saslara Sanal makineleride ssdlere kurduk ağırlığın sebebi bundan dolayımıdır acaba ?

 
CevapAlıntı
Gönderildi : 21/05/2020 01:37
ibrahim yildiz
(@ibrahimyildiz)
Tecrübeli Üye

Niçin bu kadar bir birinden farklı ram taktınız ki bank lere göre voltajları bile tutmuyor. ILO hata vermemiş makinede gördüğüne göre demek ki büyük bir problem yok diye düşünürüz sunucular mutlaka uyarı verirdi. Ancak ben olsam uzun bir memtest yapardım. Bu size belleklerden emin olmayı sağlar. Uyarılar alırsanız doğru yöntem bellekleri cpu'lara kapasite, hız ve rank'lerine göre dağıtmak olur. Biraz uğraştırabilir.
Diğer söylediğiniz şeyler loading gibi çok göreceli şeyler. Loading daha çok disk performansına bakar. Örneğin laptop'unuzda hızlı bir ssd olabilir sunucu raid array doğru kurgulanmamış olabilir yada fiziksel sunucu diskleri o anda yük altında olabilir. Yani sunucu tecrübeniz varsa ayrıntılı analiz ve performance monitoring yapmalısınız ki darboğazlarla ilgili daha ayrıntılı bilgi edinebilin. Forumda benzer sorgular mevcut yöntemlere dair inceleyin derim.

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 21/05/2020 01:44
Turan COŞKUN
(@turancoskun)
Tecrübeli Üye Forum Yöneticisi

Uğur bey,

Yapınızı incelemeden sorun direk bu demek mümkün değil.

Kobi seviyesinde standalone mimari için benzer disk yapılandırmaları kullanıyor, sorun olmaması gerekir.

Üstte önerdiğim adımları uygulayın, sorun devam ederse ise tekrar bakalım. 

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 21/05/2020 01:45
Uğur TAŞLI beğendi
ibrahim yildiz
(@ibrahimyildiz)
Tecrübeli Üye

@tslugr
HDD ve SSD ler tek bir raid 10 array altında mı birleştirildi? şayet böyleyse bu yanlış bir yapılandırma. Yok kendi içlerinde 2 ayrı raid array halindeyse problem olmaz. Elinizde başka sunucu varsa anvilpro ile mukayeseli disk benchmarkları yaparak da fikir edinebilirsiniz.

 

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 21/05/2020 01:50
Uğur TAŞLI beğendi
Uğur TAŞLI
(@tslugr)
Üye

@ibrahimyildiz Hocam ram kullanımı vs normel görünüyor ama sizce frekansı düşük ramleri mi sökmeliyim voltajı düşük ramleri mi görsele göre nasıl yapılandırma mı tavsiye edersiniz ?

CevapAlıntı
Gönderildi : 21/05/2020 01:51
Uğur TAŞLI
(@tslugr)
Üye

@ibrahimyildiz Ayrı ayrı yapılandırdım Hocam fakat işletim sistemini sasa kurdum .

CevapAlıntı
Gönderildi : 21/05/2020 01:52
Uğur TAŞLI
(@tslugr)
Üye

@turancoskun Hocam Görseldeki Ram yapılandırmamda bir problem mevcutmudur sizce memtest yapmam gerekir mi şuana kadar ram ile alakalı bir problem yaşamadım ram kullanımıda normel fakat biraz ramlerdende @ibrahimyildiz Hocanın dediği gibi voltaj değerleri rank değerleri vs farklı bu sorun teşkil edermi ?

CevapAlıntı
Gönderildi : 21/05/2020 02:07
ibrahim yildiz
(@ibrahimyildiz)
Tecrübeli Üye

@tslugr

Tamamdır array'ler ayrı olduğuna göre sorun yok. Controller firmware'iniz mutlaka güncel olsun. Yüksüzken benchmark yapın ve Turan hocanın uyarılarını adım adım uygulayın.

Ram konusunda sizin durumun içinden çıkmak zor 🙂 ram grupların latency'leri bile tutmuyor 🙂 bir kısmı cl9 bir kısmı cl11 yanlış tercihler yapmışsınız bence. En başta dönebiliyorsanız bundan dönüp bir grubu seçip onunla devam edin tümünü aynı sınıf yapın. Son taktığınız 16gb 1600 mhz'liklerde hp değil sanırım onlar nedir göremedim tabi. Şu durumda kapasite üretmek istiyorsanız ideallerin çok uzağındasınız bu şekilde her zaman ram'ler garip performanslar sergilemeye aday olur. Ben olsam şöyle yapardım hp olmayanlardan eminseniz bir grubu seçer cpu'ların slotlarına ve tabloya göre teker teker sırayla takardım gerekiyorsa sonuncu slotlara da 1333 lükleri takardım. 2 cpu'nun ram bank'larının eşit götürülmesi önemli. Zaten sunucu hoşuna gitmeyen config. de sizi uyaracaktır. Bu dizilimde nasıl uyarmamış onu da anlamadım gerçi.:)
Yukarıda da garip birşey demişsiniz 2. cpu vardıysa ve slotları boştuysa nasıl çalışıyordu?
Siz bu ram upgrade'ini yapmadan önce performans nasıldı? ve dizilim neydi. Benzer yavaşlık gördüğünüz için mi 16'lık ram'leri aldınız.

Finalde şöyle düzenleyip bitirelim kalanı sizde. Bu donanımla bu sunucunun her şekilde memtest, benchmark ve stres testi ihtiyacı var. Lafla emin olunamayacak bir senaryo uygulamışsınız. Sanallaştırmada fiziksel donanımın dengesi çok önemlidir. Turan hocamın dediği gibi çok kaynak bol perf. demek değildir. Hypervisor mimarisi beklenenin dışında çok genel kapsamda donanımlar üzerinde rahat çalışır uyumluluğu geniştir. Ancak bus, perf. eşitliği sağlanmamışsa gözle görmek zordur ancak iç çalışmada acayip perf. çakılmalara açık olur. Zincirin zayıf halkası bahsinin bile altında seyredebilir. Bunları aklınızda tutarak revizyona gidin.

 

Bu ileti 5 ay önce ibrahim yildiz tarafından düzenlendi

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 21/05/2020 02:17
Uğur TAŞLI
(@tslugr)
Üye

@ibrahimyildiz Daha önce sadece birinci cpu da takılan 64 gb ram vardı 7 adet sanal makine vardı .

Bende gereksiz sanal makineleri kaldırdım sadece kurumun kullanabileceği şekilde 5 adet sanal makineye düşürdüm belki ileriye doğru tekrar sanal makine kurmam gerekir diye 4 adet 16 gb daha ram alarak 128 gb çıkardım daha önce sadece 1. cpuda ramler varken nasıl çalışıyordu bende anlamadım ama performansı şimdikinden pek farklı değildi sorunda zaten sonrasında performansta hic fark olmaması .

Ayrıca ramleri takarken ilk cpu daki sıralamaya göre takmıştım ve ramlerin hepside hp aynı marka model fakat değerleri farklı yeni takdığım ramlerde zaten hpe smart memory görmüyor oda enteresan bir durum.

Serverler konusunda pek tecrübeli değilim internet üzerindede hp dl380 gen 8 hakkında ram sıralaması konusunda pek bilgi alamadım yada yanlış araştırdım elimde fazla sunucu olsa demolar yapıcam fakat olmadığı için fiziksel olarak en az müdahale edebileceğim şekilde sorunu düzeltmeye çalışıyorum söylediğiniz işlemleri deniyeceğim umarım faydalı olur verdiğiniz bilgiler için çok teşekkür ediyorum sağlıklı güzel günler diliyorum 🙂

CevapAlıntı
Gönderildi : 21/05/2020 02:34
Selçuk HÜNER
(@selcukhuner)
Üye

Bir kaç konuya açıklık getireyim.
HP DL serisi ve Mikro uzmanı olarak.

1) HP DL 380 GEN8 için HP Provisioning Tool F10 tuşu ile açarak tüm firmware leri güncelleyin.

Offline güncellemek gerekirse GEN8 için en son versiyon Intelligent Provisioning Recovery Media indirerek CD yada USB ile boot ederek güncelleyin.

Link : https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_a2b2caf8066e4a8b82a966d628

RAID Controller Firmware manuel güncellemek gerekiyor, Intelligent Provisioning Recovery Media güncel halini bulamıyor.

Test ortamındaki cihazımın en son versiyonları şöyle

image

2) RAM voltaj değerleri farklı olması sorun yaratmaz. En düşük hıza göre uyum sağlayacaktır. Ancak aynı seri RAM kullanmak her zaman iyidir. HP SmartMemory yazmamasının sebebi, kullanılan RAMler resmi HP markalı olmamasından kaynaklıdır. Resmi HP etiketli olan bazı RAMlerde HPE SmartMemory yazmadığını da gördüm.

3) Mevcut RAMler her iki işlemciye de eşit şekilde dağıtmak gerekli.

4) Diskleri RAID10 yapmak bir miktar performans kaybına sebep olur. 4 Disk için Raid5 ve SSD Cache yapılabilir (RAID kart SSD Cache desteği gerekir, kart üzerinden bakmak gerek.)

5) Mikro ilk açılışındaki yavaşlık Mikro versiyonuna göre değerlendirmek gerekiyor. Mikro V15 ise DATABASE.INI dosyasındaki SQL ayarlarıyla da ilgili olabilir. SQL isim çözümleme konusunda gecikme yaşıyor olabilir. Mikro V16 ise lisans kontrolü için Mikro Web Servislere bağlantı yaptığı için firewall katmanında konuya bakmak gerekebilir.

6) SQL sanal makinaya HYPER-V üzerindeki tüm CPU ları vermeyin. 32 Core varsa 24 Core vererek deneyin.

7) Mikro bazı sorgular için SQL de bulunan TEMP tablolar kullanır. Bu temp tablolar SQL de TEMP database altında oluşturulur. 

SQL Management Studio içinden Database özelliklerinde Firma DB ve TEMP db Compatibly Level bir alt seviyeye çekilerek denemek bazen performansı arttırıyor.

8) HP ILO -> Power Management -> Power Settings altında OS Control Mode seçerek Restart yapın.

Sanallaştırma performansı için Bios seçeneklerini buradakilere göre düzenleyin.

https://kimconnect.com/hpe-gen8-bios-settings-to-prepare-host-for-virtualization-role/

Daha detaylı seçenekler için buraya bakabiliriz.

https://www.teimouri.net/optimizing-hp-bios-settings-for-vmware-vsphere/

 

CevapAlıntı
Gönderildi : 21/05/2020 13:39
Uğur TAŞLI
(@tslugr)
Üye

@selcukhuner

Merhaba Hocam verdiğiniz bilgiler için teşekkür ederim ram sıralamamda da problem olduğunu düşünüyorum ilom da bir problem var buyuz den hataları doğru göstermiyor sanırım 

İloda şöyle bir hata mevcut (Controller firmware revision 2.10.00 Embedded media initialization failed due to media write-verify test failure ) güncellemeler sonrası düzelir diye düşünüyorum.

Ram sıralamam paylaştığım görselde

Birinci CPU 

Soket 1 -8 GB

Soket 4 -8 GB

Soket 8 -8 GB

Soket 9 -16 GB 1333 MHZ

Soket 11 -8 GB

Soket 12 -16 GB 1333 MHZ

İkinci CPU

1,2,4,5 Soketlerinde 16 GB 1600 MHZ Ram mevcut.

Ramleri daha önceden birinci işlemciye takıldığı şekle bakarak bende 4 adet 16 gblik rami ikinci işlemciye takmıştım fakat söket sıralamasının birinci işlemcinin sırasına göre farklı olduğunu sonradan fark ettim.

Şu şekilde güncelleme yapsam ram konusunda da herhangi bir fark olur mu gerce şuan için 128 gb rami mi görüyor herhangi bir hata da ramle ilgilide sunucuyu birkaç kez yeniden başlattığım halde almadım yaklaşık 5 aydır bu şekilde sunucu çalışıyor.

Sıralamayı şu şekilde değiştirmeli miyim sizce ?

CPU 1
Soket 1 -8 GB
Soket 4 -8 GB
Soket 8 -16 GB 1333 MHZ
Soket 9 -16 GB
Soket 11 -16 GB
Soket 12 -16 GB

CPU 2
Soket 1 -8 GB
Soket 4 -8 GB
Soket 8 -16 GB 1333 MHZ
Soket 9 -16 GB
Soket 11 -16 GB
Soket 12 -16 GB

Ayrıca SSD leri Raid 5 Sasları da Raid 10 yapsam Server 2016 işletim sistemi kurulumunu tekrardan temiz bir şekilde ssdlere kursam sanal makineleride ssdlere alsam .

Ayrıca işletim sistemi olarak Server 2016 mı 2012 r2 mi kursam bu sunucuda daha iyi performans alırım.

Yada ramlere hiç dokunmadan söylediğiniz işlemlerimi yapmalıyım ?

 

 

 

Bu ileti 5 ay önce 4 defa Uğur TAŞLI tarafından düzenlendi
CevapAlıntı
Gönderildi : 21/05/2020 17:58
Turan COŞKUN
(@turancoskun)
Tecrübeli Üye Forum Yöneticisi

Uğur bey,

Ram sıralamasında evet hata mevcut, referans adreste "memory population guidelines" başlığı aradığınız yer.

https://www.harddrivesdirect.com/quickspecs_proliant_DL380pG8.php

P1-A-,P2-A,P1-B,P2-B,P1-C,P2-C sıralaması ile ilerlemelisiniz

Tek bir fiziksel host üzerinde sadece sizin bağlı olduğunuz bir test ortamında, raid5/10, w2k12/w2k16 tercihinizden önce, kaynak planlaması ile başlamalısınız, burası hatalıydı.

Üstte önerdiğim adımları kısaca test edebilseydiniz, aslında soruların çoğu cevaplanmış olacaktı.

Önerileri uygulamadığınız sürece takılacağınız sorunların bir sonu yok.

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 21/05/2020 22:50
Uğur TAŞLI
(@tslugr)
Üye

@turancoskun İlginiz için teşekkür ederim hocam bayramdan sonra işlemlere başlayacağım sonucu tekrar buraya yazarım .

CevapAlıntı
Gönderildi : 21/05/2020 23:41
Turan COŞKUN
(@turancoskun)
Tecrübeli Üye Forum Yöneticisi

tamamdır, geri bildirimini bekliyoruz.

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 22/05/2020 11:23
Uğur TAŞLI
(@tslugr)
Üye

Merhaba Arkadaşlar ,

Geri dönüşüm biraz geç oldu kusura bakmayın . Ram Sıralamasını Kapakta yer alan sıralamayı inceleyerek düzelttim performans olarak fazla bir değişiklik hissetmedim . Sistemi sıfırdan kuracaktım fakat ilo da Controller firmware revision 2.10.00 Embedded media initialization failed due to media write-verify test failure hatası verdiği için hatayı düzeltmekle baya bir uğraştım hpe nin sitesindeki tüm kaynaklardan yararlandım fakat hata düzelmiş gibi görünüp bir süre sonra tekrar aynı noktaya dönüyor ilo firmware 2.75 güncellediğim halde sorunu düzelmedi ayrıca Intelligent Provisioning usb boot etmiştim yüklemede hep hata verdiği ve elimde de dvd olmadığından dolayı yükleyemedim Intelligent Provisioning ilodaki problem nand format yaptıktan sonra düzelttiğin den bahsediyordu fakat dvd ye boot etmek gerekiyor sanırım internetten araştırdığım kadarıyla tüm kaynaklar dvd ile yükleme yapmış. kısacası iloyla uğraştığım için diğer işlemleri sabaha kadar yetiştiremedim. Sistemi bu şekilde çalıştırmak zorunda kaldım yedek server olmaması ve sistemin 7/24 kullanılması bakım yapmak için kısıtlı zaman olması çok kötü bir durum ayrıca hp dl380p gen 8 çok eski bir sunucu uefi desteği bile yok yeni server almak daha mantıklı gibi önerilere açığım tabi şu sorunlarıda çözebilirsem geri bildirimde tekrar bulunacağım yardımcı olan herkese teşekkür ediyorum. 🙂

CevapAlıntı
Gönderildi : 05/09/2020 15:25
ibrahim yildiz
(@ibrahimyildiz)
Tecrübeli Üye

https://community.hpe.com/t5/proliant-servers-ml-dl-sl/sd-card-embedded-media-initialization-failed/td-p/7017878
https://sysadminguides.org/2018/08/26/fix-ilo-hp-error-embedded-flash-sd-card-embedded-media-manager-failed-initialization/

buradaki ekran görüntüsüne göre adımları uygulaman lazım. Format atıldığı halde tekrar ediyorsa sd-card bozulmuş olabilir teminine bakmanız lazım.
sunucuda dvd yoksa external bir usb dvd denemen lazım.

Bu ileti 2 ay önce ibrahim yildiz tarafından düzenlendi

****************************************************************
Probleminiz Çözüldüğünde Sonucu Burada Paylaşırsanız.
Sizde Aynı Problemi Yaşayanlar İçin Yardım Etmiş Olursunuz.
Eğer sorununuz çözüldü ise lütfen "çözüldü" olarak işaretlerseniz diğer üyeler için çok büyük kolaylık sağlayacaktır.
*****************************************************************

CevapAlıntı
Gönderildi : 06/09/2020 01:05
Uğur TAŞLI
(@tslugr)
Üye

@ibrahimyildiz Merhaba Hocam Paylaştığınız linkteki aşamaları denedim fakat işlem başarılı olduğu halde bir süre sonra tekrar aynı hataya döndü fakat format atmadım yedekleri almak baya uzun sürdü birde iloyla baya uğraştığım için zaman yetmedi başka bir zaman  Intelligent Provisioning yükleyip tekrar deniyeceğim şuan için ilodaki problem logları takip etmek dışında bir sorun teşkil etmez sanıyorum ?

CevapAlıntı
Gönderildi : 07/09/2020 08:31
Paylaş: