Cisco router ü...
 
Bildirimler
Hepsini Temizle

Cisco router üzerinde PBR policy base routing sorunu  

Taylan ŞİMŞEK
(@TaylanSiMSEK)
Üye

Merhaba,

Bir kaç gündür policy base routing konusunu araştırıyorum bunun ile ilgili döküman ve video da buldum GNS3 ile denediğim ve çalıştırdığım conf real de sorun yaratıyor kısaca ; Router console bağlantısı üzerinden trace ettiğim zaman paketin istediğim interface üzerinden gönderildiğini görüyorum ACL'de hemen match ettiğini belirtiyor ama herhangi bir pc'den trace ettiğimde paketin default route kullandığını görüyorum, ilginçtir routerda ACL bu paketide match ettiğini bildiriyor.Sorun ne olabilir ?

Konfigürasyon örneği aşağıdaki gibi ;

interface Tunnel1
 description Tunnel_To_MERKEZ
 ip address 172.16.0.2 255.255.255.252
 ip mtu 1420
 tunnel source Dialer1
 tunnel destination 88.88.88.88
 tunnel mode ipsec ipv4
 tunnel protection ipsec profile selsec
!
interface FastEthernet0/0
 ip address 10.0.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip route-cache policy
 duplex auto
 speed auto
!
!
interface ATM0/0/0
 no ip address
 no atm ilmi-keepalive
 bundle-enable
!
interface ATM0/0/0.1 point-to-point
 pvc 8/35
  pppoe-client dial-pool-number 1
 !
!
interface Serial0
 no ip address
 encapsulation frame-relay IETF
 no fair-queue
 frame-relay traffic-shaping
 frame-relay lmi-type ansi
!
interface Serial0.1 point-to-point
 description MERKEZ
 bandwidth 512
 ip address 192.168.0.2 255.255.255.0
 snmp trap link-status
 no cdp enable
 frame-relay interface-dlci 100
  class voice512
!

interface Dialer1
 xxxxxx
 xxxxxx vs
 ppp chap hostname xxx@ttnet
 ppp chap password 0 xxx
 ppp pap sent-username xxx@ttnet password xxx
!
ip local policy route-map PBR
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Tunnel1
ip route 0.0.0.0 0.0.0.0 Serial0.1 10
ip route 88.88.88.88 255.255.255.255 dialer1
!
!
ip nat inside source list 1 interface Dialer1 overload
!
ip access-list extended PBR
 permit ip any host 10.0.0.3 log
 permit ip any host 10.0.0.25 log
!

access-list 1 permit 10.0.1.0 0.0.0.255

route-map PBR permit 10
 match ip address PBR
 set interface Serial0/1/0.1
!

Alıntı
Topic starter Gönderildi : 20/04/2010 21:56
Gurcan Boduroglu
(@GurcanBoduroglu)
Üye

Selam,

 Ben konfigürasyonda nat' ın outside bacağını göremedim.

CevapAlıntı
Gönderildi : 21/04/2010 05:06
İlyas YILDIZ
(@ilyasYILDIZ)
Üye

Merhaba ;

Eğer access list PBR 'da belirtilern ip bloğunu  default olarak serial0.1 int'e göndermek istiyorsanız route-map aşağıdaki gibi yazın ;

 route-map PBR permit 10
 description ***** ????? *****
 match ip address PBR
 set ip default next-hop interface Serial0/1/0.1 ( karşı tarafın ip adresini de yazabilirisin , daha sağlıklı olur )

route-map PBR permit 20

CevapAlıntı
Gönderildi : 21/04/2010 12:23
Taylan ŞİMŞEK
(@TaylanSiMSEK)
Üye

Merhaba İlyas bey,

Malesef bunu daha önce denemiştim değişiklik yaratmıyor.

CevapAlıntı
Topic starter Gönderildi : 21/04/2010 21:03
İlyas YILDIZ
(@ilyasYILDIZ)
Üye

Merhaba , fa0/0 altına ilgili polic-map kuralını uygularsanız çalışacaktır.

 

 interface fa0/0

ip local policy route-map PBR

CevapAlıntı
Gönderildi : 22/04/2010 11:36
Taylan ŞİMŞEK
(@TaylanSiMSEK)
Üye

İlyas Bey Merhaba,

Öncelikle yardımınız için çok teşekkür ederim.

Route-map F0/0 interface'ine uygulandı ama sorun devam etti. ACL aşağıdaki gibi yeniden düzenlendi ve sorun çözüldü.

ip access-list extended PBR
permit ip any host 10.0.0.16
permit ip host 10.0.0.16 any

CevapAlıntı
Topic starter Gönderildi : 22/04/2010 14:29
Paylaş: