Anasayfa » Forum

2008 64 bit r2 str ...
 
Bildirimler

2008 64 bit r2 str server üzerinde sql 2008 r2 kurulu ama şöyle bir hata veriyor  

  RSS
 Anonim

arkadaşlar program çalışmadıgından event ı kontrol edince aşağıdaki gibi hata veriyor arkadaşlar programı patronlar kullanıyor sabaha çözmüş olmam gerekiyor acil yardımlarınızı bekliyorum şimdiden tşkler.


 







































































Details
Product: SQL Server
ID: 2
Source: MSSQLServer
Version: 10.0
Component: SQLEngine
Message: An error has occurred while establishing a connection to the server. When connecting to SQL Server, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (.Net SqlClient Data Provider)
   
Explanation

SQL Server did not respond to the client request because the server is probably not started.

   
User Action

Make sure that the server is started.

   
   
Version: 9.0
Component: SQLEngine
Message: An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (.Net SqlClient Data Provider)
   
Explanation

SQL Server did not respond to the client request because the server is probably not started.

   
User Action

Make sure that the server is started.

Alıntı
Gönderildi : 09/01/2012 22:43
 Anonim

arkadaşlar sql çalışmıyor sanırım ani kapanmadan dolayı oldu sql i yeniden nasıl başlatabilirim kaldırmam mı gerekli kaldırısam verileri nasıl alabilirim sql manege de çalışmıyor.

CevapAlıntı
Gönderildi : 09/01/2012 23:12
 Anonim

arkadaşlar sql e bağlanırken böyle bir hata veriyor


CevapAlıntı
Gönderildi : 10/01/2012 00:38
Selahattin SADOGLU
(@SelahattinSADOGLU)
Üye

Merhaba,

a. Start > All Programs > SQL Server 2005 > Configuration Tools > SQL Server Surface Area Configuration
b. Surface Area Configuration üzerinde Services and Connection gelin.
c. Problem yaşadğınız instance hangisiyse onu seçiniz > Database Engine > Remote Connections gelin.
d. Enable local and remote connections > ‘TCP/IP’ ve ‘Named Pipes’ olan kısımları aktif hale getiriniz.

Saygılarımla,

CevapAlıntı
Gönderildi : 10/01/2012 01:05
 Anonim

[quote user="Selahattin SADOGLU"]

Merhaba,


a. Start > All Programs > SQL Server 2005 > Configuration Tools > SQL Server Surface Area Configuration
b. Surface Area Configuration üzerinde Services and Connection gelin.
c. Problem yaşadğınız instance hangisiyse onu seçiniz > Database Engine > Remote Connections gelin.
d. Enable local and remote connections > ‘TCP/IP’ ve ‘Named Pipes’ olan kısımları aktif hale getiriniz.


Saygılarımla,


[/quote]


 


dostum 2008 sql r2 kullandığımız için configuratin tools da >


 "SQL Server Surface Area Configuration" bu kısım çıkmıyor. dediğiniz ayarları yapamıyorum. başka bir yerlerden yapmam mümkün mü yoksa kaldırıp kurmam mı gerekli.
"

CevapAlıntı
Gönderildi : 10/01/2012 01:32
 Anonim

[quote user="Selahattin SADOGLU"]

Merhaba,


a. Start > All Programs > SQL Server 2005 > Configuration Tools > SQL Server Surface Area Configuration
b. Surface Area Configuration üzerinde Services and Connection gelin.
c. Problem yaşadğınız instance hangisiyse onu seçiniz > Database Engine > Remote Connections gelin.
d. Enable local and remote connections > ‘TCP/IP’ ve ‘Named Pipes’ olan kısımları aktif hale getiriniz.


Saygılarımla,


[/quote]


 


dostum 2008 sql r2 kullandığımız için configuratin tools da >


 "SQL Server Surface Area Configuration" bu kısım çıkmıyor. dediğiniz ayarları yapamıyorum. başka bir yerlerden yapmam mümkün mü yoksa kaldırıp kurmam mı gerekli.
"

CevapAlıntı
Gönderildi : 10/01/2012 01:33
Selahattin SADOGLU
(@SelahattinSADOGLU)
Üye

Yanlış bilgilendirdiğim için özür dilerim.Şunları denermisiniz.

Microsoft SQL Server 2008 >> Configuration Tools >> SQL Server Configuration Manager >> SQL Server Services
sırasıyla buraya kadar gelin.SQL Server services hemen açılan pencereden sol tarafta seçili iken sağ tarafta SQL Server(MSSQLSERVER)
çalıştığından emin olunuz.
sonrasında ;
Microsoft SQL Server 2008 >> Configuration Tools >> SQL Server Configuration Manager >> açınız.Açılan yerden SQL Server Network Configuration
altından Protocols for MSSQLSERVER gelin.Sonra sağ taraftan TCP/IP sağ tıklayıp "enable" tıklayın.
3.olarak Windows Firewall çalışmadığından emin olunuz.
Diğer bir alternatif SQL Server Management studio açınız.Sonrasında sağ taraftan sunucu adının yazılın olduğu (object explorer altında)
buna sağ tıklayarak properties gelin.Açılan yerden sağ taraftan "connections" gelin.Sonra sol alttan kısımdan "Allow remote connections to this server
işaretleyiniz.
Diğer bir bakmanız gereken  yer Microsoft SQL Server 2008 >> Configuration Tools >> SQL Server Configuration Manager >> SQLServer  Services gelin.
Sonra  sol taraftan SQL Server Browser sağ tıklayıp "enable" yapın.

 

Saygılarımla,

CevapAlıntı
Gönderildi : 10/01/2012 01:47
 Anonim

dostum Microsoft SQL Server 2008 >> Configuration Tools >>  buranın altında "sql server installation center" var o yüzden diğer bölüm e gelemiyorum bu arada isterseniz uzak bağlantı ayarlayabilirim. size

CevapAlıntı
Gönderildi : 10/01/2012 02:04
Selahattin SADOGLU
(@SelahattinSADOGLU)
Üye

Merhaba,

Hata resiminde bir şey dikkatimi çekti.Bağlanırken "local" bağlanmaya çalışmışsınız.Tekrar SQL Management ekranını açınız.Bağlanma ekranından Server adı kısmından sadece "localhost" ve ya " 127.0.0.1" yazarak bağlanmaya çalışınız.

CevapAlıntı
Gönderildi : 10/01/2012 02:09
 Anonim

dostum bu arada server ın şifresini değiştirmiştim bir etkisi olacağını düşünmüyorum ama bilemiyorumda. bu arada 127.0.0.1 yazdım ama yine bağlanamadı.

CevapAlıntı
Gönderildi : 10/01/2012 02:14
Selahattin SADOGLU
(@SelahattinSADOGLU)
Üye

Localhost olarak da denediniz mi?ayrıca hizmetler kısmında SQL Server browser ve diğer servislerin çalıştığından  emin olunuz.

CevapAlıntı
Gönderildi : 10/01/2012 02:17
 Anonim

[quote user="Selahattin SADOGLU"]Localhost olarak da denediniz mi?ayrıca hizmetler kısmında SQL Server browser ve diğer servislerin çalıştığından  emin olunuz.
[/quote]


 


sql server browser ve sql server vss writer, sql server integration services , sql full text çalışıyor diğer servisler sql le ilgili servisler çalışmıyor çalıştırmaya çalıştığımda da " windows could not start the sql server (mssqlserver)service on local computer" diye bir hata veriyor.


hocam olmadı yarın sabah felan da bağlanabilirmisiniz?

CevapAlıntı
Gönderildi : 10/01/2012 02:24
Selahattin SADOGLU
(@SelahattinSADOGLU)
Üye

Son çözüm o zaman SQL Server yeniden yüklemen gerekiyor.Çünkü MSSQLServer yerel servis hasar görmüş.

 

Saygılar,

CevapAlıntı
Gönderildi : 10/01/2012 02:29
 Anonim

herhangi bir yedek almam gerekiyor mu program/ekle kaldır dan kaldırıp yüklemem yeterlimidir acaba. kaldırıken dikkat etmem gereken bir şeyler varmıdır slehattin bey.

CevapAlıntı
Gönderildi : 10/01/2012 02:31
 Anonim

[quote user="yildizfh"]herhangi bir yedek almam gerekiyor mu program/ekle kaldır dan kaldırıp yüklemem yeterlimidir acaba. kaldırıken dikkat etmem gereken bir şeyler varmıdır slehattin bey.[/quote] 


bu arada hocam herşey için çok teşekkürler sanırım yarın kuracam yapacak çok fazla birşey yok anladığım kadarıyla son bir umut update de etmiştim ama değişen birşey olmamışdı.

CevapAlıntı
Gönderildi : 10/01/2012 02:34
 Anonim

arkadaşlar büyük bir ihtimal sorunumuz serverda şifre değişikliği nedeni ile bu sorunu yaşadık sql de şifreleri değiştirince şu şekilde bir hata vermeye başladı onu nasıl giderebilirim bilginiz var mıdır acaba

cannot connect to (local)

additionel information

login failed user .... \administrator

CevapAlıntı
Gönderildi : 10/01/2012 14:08
 Anonim

arkadaşlar sorun server ın şifre değişikliğiymiş sql den servislerin özeliklerinden yeni şifreyi girince tüm servisler çalışmaya başladı.tşkler yardımcı olan arklere

CevapAlıntı
Gönderildi : 10/01/2012 15:22
Paylaş: